COMSOL® Multiphysics® software is the most widely used modeling tool for engineers and scientists. It allows the user to create 1D, 2D, and 3D simulated environments for computerized modeling of physical systems and devices. Designed for the senior level undergraduate, graduate, or the professional scientist or engineer, Multiphysics Modeling Using COMSOL® offers a step-by-step modeling methodology through examples that are linked to the Fundamental Laws of Physics through a First Principles Analysis approach. The text explores a breadth of multiphysics models in coordinate systems that range from 1D to 3D and introduces the readers to the numerical analysis modeling techniques employed in the COMSOL® Multiphysics® software. After readers have built and run the examples, they will have a much firmer understanding of the concepts, skills, and benefits acquired from the use of computerized modeling techniques to solve their current technological problems and to explore new areas of application for their particular technological areas of interest.

KEY FEATURES

- Presents the physics of First Principles relevant to the problem and correlates them with the observed behaviors demonstrated in each multiphysics model
- Introduces the numerical analysis modeling techniques employed in the COMSOL® Multiphysics® software
- Includes executable copies of each model and related animations on the accompanying DVD
- Focuses on models in the electrical, electronic, electromagnetic, optical, thermal physics, and biophysics areas as examples for later applications in engineering, science, medicine, and biophysics for the development of devices and systems
Multiphysics Modeling using COMSOL®

A First Principles Approach

Roger W. Pryor, PhD

JONES AND BARTLETT PUBLISHERS
Sudbury, Massachusetts
BOSTON TORONTO LONDON SINGAPORE
# Contents

<table>
<thead>
<tr>
<th>Chapter 1</th>
<th>Modeling Methodology</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Guidelines for New COMSOL® Multiphysics® Modelers</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Hardware Considerations</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Coordinate Systems</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>Implicit Assumptions</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>1D Window Panes Heat Flow Models</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>1D Single-Pane Heat Flow Model</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>1D Dual-Pane Heat Flow Model</td>
<td>16</td>
<td></td>
</tr>
<tr>
<td>1D Triple-Pane Heat Flow Model</td>
<td>27</td>
<td></td>
</tr>
<tr>
<td>First Principles Applied to Model Definition</td>
<td>35</td>
<td></td>
</tr>
<tr>
<td>Common Sources of Modeling Errors</td>
<td>37</td>
<td></td>
</tr>
<tr>
<td>Exercises</td>
<td>38</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2</th>
<th>Materials and Databases</th>
<th>39</th>
</tr>
</thead>
<tbody>
<tr>
<td>Materials and Database Guidelines and Considerations</td>
<td>39</td>
<td></td>
</tr>
<tr>
<td>COMSOL® Material Library Module: Searchable Materials Library</td>
<td>40</td>
<td></td>
</tr>
<tr>
<td>MatWeb: Searchable Materials Properties Website</td>
<td>43</td>
<td></td>
</tr>
<tr>
<td>PKS-MPD: Searchable Materials Properties Database</td>
<td>48</td>
<td></td>
</tr>
<tr>
<td>References</td>
<td>61</td>
<td></td>
</tr>
<tr>
<td>Exercises</td>
<td>62</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 3</th>
<th>1D Modeling</th>
<th>63</th>
</tr>
</thead>
<tbody>
<tr>
<td>1D Guidelines for New COMSOL® Multiphysics® Modelers</td>
<td>63</td>
<td></td>
</tr>
<tr>
<td>1D Modeling Considerations</td>
<td>63</td>
<td></td>
</tr>
<tr>
<td>Coordinate System</td>
<td>64</td>
<td></td>
</tr>
</tbody>
</table>
# Chapter 6 2D Simple Mixed-Mode Modeling 321

2D Mixed-Mode Guidelines for New COMSOL® Multiphysics® Modelers 321
2D Mixed-Mode Modeling Considerations 321
2D Coordinate System 322
2D Axisymmetric Coordinate System 324
Joule Heating and Heat Conduction Theory 324
Heat Conduction Theory 325
2D Resistive Heating Modeling 326
2D Resistive Heating Model 326
First Variation on the 2D Resistive Heating Model 345
Second Variation on the 2D Resistive Heating Model, Including Alumina Isolation 366
2D Resistive Heating Models: Summary and Conclusions 388
2D Inductive Heating Considerations 389
2D Axisymmetric Coordinate System 389
2D Axisymmetric Inductive Heating Model 393
First Variation on the 2D Axisymmetric Inductive Heating Model 411
Second Variation on the 2D Axisymmetric Inductive Heating Model 433
## Chapter 7  
### 2D Complex Mixed-Mode Modeling  
459

2D Complex Mixed-Mode Guidelines for New COMSOL® Multiphysics® Modelers  
459

2D Complex Mixed-Mode Modeling Considerations  
459

2D Coordinate System  
461

Electrical Impedance Theory  
461

2D Electric Impedance Sensor Model: Basic  
464

Basic 2D Electric Impedance Sensor Model: Summary and Conclusions  
475

2D Electric Impedance Sensor Model: Advanced  
477

2D Electric Impedance Sensor Models: Summary and Conclusions  
492

Generator and Power Distribution Basics  
493

2D AC Generators: Static and Transient  
498

2D AC Generator Model (2D_ACG_1): Static  
498

2D AC Generator Model (2D_ACG_2): Transient  
522

2D AC Generators, Static and Transient Models: Summary and Conclusions  
529

2D AC Generator: Sector—Static and Transient  
530

2D AC Generator Sector Model (2D_ACGS_1): Static  
531

2D AC Generators, Static Sector Model: Summary and Conclusions  
555

2D AC Generator Sector Model (2D_ACGS_2): Transient  
557

2D AC Generators, Static and Transient Sector Models: Summary and Conclusions  
568

References  
569

Exercises  
570

## Chapter 8  
### 3D Modeling  
571

3D Modeling Guidelines for New COMSOL® Multiphysics® Modelers  
571

3D Modeling Considerations  
571

3D Coordinate System  
572
Contents

Chapter 9 Perfectly Matched Layer Models 671

Perfectly Matched Layer Modeling Guidelines
and Coordinate Considerations 671
PML Theory 671
PML Models 676
2D Dielectric Lens Model, with PMLs 676
2D Dielectric Lens Model, with PMLs: Summary
and Conclusions 690
2D Dielectric Lens Model, without PMLs 691
2D Dielectric Lens Model, with and without PMLs:
Summary and Conclusions 702
2D Concave Mirror Model, with PMLs 707
Chapter 10  Bioheat Models  747

Bioheat Modeling Guidelines and Coordinate Considerations  747
Bioheat Equation Theory  747
Tumor Laser Irradiation Theory  749
  2D Axisymmetric Tumor Laser Irradiation Model  749
  2D Axisymmetric Tumor Laser Irradiation Model: Summary
  and Conclusions  768
Microwave Cancer Therapy Theory  769
  2D Axisymmetric Microwave Cancer Therapy Model  770
  2D Axisymmetric Microwave Cancer Therapy Model: Summary
  and Conclusions  794
References  794
Exercises  795

Index  797
The purpose of this book is to introduce hands-on model building and solving with COMSOL® Multiphysics® software to scientists, engineers, and others interested in exploring the behavior of different physical device structures on a computer, before actually going to the workshop or laboratory and trying to build whatever it is.

The models presented in this text are built within the context of the physical world (applied physics) and are explored in light of first principles analysis techniques. As with any other method of problem solution, the information contained in the solutions from these computer simulations is as good as the materials coefficients and the fundamental assumptions employed in building the models.

The primary advantage in combining computer simulation and first principles analysis is that the modeler can try as many different approaches to the solution of the same problem as needed to get it right (or at least close to right) in the workshop or laboratory the first time that device components are fabricated.

## Acknowledgments

I would like to thank David Pallai of Jones and Bartlett Publishers for his ongoing encouragement in the completion of this book. I would also like to thank the many staff members of COMSOL, Inc., for their help and encouragement in completing this effort.

I would especially like to thank my wife, Beverly E. Pryor, for the many hours that she spent reading the manuscript and verifying the building instructions for each of the models. Any errors that remain are mine and mine alone.

Roger W. Pryor, Ph.D.
COMSOL® Multiphysics® software is a powerful finite element (FEM), partial differential equation (PDE) solution engine. The basic COMSOL Multiphysics software has eight add-on modules that expand the capabilities of the basic software into the following application areas: AC/DC, Acoustics, Chemical Engineering, Earth Science, Heat Transfer, MEMS, RF, and Structural Mechanics. The COMSOL Multiphysics software also has other supporting software, such as the CAD Import Module and the Material Library.

In this book, scientists, engineers, and others interested in exploring the behavior of different physical device structures through computer modeling are introduced to the techniques of hands-on building and solving models through the direct application of the COMSOL Multiphysics software, the AC/DC Module, the Heat Transfer Module, and the RF Module. Chapter 9 explores the use of perfectly matched layers (PML) in the RF Module. The final technical chapter (Chapter 10) explores the use of the bioheat equation in the Heat Transfer Module.

The models presented here are built within the context of the physical world (applied physics) and are presented in light of first principles analysis techniques. As with any other methodology of problem solution, the information derived from the modeling solutions through use of these computer simulations is only as good as the materials coefficients and the fundamental assumptions employed in building the models.

The primary advantage derived from combining computer simulation and first principles analysis is that the modeler can try as many different approaches to the solution of the same problem as needed to get it right (or at least close to right) in the workshop or laboratory before the first device components are fabricated and tested. The modeler can also use the physical device test results to modify the model parameters and arrive at a final solution more rapidly than by simply using the cut-and-try methodology.

### Chapter Topics

This book comprises ten technical chapters. Its primary focus is to demonstrate to the reader the hands-on technique of model building and solving. The COMSOL Concepts and Techniques are shown in Figure 1. The COMSOL modules employed in the various
<table>
<thead>
<tr>
<th>Concept/Technique</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
<th>9</th>
<th>10</th>
</tr>
</thead>
<tbody>
<tr>
<td>1D PDE modeling</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2D Axisymmetric coordinates</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2D Axisymmetric modeling</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2D Modeling</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3D Modeling</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Animation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Azimuthal inductive heating</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bioheat equation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Boundary conditions</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Boundary integration</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CAD drawings (geometry objects), export and import</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Conductive media Pc</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Constants, import and export</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cross-section plot</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cylindrical coordinates</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Deformed mesh – moving mesh (ALE)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Domain plot parameter</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Electromagnetics</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Electrostatic potentials</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Electro-thermal coupling</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Floating contacts</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Free mesh parameters</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Geometric assembly (pair creation across a boundary)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Global equations</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Heat transfer coefficients</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Imbalance-offset geometry</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Induction heating</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>In-plane electric currents</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>In-plane te waves</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Iterative solver</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Laprangerg parameters</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Laplacian operator</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Magnetostatic modeling</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Materials library</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum element size</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mesh mapping</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mixed-materials modeling</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mixed-mode modeling</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Opaque and transparent thermally conductive materials</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ordinary differential equation (ODE)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Parametric solutions</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Perfectly matched layers</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Periodic point conditions</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Perpendicular induction currents</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Polyline drawings</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Quadrilateral mesh (Quad)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Quasi-static solutions</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reference frame</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rotating machinery</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scalar expressions</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Scalar variables</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Static solutions</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Subdomain mesh</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Suppress subdomain</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Surface integrals</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thin layer approximation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thin layer subdomain</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Time-harmonic analysis</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Transient analysis</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Triangular mesh</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Weak constraints</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
models in specific chapters are shown in Figure 2, and the physics concepts and techniques employed in the various models in specific chapters are shown in Figure 3.

These grids link the overall presentation of this book to the underlying modeling, mathematical, and physical concepts. In this book, in contrast to some other books with which the reader may be familiar, key ancillary information, in most cases, is contained in the notes.

Please be sure to read, carefully consider, and apply, as needed, each note.

**Chapter 1. Modeling Methodology**

Chapter 1 begins the introduction to the modeling process by discussing the fundamental considerations involved: the hardware (computer platform), the coordinate systems (physics), the implicit assumptions (lower dimensionality considerations), and first principles analysis (physics). Three relatively simple 1D models are presented, built, and solved for comparison: one-pane, two-pane, and three-pane thermal insulation window structures. Comments are also included on common sources of modeling errors.

**Chapter 2. Materials and Databases**

Chapter 2 briefly introduces three sources of materials properties data: the COMSOL Material Library, MatWeb, and the PKS-MPD.

The COMSOL Material Library is a module that can be added to the basic COMSOL Multiphysics software package to expand the basic library that is already included. It contains data on approximately 2500 materials, including elements, minerals, soil, metal alloys, oxides, steels, thermal insulators, semiconductors, and optical materials. Each material can have up to 27 defined properties. Each of those defined properties is available as a function of temperature.

MatWeb is an online searchable subscription materials properties data source. MatWeb has three classes of access: Unregistered (free limited feature access), Registered Member (free expanded feature access), and Premium Member (fee-based access).
<table>
<thead>
<tr>
<th>Physics Concepts</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
<th>9</th>
<th>10</th>
</tr>
</thead>
<tbody>
<tr>
<td>AC induction</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Anisotropic conductivity</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td>Antennas</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Bioheat equation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td>Boltzmann thermodynamics</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td>Complex AC theory</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td>Complex impedance</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Concave mirror</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Coulomb gauge</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Dielectric lenses</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Distributed resistance</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Electrical impedance theory</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Electrochemical polishing</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Electrostatic potentials in different geometric configurations</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Faraday’s law</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>First Estimate Review</td>
<td></td>
<td>○</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Foucault (eddy) currents</td>
<td></td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fourier’s law</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Free-space permittivity</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Good first approximation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hall effect</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Hard and soft nonlinear magnetic materials</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Heat conduction theory</td>
<td>○</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Helmholtz coil</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td>○</td>
</tr>
<tr>
<td>Information transmission</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Insulated containers</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Joule heating</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Lorentz force</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Magnetic field</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Magnetic permeability</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Magnetic vector potential</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Magnetostatics</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Maxwell’s equations</td>
<td>○</td>
<td>○</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mechanical to electrical energy conversion</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Microwave irradiation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Newton’s law of coding</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ohm’s law</td>
<td>○</td>
<td>○</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Optical (laser) irradiation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Pennes’s equation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Perfectly matched layers: 2D planar, 3D cartesian cylindrical and Spherical</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Perfusion</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Planck’s constant</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Power transmission grids, AC and DC</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Power transmission, AC and DC</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reactance</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Semiconductor dual carrier types</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Skin depth</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Soliton waves</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Telegraphs equation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>○</td>
</tr>
<tr>
<td>Thin layer resistance</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vacuum</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vector dot product current (K*Nj, DC)</td>
<td>○</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
access to all features, plus selected data storage and modeling software formatted data export). MatWeb has 69,000 data sheets for materials, including plastics, metals, ceramics, semiconductors, fibers, and various other commercially available materials.

PKS-MPD (Pryor Knowledge Systems—Materials Properties Database) is a new searchable materials properties database with data on more than 4000 materials, including elements, minerals, soil, metal alloys, oxides, steels, thermal insulators, semiconductors, optical materials, and biomaterials (tissue). Each material can have up to 43 defined properties. Each of those defined properties is associated with the temperature of measurement and the frequency of measurement. The collection of defined properties for each materials property datum is exportable in a format suitable for use with the COMSOL Multiphysics software.

### Chapter 3. 1D Modeling

The first half of Chapter 3 models the 1D KdV equation and two variations. The KdV equation is a powerful tool that is used to model soliton wave propagation in diverse media (e.g., physical waves in liquids, electromagnetic waves in transparent media). It is easily and simply modeled with a 1D PDE mode model.

The second half of Chapter 3 models the 1D telegraph equation and two variations. The telegraph equation is a powerful tool that is used to model wave propagation in diverse transmission lines. It can be used to thoroughly characterize the propagation conditions of coaxial lines, twin pair lines, and microstrip lines, among other things. The telegraph equation is easily and simply modeled with a 1D PDE mode model.

### Chapter 4. 2D Modeling

The first half of Chapter 4 models the 2D electrochemical polishing model. This model is a powerful tool that can be used to model surface smoothing for diverse projects (e.g., microscope samples, precision metal parts, medical equipment and tools, large and small metal drums, thin analytical samples, vacuum chambers).

The second half of Chapter 4 models the 2D Hall effect. The 2D Hall Effect model is a powerful tool that can be used to model Hall effect magnetic sensors for sensing fluid flow, rotating and linear motion, proximity, current, pressure, and orientation.

### Chapter 5. 2D Axisymmetric Modeling

The first half of Chapter 5 models three 2D axisymmetric cylinder conduction models. From a comparison of the three models, it can be readily observed that the presence of a vacuum cavity significantly reduces the rate of heat flow through the model and raises the equilibrium temperature at the surface receiving the heat flux.
The second half of Chapter 5 models three 2D axisymmetric thermos container models. From a comparison of the three models, it can be readily observed that the presence of a vacuum cavity significantly reduces the rate of heat flow through the model and the associated heat loss.

**Chapter 6. 2D Simple Mixed-Mode Modeling**

The first half of Chapter 6 models three 2D resistive heating models. These models are more illustrative of the mixed-mode modeling concept than they are directly amenable to the comparison of calculated values. They present different examples of the diversity of applied scientific and engineering model designs that can be explored using electro-thermal coupling and transient analysis. These models also demonstrate the significant power of relatively simple physical principles, such as Ohm’s law and Joule’s law.

The second half of Chapter 6 models three 2D axisymmetric inductive heating models. These models demonstrate the difference in level of complexity between single-coil and multi-coil models. In the Inductive_Heating_1 model, the concept of inductively produced heating is introduced. In the Inductive_Heating_2 model, the concept of inductively produced heating is applied to a practical application (a heated crucible) so as to present one example of the diverse applied scientific and engineering model designs that can be explored using electro-thermal coupling and transient analysis. In the Inductive_Heating_3 model, the crucible is filled with a commonly used metal for melting.

These models are examples of the good first approximation type of model. In other words, they demonstrate the significant power of relatively simple physical principles, such as Ohm’s law and Joule’s law, when applied in the COMSOL Multiphysics modeling environment. They could, of course, be modified by the addition of calculations, insulating materials, and heat loss through convection, among other changes.

**Chapter 7. 2D Complex Mixed-Mode Modeling**

The first third of Chapter 7 introduces two 2D electric impedance sensor models: basic and advanced. Those models employ high-frequency currents—1 MHz alternating currents AC—to explore the differential impedance within a body of material in a noninvasive fashion. Such currents are applied to the material of the modeled body to locate volumes that differ in impedance from the impedance of the bulk material by monitoring the local impedance.

The basic version models the location of a fixed-volume impedance difference. The advanced version models the location of a fluctuating difference volume, as might be seen in a medical application measuring lung function. 2D electric impedance tomography research is currently exploring the application of this type of impedance...
sensing measurement technology to the detection of breast cancer, lung function, brain function, and numerous other areas.

The second third of Chapter 7 introduces two 2D AC generator models: static and transient. These models generate low-frequency (60 Hz) current and voltage, as would be typically found on the power transmission grid. They demonstrate the use of both hard (not easily magnetized) and soft (easily magnetized) nonlinear magnetic materials in the construction of rotating machines for the conversion of mechanical energy to electrical energy.

The last third of Chapter 7 introduces two 2D AC generator sector models: static and transient. These models generate low-frequency (60 Hz) current and voltage, as would be typically found on the power transmission grid. They demonstrate the use of both hard (not easily magnetized) and soft (easily magnetized) nonlinear magnetic materials in the construction of a rotating machine for the conversion of mechanical energy to electrical energy. An ordinary differential equation (ODE) is incorporated into the sector model to handle the torque-related aspects of the model calculations.

Chapter 8. 3D Modeling

The first third of Chapter 8 models the 3D thin layer resistance model, thin layer approximation, and the thin layer resistance model, thin layer subdomain. The first model employs the thin layer approximation to solve a model by replacing the center domain with a contact-resistance identity pair. Such an approximation has broad applicability. It is important to note that the use of the thin layer approximation is applicable to any problem in which flow is described by the divergence of a gradient flux (e.g., diffusion, heat conduction, flow through porous media under Darcy’s law).

The application of the thin layer approximation is especially valuable to the modeler when the differences in domain thickness are so great that the mesh generator fails to properly mesh the model or creates more elements than the modeling platform can handle (“run out of memory” problem). In those cases, this approximation may enable a model to be solved that would otherwise fail.

A direct comparison is made of the model solutions by comparing the results obtained from the cross-section plots. As seen from the examination of those plots, the only substantial difference between the two solutions is the electrical potential difference across subdomain 2 (the thin layer). Thus the modeler can choose the implementation that best suits his or her system and time constraint needs, without suffering excessive inaccuracies based on the approximation method.

The second third of Chapter 8 introduces the 3D electrostatic potential model. This modeling technique demonstrates one of the methods that can be used by the modeler to explore electrostatic potentials in different geometric configurations. It can be applied to both scientific and engineering applications (e.g., ranging from X-ray
tubes and particle accelerators to paint sprayers and dust precipitators). The 3D_ESP_2 model is typical of those that might be found in a particle beam analyzer or a similar engineering or scientific device.

The last third of Chapter 8 models the 3D magnetic field of a Helmholtz coil. This model demonstrates the magnetic field uniformity of a Helmholtz coil pair. This magnetostatic modeling technique can be applied to a diverse collection of scientific and engineering applications (e.g., ranging from magnetometers and Hall effect sensors to biomagnetic and medical studies).

A related model, the 3D magnetic field of a Helmholtz coil with a magnetic test object, demonstrates the magnetic field concentration when a high relative permeability object lies within the field of the Helmholtz coil. This magnetostatic modeling technique can be applied to a diverse collection of scientific and engineering test, measurement, and design applications.

## Chapter 9. Perfectly Matched Layer Models

The first half of Chapter 9 introduces the 2D dielectric lens models, with and without perfectly matched layers (PMLs). [The PML model best approximates a free space environment (no reflections).] Comparison is made between the two models. The differences in the electric field, $z$-component visualizations between the PML and no-PML models amount to approximately 2%. Depending on the nature of the problem, such differences may or may not be significant. What these differences show the modeler is that he or she needs to understand the application environment well so as to build the best model. For other than free space environments, the modeler needs to determine the best boundary condition approximation using standard practices and a first principles approach. Always do a first principles analysis of the environment before building the model.

The second half of Chapter 9 introduces the 2D concave mirror models, with and without PMLs. There are only small differences in the electric field, $z$-component visualizations between the PML and no-PML models for the concave mirror. This lack of large differences between the PML and no-PML models again shows the modeler that he or she needs to understand the relative importance of the modeled values to evaluate the application and the application environment so as to build the best model.

## Chapter 10. Bioheat Models

The bioheat equation plays an important role in the development and analysis of new therapeutic medical techniques (e.g., killing of tumors). If the postulated method raises the local temperature of the tumor cells without excessively raising the temperature of the normal cells, then the proposed method will probably be successful.
The results (estimated time values) from the model calculations will significantly reduce the effort needed to determine an accurate experimental value. The guiding principle needs to be that tumor cells die at elevated temperatures. The literature cites temperatures that range from 42 °C (315.15 K) to 60 °C (333.15 K).

The first half of Chapter 10 models the bioheat equation as applied with a photonic heat source (laser). The second half of the chapter models the bioheat equation as applied with a microwave heat source.

NOTE: Executable copies of each model and related animations are available in full color on the accompanying DVD.
Guidelines for New COMSOL® Multiphysics® Modelers

Hardware Considerations

Coordinate Systems

Implicit Assumptions

1D Window Panes Heat Flow Models

1D Single-Pane Heat Flow Model

1D Dual-Pane Heat Flow Model

1D Triple-Pane Heat Flow Model

First Principles Applied to Model Definition

Common Sources of Modeling Errors

Guidelines for New COMSOL® Multiphysics® Modelers

Hardware Considerations

There are two basic rules to selecting hardware that will support successful modeling. First, new modelers should be sure to determine the minimum system requirements that their version of COMSOL® Multiphysics® software needs before borrowing or buying a computer to run their new modeling software. Second, these new modelers should run their copy of COMSOL Multiphysics software on the best platform with the highest processor speed and the most memory obtainable: The bigger and faster, the better. It is the general rule that the speed of model processing increases directly as a function of the processor speed, the number of platform cores, and the available memory.

NOTE: The number of platform cores is equal to the number of coprocessors designed into the computer (e.g., one, two, four, eight, ...).

The platform that this author uses is an Apple® Mac Pro®, running Mac OS X® version 10.5.x, and also running Parallels Desktop® 3.x with Microsoft® Windows XP®.
This Mac Pro has four 3 GHz cores and 16 GB of RAM. This platform, as configured, is more powerful, more versatile, more stable, and more cost-effective than other potential choices. It can handle complex 3D models in short computational times (more speed, more memory)—that is, in minutes instead of the hours that may be required by less powerful systems. This configuration can run any of the 32-bit COMSOL Multiphysics software, when using COMSOL Multiphysics Version 3.4. The Apple hardware is configured for 64-bit processing and will run at the 64-bit rate when using COMSOL Multiphysics Version 3.5. If new modelers desire a different 64-bit operating system than Macintosh OS X, then they will need to choose either a Sun® or a Linux® platform, using UNIX® or a PC with a 64-bit Microsoft Windows operating system.

The “3 GHz” specification is the operating speed of each of the cores and the “16 GB” is the total shared random access memory (RAM). The “64-bit” refers to the width of a processor instruction.

Once the best available processor is obtained, within the constraints of your budget, install your copy of COMSOL Multiphysics software, following the installer instructions. Once installed, COMSOL Multiphysics software presents the modeler with a graphical user interface (GUI). For computer users not familiar with the GUI concept, information in such an interface is presented primarily in the form of pictures with supplemental text, not exclusively text.

**Coordinate Systems**

Figure 1.1 shows the default (x-y-z) coordinate orientation for COMSOL modeling calculations. This coordinate system is based on the right-hand rule.

The right-hand rule is summarized by its name. Look at your right hand, point the thumb up; point your first finger away from your body, at a right angle (90 degrees) to your thumb; and point your second finger at a right angle to the thumb and first finger, parallel to your body. Your thumb represents the z-axis, your first finger represents the x-axis, and your second finger represents the y-axis.

In this right-handed coordinate system, x rotates into y and generates z. If you have a need to convert your model from the x-y-z frame to a Spherical Coordinate frame, then the transformation can be implemented using built-in COMSOL mathematical functions. The x-y-z to spherical coordinate conversion is achieved through the following equations:

Spherical radius \( r \): \[ r = \sqrt{x^2 + y^2 + z^2} \]  (1.1)
The built-in function \( \sqrt{\text{argument}} \) indicates that COMSOL Multiphysics will take the positive square root of the argument contained between the parentheses. The built-in function \( \tan2(\text{argument}) \) indicates that COMSOL Multiphysics will convert the argument contained between the parentheses to an angle in radians (in this case, phi). The built-in function \( \cos(\text{argument}) \) indicates that COMSOL Multiphysics will convert the argument contained between the parentheses to an angle in radians (in this case, theta).

To employ these spherical conversion equations in your model, you will need to start COMSOL Multiphysics, select “3D” in the Model Navigator Screen, select the desired Application Mode, and click the OK button. Using the pull-down menu, select Options > Expressions > Scalar Expressions and then enter equations 1.1, 1.2, and 1.3 in the Scalar Expressions window, as shown in Figure 1.2.
When a list of operations is presented sequentially (A > B > C > D), the modeler is expected to execute those operations in that sequence in COMSOL.

Once these equations are available in the model, the $x$-$y$-$z$ coordinates can be converted as shown in Figures 1.3 and 1.4.

The rotational sense of an angular transform is determined by viewing the angular rotation as one would view a typical analog clock face. The vector $\mathbf{r}$ rotating from $x$ into $y$ for a positive angle $\phi$ is counterclockwise, because $\phi$ equals zero at the positive $x$-axis. The vector $\mathbf{r}$ rotating from $z$ into $x$ for a positive angle $\theta$ is clockwise, because $\theta$ equals zero at the positive $z$-axis.
As all potential COMSOL modelers know, the Cartesian ($x$-$y$-$z$) and Spherical Coordinate ($r$-phi-theta) reference frames are not the only coordinate systems that can be used as the basis frame for Multiphysics models. In fact, when you first open the Model Navigator, you are given the option and are required to choose one of the following modeling coordinate systems: 1D, 2D, 3D, Axial Symmetry (1D), or Axial Symmetry (2D). The coordinate system that you choose determines the geometry and specific subgroup of COMSOL Application Modes that can be applied in that selected geometry (geometries).

**NOTE** An Application Mode is the initial collection of equations, independent variable(s), dependent variable(s), default settings, boundary conditions, and other properties that are appropriate for the solution of problems in that branch of physics (e.g., acoustics, electromagnetics, heat transfer). As indicated by the name “Multiphysics,” multiple branches of physics can be applied within each model. Diverse models that demonstrate the application of the multiphysics concept will be explored in detail as this book progresses.

### Implicit Assumptions

A modeler can generate a first-cut problem solution as a reasonable estimate, by choosing initially to use a lower-dimensionality coordinate space than 3D (e.g., 1D, 2D Axisymmetric). By making a low-dimensionality geometric choice, a modeler can significantly reduce the total time needed to achieve a detailed final solution for the chosen prototype model. Both new modelers and experienced modelers alike must be especially careful to fully understand the underlying (implicit) assumptions, unspecified conditions, and default values that are incorporated into the model as a result of simply selecting the lower-dimensionality geometry.
A first-cut solution is the equivalent of a back-of-the-envelope or on-a-napkin solution. Solutions of this type are relatively easy to formulate, are quickly built, and provide a first estimate of whether the final solution of the full problem is deemed to be (should be) within reasonable bounds. Creating a first-cut solution will often allow the modeler to decide whether it is worth the time and money required to create a fully implemented higher-dimensionality (3D) model.

Space, as all modelers know, comes with four basic dimensions: three space dimensions \((x-y-z)\) and one time dimension \((t)\). For example, the four dimensions might be \(x-y-z-t\), or \(r-\phi-\theta-t\). Relativistic effects can typically be neglected, except in cases of high velocity or ultra-high accuracy. Neither of these types of problems will be covered in this book.

Relativistic effects typically become a concern only for bodies in motion with a velocity approaching that of the speed of light \((\sim 3.0 \times 10^8 \text{ m/s})\) or for ultra-high resolution time calculations at somewhat lower velocities.

The types of calculations presented within this book are typically for steady-state models or for relatively low-velocity transient model solutions. Any transient solution model can be solved using a quasi-static methodology.

In a steady-state model, the controlling parameters are defined as numerical constants and the model is allowed to converge at the equilibrium state defined by the specified constants. In the quasi-static methodology, a model solution to a problem is found by initially treating the model as a steady-state problem. Incrementally modifying the modeling constants then moves the model problem solution toward the desired transient solution.

### 1D Window Panes Heat Flow Models

Consider, for example, a brief comparison between a relatively simple 1D heat flow model and the identical problem presented as a 3D model. The models considered here are those of a single-pane, dual-pane, or triple-pane window mounted in the wall of a building on a typical winter’s day. The questions to be answered are Why use a dual-pane window? and Why use a triple-pane window?

#### 1D Single-Pane Heat Flow Model

Run the COMSOL Multiphysics application. Select “New” and then select “1D” in the Model Navigator. Then select “COMSOL Multiphysics.” Select “Heat Transfer” followed by “Conduction” and then “Steady-state analysis.” Click OK.
After the 1D workspace appears, enter the constant values needed for this model: Use the menu bar to select Options > Constants. Enter the following items: T_in tab 70[degF] tab Interior Temperature tab T_out tab 0[degF] tab Exterior Temperature tab p tab 1[atm] (in Version 3.4) or 1.01325e5[Pa] (for earlier versions) tab air pressure tab; see Figure 1.5. Click the Apply button. These entries in the Constants window define the Interior Temperature, the Exterior Temperature, and the air pressure for use in this model. Click on the disk icon in the lower-left corner of the Constants window (Export Variables to File) to save these constants as ModelOC_1D_WP1.txt for use in the comparison models to follow later in this chapter. Click the OK button.

Next, draw a line to represent the thickness of a 1D window pane: Use the menu bar and select Draw > Specify Objects > Line. Enter the following: 0.000 space 0.005; see Figure 1.6. Leave the default Polyline, and click the OK button. Click the Zoom Extents icon in the toolbar.

Once the Zoom Extents icon is clicked, the specified 0.005 m line will appear in the workspace, as shown in Figure 1.7.

After the 0.005 m line has been created in the workspace, use the menu bar and select Physics > Subdomain Settings > 1. The window shown in Figure 1.8 contains the known properties of copper (Cu) as the default materials properties values.
COMSOL Multiphysics software is based on the Finite Element Method (FEM). To ensure that it is as easy as possible to use out of the box for modelers, both new and experienced, COMSOL inserts default materials properties and numerical parameters settings values to avoid singularities and other errors in the calculation of solutions. The modeler will need to verify that all materials and parameter values that are incorporated into their particular models are the appropriate values for the desired solution.
If copper is not the material of choice, as in this heat transfer model, then the materials property values need to be changed.

The implicit assumption here would be that the default values in the Subdomain Settings window are the correct values that the modeler needs to build the desired model. Specifically, that assumption would be true only if the modeler were building the heat transfer model using copper. In general, that implicit assumption is not correct. The modeler needs to know before building any new models what the approximate expected values are for the particular properties of the materials selected for use in the model. A number of sources have detailed materials properties values available: Some sources are available at no cost, while other sources have different levels of availability for different fees. Materials properties sources are discussed in Chapter 2.

For this model, click the Load button, and then select “Basic Materials Properties” and “Silica Glass.” Click OK. All the appropriate values displayed in the Value/Expression subwindows in the Subdomain Settings window are altered as the new values are loaded from the library. (Silica glass has a thermal conductivity value roughly 0.35% of that of copper.)

Once the thermal conductivity is loaded from the materials properties library, enter \( T_{in} \) in the \( T_{ext} \) and \( T_{amb} \) windows, as shown in Figure 1.9.

Click the Init button and enter \( T_{in} \) as shown in Figure 1.10. Click OK. Setting the \( T_{in} \) value as the initial temperature of the window pane (subdomain 1) allows for quicker convergence of the model and avoids any singularities.
Now the modeler needs to enter the appropriate Boundary Settings. Using the menu bar, select Physics > Boundary Settings. After the Boundary Settings window appears, as shown in Figure 1.11, select “1” in the Boundary Settings Boundary selection window.

![Boundary Settings window](image)

**Figure 1.10** 1D Subdomain Settings Init window settings

Now the modeler needs to enter the appropriate Boundary Settings. Using the menu bar, select Physics > Boundary Settings. After the Boundary Settings window appears, as shown in Figure 1.11, select “1” in the Boundary Settings Boundary selection window.

![Boundary Settings window](image)

**Figure 1.11** Boundary Settings window
Next, select “Heat flux” from the Boundary conditions pull-down menu. Enter 15 in the Heat transfer coefficient window (h). Enter T_in in the External temperature window (T_{inf}). Enter T_in in the Ambient temperature window (T_{amb}). Click the Apply button. Figure 1.12 shows the filled-in Boundary Settings window for boundary 1.

Now select “2” in the Boundary Settings Boundary selection window. Select “Heat flux” as the Boundary condition. Enter 15 in the Heat transfer coefficient window (h). Enter T_{out} in the External temperature window (T_{inf}). Enter T_{out} in the Ambient temperature window (T_{amb}). Click the Apply button. Figure 1.13 shows the filled-in Boundary Settings window for boundary 2. Click OK.

All the Subdomain Settings and the Boundary Settings have now been either chosen or entered. The next step is to mesh the model. In this simple model, all the modeler needs to do is use the toolbar and select “Initialize Mesh.” Figure 1.14 shows the initial mesh. The line segments between the dots are the mesh elements.

To improve the resolution, the mesh will be refined twice. All the modeler needs to do is use the toolbar and select Refine Mesh > Refine Mesh. The refined mesh of the single-pane model now contains the 60 elements shown in Figure 1.15, rather than the original 15 elements shown in Figure 1.14.

For this model, the software will be allowed to automatically select the Solver and Solver Parameters. To solve this model, go to the menu bar and select Solve > Solve Problem. The solution is found almost immediately, in 0.014 second. The solution is plotted using the default Postprocessing values and is shown in Figure 1.16.
The precise length of time required for the solution of a given model depends directly on the configuration of the platform and the overhead imposed by the operating system.

The implicit assumption here would be that the default values in the Postprocessing window are the correct values that the modeler needs to plot the calculated results of the built model. Specifically, that assumption in general will not be true. For example, in the case of this model, the default plot is in Kelvins (K), when the modeler would probably prefer degrees Fahrenheit. Also, it would be helpful to show the change in temperature as a function of the distance into the window pane.

The modeler needs to know before building a new model what the approximate expected resultant values are for the particular properties of the materials selected for use in the model. A firm understanding of the basic physics involved and the appropriate conservation laws that apply to the model are required for analysis, understanding, and configuration of the Postprocessing presentation(s).

The plot presentation is changed as follows: Select Postprocessing > Plot Parameters from the menu bar. When the Plot Parameters window shown in Figure 1.17 appears, select “Line” (Figure 1.18) and then “°F (degF)” from the Unit pull-down bar.
Select “Use expression to color line.” Click the Color Expression button to display the Line Color Expression window (Figure 1.19). Select “°F (degF)” from the Unit pull-down bar. Click OK, and then click OK again. The Plot Presentation will be rendered as shown in Figure 1.20.

1D Single-Pane Analysis and Conclusions
The 1D single-pane window model, though simple, reveals several fundamental factors about the physics of heat flow through the single-pane window. The interior temperature $T_{\text{in}}$ was established at 70 °F. The exterior temperature $T_{\text{out}}$ was established at 0 °F. The calculated temperature at the midpoint of the single pane is the median value
**FIGURE 1.16** 1D single-pane window solution plotted using default values

**FIGURE 1.17** 1D single-pane Plot Parameters General window
The temperature difference between the inner surface of the pane and the outer surface of the pane is approximately 2 °F. The temperature difference between the air in the heated room (70 °F) and the interior surface of the single pane (35.9 °F) is approximately 34 °F. This temperature difference between the ambient temperature and the single-pane window will at least result in water vapor condensation (fogging) and heat loss to the exterior.

**NOTE** When building models, be sure to save early and often.
1D Dual-Pane Heat Flow Model

This 1D model explores the physics of a dual-pane window with an air space between the panes. This model is parametrically similar to the single-pane window model for ease of comparison of the modeling results.

Run the COMSOL Multiphysics application. Select “New” and then select “1D” in the Model Navigator. Select COMSOL Multiphysics > Heat Transfer > Conduction > Steady-state analysis. Click OK.

After the 1D workspace appears, use the menu bar to select Options > Constants. Import the file ModelOC_1D_WP1.txt saved earlier. To import this file, click on the Folder icon in the lower-left corner of the Constants window. These imported entries, as shown in Figure 1.21, define the Interior Temperature, the Exterior Temperature, and the air pressure for use in this model and the models to follow.

Modeling a dual-pane window requires that three lines be drawn in the workspace window. The drawn lines represent the left (first) pane, the air space, and the right (second) pane, respectively. To use the menu bar to draw the first line, select Draw > Specify Objects > Line. Enter 0.000 space 0.005 in the window, as shown in Figure 1.22. Leave the default Polyline, and click the OK button. Next, use the menu bar to draw the second line. Select Draw > Specify Objects > Line. Enter 0.005 space 0.015 in the window, as shown in Figure 1.23. Leave the default Polyline, and click the OK
button. Finally, using the menu bar, draw the third line. Select Draw > Specify Objects > Line. Enter 0.015 space 0.020 in the window. Leave the default Polyline, and click the OK button. Figure 1.24 shows the results of the model line creation before clicking the Zoom Extents icon in the toolbar.

Once the Zoom Extents icon is clicked, the specified dual-pane Window model will appear in the workspace as shown in Figure 1.25.

Next, using the menu bar, select Physics > Subdomain Settings. Once the Subdomain Settings window appears, select “1” in the Subdomain selection window. For this model, select Load > Basic Materials Properties > Silica Glass. Click OK. All the appropriate values displayed in the Value/Expression subwindows in the Subdomain Settings window are altered as the new values are loaded from the library. (Silica glass has a thermal conductivity value roughly 0.35% of that of copper.)

Once the thermal conductivity is loaded from the materials properties library, enter $T_{in}$ in the $T_{ext}$ and $T_{amb\text{trans}}$ windows, as shown in Figure 1.26. Click the Apply button.

Next, select “2” in the Subdomain selection window. For this model, select Load > Basic Materials Properties > Air, 1 atm. Click OK. All the appropriate values displayed in the Value/Expression subwindows in the Subdomain Settings window are altered as the new values are loaded from the library.

![1D dual-pane Constants specification window](image1)

**FIGURE 1.21** 1D dual-pane Constants specification window

![1D dual-pane Line specification window for the left pane](image2)

**FIGURE 1.22** 1D dual-pane Line specification window for the left pane
Once the thermal conductivity is loaded from the materials properties library, enter $T_{in}$ in the $T_{ext}$ and $T_{amb\text{trans}}$ windows, as shown in Figure 1.27. Click the Apply button.

Next, select “3” in the Subdomain selection window. For this model, Select Library materials list > Silica Glass. The previously selected values loaded from the materials library are loaded into this subdomain.

Once the thermal conductivity is loaded from the materials properties library, enter $T_{out}$ in the $T_{ext}$ and $T_{amb\text{trans}}$ windows, as shown in Figure 1.28. Click the Apply button.

Next, set the initial conditions for each subdomain (1, 2, 3) by clicking the Init button and then entering the initial conditions shown in Table 1.1. Click OK.

Now, the modeler needs to enter the appropriate Boundary Settings. Using the menu bar, select Physics > Boundary Settings, as shown in Figure 1.29.
Once the Boundary Settings window appears, select “1” in the Boundary selection window. Select “Heat flux” as the Boundary condition. Enter 15 in the Heat transfer coefficient window (h). Enter $T_{in}$ in the External temperature window ($T_{inf}$). Enter $T_{in}$ in the Ambient temperature window ($T_{amb}$). Click the Apply button. Figure 1.30 shows the filled-in Boundary Settings window for boundary 1.

**FIGURE 1.25** 1D dual-pane workspace after clicking the Zoom Extents icon

Once the Boundary Settings window appears, select “1” in the Boundary selection window. Select “Heat flux” as the Boundary condition. Enter 15 in the Heat transfer coefficient window (h). Enter $T_{in}$ in the External temperature window ($T_{inf}$). Enter $T_{in}$ in the Ambient temperature window ($T_{amb}$). Click the Apply button. Figure 1.30 shows the filled-in Boundary Settings window for boundary 1.

**FIGURE 1.26** 1D dual-pane Subdomain Settings Physics window settings, left pane
CHAPTER 1  MODELING METHODOLOGY

![FIGURE 1.27](image1.png)  1D dual-pane Subdomain Settings Physics window settings, air gap

**Table 1.1  Subdomain Settings, Initial Conditions**

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>1</th>
<th>2</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Init</td>
<td>$T_{in}$</td>
<td>$T_{in}$</td>
<td>$T_{out}$</td>
</tr>
</tbody>
</table>

![FIGURE 1.28](image2.png)  1D dual-pane Subdomain Settings Physics window settings, right pane
Now select “4” in the Boundary Settings Boundary selection window. Select “Heat flux” as the Boundary condition. Enter 15 in the Heat transfer coefficient window (h). Enter $T_{out}$ in the External temperature window ($T_{inf}$). Enter $T_{out}$ in the Ambient temperature window ($T_{amb}$). Click the Apply button. Figure 1.31 shows the filled-in Boundary Settings window for boundary 4. Click OK.
At this point, a new modeler probably wonders why no conditions have been specified for boundaries 2 and 3. The COMSOL Multiphysics software default condition is to automatically establish continuity for interior boundaries. The numbers for boundaries 2 and 3 are grayed out to indicate that they are not available for setting. The default boundary settings can be overridden, if needed, by the advanced modeler by clicking the Interior boundaries check box to make boundaries 2 and 3 accessible.

Once all the Subdomain Settings and the Boundary Settings for this model have been either chosen or entered, the next step is to mesh the model. In this simple model, all the modeler needs to do is use the menu bar and Select “Initialize Mesh.” Figure 1.32 shows the initial mesh with 16 elements.

The mesh will be refined twice to improve the resolution. All the modeler needs to do is use the toolbar and select Refine Mesh > Refine Mesh. The refined mesh of the dual-pane model now contains the 64 elements shown in Figure 1.33, rather than the original 16 elements shown in Figure 1.32.

For this model, the software will be allowed to automatically select the Solver and Solver Parameters. To solve this model, go to the menu bar and select Solve > Solve Problem. The solution is found almost immediately, in 0.317 second (the time to solution will vary, depending on the platform). The solution is plotted using the default Postprocessing values and is shown in Figure 1.34.
The implicit assumption here would be that the default values in the Postprocessing window are the correct values that the modeler needs to plot the calculated results of the built model. Specifically, that assumption in general will not be true. The modeler needs to know before building a new model what the approximate expected resultant values are for the particular properties of the materials selected for use in the model. A firm understanding of the basic physics involved and the appropriate conservation laws that apply to the model are required for analysis, understanding, and configuration of the Postprocessing presentation(s).

The plot presentation is changed as follows: Select Postprocessing > Plot Parameters from the menu bar. When the Plot Parameters window shown in Figure 1.35 appears, select “Line” (Figure 1.36) and then “°F (degF)” from the Unit pull-down bar (Figure 1.37). Select “Use expression to color lines.” Click the Color Expression button...
**FIGURE 1.34** 1D dual-pane window solution plotted using default values

**FIGURE 1.35** 1D dual-pane Plot Parameters General window
FIGURE 1.36  1D dual-pane Plot Parameters Line window

FIGURE 1.37  1D dual-pane window solution set to use °F
(Figure 1.38). Select “°F (degF)” from the Unit pull-down bar (Figure 1.39). Click OK, and then click OK again. The plot presentation will be rendered as shown in Figure 1.40.

**Dual-Pane Analysis and Conclusions**

The 1D dual-pane window model, though simple, reveals several fundamental factors about the physics of heat flow through the dual-pane window. The interior temperature \( T_{in} \) was established at 70 °F, as in the single-pane model. The exterior temperature \( T_{out} \) was established at 0 °F, as in the single-pane model. The calculated temperature at the midpoint of the single pane is the median value of the interior and
exterior temperatures, 35 °F. The temperature difference between the inner surface of the left pane and the outer surface of the left pane is approximately 0.48 °F. The temperature difference between the inner surface of the right pane and the outer surface of the right pane is also approximately 0.48 °F. The temperature difference between the inner surface and the outer surface of the dual-pane window is approximately 53 °F, as compared to approximately 2 °F for the single-pane window.

The temperature difference between the air in the heated room (70 °F) and the interior surface (61.5 °F) of the dual-pane window is approximately 8.5 °F. This small temperature difference will result in some heat loss and minimal water vapor condensation (fogging).

Compare the result for the dual-pane window to that of the single-pane window. The temperature difference between the air in the heated room (70 °F) and the interior surface of the single-pane window (35.9 °F) is approximately 34 °F. This temperature difference between the ambient temperature and the single-pane window will at least result in water vapor condensation (fogging) and heat loss to the exterior.

1D Triple-Pane Heat Flow Model

This 1D model explores the physics of a triple-pane window with an air space between each pair of panes. This model is parametrically similar to the single-pane and dual-pane models for ease of comparison of the modeling results.
Run the COMSOL Multiphysics application. Select “New” and then “1D” in the Model Navigator. Select COMSOL Multiphysics > Heat Transfer > Conduction > Steady-state analysis. Click the OK button.

After the 1D workspace appears, use the menu bar to select Options > Constants. Import the file ModelOC_1D_WP1.txt saved earlier. To import this file, click on the Folder icon in the lower-left corner of the Constants window. These imported entries, as shown in Figure 1.41, define the Interior Temperature, the Exterior Temperature, and the air pressure for use in this model and the models to follow.

Modeling a triple-pane window requires that five lines be drawn in the workspace window. The drawn lines represent the left (first) pane, the first air space, the center (second) pane, the second air space, and the right (third) pane, respectively. Use the toolbar to draw the first line: Select Draw > Specify Objects > Line. Enter 0.000 space 0.005 in the window. Leave the default Polyline, and then click the OK button. Next, use the menu bar to draw the remaining four lines, as indicated in Table 1.2. Then, click the Zoom Extents icon in the toolbar. The finished workspace configuration is shown in Figure 1.42.

### Table 1.2 Triple-Pane Window Workspace Lines

<table>
<thead>
<tr>
<th>Line</th>
<th>Start</th>
<th>End</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.000</td>
<td>0.005</td>
</tr>
<tr>
<td>2</td>
<td>0.005</td>
<td>0.015</td>
</tr>
<tr>
<td>3</td>
<td>0.015</td>
<td>0.020</td>
</tr>
<tr>
<td>4</td>
<td>0.020</td>
<td>0.030</td>
</tr>
<tr>
<td>5</td>
<td>0.030</td>
<td>0.035</td>
</tr>
</tbody>
</table>
Next, using the menu bar, select Physics > Subdomain Settings. Once the Subdomain Settings window appears, select “1” in the Subdomain selection window. For this model, select Load > Basic Materials Properties > Silica Glass. Click OK (see Figure 1.43). Enter the remaining Subdomain Settings as shown in Table 1.3.
Next, set the initial conditions for each subdomain (1, 2, 3, 4, 5) by clicking the Init button and then entering the initial conditions shown in Table 1.4. See Figure 1.44.

Having configured the Subdomain Settings for this model, the modeler needs to enter the appropriate Boundary Settings. Using the menu bar, select Physics > Boundary Settings. The Boundary Settings window appears, as shown in Figure 1.45.
Once the Boundary Settings window appears, select “1” in the Boundary selection window. Select “Heat flux” as the Boundary condition. Enter 15 in the Heat transfer coefficient window (h). Enter T\_in in the Ambient temperature window (T\_inf). Enter T\_in in the External temperature window (T\_amb). Click the Apply button. Figure 1.46 shows the filled-in Boundary Settings window for boundary 1.
remaining Boundary Settings as shown in Table 1.5. Click the Apply button after each entry, and click OK at the end of the process.

```
Table 1.5 Boundary Settings

<table>
<thead>
<tr>
<th>Boundary</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>condition</td>
<td>Heat flux</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>Heat flux</td>
</tr>
<tr>
<td>h</td>
<td>15</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>15</td>
</tr>
<tr>
<td>T_inf</td>
<td>T_in</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>T_out</td>
<td></td>
</tr>
<tr>
<td>T_amb</td>
<td>T_in</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>T_out</td>
<td></td>
</tr>
</tbody>
</table>

*Do not alter the default setting.
```

At this point, as mentioned in the discussion of the dual-pane window model, no conditions are specified for boundaries 2, 3, 4, and 5, because the COMSOL Multiphysics software default condition is to automatically establish continuity for interior boundaries. The numbers for boundaries 2, 3, 4, and 5 are grayed out to indicate that they are not available for setting. The default boundary settings can be overridden, if needed, by the advanced modeler.

Once all the Subdomain Settings and the Boundary Settings for this model have been either chosen or entered, the next step is to mesh the model. In this model, all the modeler needs to do is use the toolbar and select “Initialize Mesh.” Figure 1.47 shows the initial mesh with 16 elements.

To improve the resolution, the mesh will be refined twice. All the modeler needs to do is use the menu bar and select Refine Mesh > Refine Mesh. The refined mesh of the triple-pane model now contains the 64 elements shown in Figure 1.48, rather than the original 16 elements shown in Figure 1.47.
For this model, the software will be allowed to automatically select the Solver and Solver Parameters. To solve this model, go to the menu bar and select Solve > Solve Problem. The solution is found almost immediately, in 0.346 second (the length of time to solution will vary depending on the platform). The solution is plotted using the default Postprocessing values and is shown in Figure 1.49.
As noted earlier in the solutions of the single-pane and dual-pane models, the postprocessing parameters need to be altered to reveal the most information at a glance.

The plot presentation is changed as follows: Select Postprocessing > Plot Parameters from the menu bar. When the Plot Parameters window appears, select “Line” and then “°F (degF)” from the Unit pull-down bar. Select “Use expression to color lines.” Click the Color Expression button. Select “°F (degF)” from the Unit pull-down bar. Click OK and then click OK again. The plot presentation will be rendered as shown in Figure 1.50.

**Triple-Pane Analysis and Conclusions**

The 1D triple-pane window model reveals several fundamental factors about the physics of heat flow through the triple-pane window. The interior temperature $T_{in}$ was established at 70 °F, as in the single-pane and dual-pane models. The exterior temperature $T_{out}$ was established at 0 °F, as in the single-pane and dual-pane models. The temperature difference between the inner surface and the outer surface of the three different window types are compared as shown in Table 1.6.

The temperature difference between the air in the heated room (70 °F) and the interior surface of the triple-pane window (65.2 °F) is approximately 4.8 °F. This
minimal temperature difference will result in little heat loss and little, if any, water vapor condensation (fogging).

Comparing the results for the three different window configuration models shows that there will be a large reduction in heat loss and annoyance factors (condensation) associated with a change from a single-pane window to a dual-pane window design. The incremental cost of such a design change would typically be less than 100%. However, adding the third pane to the window design reduces the heat loss by only a few percentage points and adds little to the cosmetic enhancement of the design (lack of fogging).

One of the basic reasons for modeling potential products is to evaluate their relative performance before the actual building of a first experimental physical model. Comparison of these three window models allows such a comparison to easily be made on a “first principles” basis, which will be discussed in the following section of this chapter. That approach is known as the “Model first, build second” approach to engineering design. When the model properly incorporates the fundamental materials properties and design factors, both the time and the cost to develop a fully functional prototype product are significantly reduced.

### Table 1.6 Comparison of Single-, Dual-, and Triple-Pane Windows

<table>
<thead>
<tr>
<th></th>
<th>Single</th>
<th>Dual</th>
<th>Triple</th>
</tr>
</thead>
<tbody>
<tr>
<td>ΔT (°F) across all panes</td>
<td>2</td>
<td>53</td>
<td>60</td>
</tr>
<tr>
<td>ΔT (°F) inner pane surface to room ambient temperature</td>
<td>34</td>
<td>8.5</td>
<td>4.8</td>
</tr>
</tbody>
</table>

*Note: Some of the basic reasons for modeling potential products is to evaluate their relative performance before the actual building of a first experimental physical model. Comparison of these three window models allows such a comparison to easily be made on a “first principles” basis, which will be discussed in the following section of this chapter. That approach is known as the “Model first, build second” approach to engineering design. When the model properly incorporates the fundamental materials properties and design factors, both the time and the cost to develop a fully functional prototype product are significantly reduced.*

### First Principles Applied to Model Definition

*First principles analysis* is an analysis whose basis is intimately tied to the fundamental laws of nature. In the case of models described in this book, the modeler should be able to demonstrate both to himself or herself and to others that the calculated results derived from those models are consistent with the laws of physics and the observed properties of materials. Basically, the laws of physics require that what goes in (e.g., as mass, energy, charge) must come out (e.g., as mass, energy, charge) or must accumulate within the boundaries of the model.
In the COMSOL Multiphysics software, the default interior boundary conditions are set to apply the conditions of continuity in the absence of sources (e.g., heat generation, charge generation, molecule generation) or sinks (e.g., heat loss, charge recombination, molecule loss).

The careful modeler will be able to determine by inspection that the appropriate factors have been considered in the development of the specifications for the various geometries, for the material properties of each subdomain, and for the boundary conditions. He or she must also be knowledgeable of the implicit assumptions and default specifications that are normally incorporated into the COMSOL Multiphysics software model, when a model is built using the default settings.

Consider, for example, the three window models developed earlier in this chapter. By choosing to develop those models in the simplest 1D geometrical mode, the implicit assumption was made that the heat flow occurred in only one direction. That direction was basically normal to the surface of the window and from the high temperature (inside temperature) to the low temperature (outside temperature), as shown by the heat flow indicator in Figure 1.51.

That assumption essentially eliminates the consideration of heat flow along other paths, such as through the window frame, through air leaks around the panes, and so forth. It also assumes that the materials are homogeneous and isotropic, and that there are no thin thermal barriers at the surfaces of the panes. None of these assumptions is typically true in the general case. However, by making such assumptions, it is possible to easily build a first approximation model.
A first approximation model captures all of the essential features of the problem that needs to be solved, without dwelling excessively on minutiae. A good first approximation model will yield an answer that is sufficiently accurate to enable the modeler to determine whether he or she needs to invest the time and resources necessary to build a higher-dimensionality, significantly more-accurate model.

**Common Sources of Modeling Errors**

There are four primary sources of modeling errors: insufficient model preparation time, insufficient attention to detail during the model preparation and creation phase, insufficient understanding of the physical and modeling principles required for the creation of an adequate model, and lack of a comprehensive understanding of what defines an adequate model in the modeler’s context. The most common modeling errors are those that result from the modeler taking insufficient care in either the development of model details or the incorporation of conceptual errors and/or the generation of keying errors during data/parameter/formula entry.

**Note** One primary source of errors occurs during the process of naming variables. The modeler should be careful to never give the same name to his or her variables as COMSOL gives to the default variables. COMSOL Multiphysics software seeks a value for the designated variable everywhere within its operating domain. If two or more variables have the same designation, an error is created. Also, it is best to avoid human errors by using uniquely distinguishable characters in variable names (i.e., avoid using the lowercase “L,” the number “1,” and the uppercase “I,” which in some fonts are relatively indistinguishable; similarly, avoid the uppercase “O” and the number zero “0”). Give your variables meaningful names (e.g., T_in, T_out, T_hot). Also, variable names are case sensitive; that is, T_in is not the same as T_IN.

The first rule in model development is to define the nature of the problem to be solved and to specify in detail which aspects of the problem the model will address. The definition of the nature of the problem should include a hierarchical list of the magnitude of the relative contribution of physical properties vital to the functioning of the anticipated model and their relative degree of interaction.

**Note** Examples of typical physical properties that are probably coupled in any developed model are heat and geometrical expansion/contraction (liquid, gas, solid), current flow and heat generation/reduction, phase change and geometrical expansion/contraction (liquid, gas, solid) and/or heat generation/reduction, and chemical reactions. Be sure to investigate your problem and build your model carefully.
Having built the hierarchical list, the modeler should then estimate the best physical, least-coupled, lowest-dimensionality modeling approach to achieve the most meaningful first approximation model.

### Exercises

1. Build, mesh, and solve the 1D single-pane window problem presented earlier in this chapter.
2. Build, mesh, and solve the 1D dual-pane window problem presented earlier in this chapter.
3. Build, mesh, and solve the 1D triple-pane window problem presented earlier in this chapter.
4. Add a fourth pane, and build, mesh, and solve the problem. Analyze, compare, and contrast the results with the results of Exercises 1, 2, and 3.
In This Chapter

Materials and Database Guidelines and Considerations
COMSOL® Material Library Module: Searchable Materials Library
MatWeb: Searchable Materials Properties Website
PKS-MPD: Searchable Materials Properties Database

Materials and Database Guidelines and Considerations

Materials selection and definition are the most important tasks performed by the modeler during the preliminary stages of model building preparation. The selection of appropriate materials is vital to the ultimate functionality of the device or process being modeled. Once the modeler has decided on a good first approximation to the device/process being modeled, the materials selection process begins.

A good first approximation is a problem statement that incorporates all the essential (first-order) physical properties and functionality of the device/process to be modeled.

Not all properties of all materials are or can be incorporated into the modeling process at the same time, because modeling resources (e.g., computer memory, computer speed, number of cores) are limited. It is important that the modeler start the modeling process by building a model that incorporates the most critical physical and functional aspects of the developmental problem under consideration.

To put the problem in perspective, a simple search of the Web on the term “materials properties database” yields approximately 48 million hits. Obviously, the modeler is not going to exhaustively explore all such links.

 Exploration of any given subset of the 48 million links for the properties of specific materials will reveal several possible standard results: (1) those links do not have a value for the desired material property; (2) those links do have values for the desired material property, but in unconventional units that need to be converted and then
compared for relative accuracy and reliability; (3) some of those links do have values for the desired material property, in the desired units, that need to be compared for relative accuracy and reliability; (4) a link is found that has some of the desired properties for a particular material, but not all of the needed properties; and (5) once found, property values need to be hand-copied and hand-entered into the model. In any case, many hours can be spent trying to obtain and determine accurate values for specific properties of particular materials.

COMSOL® Multiphysics® software and the associated add-on modules include basic materials libraries. The information contained in those basic materials libraries may easily be enhanced by the addition of other materials properties data through several different means. This chapter discusses three solutions to the obtaining and supplying of materials properties values directly to COMSOL Multiphysics software models. Each of these three solutions approaches the problem solution from a different viewpoint, with the same desired result—that is, supplying the modeler with the best materials properties values available to meet the modeler’s needs.

COMSOL® Material Library Module: Searchable Materials Library

The COMSOL Material Library is a module that can be added through licensing to the basic COMSOL Multiphysics software package to expand the included basic library. The COMSOL Material Library Module has data on approximately 2500 materials including elements, minerals, soil, metal alloys, oxides, steels, thermal insulators, semiconductors, and optical materials, at the minimum. It is searchable by name, DIN, and UNS numbers. Each material can have a maximum of 27 defined properties. Each of those defined properties is available as a function of temperature.

There are two methods to gain access to the Material Library. The first method is through the Options menu. This path can be used to screen materials in advance of building a model. The second method is through the Load button on the Subdomain Settings page. This path incorporates the materials into the model library. Once the Material Library Module has been activated, the technique for using the library is the same. In this example, the Options menu route is used:

1. Activate the COMSOL Multiphysics application.
2. Select COMSOL Multiphysics > Heat Transfer > Convection and Conduction > Steady-state analysis. See Figure 2.1.
3. Click OK.
4. Select Options > Materials/Coefficients Library. See Figure 2.2.

The modeler can determine if the items in the Material Library Module are available by viewing the list in the Materials selection window. The first entry in the
FIGURE 2.1 Model Navigator window

FIGURE 2.2 Materials/Coefficients Library search and/or selection window
FIGURE 2.3 Materials/Coefficients Library Materials selection window

Materials selection list is Model (0), which indicates that none of the materials in any of the libraries have been selected for use in the current model. The second entry in the Materials selection list is Material Library (2542); it indicates that 2542 materials are available to be selected for use in the current model. See Figure 2.3.

Suppose, for example, the modeler is interested in the properties of copper and copper alloys. He or she would follow these steps:

1. Enter “copper” in the Search string window.
2. Click the Search button. The search results show 87 possible materials are in the library. See Figure 2.4.
3. Select Copper Alloys (84) > UNS C10100. The UNS C10100 is what is known as oxygen-free copper. This high-quality copper is widely used in the electronics industry. The properties of UNS C10100 are shown in the Material properties display window. See Figure 2.5.

4. To see only the defined properties, check the Hide undefined properties check box. See Figures 2.6 and 2.7.

A similar process can be followed for other material choices.

MatWeb: Searchable Materials Properties Website

MatWeb is an online searchable subscription materials properties data source. MatWeb has 69,000 data sheets for materials that include plastics, metals, ceramics, semiconductors, fibers, and various other commercially available materials. See Figure 2.8.

MatWeb has three classes of access: Un-Registered (free limited feature access), Registered Member (free expanded feature access), and Premium Member (fee-based access to all features, plus selected data storage and modeling software formatted data...
**FIGURE 2.6** Materials/Coefficients Library, UNS C10100 defined properties, first half

**FIGURE 2.7** Materials/Coefficients Library, UNS C10100 defined properties, second half
MatWeb, Your Source for Materials Information

What is MatWeb? MatWeb's searchable database of materials properties includes data sheets of thermoplastic and thermoset polymers such as ABS, nylon, polycarbonate, polyester, polyethylene and polypropylene; metals such as aluminum, cobalt, copper, lead, magnesium, nickel, steel, superalloys, titanium and zinc alloys; ceramics; plus semiconductors, fibers, and other engineering materials.

export). All features of the following example can be run (for free) as a Registered user, except for the export feature. To export the selected data, the modeler needs to acquire a Premium membership. See Figure 2.9.

The following example shows the results of a Premium membership search.

1. After login, select “Metal UNS Number” on the login home page. See Figure 2.10.
2. The Web page is shifted to the Metal Alloy UNS Number Search page. See Figure 2.11.

FIGURE 2.8 MatWeb site, home page

FIGURE 2.9 MatWeb membership level features comparison page

FIGURE 2.10 MatWeb selection search types, login home page
3. Select “UNS C10100” from the A to D drop-down list. See Figure 2.12.

4. Click the FIND button to the right of the selected material number. The search has found 22 data sheets for UNS C10100 (oxygen-free electronic-grade copper); see Figure 2.13.

5. Using the Task pull-down list in the menu bar, create a folder named Copper.

6. Select item 1. See Figure 2.14.

7. Select “Export to COMSOL” from the task list in the menu bar. The available properties values for UNS C10100 are exported as a text file to the modeler’s computer. See Figure 2.15.

   The exported file can be directly imported into COMSOL Multiphysics as follows:

   1. Open COMSOL Multiphysics in the application mode of choice.
   2. Using the menu bar, select Options > Materials/Coefficients Library.
   3. Click the Add Library button.

   There are many other features available to the Premium Member at the MatWeb website. Those features can be explored at the modeler’s convenience.
FIGURE 2.13  MatWeb search results for UNS C10100 (oxygen-free electronic-grade copper)

FIGURE 2.14  MatWeb selection of UNS C10100 (oxygen-free electronic-grade copper)
PKS-MPD (Pryor Knowledge Systems–Materials Properties Database)\textsuperscript{6,7} is a searchable materials properties database with data on more than 4000 materials, including elements, minerals, soil, metals, metal alloys, oxides, steels, thermal insulators, semiconductors, optical materials, and biomaterials (tissue). Each material can have a maximum of 43 defined properties. Each of those defined properties is associated with the temperature of measurement and the frequency of measurement, as available. The collection of defined properties for each materials property datum is exportable in a format suitable for the COMSOL Multiphysics software.

The PKS-MPD selection page, on first use, requires that the modeler choose the version of COMSOL Multiphysics software in use to correctly format the export files (the COMSOL Multiphysics version selection choice remains as chosen until later changed). See Figure 2.16.

Using the same example material as previously, UNS C10100 (oxygen-free electronic-grade copper), the selection criteria can be entered by at least two different paths. To use the first path:

1. Click the Composition tab and select Copper (Cu) from the pull-down list. See Figure 2.17.
2. Click the Add to Search button. See Figure 2.18.

The Selection Criteria window shows that the search yields 440 possible copper-containing candidate materials. Because oxygen-free electronic-grade copper is known to be very pure, the search can be narrowed by adding a specification of the compositional percentage of Cu to the search.

1. Select Copper (Cu) from the element pull-down list.
2. Check the Specify percentage range check box.
3. Enter Min. = 99.9 and Max. = 100 in the appropriate edit windows. See Figure 2.19.
4. Click the Add to Search button. See Figure 2.20.
FIGURE 2.16 PKS-MPD main selection page

FIGURE 2.17 PKS-MPD Composition selection page for Copper (Cu)
FIGURE 2.18  PKS-MPD Composition selection added page for Copper (Cu)

FIGURE 2.19  PKS-MPD Composition percentage range selection page for Copper (Cu)
The Selection Criteria window shows that the search yields three possible copper candidate materials. Click the Print Materials button to view the candidate materials and optionally print a data sheet. See Figure 2.21.

The remaining materials candidates are Copper; Copper (UNS C10100); and Copper Alloy, pure copper, UNS C10200.

1. Select “Copper (UNS C10100).” See Figure 2.22.
2. Double-click the selection to view the properties data for the candidate material(s). See Figure 2.23.
3. Click the Accept button (far right, check-marked button).
5. Click OK on the Page Setup window.
7. Click either the Cancel button or the Print button.
8. Click the Export to Model SW button.
### FIGURE 2.21 PKS-MPD Composition materials selection page for Copper (Cu)

<table>
<thead>
<tr>
<th>Material Name</th>
<th>MaterialChemSymbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copper</td>
<td>Cu</td>
</tr>
<tr>
<td>Copper (UNS C10100)</td>
<td>Cu+</td>
</tr>
<tr>
<td>Copper Alloy, pure copper, UNS C10200</td>
<td>99.95Cu</td>
</tr>
</tbody>
</table>

### FIGURE 2.22 PKS-MPD Print Materials selection page for Copper (UNS C10100)

<table>
<thead>
<tr>
<th>Material Name</th>
<th>MaterialChemSymbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copper</td>
<td>Cu</td>
</tr>
<tr>
<td>Copper (UNS C10100)</td>
<td>Cu+</td>
</tr>
<tr>
<td>Copper Alloy, pure copper, UNS C10200</td>
<td>99.95Cu</td>
</tr>
</tbody>
</table>
9. Select “Copper (UNS C10100)” See Figure 2.26.
10. Double-click “Copper (UNS C10100)” to verify the candidate material selection choice. See Figure 2.27.
11. Click the Accept button (far right, check-marked button).
12. Close the selection window. See Figure 2.28.
13. Click Yes.
14. Enter Copper (UNS C10100) in the Material Library Name Request window (to provide a name for the entry in the export log).
15. Click OK. See Figure 2.29.

**NOTE** In the case where the material property is measured under different conditions (e.g., temperature, frequency), the modeler must choose which value he or she wishes to export for use with the material.
<table>
<thead>
<tr>
<th>Property / Comments</th>
<th>Symbol / T0 Min</th>
<th>Value / T0 Max</th>
<th>UOM / T0 UOM</th>
</tr>
</thead>
<tbody>
<tr>
<td>Thermal expansion coeff. (alpha)</td>
<td>alpha</td>
<td>1.7700e+5</td>
<td>1/K</td>
</tr>
<tr>
<td>At 20-300 degC (68-570 degF) for ceramic-to-metal seals.</td>
<td></td>
<td>573.15</td>
<td></td>
</tr>
<tr>
<td>Yield Strength</td>
<td>Ys_pks</td>
<td>6.9000e+7</td>
<td>Pa</td>
</tr>
<tr>
<td>At 20-300 degC (68-570 degF) for ceramic-to-metal seals.</td>
<td></td>
<td>573.15</td>
<td>K</td>
</tr>
<tr>
<td>Tensile Strength (Syt)</td>
<td>Syt</td>
<td>2.0000e+8</td>
<td>Pa</td>
</tr>
<tr>
<td>At 20-300 degC (68-570 degF) for ceramic-to-metal seals.</td>
<td></td>
<td>573.15</td>
<td>K</td>
</tr>
<tr>
<td>Elongation modulus</td>
<td></td>
<td>45.0</td>
<td>%</td>
</tr>
<tr>
<td>At 20-300 degC (68-570 degF) for ceramic-to-metal seals.</td>
<td></td>
<td>573.15</td>
<td>K</td>
</tr>
<tr>
<td>Young's modulus (E)</td>
<td>E</td>
<td>1.1500e+11</td>
<td>Pa</td>
</tr>
<tr>
<td>At 20-300 degC (68-570 degF) for ceramic-to-metal seals.</td>
<td></td>
<td>573.15</td>
<td>K</td>
</tr>
<tr>
<td>Density (rho)</td>
<td>rho</td>
<td>8.9600</td>
<td>kg/m^3</td>
</tr>
<tr>
<td>Density may depend considerably on previous treatment.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Boiling Point</td>
<td>bpt_pks</td>
<td>2.8600</td>
<td>K</td>
</tr>
<tr>
<td>Heat Capacity (C)</td>
<td>C</td>
<td>380.0</td>
<td>J/(Kg*K)</td>
</tr>
<tr>
<td>Heat of fusion</td>
<td>th_pks</td>
<td>2.1180e+5</td>
<td>J/Kg</td>
</tr>
<tr>
<td>Thermal expansion coeff. (alpha)</td>
<td>alpha</td>
<td>1.6500e-5</td>
<td>1/K</td>
</tr>
<tr>
<td>Thermal conductivity (k)</td>
<td>k</td>
<td>393.9779</td>
<td>W/(m*K)</td>
</tr>
<tr>
<td>+/- 0.005 cal/cm^2/2/cm/s/K</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Electrical Resistivity (res)</td>
<td>res</td>
<td>1.6700e-8</td>
<td>Ohm-m</td>
</tr>
<tr>
<td>At 20 degC (68 degF).</td>
<td></td>
<td>293.15</td>
<td>K</td>
</tr>
<tr>
<td>Electrical Conductivity (sigma)</td>
<td>sigma</td>
<td>5.9770e+7</td>
<td>S/m</td>
</tr>
<tr>
<td>At 20 degC (68 degF). Derived from electrical resistivity.</td>
<td></td>
<td>293.15</td>
<td>K</td>
</tr>
<tr>
<td>Young's modulus (E)</td>
<td>E</td>
<td>1.1050e+11</td>
<td>Pa</td>
</tr>
<tr>
<td>Melting Point</td>
<td>mpT_pks</td>
<td>1.3560</td>
<td>K</td>
</tr>
<tr>
<td>+/- 0.1 degC</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Specific gravity</td>
<td></td>
<td>8.36</td>
<td>NONE</td>
</tr>
<tr>
<td>Derived from density in g/cm^3.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Young's modulus (E)</td>
<td>E</td>
<td>1.2800e+11</td>
<td>Pa</td>
</tr>
<tr>
<td>At room temperature 20 degC (69 degF).</td>
<td></td>
<td>293.15</td>
<td>K</td>
</tr>
<tr>
<td>Shear modulus (Gxy)</td>
<td>Gxy</td>
<td>4.6800e+10</td>
<td>Pa</td>
</tr>
<tr>
<td>At room temperature 20 degC (68 degF).</td>
<td></td>
<td>293.15</td>
<td>K</td>
</tr>
<tr>
<td>Poisson's Ratio (mu)</td>
<td>mu</td>
<td>3.0800e-1</td>
<td>NONE</td>
</tr>
<tr>
<td>At room temperature 20 degC (68 degF).</td>
<td></td>
<td>293.15</td>
<td>K</td>
</tr>
<tr>
<td>Yield Strength</td>
<td>Ys_pks</td>
<td>3.3300e+7</td>
<td>Pa</td>
</tr>
<tr>
<td>At room temperature 20 degC (69 degF).</td>
<td></td>
<td>293.15</td>
<td>K</td>
</tr>
</tbody>
</table>

FIGURE 2.24 PKS-MPD Material Properties Print Preview Page 1 for Copper (UNS C10100)
### Material Properties

<table>
<thead>
<tr>
<th>Property / Comments</th>
<th>Symbol/T0 Min</th>
<th>Value/T0 Max</th>
<th>UOM / T0 UOM</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tensile Strength (Syt) At room temperature 20 degC (68 degF)</td>
<td>Syt</td>
<td>293.15</td>
<td>2.0900e+8</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Elongation At room temperature 20 degC (68 degF)</td>
<td></td>
<td>33.3</td>
<td>293.15</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Element :</th>
<th>Percent Min</th>
<th>Percent Max</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copper (Cu)</td>
<td>99.99</td>
<td>99.99</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>MaterialType :</th>
</tr>
</thead>
<tbody>
<tr>
<td>Metal</td>
</tr>
<tr>
<td>Metal, Non-Ferrous</td>
</tr>
<tr>
<td>Alloy</td>
</tr>
</tbody>
</table>

**FIGURE 2.25** PKS-MPD Material Properties Print Preview Page 2 for Copper (UNS C10100)

**FIGURE 2.26** PKS-MPD Materials selection Properties display page for Copper (UNS C10100)
FIGURE 2.27 PKS-MPD Materials selection Properties display page for Copper (UNS C10100)

FIGURE 2.28 PKS-MPD Materials selected verification page for Copper (UNS C10100)
16. Select the Tensile Strength (Syt) for Copper (UNS C10100) at room temperature.  
17. Click Exit.  

Continue the selection process for each property as displayed. When finished, click the Exit button for each property. The file is then exported as a text file with library management data leading. Figure 2.30 shows the material properties exported.  

The exported file can be directly imported into COMSOL Multiphysics as follows:  

1. Open COMSOL Multiphysics in the application mode of choice.  
2. Using the menu bar, select Options > Materials/Coefficients Library.  
3. Click the Add Library button. See Figure 2.31.  
4. Select the newly exported Copper (UNS C10110) library. See Figure 2.32.
FIGURE 2.30  PKS-MPD Materials selection properties for Copper (UNS C10100) exported

FIGURE 2.31  Materials/Coefficients Library edit page
5. Click OK. The Copper (UNS C10100) (1) library is added as the last item on the Materials library list in the Materials window. See Figure 2.33.

6. Click OK.

The second method of Searching if the modeler knows the UNS number, is simply to enter that number.
1. Click the Clear button.
2. Select “Other Characteristics.”
3. Enter @UNS C10100@.
4. Click the Add to Search button. See Figure 2.34.
5. The search yields one candidate material. Click the Print Materials button. See Figure 2.35.

The rest of the instructions for printing, exporting, and adding materials properties to the COMSOL library are the same as given previously.
References

1. Explore the processes of finding and exporting materials properties with the COMSOL Material Library module presented in this chapter.

2. Explore the processes of finding and exporting materials properties with MatWeb as presented in this chapter.

3. Explore the processes of finding and exporting materials properties with PKS-MPD as presented in this chapter.
1D Guidelines for New COMSOL® Multiphysics® Modelers
1D Modeling Considerations
Coordinate System
1D KdV Equation: Solitons and Optical Fibers
COMSOL KdV Equation Model
First Variation on the KdV Equation Model
Second Variation on the KdV Equation Model
1D KdV Equation Models: Summary and Conclusions
1D Telegraph Equation
COMSOL 1D Telegraph Equation Model
First Variation on the Telegraph Equation Model
Second Variation on the Telegraph Equation Model
1D Telegraph Equation Models: Summary and Conclusions

1D Guidelines for New COMSOL® Multiphysics® Modelers

1D Modeling Considerations

1D modeling is both the least difficult and potentially the most difficult type of model to build, irrespective of the modeling software utilized. The least difficult aspect of 1D model building arises from the fact that the geometry is simple: In a 1D model, the modeler can have only a single line or a sequence of line segments as the modeling space. However, the physics in a 1D model can range from reasonably easy (simple) to extremely difficult (complex).

NOTE COMSOL® Multiphysics® software has two 1D modes: 1D (beginning-level through moderate-level modeling) and 1D Axisymmetric (advanced-level modeling). In keeping with the introductory focus of the material in this text, only 1D models (beginning-level through moderate-level models) will be presented. For information on the 1D Axisymmetric geometry, the associated physics, and the use of the same,
refer to the COMSOL manuals, the COMSOL website, and the general COMSOL Multiphysics software-related research literature.

The 1D model implicitly assumes that the energy flow, the materials properties, the environment, and any other conditions and variables that are of interest are homogeneous, isotropic, and constant, unless otherwise specified, throughout the entire domain of interest, both within the model and in the environs of the model. In other words, the properties assigned to the 1D model are representative of the properties of proximate nonmodeled regions. Bearing that in mind, the modeler needs to ensure that all modeling conditions and associated parameters have been properly considered, defined, or set to the appropriate values.

As mentioned earlier, it is always preferable for the modeler to be able to accurately anticipate the expected behavior (results) of the model. Calculated solution values that deviate widely from the expected values or from comparison values measured in experimentally derived realistic models are probably indicative of one or more modeling errors either in the original model design, in the earlier model analysis, or in the understanding of the underlying physics, or are simply due to human error.

**Coordinate System**

In a 1D model, there are only two coordinates: space \((x)\) and time \((t)\). In a steady-state solution, parameters vary only as a function of space \((x)\). In a transient solution model, parameters can vary both in space \((x)\) and in time \((t)\). The space coordinate \((x)\) typically represents distance throughout which the model is to calculate the change of the specified observables (i.e., temperature, heat flow, pressure, voltage, current).

To assist the reader to achieve a broader exposure to the applicability of physics discussed in this book and to demonstrate the power of 1D modeling techniques, modeling examples are presented that demonstrate techniques from two different, but similar, broadly applicable areas of physics. The examples presented explore wave propagation, in the broadest general sense.

### 1D KdV Equation: Solitons and Optical Fibers

The KdV equation\(^1\) is a well-known example of a group of nonlinear partial differential equations\(^2\) called exactly solvable.\(^3\) That type of equation has solutions that can be specified with exactness and precision.

Nonlinear partial differential equations play an extremely important role in the description of physical systems.\(^4\) Nonlinear partial differential equations are, by and large, inherently difficult to solve and require a unique approach for each equation type.
The KdV equation, solved in 1895 by Diederik Korteweg and Gustav de Vries, mathematically describes the propagation of a surface disturbance on a shallow canal. The effort to solve this wave propagation problem was undertaken based on observations by John Scott Russell in 1834, among others. Subsequent activity in this mathematical area has led to soliton application in magnetics and optics. Work on soliton propagation problems is currently an active area of research.

The following numerical solution model (KdV equation) was originally developed by COMSOL for distribution with the Multiphysics software as an equation-based model. Here, we will build the model as presented in the COMSOL Model Library and then explore variations and expansions on the model.

It is important for the new modeler to personally try to build each model presented within the text. There is no substitute for the hands-on experience of actually building, meshing, solving, and postprocessing a model. Many times the inexperienced modeler will make and subsequently correct errors, adding to his or her experience and fund of modeling knowledge. Even the simplest model will expand the modeler’s fund of knowledge.

The KdV equation (as written in standard notation) is

\[ \partial_t u + \partial_x^3 u + 6u \partial_x u = 0 \]  

(3.1)

In the COMSOL documentation, the formula is shown as

\[ u_t + uu_{xxx} = 6uu_x \ ] \Omega = [-8, 8] \]  

(3.2)

The difference between the two equations is that (3.2) is the negative form of (3.1), which will be adjusted during postprocessing.

The boundary conditions are periodic, as shown here:

\[ u(-8, t) = u(8, t) \quad \text{periodic} \]  

(3.3)

The initial condition for this model is

\[ u(x, 0) = -6 \sech^2(x) \]  

(3.4)

Once the modeler builds and solves this model, it will be seen that the pulse immediately divides into two soliton pulses, with different width and propagation speeds.

**COMSOL KdV Equation Model**

To start building the KdV_Equation_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “1D” from the Space dimension pull-down list. Select COMSOL Multiphysics > PDE Modes > PDE, General
CHAPTER 3  1D MODELING

Form > Time-dependent analysis. Type \(u_1\) space \(u_2\) in the dependent variables edit field. Click OK. Using the menu bar, select Options > Axes/Grid Settings. Enter \(-9\) tab \(9\) in the edit fields to define the \(x\) geometry. Click OK. See Figure 3.1.

Using the menu bar, select Draw > Specify Objects > Line. Enter \(-8\) space \(8\) in the Line edit window. Click OK. See Figure 3.2.

**FIGURE 3.1** 1D Axes/Grid Settings window (\(x\))

**FIGURE 3.2** 1D geometry for the KdV equation model
Periodic Boundary Condition Settings

For the new modeler unfamiliar with periodic boundary conditions, their use allows the domain (x values) of the model to be extended essentially indefinitely. For example, the modeling workspace of a line has two ends that would form two abrupt terminations, if not somehow compensated for. The use of periodic boundary conditions forms the line into a circle, which is mathematically infinite (endless).

Having established the 1D geometry (line), the next step is to define the fundamental physics conditions. From the menu bar, select Physics > Periodic Conditions > Periodic Boundary Conditions. After the Periodic Boundary Conditions window appears, on the Source page, select “1” in the Boundary selection window. See Figure 3.3.

Enter u1 in the Expression edit window, and then press the Enter key. The constraint name “pconstr1” will appear in the Constraint name column. See Figure 3.4.
Click the Destination tab. Select “2” as the boundary, and enter u1 in the edit window. See Figure 3.5.

Click the Source Vertices tab. Select “1” as the vertex, and then click the >> button. See Figure 3.6.

Click the Destination Vertices tab. Select “2” as the vertex, and then click the >> button. See Figure 3.7.

Click the Source tab. Select “1” as the boundary, and then type u2 in the second Expression window. Press the Enter key. The label “pconstr2” will appear in the Constraint name column. See Figure 3.8.

Click the Destination tab. Select “2” as the boundary, and then enter u2 in the Expression edit window. See Figure 3.9.
**FIGURE 3.7** Periodic Boundary Conditions window, Destination Vertices page, vertex 2

**FIGURE 3.8** Periodic Boundary Conditions window, Source page, boundary 1, variable u2

**FIGURE 3.9** Periodic Boundary Conditions window, Destination page
Click the Source Vertices tab. Select “1” as the vertex, and then click the >> button. See Figure 3.10.

Click the Destination Vertices tab. Select “2” as the vertex, and then click the >> button. See Figure 3.11. Click OK.

**Boundary Conditions Settings**

The next step is to set the boundary conditions. Using the menu bar, select Physics > Boundary Settings. Using Table 3.1 as a guide, on the Type page, select boundaries 1 and 2. Click the Neumann button, and then click the G tab. Verify or type 0 in each edit window. Click OK.
Boundary conditions settings specify the values that a solution to the problem being solved needs to take on at the boundary (edge). Two types of boundary conditions are used in this book: Dirichlet and Neumann. In the Dirichlet boundary condition, \( f(a) = n_1 \) and \( f(b) = n_2 \), where \( a, b \) are the boundary points and \( n_1, n_2 \) are given numbers.

In the Neumann boundary condition, \( df(a)/dx = n_3 \) and \( df(b)/dx = n_4 \), where \( a, b \) are the boundary points and \( n_3, n_4 \) are given numbers. Mixed boundary conditions, which are a more advanced topic and will not be covered here, are also possible.

Subdomain Settings

The next step in building the KdV equation model is to set the Subdomain Settings. Select Physics > Subdomain Settings. Once the Subdomain Settings window appears, select subdomain 1, and enter the coefficient values under the correct tab as shown in Table 3.2.

Once the PDE coefficients have been entered, Click the Init tab. Enter the initial conditions shown in Table 3.3, and then click OK.

### Table 3.1 Boundary Settings Window

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Boundary 1</th>
<th>Boundary 2</th>
<th>G(1)</th>
<th>G(2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Neumann</td>
<td>Neumann</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

### Table 3.2 Subdomain Settings window, PDE coefficients

<table>
<thead>
<tr>
<th>PDE Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \Gamma(1) )</td>
<td>u2</td>
</tr>
<tr>
<td>( \Gamma(2) )</td>
<td>u1x</td>
</tr>
<tr>
<td>( F(1) )</td>
<td>6<em>u1</em>u1x</td>
</tr>
<tr>
<td>( F(2) )</td>
<td>u2</td>
</tr>
<tr>
<td>( d_s(11) )</td>
<td>1</td>
</tr>
<tr>
<td>( d_s(12) )</td>
<td>0</td>
</tr>
<tr>
<td>( d_s(21) )</td>
<td>0</td>
</tr>
<tr>
<td>( d_s(22) )</td>
<td>0</td>
</tr>
</tbody>
</table>

### Table 3.3 Initial Conditions Window

<table>
<thead>
<tr>
<th>Initial Condition</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>( u1(t_0) )</td>
<td>(-6*sech(x)^2)</td>
</tr>
<tr>
<td>( u2(t_0) )</td>
<td>(-24<em>sech(x)^2</em>tanh(x)^2+12<em>sech(x)^2</em>(1-tanh(x)^2))</td>
</tr>
</tbody>
</table>
Mesh Generation

From the menu bar, select Mesh > Free Mesh Parameters. Type 0.1 in the Maximum element size edit window, as shown in Figure 3.12. The mesh consists of 160 elements. Click OK.

From the menu bar, select Mesh > Initialize Mesh. The result of the meshing operation is shown in Figure 3.13.
Solving the KdV Equation Model

First, using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver. Type linspace(0, 2, 81) in the Times edit window, as shown in Figure 3.14. This instruction divides the time-space into 81 equal intervals, in the period from 0 to 2 seconds.

When the instruction linspace(a, b, c) is typed, it must be typed with no space between the last “e” of “linspace” and the open parenthesis (of the argument specification (a, b, c). If it is not typed exactly this way, the COMSOL Multiphysics software will indicate an error!

Click the Time Stepping tab. Type 2 in the Maximum BDF order edit window, as shown in Figure 3.15. Click OK.

Using the menu bar, select Solve > Solve Problem. The solution that is immediately seen is the negated (–) solution at the last time interval (t = 2 seconds), as shown in Figure 3.16.
**FIGURE 3.15** Solver Parameters window, Time Stepping page

**FIGURE 3.16** Negated KdV model solution
Postprocessing

The positive solution can be viewed as follows: Select Postprocessing > Plot Parameters. Click the Line tab. Type –u1 in the Expression edit window. Click the Apply button. The positive results are shown in Figure 3.17.

Save the KdV Equation model as Model3_KdV_1.

The solution to the KdV equation can also be viewed as an animation. To view the solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears (see Figure 3.18), click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 3.19). Click the Start Animation button. Save the KdV equation model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie3_KdV_1.avi that was supplied with this book.

Many modelers are better able to understand the dynamics of the solution when the solution is presented as an animation. It is available in addition to the presentation of the solution as a series of static plots.

The file extension that is created during the Save operation is platform dependent. If the platform is a Power Mac® computer, the extension for an animation will be different (.mov) than that for a Mac® computer with Intel® processor or a PC (.avi). Either can be played using a free QuickTime® player (http://www.apple.com/quicktime).
Figure 3.18  KdV model solution Plot Parameters window, Line page

Figure 3.19  KdV model solution, Animate page
First Variation on the KdV Equation Model

The previous solution to the KdV equation results in two soliton pulses propagating in the same medium at the same time. Next, we will explore how the model behaves when the initial conditions are modified. In this case, the argument is made smaller.

Information transmission relies on the measurement of a difference. In Morse code (a time differentiation method), the difference is between a long pulse, a short pulse, and no pulse. No pulse signifies no message. Thus, even if a message was sent, if it was not received (detected), then the recipient of the non-message classifies the message traffic as zero. To receive a message, the received signal must be of adequate amplitude (analog), of adequate duration (time), and in the expected frequency band of the receiver. The signal amplitude must be sufficiently greater than the detection threshold to allow information to be collected. The signal-to-noise ratio determines the minimum detectable signal.8

The stable, long-distance, light pulses used to convey information through optical fibers are known as temporal solitons.9 To achieve detectability, the fiber is designed to compensate for dispersion (frequency spreading) and power loss.

First, save a copy of the just-created KdV equation model as Model3_KdV_2. You can then modify the KdV equation model without being concerned about damaging the original model.

If Model3_KdV_2 is already open on your desktop, skip to the “Scalar Expressions” section. If Model3_KdV_2 is not already open on your desktop, using the menu bar, select File > Open. When the Open Model window is displayed as in Figure 3.20, select “Model3_KdV_2.” Click OK.

Scalar Expressions

Using the menu bar, select Options > Expressions > Scalar Expressions. When the Scalar Expressions window opens, type x_a in the Name column and x/1.33 in the Expression column, as shown in Figure 3.21. Click OK.

The scalar expression that was just created will be used as the new argument for the initial conditions of the KdV equation model.

Having created the new scalar variable x_a, the next step is to modify the Initial Conditions expression(s).

Changing the Subdomain Settings

The next step in modifying the KdV equation model is to change the Subdomain Settings. Select Physics > Subdomain Settings. Once the Subdomain Settings window
appears, select subdomain 1. Verify that the coefficient value under each of the indicated tabs is as shown in Table 3.4.

Once the PDE coefficients have been verified, click the Init tab. Either modify the existing equations or enter the initial conditions shown in Table 3.5, and then click OK.
Table 3.4  Subdomain Settings Window, PDE Coefficients

<table>
<thead>
<tr>
<th>PDE Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>( G(1) )</td>
<td>( u_2 )</td>
</tr>
<tr>
<td>( G(2) )</td>
<td>( u_1 x )</td>
</tr>
<tr>
<td>( F(1) )</td>
<td>( 6 u_1 u_1 x )</td>
</tr>
<tr>
<td>( F(2) )</td>
<td>( u_2 )</td>
</tr>
<tr>
<td>( d_{a(11)} )</td>
<td>( 1 )</td>
</tr>
<tr>
<td>( d_{a(12)} )</td>
<td>( 0 )</td>
</tr>
<tr>
<td>( d_{a(21)} )</td>
<td>( 0 )</td>
</tr>
<tr>
<td>( d_{a(22)} )</td>
<td>( 0 )</td>
</tr>
</tbody>
</table>

Because the new KdV equation model is a revised copy of the original KdV equation model, the new model will need to be reset. Using the menu bar, select File > Reset Model.

NOTE: The Reset Model command clears the copied model of previous meshes and solutions.

Mesh Generation

From the menu bar, select Mesh > Free Mesh Parameters. Verify or type 0.1 in the Maximum element size edit window, as shown in Figure 3.22. Click OK.

From the menu bar, select Mesh > Initialize Mesh. The result of the meshing operation is shown in Figure 3.23.

Solving the First Revised KdV Equation Model

Using the menu bar, select Solve > Solver Parameters. Verify that the COMSOL Multiphysics software automatically selected the Time dependent solver. Verify or type linspace(0, 2, 81) in the Times edit window, as shown in Figure 3.24. This instruction divides the time-space into 81 equal intervals, in the period from 0 to 2 seconds.

Table 3.5  Initial Conditions Window

<table>
<thead>
<tr>
<th>Initial Condition</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>( u_1(t_0) )</td>
<td>(-6 \text{sech}(x_a)^2)</td>
</tr>
<tr>
<td>( u_2(t_0) )</td>
<td>(-24 \text{sech}(x_a)^2 \text{tanh}(x_a)^2 + 12 \text{sech}(x_a)^2 \times (1-\text{tanh}(x_a)^2))</td>
</tr>
</tbody>
</table>
Click the Time Stepping tab. Verify or type 2 in the Maximum BDF order edit window, as shown in Figure 3.25. Click OK.

Using the menu bar, select Solve > Solve Problem.

In this variation, the solution that is immediately seen is not the negated (−) solution at the last time interval. Instead, the solution shown is the positive solution.
FIGURE 3.24 Solver Parameters window

FIGURE 3.25 Solver Parameters window, Time Stepping page
of the KdV Equation, because the sign inversion (−) was adjusted in postprocessing of the copied model. The results of the changed argument solution are shown in Figure 3.26.

Save this KdV Equation model as Model3_KdV_2 to retain the current solution.

**Postprocessing Animation**

This solution to the KdV equation can also be viewed as an animation. To view the solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 3.27). Click the Start Animation button. Save this KdV equation model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie3_KdV_2.avi that was supplied with this book.

*NOTE* The reduction of the argument for the initial conditions results in the splitting of the initial, single soliton pulse into three separate soliton pulses that propagate through the medium (e.g., optical fiber) at three different velocities and arrive at the receiver at different times.

Adoption of either the first solution or the second solution in an information transmission system would cause serious message distortion or interference problems.
at the receiving site. These solutions would cause the same nature of interference as multiple-path propagation in atmospheric transmission (e.g., the same signal arriving several times at the same receiver in a slightly delayed mode).

**Second Variation on the KdV Equation Model**

The first revised solution to the KdV equation results in three soliton pulses propagating in the same medium at the same time. Next, we will explore how the model behaves when the initial conditions are again modified. In this case, the argument of the initial conditions will be increased in size.

---

**NOTE** Remember—information transmission relies on the measurement of a difference. Each pulse is one bit of information. No pulse signifies no message. Thus, even if a message was sent, if it was not received (detected), then the recipient of the non-message classifies the message traffic as zero.

To receive the correct message, the signal must be of adequate amplitude (analog), of adequate duration (time), in the expected frequency band of the receiver, and must correlate exactly with the message sent. The signal amplitude must be sufficiently greater than the detection threshold to allow information to be collected and must not contain spurious, random pulses.
First, save a copy of the just-created first variation on the KdV equation model as Model3_KdV_3. You can then modify the KdV equation model without being concerned about damaging the just-built model.

If Model3_KdV_3 is already open on your desktop, skip to the “Scalar Expressions” section. If Model3_KdV_3 is not already open on your desktop, using the menu bar, select File > Open. When the Open Model window is displayed as in Figure 3.28, select “Model3_KdV_3.” Click OK.

**Scalar Expressions**

Using the menu bar, select Options > Expressions > Scalar Expressions. When the Scalar Expressions window opens, verify or type x_a in the Name column and pi/2*x in the Expression column, as shown in Figure 3.29. Click OK.

The scalar expression that was just created will be used as the new larger argument for the initial conditions of the second variation on the KdV equation model.

Having created the new Scalar Variable x_a, the next step is to modify the Initial Conditions expression(s).
Changing the Subdomain Settings

The next step in modifying this version of the KdV equation model is to change the Subdomain Settings. Select Physics > Subdomain Settings. Once the Subdomain Settings window appears, select subdomain 1. Verify that the coefficient value assigned to each of the indicated tabs is as shown in Table 3.6.

Once the PDE coefficients have been verified, click the Init tab. Verify the existing equations or type the initial conditions found in Table 3.7, and then click OK.

Table 3.6 Subdomain Settings Window, PDE Coefficients

<table>
<thead>
<tr>
<th>PDE Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>$f(1)$</td>
<td>$u_2$</td>
</tr>
<tr>
<td>$f(2)$</td>
<td>$u_1x$</td>
</tr>
<tr>
<td>$f(1)$</td>
<td>$6u_1u_1x$</td>
</tr>
<tr>
<td>$f(2)$</td>
<td>$u_2$</td>
</tr>
<tr>
<td>$d_{a}(11)$</td>
<td>$1$</td>
</tr>
<tr>
<td>$d_{a}(12)$</td>
<td>$0$</td>
</tr>
<tr>
<td>$d_{a}(21)$</td>
<td>$0$</td>
</tr>
<tr>
<td>$d_{a}(22)$</td>
<td>$0$</td>
</tr>
</tbody>
</table>

Table 3.7 Initial Conditions Window

<table>
<thead>
<tr>
<th>Initial Condition</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>$u_1(t_0)$</td>
<td>$-6\text{sech}(x_a)^2$</td>
</tr>
<tr>
<td>$u_2(t_0)$</td>
<td>$-24\text{sech}(x_a)^2\text{tanh}(x_a)^2+12\text{sech}(x_a)^2*(1-\text{tanh}(x_a)^2)$</td>
</tr>
</tbody>
</table>
Because the new KdV equation model is a revised copy of the original KdV equation model, this model will need to be reset. Using the menu bar, select File > Reset Model. The Reset Model command clears the copied model of previous meshes and solutions.

Mesh Generation

From the menu bar, select Mesh > Free Mesh Parameters. Verify or type 0.1 in the Maximum element size edit window, as shown in Figure 3.30. Click OK.

From the menu bar, select Mesh > Initialize Mesh. The result of the meshing operation is shown in Figure 3.31.

Solving the Second Revised KdV Equation Model

Using the menu bar, select Solve > Solver Parameters. Verify that the COMSOL Multiphysics software automatically selected the Time dependent solver. Verify or type linspace(0, 2, 81) in the Times edit window, as shown in Figure 3.32. This instruction divides the time-space into 81 equal intervals, in the period from 0 to 2 seconds.

Click the Time Stepping tab. Verify or type 2 in the Maximum BDF order edit window, as shown in Figure 3.33. Click OK.

Using the menu bar, select Solve > Solve Problem.

The solution that is immediately seen is not the negated (−) solution at the last time interval. Instead, the solution shown is the positive solution of the KdV equation,
FIGURE 3.31 Remeshed model

FIGURE 3.32 Solver Parameters window
because the sign inversion (–) was adjusted in postprocessing of the previous model. The results of the changed argument solution are as shown in Figure 3.34.

Save this KdV equation model as Model3_KdV_3 to retain the current solution.

Postprocessing Animation

This solution to the KdV equation can also be viewed as an animation. To view this solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 3.35). Click the Start Animation button. Save this KdV equation model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie3_KdV_3.avi that was supplied with this book.

The result of the argument change for the second variation on the KdV equation model initial conditions is the generation of a single soliton that propagates through the medium (e.g., optical fiber) at one velocity. This soliton pulse will reliably convey information to the receiving station.

One factor that this model does not address is the loss of energy (attenuation) as a function of distance. It is a more advanced topic that will not be covered in this book.
FIGURE 3.34  Second variation on the KdV equation model solution

FIGURE 3.35  KdV model solution, Animate page
CHAPTER 3 1D MODELING

1D KdV Equation Models: Summary and Conclusions

The KdV equation is a powerful tool that can be used to model soliton wave propagation in diverse media (e.g., physical waves in liquids, electromagnetic waves in transparent media). It is easily and simply modeled with a 1D PDE model.

1D Telegraph Equation

The telegraph equation was developed by Oliver Heaviside and first published about 1885. The telegraph equation is based on a lumped constant, four-terminal electrical component model, as shown in Figure 3.36.

In this schematic model of the telegraph wires (and other transmission lines), there are four fundamental components: resistance (R) per unit of length (e.g., foot, meter), inductance (L) per unit of length (e.g., foot, meter), conductance (G) per unit of length (e.g., foot, meter), and capacitance (C) per unit of length (e.g., foot, meter). The differential equations for voltage (V) and current (I) have the same form, as shown in equations 3.5 and 3.6.

Equation 3.5 shows the partial differential equation for voltage (V):

\[
\frac{\partial^2 V}{\partial x^2} = LC \frac{\partial^2 V}{\partial t^2} + (RC + GL) \frac{\partial V}{\partial t} + GRV \tag{3.5}
\]

Equation 3.6 shows the partial differential equation for current (I):

\[
\frac{\partial^2 I}{\partial x^2} = LC \frac{\partial^2 I}{\partial t^2} + (RC + GL) \frac{\partial I}{\partial t} + GRI \tag{3.6}
\]

Equations 3.5 and 3.6 are similar in form to equation 3.7, as shown here for the COMSOL Multiphysics telegraph equation model:

\[
u'' + (\alpha + \beta) u' + \alpha \beta u = c^2 u_{xx} \tag{3.7}
\]
where $\alpha$ and $\beta$ are positive constants, $c$ is the transport velocity, and $u$ is the voltage.

Equation 3.5 can be restated in subscript notation:

$$u_{xx} = LC_\tau \tau + (RC + GL) u_t + GRu$$

(3.8)

Rearranging the terms of equation 3.7 gives the following equation:

$$u_{xx} = \frac{1}{c^2} u_{\tau \tau} + \frac{1}{c^2} (\alpha + \beta) u_t + \frac{1}{c^2} \alpha \beta u$$

(3.9)

Comparing equations 3.8 and 3.9 yields

$$LC = \frac{1}{c^2}$$

(3.10)

and

$$\alpha + \beta = \frac{(RC + GL)}{LC}$$

(3.11)

and

$$\alpha \beta = \frac{GR}{LC}$$

(3.12)

Solving for $\alpha$ and $\beta$:

$$\alpha = \frac{CGL + C^2R - \sqrt{-4CGLR + (-CGL - C^2R)^2}}{2L}$$

(3.13)

$$\beta = \frac{CGL + C^2R + \sqrt{-4CGLR + (-CGL - C^2R)^2}}{2L}$$

or

$$\alpha = \frac{CGL + C^2R + \sqrt{-4CGLR + (-CGL - C^2R)^2}}{2L}$$

$$\beta = \frac{CGL + C^2R - \sqrt{-4CGLR + (-CGL - C^2R)^2}}{2L}$$

In the event that

$$R = G = 0$$

(3.14)
the transmission line is considered lossless and the telegraph equation becomes

$$u_{xx} = LC u_{tt}$$  \hspace{1cm} (3.15)

**COMSOL 1D Telegraph Equation Model**

**Model Navigator**

To start building the telegraph equation model, activate the COMSOL Multiphysics software. In the Model Navigator, select “1D” from the Space dimension pull-down list. Select COMSOL Multiphysics > PDE Modes > PDE, Coefficient Form > Time-dependent analysis, wave type. Verify that Lagrange-Quadratic elements have been selected in the Element pull-down list. Click OK.

**1D Geometry**

Once the COMSOL Multiphysics 1D workspace window has appeared, using the menu bar, select Draw > Specify Objects > Line. Type 0 space 1 in the Coordinates edit window of the Line window. Click OK. Using the toolbar, click the Zoom Extents button. The 1D geometry will appear as shown in Figure 3.37.
### Table 3.8  Constants Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>c</td>
<td>1</td>
</tr>
<tr>
<td>alpha</td>
<td>0.25</td>
</tr>
<tr>
<td>beta</td>
<td>0.25</td>
</tr>
</tbody>
</table>

### Table 3.9  Boundary Settings Window

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Boundary 1</th>
<th>Boundary 2</th>
<th>q</th>
<th>g</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Neumann</td>
<td>Neumann</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Setting</td>
<td></td>
<td></td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

## Constants

Using the menu bar, select Options > Constants. Type the constants in the Constants edit window, as indicated in Table 3.8, and then click OK.

## Boundary Conditions

Using the menu bar, select Physics > Boundary Settings. After the Boundary Settings window appears, select both boundaries 1 and 2. Enter or verify the settings indicated in Table 3.9, and then click OK.

## Subdomain Settings

The next step in building the telegraph equation model is to set the Subdomain Settings. Select Physics > Subdomain Settings. Once the Subdomain Settings window appears, select subdomain 1 and enter the coefficient values under the correct tab as shown in Table 3.10. Verify and then leave the other coefficient settings at their 0 value, as shown in Figure 3.38.

### Table 3.10  Subdomain Settings Window, PDE Coefficients

<table>
<thead>
<tr>
<th>PDE Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>c</td>
<td>c*c</td>
</tr>
<tr>
<td>a</td>
<td>alpha*beta</td>
</tr>
<tr>
<td>f</td>
<td>-(alpha+beta)*ut</td>
</tr>
<tr>
<td>e_a</td>
<td>1</td>
</tr>
<tr>
<td>d_a</td>
<td>0</td>
</tr>
</tbody>
</table>
Once the PDE coefficients have been entered, click the Init tab. Enter the initial conditions found in Table 3.11, and then click OK. See Figure 3.39.

Mesh Generation
Using the toolbar, select Initialize Mesh > Refine Mesh once. The final mesh, with 30 elements, is shown in Figure 3.40.

Solving the Telegraph Equation Model
Using the menu bar, select Solve > Solver Parameters. Once the Solver Parameters window appears, click the Time Stepping tab. Place a check mark in the Manual tuning of step size check box. Type 0.002 in the Initial time step edit field, as shown in Figure 3.41. Click OK.

Table 3.11  Initial Conditions Window

<table>
<thead>
<tr>
<th>Initial Condition</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>u1(t₀)</td>
<td>exp(-3*(x/0.2-1)^2)</td>
</tr>
<tr>
<td>u2(t₀)</td>
<td>0</td>
</tr>
</tbody>
</table>
FIGURE 3.39  PDE window, Init page

FIGURE 3.40  PDE, telegraph equation model mesh
The 0.002 time step is selected, in this case, to yield adequate solution resolution without requiring extensive resource consumption (computer/modeler time).

Using the menu bar, select Solve > Solve Problem. The solution for the final time interval is as shown in Figure 3.42.

**Postprocessing**

Using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the General tab. Place a check mark in the Keep current plot check box. Select “Solution at time: 0.” Click the Apply button. Select “Solution at time: 0.5.” Click the Apply button, and then click OK. Figure 3.43 shows the resulting plot of the pulse amplitude as it propagates from left to right.

**Postprocessing Animation**

This solution to the telegraph equation can also be viewed as an animation. To view this solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the Animate tab. On the Animate page,
FIGURE 3.42 Telegraph equation model solution

FIGURE 3.43 Telegraph equation pulse amplitude plot
select all the solutions in the Stored output times window (see Figure 3.44). Click the Start Animation button. Save this telegraph equation model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie3_Te_TE_1.avi that was supplied with this book.

Select File > Save as. Type Model3_TeEq_1 in the Save As edit window.

**First Variation on the Telegraph Equation Model**

The previous solution to the telegraph equation shows a pulse propagating from left to right. Let us now explore how the model behaves when the initial conditions are modified. In this case, the argument is made smaller, reflecting the behavior of a lower-loss transmission line.

Information transmission relies on the measurement of differences, as stated earlier. To receive a message, the signal must be of detectable amplitude (analog), of detectable duration (time), and in the pass-band (correct frequency or frequency spread) of the receiver. The signal amplitude must be sufficiently greater than the detection threshold and above the noise level (on the average) to allow information to be collected.

First, save a new copy of the just-created telegraph equation model Model3_TeEq_1 as Model3_TeEq_2. You can then modify the telegraph equation model without being concerned about damaging the original model.
Using the menu bar, select Options > Constants. After the Constants window appears, type the expressions indicated in Table 3.12 (also see Figure 3.45), and then click OK.

**Boundary Conditions**

Using the menu bar, select Physics > Boundary Settings. After the Boundary Settings window appears, select both boundaries 1 and 2. Enter or verify the settings indicated in Table 3.13 (also see Figure 3.46). Click OK.

**Subdomain Settings**

The next step in building the revised telegraph equation model is to set the Subdomain Settings. Select Physics > Subdomain Settings. Once the Subdomain Settings window appears, set the following:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Boundary 1</th>
<th>Boundary 2</th>
<th>q</th>
<th>g</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Neumann</td>
<td>Neumann</td>
<td>q</td>
<td>g</td>
</tr>
<tr>
<td>Setting</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
appears, select subdomain 1. Enter or verify the coefficient values under the correct tab as shown in Table 3.14. Leave the other coefficient settings at their 0 value, as shown in Figure 3.47.

Once the PDE coefficients have been entered or verified, click the Init tab. Type or verify the initial conditions found in Table 3.15 in the edit windows, as shown in Figure 3.48. Click OK.

**Model Reset**
Select File > Reset Model > Yes.

<table>
<thead>
<tr>
<th>Table 3.14</th>
<th>Subdomain Settings Window, PDE Coefficients</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>PDE Coefficient</strong></td>
<td><strong>Value</strong></td>
</tr>
<tr>
<td>$c$</td>
<td>$c^2$</td>
</tr>
<tr>
<td>$a$</td>
<td>$\alpha \beta$</td>
</tr>
<tr>
<td>$f$</td>
<td>$-(\alpha + \beta) u_t$</td>
</tr>
<tr>
<td>$e_a$</td>
<td>1</td>
</tr>
<tr>
<td>$d_a$</td>
<td>0</td>
</tr>
</tbody>
</table>
Mesh Generation

Using the toolbar, select Initialize Mesh > Refine Mesh once. The final 30-element mesh is shown in Figure 3.49.

Solving the Telegraph Equation Model

Using the menu bar, select Solve > Solver Parameters. Once the Solver Parameters window appears, click the Time Stepping tab. Place a check mark in the Manual tuning of step size check box. Type 0.002 in the Initial time step edit field, as shown in Figure 3.50. Click OK.

As mentioned in an earlier note, the 0.002 time step is selected to yield adequate solution resolution without requiring extensive resource consumption (computer/modeler time).

Using the menu bar, select Solve > Solve Problem.
CHAPTER 3  1D MODELING

FIGURE 3.49  Telegraph equation model mesh
Postprocessing

Using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the General tab. Place a check mark in the Keep current plot check box. Select “Solution at time: 0.” Click the Apply button. Select “Solution at time: 0.5.” Click the Apply button, and then click OK. Figure 3.51 shows the resulting plot of the pulse amplitude as it propagates from left to right. Note that the final pulse amplitude is 0.9 as compared to 0.7 for the original model.

Postprocessing Animation

This solution to the telegraph equation can also be viewed as an animation. To view this solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 3.52). Click the Start Animation button. Save this telegraph equation model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie3_TE_2.avi that was supplied with this book.
FIGURE 3.51  Telegraph equation pulse amplitude plot, low-loss line

FIGURE 3.52  Telegraph equation Plot Parameters window, Animate page
Select File > Save as. Type Model3_TeEq_2 in the Save As edit window. Click the Yes button to replace the earlier file.

**Second Variation on the Telegraph Equation Model**

The previous solution to the telegraph equation shows a pulse propagating from left to right. Let us now explore how the model behaves when the initial conditions are modified. In this case, the argument is made larger, reflecting the behavior of a higher-loss transmission line.

As stated earlier, information transmission relies on the measurement of differences. To receive a message, the signal must be of detectable amplitude (analog), of detectable duration (time), and in the pass-band (correct frequency or frequency spread) of the receiver. The signal amplitude must be sufficiently greater than the detection threshold and above the noise level (on the average) to allow information to be collected.

First, save a new copy of the just-created telegraph equation model Model3_TeEq_2 as Model3_TeEq_3. You can then modify the telegraph equation model without being concerned about damaging the just-built model.

Using the menu bar, select Options > Constants. After the Constants window appears, type the expressions indicated in Table 3.16 (also see Figure 3.53), and then click OK.
Using the menu bar, select Physics > Boundary Settings. After the Boundary Settings window appears, select both boundaries 1 and 2. Enter or verify the settings indicated in Table 3.17, as shown in Figure 3.54. Click OK.

Subdomain Settings
The next step in building the revised telegraph equation model is to set the Subdomain Settings. Select Physics > Subdomain Settings. Once the Subdomain Settings window appears, select subdomain 1. Enter or verify the coefficient values under the correct tab as shown in Table 3.18. Leave the other coefficient settings at their 0 value, as shown in Figure 3.55.

Once the PDE coefficients have been entered or verified, click the Init tab. Type or verify the initial conditions found in Table 3.19 in the edit windows, as shown in Figure 3.56. Click OK.
### Table 3.18  Subdomain Settings Window, PDE Coefficients

<table>
<thead>
<tr>
<th>PDE Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>$c$</td>
<td>$c^c$</td>
</tr>
<tr>
<td>$a$</td>
<td>$\alpha^\beta$</td>
</tr>
<tr>
<td>$f$</td>
<td>$-(\alpha+\beta)u_t$</td>
</tr>
<tr>
<td>$e_a$</td>
<td>1</td>
</tr>
<tr>
<td>$d_a$</td>
<td>0</td>
</tr>
</tbody>
</table>

### Figure 3.55  PDE, Subdomain Settings window, PDE Coefficients

### Table 3.19  Initial Conditions Window

<table>
<thead>
<tr>
<th>Initial Condition</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>$u_1(t_0)$</td>
<td>$\exp(-3*(x/0.2-1)^2)$</td>
</tr>
<tr>
<td>$u_2(t_0)$</td>
<td>0</td>
</tr>
</tbody>
</table>
CHAPTER 3  1D MODELING

Model Reset
Select File > Reset Model > Yes.

Mesh Generation
Using the tool bar, select Initialize Mesh > Refine Mesh once. The final 30-element mesh is shown in Figure 3.57.
Solving the Telegraph Equation Model

Using the menu bar, select Solve > Solver Parameters. Once the Solver Parameters window appears, click the Time Stepping tab. Place a check mark in the Manual tuning of step size check box. Enter or verify 0.002 in the Initial time step edit field, as shown in Figure 3.58. Click OK.

As mentioned in an earlier note, the 0.002 time step is selected to yield adequate solution resolution without requiring extensive resource consumption (computer/modeler time).

Using the menu bar, select Solve > Solve Problem. The solution for the final time interval is as shown in Figure 3.59.

Postprocessing

Using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the General tab. Place a check mark in the Keep
current plot check box. Select “Solution at time: 0.” Click the Apply button. Select “Solution at time: 0.5.” Click the Apply button, and then click OK. Figure 3.60 shows the resulting plot of the pulse amplitude as it propagates from left to right.

**Postprocessing Animation**

This solution to the telegraph equation can also be viewed as an animation. To view this solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 3.61). Click the Start Animation button. Save this telegraph equation model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie3_TE_3.avi that was supplied with this book.

Select File > Save as. Type Model3_TeEq_3 in the Save As edit window. Click the Yes button to replace the earlier file.

**1D Telegraph Equation Models: Summary and Conclusions**

The telegraph equation is a powerful tool that can be used to model wave propagation in diverse transmission lines. It can be used to thoroughly characterize the propagation conditions of coaxial lines, twin pair lines, microstrip lines, and more. The telegraph equation is easily and simply modeled with a 1D PDE mode model.
**FIGURE 3.60** Telegraph equation pulse amplitude plot, high-loss line

**FIGURE 3.61** Telegraph equation Plot Parameters window, Animate page
References


Exercises

1. Build, mesh, and solve the 1D KdV equation problem presented in this chapter.
2. Build, mesh, and solve the first variation of the KdV equation problem presented in this chapter.
3. Build, mesh, and solve the second variation of the KdV equation problem presented in this chapter.
4. Build, mesh, and solve the telegraph equation problem presented in this chapter.
5. Build, mesh, and solve the first variation of the telegraph equation problem presented in this chapter.
6. Build, mesh, and solve the second variation of the telegraph equation problem presented in this chapter.
7. Explore other variations of the arguments in the KdV equation model.
8. Explore other variations of the arguments in the telegraph equation model.
9. Explore the role that characteristic impedance plays in transmission lines.
In This Chapter

2D Guidelines for New COMSOL® Multiphysics® Modelers
   2D Modeling Considerations
   Coordinate System
2D Electrochemical Polishing (Electropolishing) Theory
   COMSOL 2D Electrochemical Polishing Model
   First Variation on the 2D Electrochemical Polishing Model
   Second Variation on the 2D Electrochemical Polishing Model
   2D Electrochemical Polishing Models: Summary and Conclusions
2D Hall Effect Model Considerations
   2D Hall Effect Model
   First Variation on the 2D Hall Effect Model
   Second Variation on the 2D Hall Effect Model
   2D Hall Effect Models: Summary and Conclusions

2D Guidelines for New COMSOL® Multiphysics® Modelers

2D Modeling Considerations

2D modeling can be less difficult than 1D modeling, having fewer implicit assumptions, and yet potentially can still be a challenging type of model to build, depending on the underlying physics involved, irrespective of the modeling software utilized. The least difficult aspect of 2D model building arises from the fact that the geometry is relatively simple: In a 2D model, the modeler has only a single plane as the modeling space. However, the physics in a 2D model can range from relatively easy to extremely complex.

Note: COMSOL® Multiphysics® software has two 2D modeling modes: 2D (beginning-level through advanced-level 2D modeling) and 2D Axisymmetric (advanced-level 2D modeling). In keeping with the introductory focus of the material in this text, both model types, their associated physics, and the related methodology for
use of the models, are introduced in Chapters 4 and 5. Significantly more advanced 2D modeling techniques exist than are presented in these two chapters. Examples of some of those more challenging techniques are reserved for introduction in Chapters 6 and 7. For further expansion of the 2D modeling horizons, refer to the COMSOL manuals, the COMSOL Website, and the general COMSOL Multiphysics software-related research literature.

The 2D model implicitly assumes, in compliance with the laws of physics, that the energy flow, the materials properties, the environment, and any other conditions and variables that are of interest are homogeneous, isotropic, and constant, unless otherwise specified, throughout the entire domain of interest, both within the model and, through the boundary conditions, in the environs of the model. Bearing that in mind, the modeler needs to ensure that all of the modeling conditions and associated parameters (default settings) in each new model created have been properly considered, defined, or set to the appropriate values.

The modeler also needs to seriously consider the steps that will be required in properly establishing the correct postprocessing and visualization settings to extract the desired information from the modeling solution. The default parameter settings on any given model will probably not present exactly the information that the modeler needs or desires, although it will probably come close. It is the responsibility of the modeler to determine exactly which of the myriad of postprocessing and visualization choices available in the COMSOL Multiphysics software to employ.

It is always preferable for the modeler to be able to accurately anticipate the expected behavior (results) of the model and the way in which those results should be presented. Never assume that the default values that are initially present when the model is first created will suit the needs of a new model. Always verify that the values employed in the model are the correct values needed for that model. Calculated solution values that significantly deviate from the expected values or from comparison values measured in experimentally derived realistic models are probably indicative of one or more modeling errors either in the original model design, in the earlier model analysis, or in the understanding of the underlying physics, or are simply due to human error.

**Coordinate System**

In 2D models, there are three coordinates: space \((x)\), space \((y)\), and time \((t)\). In a steady-state solution to a 2D model, parameters can vary only as a function of position in the space \((x)\) and space \((y)\) coordinates. Such a 2D model represents the parametric condition of the model in a time-independent mode (quasi-static). In a transient solution model, parameters can vary both by position in space \((x)\) and space \((y)\), and in time \((t)\).
The transient solution model is essentially a sequential collection of steady-state (quasi-static) solutions. The space coordinates \((x)\) and \((y)\) typically represent a distance coordinate throughout which the model is to calculate the change of the specified observables (i.e., temperature, heat flow, pressure, voltage, current) over the range of values \((x_{\text{min}} < x < x_{\text{max}})\) and \((y_{\text{min}} < y < y_{\text{max}})\). The time coordinate \((t)\) represents the range of values \((t_{\text{min}} < t < t_{\text{max}})\) from the beginning of observation period \((t_{\text{min}})\) to the end of observation period \((t_{\text{max}})\).

To assist the reader to achieve a broader exposure to the applicability of the physics discussed here and to demonstrate the power of the basic COMSOL 2D modeling techniques, the modeling examples in this chapter illustrate techniques from two substantially different, but important and widely applied technologies currently employed in applied engineering and physics. The first example presented, electropolishing, explores the modeling of a processing methodology utilized in the fabrication and finishing of many metallic objects that require a smooth surface (e.g., microscope samples, precision metal parts, medical equipment and tools, large and small metal drums, thin analytical samples, vacuum chambers). The second example, the Hall effect (a magnetic sensor technology), explores the behavior of currents (electrons or holes) flowing in a semiconducting material (e.g., Si, Ge) under the influence of an external magnetic field.

---

### 2D Electrochemical Polishing (Electropolishing) Theory

Electrochemical polishing\(^1\) (also known as electropolishing\(^2\)) is a well-known process in the metal finishing industry. It allows the finished surface smoothness of a conducting material to be cleanly controlled to a high degree of precision, using relatively simple processing equipment. The electrochemical polishing technique eliminates the abrasive residue typically present on the polished surface from a mechanical polishing process; it also eliminates the need for complex, mechanical polishing machinery.

---

**NOTE** The science of electricity, and consequently that of electrochemistry, started with the work of William Gilbert through his study of magnetism. Gilbert first published his studies in 1600.\(^3\) Charles-Augustin de Coulomb,\(^4\) Joseph Priestley,\(^5\) Georg Ohm,\(^6\) and others made additional independent contributions that furthered the basic understanding of the nature of electricity and electrochemistry. Those contributions led to the discovery and disclosure by Michael Faraday\(^7\) of his two laws of electrochemistry in 1832.

The numerical solution model for electrochemical polishing was originally developed by COMSOL for distribution with the Multiphysics software as a COMSOL Multiphysics electromagnetics model. This model introduces two important basic concepts, the first in applied physics and the second in applied
modeling: (1) electropolishing and (2) the moving mesh (ALE = arbitrary Lagrangian–Eulerian\(^8\)). The electrochemical polishing model built in this chapter is substantially the same as presented in the COMSOL Model Library. In this chapter, following development of the first model, variations and expansions on the basic electrochemical polishing model are explored.

It is important for the new modeler to personally build each model presented within this text. There is no substitute in the path to an understanding of the modeling process for the hands-on experience of actually building, meshing, solving, and postprocessing a model. Many times the inexperienced modeler will make and subsequently correct errors, adding to his or her experience and fund of modeling knowledge. Even building the simplest model will expand the modeler’s fund of knowledge.

Polishing (smoothing) of a material surface, via either mechanical or electrochemical means, results from the reduction of asperities (bumps) to achieve a nominally smooth surface (uniform thickness \(\pm \Delta\) thickness). In a mechanical polishing technique, the reduction of asperities occurs through the use of finer (smaller) and finer grit (abrasive) sizes. The mechanical polishing of many surfaces is difficult, if not impossible, owing to the complexity and/or physical size of such surfaces. Figure 4.1 shows a simple asperity, as will be modeled in this section of the chapter.

The surface of the electrode, using this method, is polished by the differential removal of material from local asperities in selected areas, accomplished through the immersion of the nominally rough electrode in an electrolyte and the application of a current (electron bombardment). A first-order approximation to the experimentally observed material removal process is that the rate (velocity) of material removal \(U\) from the electrode surface is proportional to the amplitude of the current and direction of the current \(J\), relative to the local surface normal vector \(n\) (see Figure 4.2):

\[
U = -K^{*}J \cdot n = -K^{*}J_n
\]  

(4.1)

![FIGURE 4.1 2D An asperity (bump) on an electrode](image)
The electropolishing technique, to a first approximation, is the inverse of electroplating. As a result, the rate of removal of material (velocity $U$) from the nominally rough surface of the positive electrode is proportional to the normal current density at the positive electrode surface, as shown in equation 4.1.

The exact value of the proportionality constant ($K$) in physical applications (e.g., research experiments, processing) is determined by the electrode material, the electrolyte, the temperature, and other factors, and, to some extent, will be explored in later examples in this chapter.

For this model, the proportionality constant is chosen to be

$$K = 1.0 \times 10^{-11} \text{m}^3/(\text{A*s})$$

where $m = \text{meters}$

$A = \text{amperes}$

$s = \text{seconds}$

Obviously, because material is removed from the positive electrode during the electropolishing process, the spacing between the upper and lower electrodes will increase. The time rate of change of the model geometry (electrode spacing) needs to be accommodated somewhere within the model. The Moving Mesh (ALE = arbitrary Lagrangian–Eulerian) Application Mode accommodates that time rate of change, resulting from the normal current ($J_n$) flowing in the electrolyte during the quasi-static use of the Conductive Media DC Application Mode.

The Moving Mesh Application Mode allows the modeler to create models in which the physics of the process introduces and controls geometric changes in the model. However, the modeler must know and work carefully within the limits of the modeling system. The Moving Mesh Application Mode is a powerful tool. However, the calculated mesh parameters can drift, as the mesh is deformed and ultimately lead to
nonphysical, nonconvergent results. Avoidance of such nonphysical results requires the modeler to understand the basic physics of the modeled problem and to choose the meshing method that yields the best overall results.

**COMSOL 2D Electrochemical Polishing Model**

To start building the Electropolishing_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select COMSOL Multiphysics > Deformed Mesh > Moving Mesh (ALE) > Transient analysis. Click the Multiphysics button, and then click the Add button.

From the Application Modes list, select COMSOL Multiphysics > Electromagnetics > Conductive Media DC. Click the Add button. See Figure 4.3. Click OK.

**Table 4.1  Constants Edit Window**

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>K</td>
<td>1.0e-11[m^3/(A*s)]</td>
<td>Coefficient of proportionality</td>
</tr>
</tbody>
</table>
Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 4.1; see Figure 4.4. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 2.8 and a height of 0.4. Select “Base: Corner” and set X equal to \(-1.4\) and Y equal to 0 in the Rectangle edit window. See Figure 4.5.

Click the Apply button, and then click OK. See Figure 4.6.

Using the menu bar, select Draw > Specify Objects > Circle. Enter a radius of 0.3. Select “Base: Center” and set X equal to 0 and Y equal to 0.6 in the Circle edit window. See Figure 4.7.

Click the Apply button, and then click OK. See Figure 4.8.

Select both the rectangle and the circle by clicking on the rectangle and Shift-clicking on the circle. See Figure 4.9.

Click the Difference button on the Draw toolbar to remove the overlapping portion of the circle from the rectangle. The upper surface of the electrolyte rectangle
**FIGURE 4.6** 2D Electropolishing_1 model electrolyte rectangle

**FIGURE 4.7** 2D Electropolishing_1 model Circle edit window
2D Electrochemical Polishing (Electropolishing) Theory

**FIGURE 4.8** 2D Electropolishing_1 model rectangle and circle

**FIGURE 4.9** 2D Electropolishing_1 model selected rectangle and circle
(CO1) is the lower surface of the electrode, with the asperity, that will be electropolished. See Figure 4.10.

The model geometry, as presently scaled, is 1.4 meters in length and 0.4 meter in height. Electropolishing is typically applied as the final finishing (smoothing) step in a precision fabrication process (e.g., metallographic samples, vacuum chambers). Thus the model geometry will need to be reduced in scale to emulate reality.

Click on the text “CO1.” Next, click the Scale button on the Draw toolbar. Enter 1e-3 in both the X and Y Scale factor edit windows. See Figure 4.11. Click OK.

Click the Zoom Extents button on the menu bar. See Figure 4.12.
Physics Subdomain Settings: Conductive Media DC

Having established the 2D geometry for the electrochemical polishing model (a rectangle with a negative asperity on the upper surface), the next step is to define the fundamental physics conditions. Using the menu bar, select Multiphysics > Conductive Media DC. Next, using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain).

Enter 10 in the Electric conductivity \( (\mu \Omega m) \) edit window. See Figure 4.13. Click OK.

Physics Boundary Settings: Conductive Media DC

Using the menu bar, Select Physics > Boundary Settings. For the indicated boundaries, select and/or enter the given boundary condition and value as shown in Table 4.2, and then click OK. See Figure 4.14.

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 5</td>
<td>Electric insulation</td>
<td>—</td>
</tr>
<tr>
<td>3, 4, 6, 7</td>
<td>Electric potential</td>
<td>30</td>
</tr>
<tr>
<td>2</td>
<td>Ground</td>
<td>—</td>
</tr>
</tbody>
</table>
**FIGURE 4.13** Subdomain Settings window

**FIGURE 4.14** 2D Electropolishing_1 model Boundary Settings, Conductive Media DC: boundaries set
Using the menu bar, select Multiphysics > Moving Mesh (ALE). Next, using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select and/or enter the given boundary condition and value as shown in Table 4.3, and then click OK. See Figure 4.15.

**Mesh Generation**

On the menu bar, click the Initialize Mesh button once.

Click the Refine Mesh button once. This results in a mesh of approximately 700 elements.

Click OK. See Figure 4.16.

**Solving the 2D Electrochemical Polishing Model**

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver. Enter 0:1:10 (typical values) in the Times edit window, as shown in Figure 4.17. This instruction causes the Solver to divide the modeling time-space into 10 equal intervals, over the period from 0 to 10 seconds. Click the Apply button, and then click OK.

---

**Table 4.3 Boundary Settings, Moving Mesh (ALE) Window**

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Coordinate</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 5</td>
<td>Global</td>
<td>Mesh velocity</td>
<td>vx = 0</td>
</tr>
<tr>
<td>3, 4, 6, 7</td>
<td>Tangent and normal</td>
<td>Mesh velocity</td>
<td>vn = -K*nJ_dc</td>
</tr>
<tr>
<td></td>
<td>Deformed mesh</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Global</td>
<td>Mesh displacement</td>
<td>dx = 0, dy = 0</td>
</tr>
</tbody>
</table>

---

This table lists the boundary conditions and values for the Moving Mesh (ALE) settings.

---

**FIGURE 4.15** 2D Electroplishing_1 model Boundary Settings, Moving Mesh (ALE): boundaries 3, 4, 6, 7 window.
FIGURE 4.16 2D Electropolishing_1 model mesh

FIGURE 4.17 2D Electropolishing_1 model Solver Parameters window
The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, always change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can try a variation on the model parameter space to seek improved results.

Using the menu bar, select Solve > Solve Problem.

Postprocessing

Select Postprocessing > Plot Parameters. Click the Surface tab, and verify that the Surface plot check box is checked.

From the Predefined quantities drop-down list, select “Conductive Media DC (dc) > Total current density, norm.” See Figure 4.18.
Click OK. See Figure 4.19.

In Figure 4.19, the model calculation shows that the maximum current density is approximately 0.92e5 A/m², in the region of the asperity. Figure 4.19 also shows that the normal current density ($J_n$) concentrated in the region of the asperity is approximately 1.5 times the normal current density elsewhere on the electrode surface. As a result, the removal rate of the electrode material will be approximately 1.5 times as high.

To see the change in the position of the electrode surface and the relative removal of material from the asperity, first select Postprocessing > Plot Parameters. Next, click the Surface tab, and verify that the Surface plot check box is checked.

From the Predefined quantities drop-down list, select “Moving Mesh (ALE) (ale) > y-displacement.” See Figure 4.20.

Click OK. Figure 4.21 shows the displacement of the electrode surface in the $y$-direction ($dy_{ale}$) after 10 seconds of electropolishing.

In Figure 4.21, the model calculation shows that the maximum displacement of the electrode surface in the $y$-direction ($dy_{ale}$) after 10 seconds of electropolishing is approximately 1.08e-4 m (0.108 mm), in the region of the asperity.
The result of the modeling calculation is approximately $1.1 \times 10^{-4}$ m. Calculating the estimated result on a “first principles” basis:

$$d = |U| \Delta t = K|J_n| \Delta t = \left( 10^{-11} \frac{m^3}{A*s} \right) \left( 10^6 \frac{A}{m^2} \right) (10^1 s) = 10^{-4} m$$

This agrees well with the results of the model.

**Postprocessing Animation**

This solution to the 2D electrochemical polishing model can also be viewed as an animation. To view the solution as a movie, using the menu bar, select Postprocessing >
Plot Parameters. Once the Plot Parameters window appears, click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 4.22). Click the Start Animation button. Save this 2D electrochemical polishing model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie4_EP_1.avi that was supplied with this book.

**First Variation on the 2D Electrochemical Polishing Model**

This model will explore the effect of the mesh element type (triangle, quadrilateral [quad]) on the ultimate values determined by the calculated solution. Both the model geometry and the model mesh play major roles in the ease of solving any particular problem.

To start building the Electropolishing_2 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select COMSOL Multiphysics > Deformed Mesh > Moving Mesh (ALE) > Transient analysis. Click the Multiphysics button, and then click the Add button.
Using the Application Modes list, select COMSOL Multiphysics > Electromagnetics > Conductive Media DC. Click the Add button. See Figure 4.23.

Click OK. Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 4.4; see Figure 4.24.

### Table 4.4 Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>K</td>
<td>1.0e-11[m^3/(A*s)]</td>
<td>Coefficient of proportionality</td>
</tr>
</tbody>
</table>
Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 2.8 and a height of 0.4. Select “Base: Corner” and set X equal to −1.4 and Y equal to 0 in the Rectangle edit window. See Figure 4.25.

Click the Apply button, and then click OK. See Figure 4.26.
FIGURE 4.25 2D Electropolishing_2 model Rectangle edit window

FIGURE 4.26 2D Electropolishing_2 model electrolyte rectangle
Using the menu bar, select Draw > Specify Objects > Circle. Enter a radius of 0.3, select “Base: Center” and set X equal to 0 and Y equal to 0.6 in the Circle edit window. See Figure 4.27.

Click OK. See Figure 4.28.

Select both the rectangle and the circle by clicking on the rectangle and Shift-clicking on the circle. See Figure 4.29.

Click the Difference button on the Draw toolbar to remove the overlapping portion of the circle from the rectangle. The upper surface of the electrolyte rectangle (CO1) is the lower surface of the electrode, with the asperity, that will be electropolished. See Figure 4.30.
**FIGURE 4.29** 2D Electropolishing model selected rectangle and circle

**FIGURE 4.30** 2D Electropolishing model electrode with asperity
The model geometry, as presently scaled, is 1.4 meters in length and 0.4 meter in height. Electropolishing is typically applied as the final finishing (smoothing) step in a precision fabrication process (e.g., metallographic samples, vacuum chambers). Thus the model geometry will need to be reduced in scale to emulate reality.

Click on the text “CO1.” Click the Scale button on the Draw toolbar. Enter 1e-3 in both the X and Y text boxes in the Scale factor edit windows. See Figure 4.31.

Click OK, and then click the Zoom Extents button on the menu bar. See Figure 4.32.
Physics Subdomain Settings: Conductive Media DC

Having established the 2D geometry for the electrochemical polishing model (a rectangle with a negative asperity on the upper surface), the next step is to define the fundamental physics conditions. Using the menu bar, select Multiphysics > Conductive Media DC. Next, using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain). Enter 10 in the Electric conductivity ($\sigma$) edit window. See Figure 4.33. Click OK.

Physics Boundary Settings: Conductive Media DC

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select and/or enter the given boundary condition and value as shown in Table 4.5. See Figures 4.34, 4.35, and 4.36.

| Table 4.5  Boundary Settings, Conductive Media DC Window |
|---|---|---|
| Boundary | Boundary Condition | Value/Expression |
| 1, 5 | Electric insulation | — |
| 3, 4, 6, 7 | Electric potential | 30 |
| 2 | Ground | — |
FIGURE 4.34  Boundary Settings (1, 5), Conductive Media DC: boundaries set

Click OK. See Figure 4.37.

Physics Boundary Settings: Moving Mesh (ALE)

Using the menu bar, select Multiphysics > Moving Mesh (ALE). Next, using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select and/or
**FIGURE 4.36** Boundary Settings (2), Conductive Media DC: boundaries set

**FIGURE 4.37** Boundary Settings (1, 5 = blue; 3, 4, 6, 7 = green; 2 = red), Conductive Media DC: boundaries set
Table 4.6  Boundary Settings, Moving Mesh (ALE) Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Coordinate</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 5</td>
<td>Global</td>
<td>Mesh velocity</td>
<td>vx = 0</td>
</tr>
<tr>
<td>3, 4, 6, 7</td>
<td>Tangent and normal</td>
<td>Mesh velocity</td>
<td>vn = −K*nJ_dc</td>
</tr>
<tr>
<td></td>
<td>Deformed mesh</td>
<td>Mesh displacement</td>
<td>dx = 0, dy = 0</td>
</tr>
</tbody>
</table>

enter the given boundary condition and value in the edit windows as indicated in Table 4.6. See Figure 4.38, 4.39, and 4.40.

Click OK. Figure 4.41 shows the Boundary Settings, Moving Mesh (ALE) options organized by color.

Mesh Generation

From the menu bar, select Mesh > Free Mesh Parameters. Click the Subdomain tab. Select subdomain 1 in the Subdomain selection window. Enter 4e-5 in the Maximum element size edit window. Select “Quad” from the Method drop-down list. See Figure 4.42.

\[ \text{The model default mesh, in the COMSOL Multiphysics software, is the triangular mesh. The triangular mesh is simpler and generates fewer parameters to calculate. However, the quad mesh may be a better mathematical fit to the model for which a solution is sought. The modeler needs to decide the most appropriate choice for the model under consideration.} \]
For a simple 2D model, the maximum element size value for a particular subdivision can be estimated by dividing the lesser ($A < B$) dimension by 10 and then testing how the calculated model satisfies the goals of the modeler.

Click the Remesh button, and then click OK. See Figure 4.43. This mesh contains approximately 754 elements.

**Solving the First Variation on the 2D Electrochemical Polishing Model**

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver. Enter 0:0.5:10 in the Times edit window, as shown in Figure 4.44. This instruction causes the Solver to divide the modeling time-space into 20 equal intervals, over the period from 0 to 10 seconds. Click OK.
**FIGURE 4.41** Boundary Settings, Moving Mesh (ALE): boundaries organized by color [green = tangent and normal coordinate system in deformed mesh; blue = global ($v_x = 0$); red = global ($dx = 0, dy = 0$)]

**FIGURE 4.42** 2D electrochemical polishing model Free Mesh Parameters window
FIGURE 4.43  2D electrochemical polishing model free mesh (quad)

FIGURE 4.44  2D electrochemical polishing model Solver Parameters window
Using the menu bar, select Solve > Solve Problem.

**NOTE** In the process of solving this model, using the Moving Mesh Application Mode (ALE), the modeler may occasionally see a warning about an “inverted mesh element.” If the solver continues on to the solution, ignore the warning. Such warnings are normal when using the deformed mesh.

If the model does not continue to a solution and the solver displays numerous warnings, then either there is an error in the model or the modeler needs to use the advanced technique called remesh (not discussed in this book).

**Postprocessing**

Select Postprocessing > Plot Parameters. Click the Surface tab, and verify that the Surface plot check box is checked. From the Predefined quantities drop-down list, select Conductive Media DC (dc) > Total current density, norm. See Figure 4.45. Click OK.
In Figure 4.46, the model calculation shows that the maximum current density is approximately 8.87e5 A/m², in the region of the asperity (very close to the calculated value in the original model). Figure 4.46 also shows that the normal current density \( J_n \) concentrated in the region of the asperity is approximately 1.5 times the normal current density elsewhere on the electrode surface. As a result, the removal rate of the electrode material will be approximately 1.5 times as high.

To see the change in the position of the electrode surface and the relative removal of material from the asperity, select Postprocessing > Plot Parameters. Click the Surface tab, and verify that the Surface plot check box is checked. From the Predefined quantities drop-down list, select Moving Mesh (ALE) (ale) > y-displacement. See Figure 4.47.

Click OK. Figure 4.48 shows the displacement of the electrode surface in the y-direction (dy_ale) after 10 seconds of electropolishing.
Postprocessing Animation

This solution to the 2D electrochemical polishing model can also be viewed as an animation. To view the solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 4.49). Click the Start Animation button. Save this 2D electrochemical polishing model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie4_EP_2.avi that was supplied with this book.
Second Variation on the 2D Electrochemical Polishing Model

This model will explore the effect of a change in the shape and number of asperities. In this model, the quad mesh element type will be used, based on the excellent values calculated in the previous modeling solution. Bear in mind that both the model geometry and the model mesh play major roles in the ease of solving any particular problem.

To start building the Electropolishing_3 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select COMSOL Multiphysics > Deformed Mesh > Moving Mesh (ALE) > Transient analysis. Click the Multiphysics button, and then click the Add button.

Using the Application Modes list, select COMSOL Multiphysics > Electromagnetics > Conductive Media DC. Click the Add button. See Figure 4.50.

Click OK. Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 4.7; also see Figure 4.51.
**Table 4.7** Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>K</td>
<td>1.0e-11(\text{m}^3/(\text{A}\cdot\text{s}))</td>
<td>Coefficient of proportionality</td>
</tr>
</tbody>
</table>
Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 2.8 and a height of 0.4. Select “Base: Corner” and set X equal to $-1.4$ and Y equal to 0 in the Rectangle edit window. See Figure 4.52.

Click the Apply button, and then click OK. See Figure 4.53.
**FIGURE 4.52** 2D Electropolishing_3 model Rectangle edit window

**FIGURE 4.53** 2D Electropolishing_3 model electrolyte rectangle
Using the menu bar, select Draw > Specify Objects > Circle. Enter a radius of 0.3. Select “Base: Center” and set x equal to 0 and y equal to 0.6 in the Circle edit window. See Figure 4.54.

Click OK. See Figure 4.55.
Using the menu bar, select Draw > Specify Objects > Ellipse. Enter 0.3 in the A-semiaxes edit window and 0.1 in the B-semiaxes edit window. Select “Base: Center” and set X equal to −1.0 and Y equal to 0.4 in the X and Y edit windows. See Figure 4.56.

Click OK. See Figure 4.57.
Select the text “E1.” Using the menu bar, select Edit > Copy. Using the menu bar, select Edit > Paste. Enter 2.0 in the X: Displacements edit window. See Figure 4.58. Click OK. See Figure 4.59.

Using the menu bar, select Draw > Create Composite Object. Enter R1-C1-E1-E2 in the Set formula edit window. See Figure 4.60.

To obtain the desired difference response, the modeler needs to key in the requested R1-C1-E1-E2 information in the edit window, rather than clicking on items in the Object selection window.
Click OK. See Figure 4.61.

The model geometry, as presently scaled, is 1.4 meters in length and 0.4 meter in height. Electropolishing is typically applied as the final finishing (smoothing) step in a precision fabrication process (e.g., metallographic samples, vacuum chambers). Thus the model geometry will need to be reduced in scale to emulate reality.
Click on the text “CO1.” Click the Scale button on the Draw toolbar. Enter 1e-3 in both the X and Y edit windows. See Figure 4.62.

Click OK, and then click the Zoom Extents button on the menu bar. See Figure 4.63.
Physics Subdomain Settings: Conductive Media DC

Having established the 2D geometry for the electrochemical polishing model (a rectangle with negative asperities on the upper surface), the next step is to define the fundamental physics conditions. Using the menu bar, select Multiphysics > Conductive Media DC. Next, using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain). Enter 10 in the Electric conductivity (\(\sigma\)) edit window. See Figure 4.64. Click OK.

Physics Boundary Settings: Conductive Media DC

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select and/or enter the given boundary condition and value as shown in Table 4.8. See Figures 4.65, 4.66, and 4.67.

Click OK. See Figure 4.68.

<table>
<thead>
<tr>
<th>Table 4.8</th>
<th>Boundary Settings, Conductive Media DC Window</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary</td>
<td>Boundary Condition</td>
</tr>
<tr>
<td>1, 7</td>
<td>Electric insulation</td>
</tr>
<tr>
<td>3–6, 8–13</td>
<td>Electric potential</td>
</tr>
<tr>
<td>2</td>
<td>Ground</td>
</tr>
</tbody>
</table>
**FIGURE 4.65** Boundary Settings (1, 7), Conductive Media DC: boundaries set

**FIGURE 4.66** Boundary Settings (3–6, 8–13), Conductive Media DC: boundaries set
**FIGURE 4.67** Boundary Settings (2), Conductive Media DC: boundary set

**FIGURE 4.68** Boundary Settings (1, 7 = blue; 3–6, 8–13 = green; 2 = red), Conductive Media DC: boundaries set
Table 4.9  Boundary Settings, Moving Mesh (ALE) Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Coordinate</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 7</td>
<td>Global</td>
<td>Mesh velocity</td>
<td>(vx = 0)</td>
</tr>
<tr>
<td>3–6, 8–13</td>
<td>Tangent and normal</td>
<td>Mesh velocity</td>
<td>(vn = -K*nJ_{dc})</td>
</tr>
<tr>
<td></td>
<td>Deformed mesh</td>
<td>Mesh velocity</td>
<td>(vn = -K*nJ_{dc})</td>
</tr>
<tr>
<td>2</td>
<td>Global</td>
<td>Mesh displacement</td>
<td>(dx = 0, dy = 0)</td>
</tr>
</tbody>
</table>

Boundary Settings: Moving Mesh (ALE)

Using the menu bar, select Multiphysics > Moving Mesh (ALE). Next, using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select and/or enter the given boundary condition and value in the edit windows as indicated in Table 4.9. See Figures 4.69, 4.70, and 4.71.

Click OK. See Figure 4.72.

Mesh Generation

From the menu bar, select Mesh > Free Mesh Parameters. Click the Subdomain tab. Select subdomain 1 in the Subdomain selection window. Enter 4e-5 in the Maximum element size edit window. Select “Quad” from the Method drop-down list. See Figure 4.73.
Click the Remesh button, and then click OK. See Figure 4.74. This mesh contains approximately 675 elements.

**Solving the Second Variation on the 2D Electrochemical Polishing Model**

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver. Enter 0:0.5:10 in the Times edit window, as shown in Figure 4.75. This instruction causes the Solver to divide the modeling time-space into 20 equal intervals, over the period from 0 to 10 seconds. Click OK.

Using the menu bar, select Solve > Solve Problem.
**FIGURE 4.72** Boundary Settings, Moving Mesh (ALE): boundaries organized by color (1, 7 = blue; 3–6, 8–13 = green; 2 = red)

**FIGURE 4.73** 2D Electrochemical polishing model Free Mesh Parameters window
FIGURE 4.74 2D Electrochemical polishing model free mesh (quad)

FIGURE 4.75 2D Electrochemical polishing model Solver Parameters window
In the process of solving this model, using the Moving Mesh Application Mode (ALE), the modeler may occasionally see a warning about an “inverted mesh element.” If the solver continues on to a solution, ignore the warning. Such warnings are normal when using the deformed mesh.

If the model does not continue to a solution and the solver displays numerous warnings, then either there is an error in the model or the modeler needs to use the advanced technique called remesh (not discussed in this book).

Postprocessing
Select Postprocessing > Plot Parameters. Click the Surface tab, and verify that the Surface plot check box is checked. From the Predefined quantities drop-down list, select Conductive Media DC (dc) > Total current density, norm. See Figure 4.76. Click OK.
In Figure 4.77, the model calculation shows that the maximum current density is approximately $8.84 \times 10^5$ A/m$^2$, in the region of the asperities. Figure 4.77 also shows that the normal current density ($J_n$) concentrated in the region of the asperities is approximately 1.5 times the normal current density elsewhere on the electrode surface. As a result, the removal rate of the electrode material will be approximately 1.5 times as high.

To see the change in the position of the electrode surface and the relative removal of material from the asperities, select Postprocessing > Plot Parameters. Click the Surface tab, and verify that the Surface plot check box is checked. From the Predefined quantities drop-down list, select Moving Mesh (ALE) (ale) > y-displacement. See Figure 4.78.

Click OK. Figure 4.79 shows the displacement of the electrode surface in the y-direction (dy_ale) after 10 seconds of electropolishing.

**Postprocessing Animation**

This solution to the 2D electrochemical polishing model can also be viewed as an animation. To view the solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, Click the Animate tab.
On the Animate page, select all the solutions in the Stored output times window (see Figure 4.80). Click the Start Animation button. Save this 2D electrochemical polishing model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie4_EP_3.avi that was supplied with this book.

2D Electrochemical Polishing Models: Summary and Conclusions

The models presented in this section have introduced the following new concepts: two-dimensional modeling (2D), deformed mesh—Moving Mesh (ALE), transient analysis, Conductive Media DC, vector dot product current (K*nJ_dc), triangular mesh, free mesh parameters, subdomain mesh, maximum element size, and quadrilateral
The 2D electrochemical polishing model is a powerful tool that can be used to model surface smoothing for diverse projects (e.g., microscope samples, precision metal parts, medical equipment and tools, large and small metal drums, thin analytical samples, vacuum chambers). A comparison of the calculated results for the three electropolishing models is shown in Table 4.10.

The differences between the calculations for the tested models are in the range of a few percentage points. It is left to the modeler to explore other differences between the models by varying the parameters, as suggested in the exercises at the end of this chapter.

Table 4.10  Electropolishing Modeling Results Summary

<table>
<thead>
<tr>
<th>Model</th>
<th>Asperities</th>
<th>Mesh</th>
<th>Peak ( J_n )</th>
<th>( \Delta J_n (%) )</th>
<th>( dy )</th>
<th>( \Delta dy ) (%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>EP_1</td>
<td>1</td>
<td>Triangular</td>
<td>9.12e5</td>
<td>—</td>
<td>1.08e-4</td>
<td>—</td>
</tr>
<tr>
<td>EP_2</td>
<td>1</td>
<td>Quad</td>
<td>8.87e5</td>
<td>~2.7</td>
<td>1.04e-4</td>
<td>~3.7</td>
</tr>
<tr>
<td>EP_3</td>
<td>3</td>
<td>Quad</td>
<td>8.83e5</td>
<td>~3.2</td>
<td>1.04e-4</td>
<td>~3.7</td>
</tr>
</tbody>
</table>
2D Hall Effect Model Considerations

In 1827, Georg Ohm published his now fundamental and famous Ohm’s law:

\[ I = \frac{V}{R} \]  \hspace{1cm} (4.4)

where

- \( I \) = current in amperes
- \( V \) = potential difference in volts
- \( R \) = resistance in ohms

See Figure 4.81.

As useful as Ohm’s law is, it is basically phenomenological. To more fully understand conduction in homogeneous, isotropic solid materials, the calculations
need to be expanded until they reflect the behavior (motion) of the fundamental charged particles (electrons, holes).

In solid materials (e.g., metals, semiconductors), there are three potential mobile carriers of charge: electrons (−), holes (+), and ions (charge sign can be either + or −, depending on the type of ion). Ions in a solid typically have a very low mobility (pinned in position) and, therefore, contribute little to the observed current flow in most solids. Ion flow will not be considered here.

In metals, due to the underlying physical and electronic structure, electrons are the only carrier. In semiconductors (e.g., Si, Ge, GaAs, InP), either electrons or holes (the absence of an electron) can exist as the primary carrier types. The density of each carrier type (electrons, holes) is determined by the electronic structure of the host material (e.g., Si, Ge, SiGe) and the density and distribution of any foreign impurity atoms (e.g., As, P, N, Al) within the host solid material. For further information on the nature of solids and the behavior of impurity atoms in a host matrix, see works by Kittel and Sze.

The resistance of a homogeneous, isotropic solid material \( R \) is defined as follows:

\[
R = \frac{\rho L}{A}
\]  

(4.5)

where

- \( \rho \) = resistivity in ohm-meters (\( \Omega \)-m)
- \( L \) = length of sample in meters (m)
- \( A \) = cross-sectional area of sample in meters squared (m²)

See Figure 4.82.
The resistivity of a homogeneous, isotropic solid material is defined as follows:\textsuperscript{12}

\[
\sigma = \frac{1}{\rho} = n_e |e| \mu_e + n_h |e| \mu_h \tag{4.6}
\]

where
\[
\begin{align*}
\rho &= \text{resistivity ohm-meters (}\Omega\text{-m}) \\
\sigma &= \text{conductivity in siemens per meter (S/m)} \\
n_e &= \text{electron density in electrons per cubic meter (N}_e/m^3) \\
n_h &= \text{hole density in holes per cubic meter (N}_h/m^3) \\
|e| &= \text{absolute value of the charge on an electron (hole) in coulombs (C)} \\
\mu_e &= \text{electron mobility in meters squared per volt-second (m}^2/(V\text{*s})) \\
\mu_h &= \text{hole mobility in meters squared per volt-second (m}^2/(V\text{*s}))
\end{align*}
\]

The Hall effect\textsuperscript{13} was discovered by Edwin Hall in 1879\textsuperscript{14} through measurements on the behavior of currents in thin gold foils, in the presence of a magnetic field. The magnetic field introduced into the current flow region of the solid in the Hall effect measurements effectively adds an anisotropic term into the conductivity of a nominally homogeneous, isotropic solid material. The anisotropic conductivity is caused by the magnetic field through the Lorentz force.\textsuperscript{15} The Lorentz force produces a proportional, differential voltage/charge accumulation between two surfaces or edges of a conducting material orthogonal to the current flow.

The Lorentz force is

\[
\mathbf{F} = q (\mathbf{E} + (\mathbf{v} \times \mathbf{B})) \tag{4.7}
\]

where
\[
\begin{align*}
\mathbf{F} &= \text{force vector on the charged particle (electron and/or hole)} \\
q &= \text{charge on the particle (electron and/or hole)} \\
\mathbf{E} &= \text{electric field vector} \\
\mathbf{v} &= \text{instantaneous velocity vector of the particle} \\
\mathbf{B} &= \text{magnetic field vector}
\end{align*}
\]

The Hall voltage\textsuperscript{16} is

\[
V_H = \frac{R_H I B}{t} \tag{4.8}
\]

where
\[
\begin{align*}
V_H &= \text{Hall voltage} \\
R_H &= \text{Hall coefficient} \\
I &= \text{current} \\
B &= \text{magnetic field} \\
t &= \text{thickness of sample}
\end{align*}
\]
The Hall coefficient \( (R_H) \) is

\[
R_H = -\frac{r}{n_e e}
\]

where

- \( r = 1 \leq x \leq 2 \)
- \( n_e \) = density of electrons
- \( e \) = charge on the electron

**Note:** In the Hall effect models presented here, it is assumed that \( r = 1 \). That assumption is a valid first approximation. For applied development models, the modeler will need to determine experimentally the best approximation for the value of \( r \) for the particular material and physical conditions being modeled.

For example, in the case that the charge carrier is a “hole,” the minus sign (\( - \)) in the equation for the Hall coefficient changes to a plus sign (\( + \)). In the case of mixed electron/hole flow, \( R_H \) can become zero.

The differential voltage/charge accumulation—Hall voltage \( (V_H) \)—that results from the Lorentz force interaction between any currents (electron and/or hole) flowing through that conducting material and the local magnetic field is shown in Figure 4.83.

As can be seen from the introductory material, depending on the characteristics of the material being modeled, the calculation of the Hall effect can be very complex. The Hall coefficient \( (R_H) \) varies for different materials and has a predominant functional dependence that involves temperature, carrier type, carrier concentration, carrier mobility, carrier lifetime, and carrier velocity. In a dual-carrier system, such as semiconducting materials (electrons and holes), under the proper conditions, \( R_H \) can become equal to zero. Semiconductor sensors, however, are among the most sensitive magnetic field Hall sensors currently manufactured.
Hall effect sensors are widely available in a large number of geometric configurations. They are typically applied in sensing fluid flow, rotating or linear motion, proximity, current, pressure, and orientation. In the 2D models presented in the remainder of this chapter, several simplifying assumptions will be made that allow the basic physics principles to be demonstrated without excessive complexity.

Owing to the underlying complexity of the Hall effect, the models in this section of Chapter 4 require the use of either the AC/DC Module or the MEMS Module, in addition to the basic COMSOL Multiphysics software. In the first model, only a single carrier conduction system (electrons) will be employed. For ease of modeling, it will be assumed that the system is quasi-static. This model introduces the COMSOL modeling concepts of point constraints and floating contacts.¹⁷

### 2D Hall Effect Model

To start building the Hall_Effect_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select AC/DC Module > Statics > Conductive Media DC. Click the Multiphysics button, and then click the Add button. See Figure 4.84.

![Model Navigator window](image)

**FIGURE 4.84** Multiphysics Model Navigator window
Click the Application Mode Properties button. Select “On” from the Weak constraints pull-down list. Select “Non-ideal” from the Constraint type pull-down list. See Figure 4.85. Click OK.

**Constants**

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 4.11; also see Figure 4.86. Click OK.

**2D Hall Effect Geometry**

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 1.8e-2 and height of 6e-3. Select “Base: Corner” x equal to -9e-3 and y equal to -3e-3 in the Rectangle edit window. See Figure 4.87.

Click OK, and then click the Zoom Extents button. See Figure 4.88.

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigma0</td>
<td>1.04e3 [S/m]</td>
<td>Silicon conductivity</td>
</tr>
<tr>
<td>Rh</td>
<td>1.25e-4 [m^3/C]</td>
<td>Hall coefficient</td>
</tr>
<tr>
<td>Bz</td>
<td>0.1 [T]</td>
<td>Magnetic field</td>
</tr>
<tr>
<td>coeff0</td>
<td>sigma0/(1+(sigma0<em>Rh</em>Bz)^2)</td>
<td>Conductivity anisotropy 2</td>
</tr>
<tr>
<td>V0</td>
<td>5.0 [V]</td>
<td>Applied voltage</td>
</tr>
<tr>
<td>t_Si</td>
<td>1.0e-3 [m]</td>
<td>Silicon thickness</td>
</tr>
<tr>
<td>coeff1</td>
<td>sigma0<em>Rh</em>Bz</td>
<td>Conductivity anisotropy 1</td>
</tr>
<tr>
<td>s11</td>
<td>coeff0</td>
<td>Conductivity matrix term 11</td>
</tr>
<tr>
<td>s12</td>
<td>coeff0*coeff1</td>
<td>Conductivity matrix term 12</td>
</tr>
<tr>
<td>s21</td>
<td>-coeff0*coeff1</td>
<td>Conductivity matrix term 21</td>
</tr>
<tr>
<td>s22</td>
<td>coeff0</td>
<td>Conductivity matrix term 22</td>
</tr>
</tbody>
</table>
In this model, points will be added to the boundary of the rectangle to define the location of the edges of the floating contacts. Using the menu bar, select Draw > Specify Objects > Point. In the Draw > Specify Objects > Point edit window, individually create each of the points shown in Table 4.12 by selecting the window, entering the data, and then clicking OK. The final rectangle with all four points is shown in Figure 4.89.

The points are added to the boundary of the rectangle so that the edges of the floating contacts are precisely defined.

2D Hall Effect Subdomain Settings

Using the menu bar, select Physics > Subdomain Settings > Subdomain 1 (the only choice). Enter t_Si in the d (Thickness) edit window. Verify that “Conductivity” is selected in the Conductivity relation pull-down list. Click in the Electric conductivity...
FIGURE 4.88  2D Hall_Effect_1 model rectangle geometry

FIGURE 4.89  2D Hall_Effect_1 model rectangle geometry with points
edit window. Select “Anisotropic-full” from the Conductivity type pull-down list. Enter the matrix elements as shown in Table 4.13; see Figure 4.90.

NOTE These matrix elements define the anisotropic coupling of the magnetic field and the current flowing in the silicon sample.

Close the Conductivity Matrix edit window by clicking on the Subdomain Settings window. After the Conductivity Matrix window closes, the matrix elements will be as shown in the Conductivity edit window on the Subdomain Settings page in Figure 4.91. Click OK.
Using the menu bar, select Physics > Boundary Settings. Enter the boundary settings as shown in Table 4.14. See Figures 4.92, 4.93, 4.94, 4.95, and 4.96.

**NOTE** The addition of the group index designation decouples the two floating contacts from each other. Failure to insert a different group index number for each floating contact couples (mathematically short-circuits) the contacts together.

Click the Weak Constr. tab. Verify that the Use weak constraints check box is checked. See Figure 4.97.

### Table 4.14 Boundary Settings

<table>
<thead>
<tr>
<th>Boundary Number</th>
<th>Condition</th>
<th>Group Index</th>
<th>Source Current/Potential</th>
<th>Figure</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Ground</td>
<td>—</td>
<td>—</td>
<td>4.92</td>
</tr>
<tr>
<td>2, 3, 6, 7</td>
<td>Electric insulation</td>
<td>—</td>
<td>—</td>
<td>4.93</td>
</tr>
<tr>
<td>4</td>
<td>Floating potential</td>
<td>2</td>
<td>0</td>
<td>4.94</td>
</tr>
<tr>
<td>5</td>
<td>Floating potential</td>
<td>1</td>
<td>0</td>
<td>4.95</td>
</tr>
<tr>
<td>8</td>
<td>Electric potential</td>
<td>—</td>
<td>V0</td>
<td>4.96</td>
</tr>
</tbody>
</table>

**2D Hall Effect Boundary Settings**

Using the menu bar, select Physics > Boundary Settings. Enter the boundary settings as shown in Table 4.14. See Figures 4.92, 4.93, 4.94, 4.95, and 4.96.
FIGURE 4.92 2D Hall_Effect_1 model Boundary Settings (1)

FIGURE 4.93 2D Hall_Effect_1 model Boundary Settings (2, 3, 6, 7)
FIGURE 4.94  2D Hall_Effect_1 model Boundary Settings (4)

FIGURE 4.95  2D Hall_Effect_1 model Boundary Settings (5)
**FIGURE 4.96** 2D Hall_Effect_1 model Boundary Settings (8)

**FIGURE 4.97** 2D Hall_Effect_1 model Boundary Settings, Weak Constr. page
Click OK. The final configuration of the boundary settings is shown in Figure 4.98.

2D Hall Effect Mesh Generation

Using the menu bar, select Mesh > Initialize Mesh. Click the Refine Mesh button twice. See Figure 4.99.

Solving the 2D Hall Effect Model

Using the menu bar, select Solve > Solver Parameters. In the Solver selection window, select “Parametric.” In the Parameter names edit window, enter Bz. In the Parameter values edit window, enter 0:0.1:2.0. See Figure 4.100. Click OK.

The Parametric Solver is chosen, in this case, so that the modeler can solve the Hall_Effect_1 model quasi-statically over a range of Bz. This allows the modeler to see solutions for a wide range of magnetic field values.

Using the menu bar, select Solve > Solve Problem.
Postprocessing

The default plot is a 2D surface plot of the voltage distribution at the highest value of the magnetic field ($B_z = 2$ tesla). See Figure 4.101.

More detailed information is displayed by adding contour lines. Using the menu bar, select Postprocessing > Plot Parameters. Click the Contour tab. Place a check mark in the Contour plot check box. Click the Uniform color radio button. Click the Color select button, and select “Black.” Click OK. See Figure 4.102.

The Hall effect voltage ($V_H$) can be seen as the voltage difference (color difference) between the top electrode and the bottom electrode, as shown in Figure 4.103.

There are two methods by which the voltage difference between the upper and lower surfaces can be determined in Figure 4.103. The first is by the color difference, as indicated by the color bar on the right side of the plot. The second is by the incremental position of the contour lines. If the voltage is constant in the vertical direction, the contour line will be straight and vertical. If the voltage changes, that change is reflected in the shape of the contour line.
FIGURE 4.100 2D Hall_Effect_1 model Solver Parameters window

FIGURE 4.101 2D Hall_Effect_1 model default surface voltage distribution plot
The exact voltage difference at any point in the model can be determined by creating a cross-section plot. Using the menu bar, select Postprocessing > Cross-Section Plot Parameters. Select the 2T solution in the Solutions to use window. See Figure 4.104.

Click the Line/Extrusion tab. Enter the coordinates shown in Table 4.15 on the Cross-Section Plot Parameters page. See Figure 4.105.
**FIGURE 4.103** 2D Hall_Effect_1 model surface voltage distribution plot (2T), with contour lines

**FIGURE 4.104** 2D Hall_Effect_1 model Cross-Section Plot Parameters, General page
Table 4.15  Cross-Section Line Data Edit Window

<table>
<thead>
<tr>
<th>Line Data</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>x0</td>
<td>0e-3</td>
</tr>
<tr>
<td>x1</td>
<td>0e-3</td>
</tr>
<tr>
<td>y0</td>
<td>-3e-3</td>
</tr>
<tr>
<td>y1</td>
<td>3e-3</td>
</tr>
</tbody>
</table>

Click OK. Figure 4.106 shows the voltage difference ($V_H$) between the electrode (top) and the modeled Si sample (bottom), for the line $x = 0$. In this case $V_H = 0.340$ volt ($V_{\text{high}} - V_{\text{low}} = 0.340$ V).

**Postprocessing Animation**

This solution to the 2D Hall_Effect_1 model can also be viewed as an animation. To view the solution as a movie, using the menu bar, select Postprocessing > Plot Parameters.

![Cross-Section Plot Parameters](image)

**FIGURE 4.105**  2D Hall_Effect_1 model Cross-Section Plot Parameters, Line/Extrusion page
Once the Plot Parameters window appears, click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 4.107). Click the Start Animation button. Save this 2D Hall effect model animation by clicking on the disk icon on the player screen. Alternatively, you can play the file Movie4_HE_1.avi that was supplied with this book.

**First Variation on the 2D Hall Effect Model**

This model reflects a closer approach to the construction of a specimen as would be constructed from a silicon wafer. In this model, both Si end contacts and side contacts have been added, as would be the case for a fabricated Si sample.

To start building the Hall_Effect_2 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select AC/DC Module > Statics > Conductive Media DC. Click the Multiphysics button, and then click the Add button. See Figure 4.108.

Click the Application Mode Properties button. Select “On” from the Weak constraints pull-down list. Select “Non-ideal” from the Constraint type pull-down list. See Figure 4.109. Click OK.
FIGURE 4.107 2D Hall_Effect_1 model animation Plot Parameters window
**FIGURE 4.108** Multiphysics Model Navigator window

**FIGURE 4.109** Application Mode Properties window
Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 4.16; also see Figure 4.110. Click OK.

### 2D Hall Effect Geometry

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 1.8e-2, and a height of 6e-3. Select “Base: Corner” x and set equal to -9e-3 and y equal to -3e-3 in the Rectangle edit window. See Figure 4.111.

Click OK, and then the click the Zoom Extents button. See Figure 4.112.

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigma0</td>
<td>1.04e3[S/m]</td>
<td>Silicon conductivity</td>
</tr>
<tr>
<td>Rh</td>
<td>1.25e-4[m^3/C]</td>
<td>Hall coefficient</td>
</tr>
<tr>
<td>Bz</td>
<td>0.1[T]</td>
<td>Magnetic field</td>
</tr>
<tr>
<td>coeff0</td>
<td>sigma0/(1+(sigma0<em>Rh</em>Bz)^2)</td>
<td>Conductivity anisotropy 2</td>
</tr>
<tr>
<td>V0</td>
<td>5.0[V]</td>
<td>Applied voltage</td>
</tr>
<tr>
<td>t_Si</td>
<td>1.0e-3[m]</td>
<td>Silicon thickness</td>
</tr>
<tr>
<td>coeff1</td>
<td>sigma0<em>Rh</em>Bz</td>
<td>Conductivity anisotropy 1</td>
</tr>
<tr>
<td>s11</td>
<td>coeff0</td>
<td>Conductivity matrix term 11</td>
</tr>
<tr>
<td>s12</td>
<td>coeff0*coeff1</td>
<td>Conductivity matrix term 12</td>
</tr>
<tr>
<td>s21</td>
<td>-coeff0*coeff1</td>
<td>Conductivity matrix term 21</td>
</tr>
<tr>
<td>s22</td>
<td>coeff0</td>
<td>Conductivity matrix term 22</td>
</tr>
</tbody>
</table>
**FIGURE 4.111** 2D Hall_Effect_2 model Rectangle edit window

**FIGURE 4.112** 2D Hall_Effect_2 model rectangle geometry
In this model, rectangles will be added to the boundary of the rectangle to define the location of the positions of the contacts and the floating contacts. Using the menu bar, select Draw > Specify Objects > Rectangle. In the Draw > Specify Objects > Rectangle edit window, individually create each of the rectangles shown in Table 4.17 by selecting the window, entering the data, and then clicking OK. The final geometry with all four added rectangles is shown in Figure 4.114.

Click the Zoom Extents button. Select Draw > Create Composite Object. Select all of the rectangles. Verify that the Keep interior boundaries check box is checked. Click OK. Figure 4.114 shows the composite object.

The contact rectangles are added to the boundary of the first rectangle so that the contacts and the floating contacts are precisely defined.

### Table 4.17  Rectangle Edit Window

<table>
<thead>
<tr>
<th>Rectangle Number</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>x Location</th>
<th>y Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2e-3</td>
<td>1e-3</td>
<td>Corner</td>
<td>-1e-3</td>
<td>3e-3</td>
</tr>
<tr>
<td>2</td>
<td>2e-3</td>
<td>1e-3</td>
<td>Corner</td>
<td>-1e-3</td>
<td>-4e-3</td>
</tr>
<tr>
<td>3</td>
<td>1e-3</td>
<td>6e-3</td>
<td>Corner</td>
<td>-1e-2</td>
<td>-3e-3</td>
</tr>
<tr>
<td>4</td>
<td>1e-3</td>
<td>6e-3</td>
<td>Corner</td>
<td>9e-3</td>
<td>-3e-3</td>
</tr>
</tbody>
</table>

**2D Hall Effect Subdomain Settings**

Using the menu bar, select Physics > Subdomain Settings. Select subdomains 1, 3, 4, and 5 in the Subdomain selection window. Enter t_Si in the d (Thickness) edit window.
Verify that “Conductivity” is selected in the Conductivity relation pull-down list. Enter \( \sigma_0 \) in the Electric conductivity window. See Figure 4.115.

Select subdomain 2 in the Subdomain selection window. Enter \( t_{\text{Si}} \) in the \( d \) (Thickness) edit window. Verify that “Conductivity” is selected in the Conductivity relation pull-down list. Click in the Electric conductivity edit window. Select “Anisotropic-full” from the Conductivity type pull-down list. Enter the matrix elements as shown in Table 4.18; see Figures 4.116 and 4.117. Click OK.

**NOTE** These matrix elements define the anisotropic coupling of the magnetic field and the current flowing in the silicon sample.

<table>
<thead>
<tr>
<th>Table 4.18 Matrix Elements Edit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td>Matrix Element Number</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
<tr>
<td>21</td>
</tr>
<tr>
<td>22</td>
</tr>
</tbody>
</table>
**FIGURE 4.115** 2D Hall_Effect_2 model geometry, Subdomain Settings (1, 3, 4, 5)

**FIGURE 4.116** 2D Hall_Effect_2 model geometry, Subdomain Settings (2)
Table 4.19  Boundary Settings

<table>
<thead>
<tr>
<th>Boundary Number</th>
<th>Condition</th>
<th>Group Index</th>
<th>Source Current/Potential</th>
<th>Figure</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Ground</td>
<td>—</td>
<td>—</td>
<td>4.118</td>
</tr>
<tr>
<td>2, 3, 5–7,</td>
<td>Electric insulation</td>
<td>—</td>
<td>—</td>
<td>4.119</td>
</tr>
<tr>
<td>10, 13–16,</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18, 19</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Floating potential</td>
<td>2</td>
<td>0</td>
<td>4.120</td>
</tr>
<tr>
<td>12</td>
<td>Floating potential</td>
<td>1</td>
<td>0</td>
<td>4.121</td>
</tr>
<tr>
<td>20</td>
<td>Electric potential</td>
<td>—</td>
<td>V0</td>
<td>4.122</td>
</tr>
</tbody>
</table>

2D Hall Effect Boundary Settings

Using the menu bar, select Physics > Boundary Settings. Enter the boundary settings as shown in Table 4.19. See Figures 4.118, 4.119, 4.120, 4.121, and 4.122.

FIGURE 4.117 2D Hall_Effect_2 model conductivity matrix elements

FIGURE 4.118 2D Hall_Effect_2 model Boundary Settings (1)
**FIGURE 4.119** 2D Hall_Effect_2 model Boundary Settings (2, 3, 5–7, 10, 13–16, 18, 19)

**FIGURE 4.120** 2D Hall_Effect_2 model Boundary Settings (8)
The addition of the group index designation decouples the two floating contacts from each other.

Select the Weak Constr. tab. Verify that the Use weak constraints check box is checked. See Figure 4.123.

Click OK. The final configuration of the boundary settings is shown in Figure 4.124.
FIGURE 4.123  2D Hall_Effect_2 model Boundary Settings, Weak Constr. page

FIGURE 4.124  2D Hall_Effect_2 model boundary settings, final configuration
2D Hall Effect Mesh Generation

Using the menu bar, select Mesh > Initialize Mesh. Click the Refine Mesh button twice. See Figure 4.125.

Solving the First Variation on the 2D Hall Effect Model

Using the menu bar, select Solve > Solver Parameters. In the Solver selection window, select “Parametric.” In the Parameter name edit window, enter Bz. In the Parameter values edit window, enter 0:0.1:2.0. See Figure 4.126. Click OK.

The Parametric Solver is chosen, in this case, so that the modeler can solve the Hall_Effect_2 Model quasi-statically. This allows the modeler to see solutions over a wide range of magnetic field values.

Using the menu bar, select Solve > Solve Problem.

Postprocessing

The default plot is a 2D surface plot of the voltage distribution at the highest value of the magnetic field (Bz = 2 Tesla). See Figure 4.127.
FIGURE 4.126 2D Hall_Effect_2 model Solver Parameters window

FIGURE 4.127 2D Hall_Effect_2 model default surface voltage distribution plot
More detailed information is displayed by adding contour lines. Using the menu bar, select Postprocessing > Plot Parameters. Click the Contour tab. Place a check mark in the Contour plot check box. Click the Uniform color radio button. Click the Color select button, and select “Black.” See Figure 4.128.

Click OK. The Hall effect voltage ($V_H$) can be seen as the voltage difference between the top electrode and the bottom electrode, as shown in Figure 4.129.

The exact voltage difference at any point in the model can be determined by creating a cross-section plot. Using the menu bar, select Postprocessing > Cross-Section Plot Parameters. Select the 2T solution in the Solutions to use window. See Figure 4.130.
FIGURE 4.129 2D Hall_Effect_2 model surface voltage distribution plot (2T), with contour lines

FIGURE 4.130 2D Hall_Effect_2 model Cross-Section Plot Parameters, General page
Click the Line/Extrusion tab. Enter the coordinates shown in Table 4.20 on the Cross-Section Plot Parameters page. See Figure 4.131.

Click OK. Figure 4.132 shows the voltage difference \( V_H \) between the electrode (top) and the modeled Si sample (bottom), for the line \( x = 0 \). In this case, \( V_H = 0.350 \) volts \( (V_{\text{high}} - V_{\text{low}} = 0.350 \text{ V}) \).

**Postprocessing Animation**

This solution to the 2D Hall_Effect_2 model can also be viewed as an animation. To view the solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 4.133). Click the
Second Variation on the 2D Hall Effect Model

This Hall effect model demonstrates the effect of having holes as the carrier in this electronic material (a p-type semiconductor). A second, lower contact has been added to allow the use of an external balancing circuit. A change is made in the value of the conductivity, because holes are less mobile than electrons in Si.

NOTE Semiconductors have two types of carriers: electrons (n-type) and holes (p-type). In a purified semiconductor, such as silicon (Si) or germanium (Ge), both carriers are thermally activated and exist in equal numbers. That native conduction mode is called the intrinsic conduction mode.

To fabricate electronic device structures, foreign atoms (As or P for n-type and Al or B for p-type) are added to the host lattice (Si). The carriers are more easily thermally activated from the foreign atoms (dopant atoms) at room temperature. This non-native
The conduction mode is called the extrinsic conduction mode. In the extrinsic mode, the carriers activated from the dopant atoms and the small number of carriers activated intrinsically become the majority carriers (e.g., electrons). The second carrier (holes in this example) becomes the minority carrier. The electron and hole carrier densities are related by the mass action law: \[ np = n_i^2 \] (4.10)

where
- \( n_i \) = intrinsic carrier density
- \( n \) = electron carrier density
- \( p \) = hole carrier density
To start building the Hall_Effect_3 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select AC/DC Module > Statics > Conductive Media DC. Click the Multiphysics button, and then click the Add button. See Figure 4.134.

Click the Application Mode Properties button. Select “On” from the Weak constraints pull-down list. Select “Non-ideal” from the Constraint type pull-down list. See Figure 4.135. Click OK.
**Table 4.21  Constants Edit Window**

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigma0</td>
<td>$2.4 \times 10^2 \text{S/m}$</td>
<td>Silicon conductivity</td>
</tr>
<tr>
<td>Rh</td>
<td>$1.25 \times 10^{-4} \text{m}^3/\text{C}$</td>
<td>Hall coefficient</td>
</tr>
<tr>
<td>Bz</td>
<td>0.1[T]</td>
<td>Magnetic field</td>
</tr>
<tr>
<td>coeff0</td>
<td>$\frac{\text{sigma0}}{(1+(\text{sigma0} \cdot \text{Rh} \times \text{Bz})^2)}$</td>
<td>Conductivity anisotropy 2</td>
</tr>
<tr>
<td>V0</td>
<td>5.0[V]</td>
<td>Applied voltage</td>
</tr>
<tr>
<td>t_Si</td>
<td>1.0e-3[m]</td>
<td>Silicon thickness</td>
</tr>
<tr>
<td>coeff1</td>
<td>$\text{sigma0} \cdot \text{Rh} \cdot \text{Bz}$</td>
<td>Conductivity anisotropy 1</td>
</tr>
<tr>
<td>s11</td>
<td>coeff0</td>
<td>Conductivity matrix term 11</td>
</tr>
<tr>
<td>s12</td>
<td>$-\text{coeff0} \cdot \text{coeff1}$</td>
<td>Conductivity matrix term 12</td>
</tr>
<tr>
<td>s21</td>
<td>coeff0(coeff1)</td>
<td>Conductivity matrix term 21</td>
</tr>
<tr>
<td>s22</td>
<td>coeff0</td>
<td>Conductivity matrix term 22</td>
</tr>
</tbody>
</table>

**Constants**

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 4.21; also see Figure 4.136. Click OK.

**2D Hall Effect Geometry**

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 1.8e-2, and a height of 6e-3. Select “Base: Corner” and set x equal to -9e-3, and y equal to -3e-3 in the Rectangle edit window. See Figure 4.137.

FIGURE 4.136  2D_Hall_Effect_3 model Constants edit window
Click OK, and then click the Zoom Extents button. See Figure 4.138.

In this model, rectangles will be added to the boundary of the rectangle to define the location of the positions of the contacts and the floating contacts. Using the menu bar, select Draw > Specify Objects > Rectangle. In the Draw > Specify Objects > Rectangle edit window, individually create each of the rectangles shown in Table 4.22 by selecting the window, entering the data, and then clicking OK.

Click the Zoom Extents button. Select Draw > Create Composite Object. Select all of the rectangles. Verify that the Keep interior boundaries check box is checked. See Figure 4.139.
Click OK. Figure 4.140 shows the composite object.

One contact rectangle at the top of the Hall effect model, two contact rectangles at the bottom, and two contact rectangles on the ends are added to the boundary of the first rectangle so that the contacts and the floating contacts are precisely defined. The three contacts (top and bottom) are a typical experimental configuration to allow the measuring instrument to balance the circuit and offset any unintended error voltages.

### 2D Hall Effect Subdomain Settings

Using the menu bar, select Physics > Subdomain Settings. Select subdomains 1, 3, 4, 5, and 6 in the Subdomain selection window. Enter $t_{Si}$ in the d (Thickness) edit window. Verify that “Conductivity” is selected in the Conductivity relation pull-down list. Enter $\sigma_0$ in the Electric conductivity window. See Figure 4.141.

<table>
<thead>
<tr>
<th>Rectangle Number</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>$x$ Location</th>
<th>$y$ Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2e-3</td>
<td>1e-3</td>
<td>Corner</td>
<td>-1e-3</td>
<td>3e-3</td>
</tr>
<tr>
<td>2</td>
<td>2e-3</td>
<td>1e-3</td>
<td>Corner</td>
<td>-4e-3</td>
<td>-4e-3</td>
</tr>
<tr>
<td>3</td>
<td>2e-3</td>
<td>1e-3</td>
<td>Corner</td>
<td>2e-3</td>
<td>-4e-3</td>
</tr>
<tr>
<td>4</td>
<td>1e-3</td>
<td>6e-3</td>
<td>Corner</td>
<td>-1e-2</td>
<td>-3e-3</td>
</tr>
<tr>
<td>5</td>
<td>1e-3</td>
<td>6e-3</td>
<td>Corner</td>
<td>9e-3</td>
<td>-3e-3</td>
</tr>
</tbody>
</table>

Table 4.22 Rectangle Edit Window
FIGURE 4.140 2D Hall_Effect_3 model geometry with added rectangles

FIGURE 4.141 2D Hall_Effect_3 model geometry, Subdomain Settings (1, 3, 4, 5, 6)
These matrix elements define the anisotropic coupling of the magnetic field and the current flowing in the silicon sample.

Select subdomain 2 in the Subdomain selection window. Enter t_Si in the d (Thickness) edit window. Verify that “Conductivity” is selected in the Conductivity relation pull-down list. Click in the Electric conductivity edit window. Select “Anisotropic-full” from the Conductivity type pull-down list. Enter the matrix elements as shown in Table 4.23; see Figures 4.142 and 4.143. Click OK.

<table>
<thead>
<tr>
<th>Matrix Element Number</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>s11</td>
</tr>
<tr>
<td>12</td>
<td>s12</td>
</tr>
<tr>
<td>21</td>
<td>s21</td>
</tr>
<tr>
<td>22</td>
<td>s22</td>
</tr>
</tbody>
</table>

**Table 4.23 Matrix Elements Edit Window**
The addition of the group index designation decouples the three floating contacts from one another.

### Table 4.24 Boundary Settings

<table>
<thead>
<tr>
<th>Boundary Number</th>
<th>Condition</th>
<th>Group Index</th>
<th>Source Current/Potential</th>
<th>Figure</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Ground</td>
<td>—</td>
<td>—</td>
<td>4.144</td>
</tr>
<tr>
<td>2, 3, 5–7, 10–12, 15–17, 20, 21</td>
<td>Electric insulation</td>
<td>—</td>
<td>—</td>
<td>4.145</td>
</tr>
<tr>
<td>23, 24</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Floating potential 1</td>
<td>1</td>
<td>0</td>
<td>4.146</td>
</tr>
<tr>
<td>14</td>
<td>Floating potential 2</td>
<td>2</td>
<td>0</td>
<td>4.147</td>
</tr>
<tr>
<td>18</td>
<td>Floating potential 3</td>
<td>3</td>
<td>0</td>
<td>4.148</td>
</tr>
<tr>
<td>25</td>
<td>Electric potential</td>
<td>—</td>
<td>V0</td>
<td>4.149</td>
</tr>
</tbody>
</table>

#### 2D Hall Effect Boundary Settings

Using the menu bar, select Physics > Boundary Settings. Enter the boundary settings as shown in Table 4.24. See Figures 4.144, 4.145, 4.146, 4.147, 4.148, and 4.149.
FIGURE 4.145  2D Hall_Effect_3 model Boundary Settings (2, 3, 5–7, 10–12, 15–17, 20, 21, 23, 24)

FIGURE 4.146  2D Hall_Effect_3 model Boundary Settings (8)
**FIGURE 4.147** 2D Hall_Effect_3 model Boundary Settings (14)

**FIGURE 4.148** 2D Hall_Effect_3 model Boundary Settings (18)
Click the Weak Constr. tab. Verify that the Use weak constraints check box is checked. See Figure 4.150.

Click OK. The final configuration of the boundary settings is shown in Figure 4.151.

**2D Hall Effect Mesh Generation**

Using the menu bar, select Mesh > Initialize Mesh. Click the Refine Mesh button twice. See Figure 4.152.

**FIGURE 4.149** 2D Hall_Effect_3 model Boundary Settings (25)

**FIGURE 4.150** 2D Hall_Effect_3 model Boundary Settings, Weak Constr. page
**FIGURE 4.151**  2D Hall_Effect_3 model boundary settings, final configuration

**FIGURE 4.152**  2D Hall_Effect_3 model mesh
Solving the Second Variation on the 2D Hall Effect Model

Using the menu bar, select Solve > Solver Parameters. In the Solver selection window, select “Parametric.” In the Parameter name edit window, enter Bz. In the Parameter values edit window, enter 0:0.1:2.0. See Figure 4.153. Click OK.

The Parametric Solver is chosen, in this case, so that the modeler can solve the Hall_Effect_3 Model quasi-statically. This allows the modeler to see solutions over a wide range of magnetic field values.

Using the menu bar, select Solve > Solve Problem.

Postprocessing

The default plot is a 2D surface plot of the voltage distribution at the highest value of the magnetic field (Bz = 2 Tesla). See Figure 4.154.
More detailed information is displayed by adding contour lines. Using the menu bar, select Postprocessing > Plot Parameters. Click the Contour tab. Place a check mark in the Contour plot check box. Click the Uniform color radio button. Click the Color select button, and select “Black.” See Figure 4.155.

Click OK. See Figure 4.156.

The exact voltage difference at any point in the model can be determined by creating a cross-section plot. Using the menu bar, select Postprocessing > Cross-Section Plot Parameters. Select the 2T solution in the Solutions to use window. See Figure 4.157.

Click the Line/Extrusion tab. Enter the coordinates shown in Table 4.25 on the Cross-Section Plot Parameters page.

<table>
<thead>
<tr>
<th>Line Data</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>x0</td>
<td>0e-3</td>
</tr>
<tr>
<td>x1</td>
<td>0e-3</td>
</tr>
<tr>
<td>y0</td>
<td>-3e-3</td>
</tr>
<tr>
<td>y1</td>
<td>4e-3</td>
</tr>
</tbody>
</table>
Select “y” on the x-axis data pull-down list. See Figure 4.158.
Click OK. Figure 4.159 shows the voltage difference \(V_H\) between the electrode (top) and the modeled Si sample (bottom), for the line \(x = 0\). In this case, \(V_H = 0.085\) volts \((V_{\text{high}} - V_{\text{low}} = 0.085\) V).

**Postprocessing Animation**
This solution to the 2D Hall_Effect_3 model can also be viewed as an animation. To view the solution as a movie, using the menu bar, select Postprocessing > Plot Parameters. Once the Plot Parameters window appears, click the Animate tab. On the Animate page, select all the solutions in the Stored output times window (see Figure 4.160). Click the Start Animation button. Save this 2D Hall effect model animation by
**FIGURE 4.156** 2D Hall_Effect_3 model surface voltage distribution plot (2T), with contour lines

**FIGURE 4.157** 2D Hall_Effect_3 model Cross-Section Plot Parameters, General page
FIGURE 4.158 2D Hall_Effect_3 model Cross-Section Plot Parameters, Line/Extrusion page

FIGURE 4.159 2D Hall_Effect_3 model plot $V_{xy}$
clicking on the disk icon on the player screen. Alternatively, you can play the file Movie4_HE_3.avi that was supplied with this book.

2D Hall Effect Models: Summary and Conclusions

The models presented in this section of Chapter 4 have introduced the following new concepts: two-dimensional modeling (2D), the Hall effect, AC/DC Module, Conductive Media DC, weak constraints, floating contacts, anisotropic conductivity, semiconductor dual-carrier types, and imbalance-offset geometry. The 2D Hall effect model is a powerful tool that can be used to model Hall effect magnetic sensors for sensing fluid flow, rotating or linear motion, proximity, current, pressure, and orientation. A comparison of the calculated results for the three Hall effect models is shown in Table 4.26.
The differences between the calculations for the tested models for the n-type carrier are in the range of a few percentage points. It can clearly be seen that the p-type silicon is only one-fourth as sensitive as the n-type material. That reduction in sensitivity is attributable to the low hole mobility. It is left to the modeler to explore other differences between the models by variation of the parameters, as suggested in the exercises at the end of this chapter.

## References


<table>
<thead>
<tr>
<th>Model</th>
<th>Floating Contacts</th>
<th>Carrier Type</th>
<th>(V_H) (V)</th>
<th>((V_H \Delta %))</th>
</tr>
</thead>
<tbody>
<tr>
<td>HE_1</td>
<td>Point defined</td>
<td>n-type (electron)</td>
<td>0.340</td>
<td>—</td>
</tr>
<tr>
<td>HE_2</td>
<td>Dual rectangle defined</td>
<td>n-type (electron)</td>
<td>0.350</td>
<td>−+3</td>
</tr>
<tr>
<td>HE_3</td>
<td>Triple rectangle defined</td>
<td>p-type (hole)</td>
<td>−0.085</td>
<td>−−75</td>
</tr>
</tbody>
</table>

17. COMSOL Multiphysics Software Models Database, Hall Plate with Floating Contacts.


### Exercises

1. Build, mesh, and solve the COMSOL 2D electrochemical polishing model problem presented in this chapter.
2. Build, mesh, and solve the first variation of the 2D electrochemical polishing model problem presented in this chapter.
3. Build, mesh, and solve the second variation of the 2D electrochemical polishing model problem presented in this chapter.
4. Build, mesh, and solve the Hall effect model presented in this chapter.
5. Build, mesh, and solve the first variation of the Hall effect model presented in this chapter.
6. Build, mesh, and solve the second variation of the Hall effect model presented in this chapter.
7. Explore other variations of the arguments in the COMSOL 2D electrochemical polishing models.
8. Explore other variations of the arguments in the Hall effect models.
9. Explore how an increase in the run time modifies the behavior of the COMSOL 2D electrochemical polishing model.
10. Explore how changes in the sample geometry affect the behavior of the Hall effect model.
In This Chapter

2D Axisymmetric Guidelines for New COMSOL® Multiphysics® Modelers
  2D Axisymmetric Modeling Considerations
  2D Axisymmetric Coordinate System
  Heat Conduction Theory
2D Axisymmetric Heat Conduction Modeling
  2D Axisymmetric Cylinder Conduction Model
  First Variation on the 2D Axisymmetric Cylinder Conduction Model
  Second Variation on the 2D Axisymmetric Cylinder Conduction Model,
    Including a Vacuum Cavity
  2D Axisymmetric Cylinder Conduction Models: Summary and Conclusions
2D Axisymmetric Insulated Container Design
  2D Axisymmetric Thermos_Container Model
  First Variation on the 2D Axisymmetric Thermos_Container Model
  Second Variation on the 2D Axisymmetric Thermos_Container Model
  2D Axisymmetric Thermos_Container Models: Summary and Conclusions

2D Axisymmetric Guidelines for New COMSOL® Multiphysics® Modelers

2D Axisymmetric Modeling Considerations

2D axisymmetric modeling can be less difficult than 1D modeling and is about the same level of difficulty as 2D modeling. Specifically, 2D axisymmetric modeling has fewer implicit assumptions than 1D modeling. The 2D axisymmetric model requires the modeler to think in terms of cylindrical coordinates and rotational symmetry. Such models can be challenging to build, depending on the underlying physics involved. The least difficult aspect of 2D axisymmetric model building arises from the fact that the geometry is still relatively simple. (In a 2D model, the modeler has only a single plane as the modeling space.) However, the physics and the rotational nature of the geometry in a 2D axisymmetric model can range from relatively easy to extremely complex.
COMSOL® Multiphysics® software has two 2D modeling modes: 2D (beginning-level through advanced-level 2D modeling) and 2D axisymmetric (advanced-level 2D modeling). In keeping with the introductory focus of the material in this text, both of the model types—that is, the 2D model introduced in Chapter 4, and the 2D axisymmetric model introduced in this chapter—along with the associated physics and the related methodology for use of the models, are introduced in this book. Significantly more advanced 2D modeling techniques exist than those presented here in Chapters 4 and 5. Examples of some of those more difficult techniques are reserved for introduction in later chapters (6 and 7). For further expansion of your 2D modeling horizons, refer to the COMSOL Manuals, the COMSOL website, and the general COMSOL Multiphysics software-related research literature.

The 2D axisymmetric model implicitly assumes, in compliance with the laws of physics, that the energy flow, the materials properties, the environment, and any other conditions and variables that are of interest are homogeneous, isotropic, or constant, unless otherwise specified, throughout the entire domain of interest, both within the model and, through the boundary conditions, in the environs of the model. Bearing that in mind, the modeler needs to ensure that all of the modeling conditions and associated parameters (default settings) in each new model created have been properly considered, defined, or set to the appropriate value(s).

The modeler also needs to seriously consider the steps that will be required to establish the correct postprocessing and visualization settings so as to extract the desired information from the modeling solution. The default parameter settings on any given model will probably not present exactly the information that the modeler needs or desires, although it may come close to meeting the modeler’s demands. It is the responsibility of the modeler to determine exactly which of the myriad of postprocessing and visualization choices available in the COMSOL Multiphysics software to employ.

As mentioned previously, it is always preferable for the modeler to be able to accurately anticipate the expected behavior (results) of the model and the presentation of its results. Do not assume that the default values that are initially present when the model is first created will suit the needs of the new model. Always verify that the values employed in the model are the correct values needed for that model. Calculated solution values that significantly deviate from the expected values or from comparison values measured in experimentally derived realistic models are probably indicative of one or more modeling errors either in the original model design, in the earlier model analysis, or in the understanding of the underlying physics, or they may simply be due to human error.
2D Axisymmetric Coordinate System

In 2D axisymmetric models, there are two geometrical coordinates: space ($r$) and space ($z$). See Figure 5.1.

In the steady-state solution to any 2D axisymmetric model, parameters can vary only as a function of the radial position in space ($r$) and the axial position space ($z$) coordinates. Such a model represents the parametric condition of the model in a time-independent mode (quasi-static). In a transient solution model, parameters can vary both by position in space ($r$) and space ($z$) and in time ($t$). The transient solution model is essentially a sequential collection of steady-state (quasi-static) solutions. The space coordinates ($r$) and ($z$) typically represent a distance coordinate throughout which the model is to calculate the change of the specified observables (i.e., temperature, heat flow, pressure, voltage, current) over the range of values ($r_{\text{min}} \leq r \leq r_{\text{max}}$) and ($z_{\text{min}} \leq z \leq z_{\text{max}}$). The time coordinate ($t$) represents the range of values ($t_{\text{min}} \leq t \leq t_{\text{max}}$) from the beginning of the observation period ($t_{\text{min}}$) to the end of the observation period ($t_{\text{max}}$).

To assist the reader in achieving a broader exposure to the applicability of the physics discussed in this chapter and to demonstrate the power of the basic COMSOL 2D axisymmetric modeling techniques, the examples in this chapter demonstrate heat transfer modeling techniques from two substantially different approaches. Heat transfer is an extremely important design consideration. It is one of the most widely needed and applied technologies employed in applied engineering and physics. Most modern products or processes require an understanding of heat transfer either during development or during the use of the product or process (e.g., automobiles, plate glass fabrication, plastic extrusion, plastic products, houses, ice cream).
Heat transfer concerns have existed since the beginning of prehistory. The science of thermodynamics, and consequently the present understanding of heat transfer, started with the work of Nicolas Leonard Sadi Carnot, as published in his 1824 paper titled “Reflections on the Motive Power of Fire.”\(^1\) The first use of the term “thermodynamics” is attributed to William Thomson (Lord Kelvin).\(^2\) Subsequent contributions to the understanding of heat, heat transfer, and thermodynamics in general were made by James Prescott Joule,\(^3\) Ludwig Boltzmann,\(^4\) James Clerk Maxwell,\(^5\) Max Planck,\(^6\) and numerous others. The physical understanding and engineering use of thermodynamics play a very important role in the technological aspects of machine and process design in modern applied science, engineering, and medicine.

The first example presented in this chapter, on cylinder conduction, explores the 2D axisymmetric steady-state modeling of heat transfer and temperature profiling for a thermally conductive material, implemented through use of the COMSOL Heat Transfer Module. In the first variation on the cylinder conduction model, a model is built using the basic COMSOL Multiphysics software. The calculated modeling results are then compared. The second variation on the cylinder conduction model explores the use of heat transfer modeling for low-pressure gas/vacuum environments.

The second 2D axisymmetric modeling example in this chapter, titled Thermos_Container, explores the modeling of heat loss for thermally insulated containers.

Insulated containers can be found applied in many different applications in modern society. Examples include Thermos containers, water heaters, and refrigerated liquid containers (for fuels, liquified gases, heat exchangers, and so on).

**Heat Conduction Theory**

Heat conduction is a naturally occurring process that is readily observed in many aspects of modern life (e.g., refrigerators, freezers, microwave ovens, thermal ovens, engines). The heat transfer process allows both linear and rotational work to be done in the generation of electricity and the movement of vehicles. The initial understanding of transient heat transfer was developed by Newton\(^7\) and started with Newton’s law of cooling:\(^8\)

\[
\frac{dQ}{dt} = h*A*(T_S - T_E)
\]

(5.1)

where
- \(\frac{dQ}{dt}\) is the incremental energy lost in joules per unit time (J/s)
- \(A\) is the energy transmission surface area (m\(^2\))
- \(h\) is the heat transfer coefficient [W/(m\(^2\)*K)]
- \(T_S\) is the surface temperature of the object losing heat (K)
- \(T_E\) is the temperature of the environment gaining heat (K)
Subsequent work by Jean Baptiste Joseph Fourier,\(^9\) based on Newton’s law of cooling, developed the law for steady-state heat conduction (known as Fourier’s law\(^10\)). Fourier’s law is expressed here in differential form:

\[
q = -k\nabla T
\]  \hspace{1cm} (5.2)

where
- \(q\) is the heat flux in watts per square meter (W/m\(^2\))
- \(k\) is the thermal conductivity of the material [W/(m*K)]
- \(\nabla T\) is the temperature gradient (K/m)

### 2D Axisymmetric Heat Conduction Modeling

The following numerical solution model (cylinder conduction) was originally developed by COMSOL as a tutorial model based on an example from the NAFEMS collection.\(^11\) It was developed for distribution with the Multiphysics software as a COMSOL Multiphysics General Heat Transfer Application Mode Model in the Heat Transfer Module Model Library. This model introduces two important basic concepts that apply to both applied physics and applied modeling: axisymmetric geometry (cylindrical) modeling and heat transfer modeling.

It is important for the new modeler to personally build each model presented within the text. There is no substitute in the path to an understanding of the modeling process for the hands-on experience of actually building, meshing, solving, and postprocessing a model. Many times the inexperienced modeler will make and subsequently correct errors, thereby adding to his or her experience and fund of modeling knowledge. Even building the simplest models will expand the modeler’s fund of knowledge.

Heat transfer modeling is important in physical design and applied engineering problems. Typically, the modeler desires to understand heat generation during a process and to either add heat or remove heat to achieve or maintain a desired temperature. Figure 5.2 shows a 3D rendition of the 2D axisymmetric cylinder conduction geometry, as will be modeled here. The dashed-line ellipses in Figure 5.2 indicate the 3D rotation that would need to occur to generate the 3D solid object from the 2D cross section shown.

### 2D Axisymmetric Cylinder Conduction Model

This model is derived from the COMSOL cylinder conduction model. In this model, however, the selected thermally conductive solid is niobium (Nb).\(^12,13\) Niobium has a variety of uses—as an alloying element in steels, as an alloying element in titanium turbine blades, in superconductors, as an anticorrosion coating, as an optical coating, and as an alloy in coinage.
To start building the Cylinder_Conduction_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Next select Heat Transfer Module > General Heat Transfer > Steady-state analysis. See Figure 5.3. Click OK.

![Figure 5.3](image-url) 2D axisymmetric Cylinder_Conduction_1 Model Navigator setup
Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 5.1; also see Figure 5.4. Click OK.

When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Since the settings in Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.08 and a height of 0.14. Select “Base: Corner” and set r equal to 0.02 and z equal to 0 in the Rectangle edit window. See Figure 5.5.

Click OK, and then click the Zoom Extents button. See Figure 5.6.

Using the menu bar, select Draw > Specify Objects > Point. In the Point edit window, enter the information shown in Table 5.2. See Figure 5.7.

Click OK. See Figure 5.8.
FIGURE 5.5 2D axisymmetric Cylinder_Conduction_1 model Rectangle edit window

FIGURE 5.6 2D axisymmetric Cylinder_Conduction_1 model cylinder rectangle

Table 5.2  Point Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>r Location</th>
<th>z Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point 1</td>
<td>0.02</td>
<td>0.04</td>
</tr>
<tr>
<td>Point 2</td>
<td>0.02</td>
<td>0.1</td>
</tr>
</tbody>
</table>
Two points have been added on the interior (small $r$ value) boundary of the rectangle (cylinder cross section) to define the upper (larger $z$ value) and lower (smaller $z$ value) bounds of the heat-flux application region.

Physics Subdomain Settings: General Heat Transfer

Having established the geometry for the 2D axisymmetric Cylinder_Conduction_1 model (a rectangle with two points on the boundary), the next step is to define the fundamental Physics conditions. Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain).
In the Subdomain edit windows, enter the information shown in Table 5.3; also see Figure 5.9. Click OK.

For static and quasi-static calculations, the only physical property value required for the conduction calculation is \( k \) (\( k_{Nb} \)). From the point of view of physical consistency, however, the density (\( \rho_{Nb} \)) and the heat capacity (\( C_p_{Nb} \)) should be included as well. If \( C_p \) and \( \rho \) are set to zero, the implication is the model includes a perfect vacuum, which is logically inconsistent with the stated value of \( k \). Also, by including the values for \( C_p \) and \( \rho \) in this location, they are conveniently available should the modeler wish to modify the model for transient analysis.

### Table 5.3 Subdomain Edit Windows

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>( k ) (isotropic)</td>
<td>( k_{Nb} )</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td>( \rho )</td>
<td>( \rho_{Nb} )</td>
<td>Density</td>
</tr>
<tr>
<td>( C_p )</td>
<td>( C_p_{Nb} )</td>
<td>Heat capacity</td>
</tr>
</tbody>
</table>

![Figure 5.9](image_url)
Physics Boundary Settings: General Heat Transfer

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select and/or enter the given boundary condition and value as shown in Table 5.4. Click OK. See Figures 5.10, 5.11, and 5.12.

Mesh Generation

On the toolbar, click the Initialize Mesh button once. Click the Refine Mesh button once. This results in a mesh of approximately 2200 elements. See Figure 5.13.

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 4</td>
<td>Thermal insulation</td>
<td>—</td>
<td>5.10</td>
</tr>
<tr>
<td>2, 5, 6</td>
<td>Temperature</td>
<td>(T_0)</td>
<td>5.11</td>
</tr>
<tr>
<td>3</td>
<td>Heat flux</td>
<td>(q_0)</td>
<td>5.12</td>
</tr>
</tbody>
</table>

Table 5.4 Boundary Settings–General Heat Transfer Edit Window

![Figure 5.10](image_url)
Solving the 2D Axisymmetric Cylinder_Conduction_1 Model

Using the menu bar, select Solve > Solve Problem. The COMSOL Multiphysics software automatically selects the Stationary Solver. The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, always change the chosen solver or the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Figure 5.14 shows the modeling solution results obtained using single-value parameters with the default solver (UMFPACK).

**Parametric Solving of the 2D Axisymmetric Cylinder_Conduction_1 Model**

Now that the model has been built, it is relatively easy to expand the model to calculate other quasi-static solutions.
2D Axisymmetric Heat Conduction Modeling

**FIGURE 5.12** 2D axisymmetric Cylinder_Conduction_1 model Boundary Settings (3) edit window

**FIGURE 5.13** 2D axisymmetric Cylinder_Conduction_1 model Mesh window
This time, instead of using the default solver, the model is run using multiple value parameters in the Parametric Solver (UMFPACK) as the initial solver. The Parametric Solver (UMFPACK) results include not only the default solution, but also solutions at a number of other values of heat flux \( q_0 \).

Using the menu bar, select File > Save as. Enter Cylinder_Conduction_1p.

From the menu bar, select File > Reset Model >Yes. On the menu bar, click the Initialize Mesh button once. Click the Refine Mesh button once. This results in a mesh of approximately 2200 elements.

From the menu bar, select Solve > Solver Parameters > Parametric. Enter \( q_0 \) in the Parameter name edit window. Enter 0:5e3:5e5 in the Parameter values edit window. See Figure 5.15. Click OK.

From the menu bar, select Solve > Solve Problem. See Figure 5.16.

**Postprocessing Animation**

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 5.17.
**FIGURE 5.15** 2D axisymmetric Cylinder Conduction 1p model Solver Parameters edit window

**FIGURE 5.16** 2D axisymmetric Cylinder Conduction 1p model using the Parametric Solver (UMFPACK)
Click the Start Animation button. See Figure 5.18.
Alternatively, you can play the file Movie5_CC_1p.avi that was supplied with this book.

First Variation on the 2D Axisymmetric Cylinder Conduction Model

This model is derived from the COMSOL cylinder conduction model. This model, however, is built using the basic COMSOL Multiphysics software package, instead of the Heat Transfer Module. The selected thermally conductive solid is, as in the initial model, niobium (Nb). The modeler should note, as mentioned previously, that for static and quasi-static calculations, the only physical property value required for the thermal conduction calculation is $k$ ($k_{\text{Nb}}$), the thermal conductivity. That property is the only one that will be used in this model.
To start building the Cylinder_Conduction_2 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select COMSOL Multiphysics > Heat Transfer > Conduction > Steady-state analysis. See Figure 5.19. Click OK.

Constants

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 5.5; also see Figure 5.20. Click OK.

When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.08 and a height of 0.14. Select “Base: Corner” and set r equal to 0.02 and z equal to 0 in the Rectangle edit window. See Figure 5.21.
Table 5.5  Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$k_{Nb}$</td>
<td>$52.335 \text{[W/(m*K)]}$</td>
<td>Thermal conductivity Nb</td>
</tr>
<tr>
<td>$T_0$</td>
<td>$2.7315 \times 10^2 \text{[K]}$</td>
<td>Boundary temperature</td>
</tr>
<tr>
<td>$q_0$</td>
<td>$5 \times 10^5 \text{[W/m}^2\text{]}$</td>
<td>Heat flux</td>
</tr>
</tbody>
</table>

**FIGURE 5.19**  2D axisymmetric Cylinder_Conduction_2 Model Navigator setup

**FIGURE 5.20**  2D axisymmetric Cylinder_Conduction_2 model Constants edit window
Click OK, and then click the Zoom Extents button. See Figure 5.22.
Using the menu bar, select Draw > Specify Objects > Point. In the Point edit window, enter the information shown in Table 5.6. See Figure 5.23.
Click OK. See Figure 5.24.

NOTE Two points have been added, as in the earlier model, on the interior (small r value) boundary of the rectangle (cylinder cross section) to define the upper (larger z value) and lower (smaller z value) bounds of the heat-flux application region.

FIGURE 5.22 2D axisymmetric Cylinder_Conduction_2 model cylinder rectangle
<table>
<thead>
<tr>
<th>Name</th>
<th>$r$ Location</th>
<th>$z$ Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point 1</td>
<td>0.02</td>
<td>0.04</td>
</tr>
<tr>
<td>Point 2</td>
<td>0.02</td>
<td>0.1</td>
</tr>
</tbody>
</table>

**FIGURE 5.23** 2D axisymmetric Cylinder_Conduction_2 model Point edit window

**FIGURE 5.24** 2D axisymmetric Cylinder_Conduction_2 model rectangle with points
Physics Subdomain Settings: General Heat Transfer

Having established the geometry for the 2D axisymmetric Cylinder_Conduction_2 model (a rectangle with two points on the boundary), the next step is to define the fundamental Physics conditions. Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain). In the Subdomain edit windows, enter the information shown in Table 5.7; also see Figure 5.25. Click OK.

NOTE: For static and quasi-static calculations, the only physical property value required for the calculation is $k$ (k_Nb).

Physics Boundary Settings: General Heat Transfer

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 5.8. Click OK. See Figures 5.26, 5.27, and 5.28.

<table>
<thead>
<tr>
<th>Table 5.7 Subdomain Edit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>$k$ (isotropic)</td>
</tr>
</tbody>
</table>

**Figure 5.25** 2D axisymmetric Cylinder_Conduction_2 Model Subdomain Settings edit window
Table 5.8  Boundary Settings—General Heat Transfer Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 4</td>
<td>Thermal insulation</td>
<td>—</td>
<td>5.26</td>
</tr>
<tr>
<td>2, 5, 6</td>
<td>Temperature</td>
<td>$T_0$</td>
<td>5.27</td>
</tr>
<tr>
<td>3</td>
<td>Heat flux</td>
<td>$q_0$</td>
<td>5.28</td>
</tr>
</tbody>
</table>

Mesh Generation

On the toolbar, click the Initialize Mesh button once. Click the Refine Mesh button once. This results in a mesh of approximately 2200 elements. See Figure 5.29.

Solving the 2D Axisymmetric Cylinder_Conduction_2 Model

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, always change the chosen solver and the parametric settings. This time, instead of using the default solver, the model is run using the Parametric Solver (UMFPACK) as the initial solver. The Parametric Solver (UMFPACK) results include not only the default solution, but also solutions at a number of other values of heat flux ($q_0$).
Using the menu bar, select Solve > Solver Parameters > Parametric. Enter \( q_0 \) in the Parameter name edit window. Enter 0:5e3:5e5 in the Parameter values edit window. See Figure 5.30. Click OK.

From the menu bar, select Solve > Solve Problem. See Figure 5.31.
FIGURE 5.29 2D axisymmetric Cylinder_Conduction_2 model mesh window

FIGURE 5.30 2D axisymmetric Cylinder_Conduction_2 model Solver Parameters edit window
Postprocessing Animation

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 5.32.

Click the Start Animation button. See Figure 5.33.

Alternatively, you can play the file Movie5_CC_2.avi that was supplied with this book.

Comparison of Cylinder Conduction Models 1p and 2

As can be readily seen in Table 5.9, the calculated values for Cylinder Conduction Models 1p and 2 are exactly the same for the simple conduction calculation, as would be expected. The advantage of using the Heat Transfer Module, as needed, is that it can accommodate more complex physics. See Figures 5.34 and 5.35.

<table>
<thead>
<tr>
<th>Model Number</th>
<th>Module Used</th>
<th>T-max</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1p</td>
<td>Heat Transfer Module</td>
<td>476.907 K</td>
<td>5.34</td>
</tr>
<tr>
<td>2</td>
<td>Basic Heat Transfer</td>
<td>476.907 K</td>
<td>5.35</td>
</tr>
</tbody>
</table>
Second Variation on the 2D Axisymmetric Cylinder Conduction Model, Including a Vacuum Cavity

This model is derived from the COMSOL cylinder conduction model. In this model, the selected thermally conductive solid is niobium (Nb).\(^{12,13}\) A vacuum cavity has been added to the cylinder geometry. With the added vacuum cavity, the modeler can explore some of the additional heat transfer modeling capabilities of the Heat Transfer Module. Vacuum isolation is a valuable tool in lowering heat loss in modern machines.

To start building the Cylinder_Conduction_3 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select Heat Transfer Module > General Heat Transfer > Steady-state analysis. See Figure 5.36. Click OK.
FIGURE 5.33 2D axisymmetric Cylinder_Conduction_2 model animation, final frame

FIGURE 5.34 2D axisymmetric Cylinder_Conduction_1p model, final frame
FIGURE 5.35 2D axisymmetric Cylinder_Conduction_2 model, final frame

FIGURE 5.36 2D axisymmetric Cylinder_Conduction_3 Model Navigator setup
Constants

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 5.10; also see Figure 5.37. Click OK.

When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

Using the menu bar, select Draw > Specify Objects > Rectangle. Create the two rectangles indicated in Table 5.11.

<table>
<thead>
<tr>
<th>Rectangle Number</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>r</th>
<th>z</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.08</td>
<td>0.14</td>
<td>Corner</td>
<td>0.02</td>
<td>0.0005</td>
<td>5.38</td>
</tr>
<tr>
<td>2</td>
<td>0.002</td>
<td>0.139</td>
<td>Corner</td>
<td>0.06</td>
<td>5.39</td>
<td></td>
</tr>
</tbody>
</table>

Table 5.10 Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_Nb</td>
<td>52.335[W/(m*K)]</td>
<td>Thermal conductivity Nb</td>
</tr>
<tr>
<td>rho_Nb</td>
<td>8.57e3[kg/m^3]</td>
<td>Density Nb</td>
</tr>
<tr>
<td>Cp_Nb</td>
<td>2.7e2[J/(kg*K)]</td>
<td>Heat capacity Nb</td>
</tr>
<tr>
<td>T_0</td>
<td>2.7315e2[K]</td>
<td>Boundary temperature</td>
</tr>
<tr>
<td>q_0</td>
<td>5e5[W/m^2]</td>
<td>Heat flux</td>
</tr>
<tr>
<td>p_0</td>
<td>1.33e-7[Pa]</td>
<td>Pressure in vacuum</td>
</tr>
</tbody>
</table>

FIGURE 5.37 2D axisymmetric Cylinder_Conduction_3 model Constants edit window
Click OK, and then click the Zoom Extents button. See Figure 5.40.

Using the menu bar, select Draw > Specify Objects > Point. In the Point edit window, enter the information shown in Table 5.12. See Figure 5.41.

Click OK. See Figure 5.42

Two points have been added on the interior (small \( r \) value) boundary of the rectangle (cylinder cross section) to define the upper (larger \( z \) value) and lower (smaller \( z \) value) bounds of the heat-flux application region.
Using the menu bar, select Draw > Create Composite Object. Enter R1 + R2 in the Set formula edit window. Verify or check the Keep interior boundaries check box. See Figure 5.43.

Click OK. See Figure 5.44

**Table 5.12  Point Edit Window**

<table>
<thead>
<tr>
<th>Name</th>
<th>r Location</th>
<th>z Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point 1</td>
<td>0.02</td>
<td>0.04</td>
</tr>
<tr>
<td>Point 2</td>
<td>0.02</td>
<td>0.1</td>
</tr>
</tbody>
</table>
CHAPTER 5  2D AXISYMMETRIC MODELING

![FIGURE 5.42](image)

**FIGURE 5.42** 2D axisymmetric Cylinder_Conduction_3 model rectangles with points

**Physics Subdomain Settings: General Heat Transfer**

Having established the geometry for the 2D axisymmetric Cylinder_Conduction_3 model (a rectangle with two points on the boundary), the next step is to define the fundamental Physics conditions. Using the menu bar, select Physics > Subdomain Settings. Select “subdomain 1” in the Subdomain selection window. In the Subdomain edit windows, enter the information shown in Table 5.13. See Figure 5.45.

![FIGURE 5.43](image)

**FIGURE 5.43** 2D axisymmetric Cylinder_Conduction_3 model Create Composite Object edit window
**FIGURE 5.44** 2D axisymmetric Cylinder_Conduction_3 model composite object

**FIGURE 5.45** 2D axisymmetric Cylinder_Conduction_3 model Subdomain Settings (1) edit window
Select “subdomain 2” in the Subdomain selection window. Click the Library material Load button. Select Liquids and Gases > Gases > Air, 1 atm. Click OK.

Enter the term $p_0$ in place of $p$ in the expression $\rho(p...$ in the Density edit window. Click on the Opacity pull-down list. Select “Transparent.” See Figure 5.46. Click OK.

The insertion of $p_0$ into the density function for air sets the pressure in the vacuum cavity. The selection of “Transparent” allows energy transfer by radiation.
For static and quasi-static calculations, the only physical property value required for the conduction calculation is \( k (k_{\text{Nb}}) \). However, from the point of view of physical consistency, the density (\( \rho_{\text{Nb}} \)) and the heat capacity (\( C_p_{\text{Nb}} \)) should be included. If \( C_p \) and \( \rho \) are set to zero, the implication is that of a perfect vacuum, which is logically inconsistent with the stated value of \( k \). Also, by including the values for \( C_p \) and \( \rho \) in this location, they are conveniently available should the modeler wish to modify the model for transient analysis.

### Physics Boundary Settings: General Heat Transfer

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 5.14. Click OK. See Figures 5.47, 5.48, and 5.49.

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 4</td>
<td>Thermal insulation</td>
<td>—</td>
<td>5.47</td>
</tr>
<tr>
<td>2, 5, 10</td>
<td>Temperature</td>
<td>( T_0 )</td>
<td>5.48</td>
</tr>
<tr>
<td>3</td>
<td>Heat flux</td>
<td>( q_0 )</td>
<td>5.49</td>
</tr>
</tbody>
</table>

**NOTE**

For static and quasi-static calculations, the only physical property value required for the conduction calculation is \( k (k_{\text{Nb}}) \). However, from the point of view of physical consistency, the density (\( \rho_{\text{Nb}} \)) and the heat capacity (\( C_p_{\text{Nb}} \)) should be included. If \( C_p \) and \( \rho \) are set to zero, the implication is that of a perfect vacuum, which is logically inconsistent with the stated value of \( k \). Also, by including the values for \( C_p \) and \( \rho \) in this location, they are conveniently available should the modeler wish to modify the model for transient analysis.

**Physics Boundary Settings: General Heat Transfer**

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 5.14. Click OK. See Figures 5.47, 5.48, and 5.49.

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 4</td>
<td>Thermal insulation</td>
<td>—</td>
<td>5.47</td>
</tr>
<tr>
<td>2, 5, 10</td>
<td>Temperature</td>
<td>( T_0 )</td>
<td>5.48</td>
</tr>
<tr>
<td>3</td>
<td>Heat flux</td>
<td>( q_0 )</td>
<td>5.49</td>
</tr>
</tbody>
</table>

**Table 5.14  Boundary Settings–General Heat Transfer Edit Window**

**FIGURE 5.47** 2D axisymmetric Cylinder_Conduction_3 model Boundary Settings (1, 4) edit window
FIGURE 5.48 2D axisymmetric Cylinder_Conduction_3 model Boundary Settings (2, 5, 10) edit window

FIGURE 5.49 2D axisymmetric Cylinder_Conduction_3 model Boundary Settings (3) edit window
Mesh Generation

From the menu bar, select Mesh > Free Mesh Parameters > Subdomain 1. Enter Maximum element size 0.002. Select Method > Quad. Click the Remesh button. Select Free Mesh Parameters > Subdomain 2. Enter Maximum element size 0.0005. Select Method > Quad. Click the Remesh button.

Click OK. See Figure 5.50.

Solving the 2D Axisymmetric Cylinder_Conduction_3 Model

From the menu bar, select Solve > Solver Parameters > Parametric. Enter q_0 in the Parameter name edit window. Enter 0:5e3:5e5 in the Parameter values edit window. See Figure 5.51. Click OK.

From the menu bar, select Solve > Solve Problem. See Figure 5.52.

Postprocessing Animation

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 5.53.
**FIGURE 5.51** 2D axisymmetric Cylinder_Conduction_3 model Solver Parameters edit window

**FIGURE 5.52** 2D axisymmetric Cylinder_Conduction_3 model using the Parametric Solver (UMFPACK)
Click the Start Animation button. See Figure 5.54.

Alternatively, you can play the file Movie5_CC_3.avi that was supplied with this book.

**2D Axisymmetric Cylinder Conduction Models: Summary and Conclusions**

The models presented in this section of Chapter 5 have introduced the following new concepts: two-dimensional axisymmetric modeling (axial symmetry [2D]), cylindrical coordinates, conductive media DC, Heat Transfer Module, heat conduction theory, opaque and transparent thermally conductive materials, and vacuum. Previously introduced concepts employed in these models include triangular mesh, free mesh parameters, subdomain mesh, maximum element size, and quadrilateral mesh (quad).
A comparison of the calculated results for the three cylinder conduction models is shown in Table 5.15. As can be readily observed, the presence of a vacuum cavity significantly reduces the rate of heat flow through the model and raises the equilibrium temperature at the surface receiving the heat flux.

For simple heat transfer models, both the basic COMSOL Multiphysics software and the Heat Transfer Module yield the same result, as would be expected. For more complex models involving such conditions as a vacuum, the Heat Transfer Module is required.

<table>
<thead>
<tr>
<th>Model Number</th>
<th>Module Used</th>
<th>Vacuum</th>
<th>T-max (K)</th>
<th>T-max (°C)</th>
<th>ΔT</th>
</tr>
</thead>
<tbody>
<tr>
<td>1p</td>
<td>Heat Transfer Module</td>
<td>No</td>
<td>476.907 K</td>
<td>203.76 °C</td>
<td>—</td>
</tr>
<tr>
<td>2</td>
<td>Basic Heat Transfer</td>
<td>No</td>
<td>476.907 K</td>
<td>203.76 °C</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>Heat Transfer Module</td>
<td>Yes</td>
<td>572.051 K</td>
<td>298.90 °C</td>
<td>95.144</td>
</tr>
</tbody>
</table>
2D Axisymmetric Insulated Container Design

Sir James Dewar\textsuperscript{14} invented the vacuum flask in 1892. The vacuum flask enabled him to store low-temperature liquified gases for longer periods of time. Being a research scientist, his primary concern was the study of the liquification process for gases and the study of the resulting liquids.

Prior to the mid-1900s, it was uncommon for research scientists to patent or commercialize new inventions, regardless of their potential commercial or economic impact. The usual process was to disclose new findings through letter publication to a learned society.\textsuperscript{15}

The term “Thermos”\textsuperscript{16} came into existence in 1904, when a German company was formed under the name Thermos GmbH to commercialize the vacuum flask technology. The vacuum flask (invented by Dewar) has come into widespread common usage by both scientists and nonscientists alike, under the name “thermos” or “thermos bottle.” As such, the name “thermos” has, through common usage, become the generic name, in the United States and some other countries, for the vacuum flask or thermos bottle. There are, of course, other insulating materials in use that are not quite as efficient as the vacuum flask but nevertheless adequate. Thus some thermos bottles (vacuum flask containers) have no vacuum, but simply a low-thermal-conductivity solid (insulating material) in the place where the vacuum would normally exist.

2D Axisymmetric Thermos\textunderscore Container Model

This model is derived from the COMSOL thermos laminar flow and thermos laminar hcoeff models. Those models can be found in the Tutorial Models folder of the Heat Transfer Module Model Library. In this model, Thermos\textunderscore Container\textunderscore 1, the walls of the flask (e.g., bottle, tank) are formed of stainless steel. In the 2D axisymmetric Thermos\textunderscore Container\textunderscore 1 model, the selected thermal insulating solid is rigid urethane foam.\textsuperscript{17} In the first variation on the 2D axisymmetric Thermos\textunderscore Container model, a vacuum cavity replaces the urethane foam. In the second variation on the 2D axisymmetric Thermos\textunderscore Container model, a glass\textsuperscript{18} material replaces the stainless steel\textsuperscript{19} wall material and the insulating vacuum cavity remains. These changes in the materials design of these models reflect some of the typical alterations and trade-offs that need to be made in the exploratory design phase of a new artifact (e.g., product, tool).

To start building the Thermos\textunderscore Container\textunderscore 1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select Heat Transfer Module > General Heat Transfer > Steady-state analysis. See Figure 5.55. Click OK.
Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 5.16; also see Figure 5.56. Click OK.

When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

When building a model, it is usually best to choose names for modeler-defined parameters (e.g., constants, scalar functions) that are easily recalled and associated with the function that they provide in the model (e.g., k_foam, rho_foam).
Building the 2D Axisymmetric Thermos Container

The actual sequence of steps required in the building of the 2D axisymmetric Thermos_Container_1 model is initially somewhat complex. However, once the model is built, the modeler can use the export and import functions to use the same physical model configuration and explore the influence of different materials and materials properties on the overall design behavior, as shown in the first and second variations of the 2D axisymmetric thermos container model.

Using the menu bar, select Draw > Specify Objects > Rectangle. Create each of the two rectangles indicated in Table 5.17.
Click OK, and then click the Zoom Extents button. See Figure 5.57.

Using the menu bar, select Draw > Specify Objects > Ellipse. Create the ellipse indicated in Table 5.18. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Create the rectangle indicated in Table 5.19. Click OK.

Select Draw > Create Composite Object. Enter E1–R3 in the Set formula edit window. Verify that the Keep interior boundaries check box is unchecked. See Figure 5.58. Click OK.

<table>
<thead>
<tr>
<th>Table 5.17 Rectangle Edit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Object Number</strong></td>
</tr>
<tr>
<td>Rectangle 1</td>
</tr>
<tr>
<td>Rectangle 2</td>
</tr>
</tbody>
</table>

**FIGURE 5.57** 2D axisymmetric Thermos_Container_1 model rectangles R1 and R2

Click OK, and then click the Zoom Extents button. See Figure 5.57.

Using the menu bar, select Draw > Specify Objects > Ellipse. Create the ellipse indicated in Table 5.18. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Create the rectangle indicated in Table 5.19. Click OK.

Select Draw > Create Composite Object. Enter E1–R3 in the Set formula edit window. Verify that the Keep interior boundaries check box is unchecked. See Figure 5.58. Click OK.

<table>
<thead>
<tr>
<th>Table 5.18 Ellipse Edit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Object Number</strong></td>
</tr>
<tr>
<td>Ellipse 1</td>
</tr>
</tbody>
</table>
Table 5.19  Rectangle Edit Window

<table>
<thead>
<tr>
<th>Object Number</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>r</th>
<th>z</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle</td>
<td>0.2</td>
<td>0.4</td>
<td>Corner</td>
<td>-0.2</td>
<td>0</td>
</tr>
</tbody>
</table>

Select Draw > Create Composite Object. Enter R2+CO1 in the Set formula edit window. Verify that the Keep interior boundaries check box is unchecked. See Figure 5.59.

Click OK. See Figure 5.60, which shows the profile of the outer tank.

Create the inner structure of the insulated tank by following the steps in Table 5.20. Select the appropriate action from the menu bar using the Draw pull-down menu. See Figure 5.61.

FIGURE 5.58  2D axisymmetric Thermos_Container_1 model half-ellipse creation

FIGURE 5.59  2D axisymmetric Thermos_Container_1 model outer tank profile creation
Table 5.20  Tank Structure Creation Steps

<table>
<thead>
<tr>
<th>Step</th>
<th>Object</th>
<th>Width/A</th>
<th>Height/B</th>
<th>Base</th>
<th>r</th>
<th>z</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Rectangle</td>
<td>0.15–0.005</td>
<td>0.3–0.005</td>
<td>Corner</td>
<td>0</td>
<td>0.005</td>
</tr>
<tr>
<td>2</td>
<td>Ellipse</td>
<td>0.15–0.005</td>
<td>0.05–0.005</td>
<td>Center</td>
<td>0</td>
<td>0.3</td>
</tr>
<tr>
<td>3</td>
<td>Rectangle</td>
<td>0.2</td>
<td>0.4</td>
<td>Corner</td>
<td>−0.2</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>Create Composite Object</td>
<td>Formula = E1–R3</td>
<td>No Interior Boundaries</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Create Composite Object</td>
<td>Formula = R2+CO1</td>
<td>No Interior Boundaries</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Rectangle</td>
<td>0.15–0.025</td>
<td>0.3–0.025</td>
<td>Corner</td>
<td>0</td>
<td>0.025</td>
</tr>
<tr>
<td>7</td>
<td>Ellipse</td>
<td>0.15–0.025</td>
<td>0.05–0.025</td>
<td>Center</td>
<td>0</td>
<td>0.3</td>
</tr>
<tr>
<td>8</td>
<td>Rectangle</td>
<td>0.2</td>
<td>0.4</td>
<td>Corner</td>
<td>−0.2</td>
<td>0</td>
</tr>
<tr>
<td>9</td>
<td>Create Composite Object</td>
<td>Formula = E1–R3</td>
<td>No Interior Boundaries</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Create Composite Object</td>
<td>Formula = R2+CO1</td>
<td>No Interior Boundaries</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Rectangle</td>
<td>0.15–0.03</td>
<td>0.3–0.03</td>
<td>Corner</td>
<td>0</td>
<td>0.03</td>
</tr>
<tr>
<td>12</td>
<td>Ellipse</td>
<td>0.15–0.03</td>
<td>0.05–0.03</td>
<td>Center</td>
<td>0</td>
<td>0.3</td>
</tr>
<tr>
<td>13</td>
<td>Rectangle</td>
<td>0.2</td>
<td>0.4</td>
<td>Corner</td>
<td>−0.2</td>
<td>0</td>
</tr>
<tr>
<td>14</td>
<td>Create Composite Object</td>
<td>Formula = E1–R3</td>
<td>No Interior Boundaries</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Create Composite Object</td>
<td>Formula = R2+CO1</td>
<td>No Interior Boundaries</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Rectangle</td>
<td>0.15–0.03</td>
<td>0.29–0.03</td>
<td>Corner</td>
<td>0</td>
<td>0.03</td>
</tr>
</tbody>
</table>
The tank lid structure is defined by adding a line that separates the lid and the body of the tank. Select Draw > Specify Objects > Line. Enter 0.15−0.03 space 0.15 in the r edit window. Enter 0.3 space 0.3 in the z edit window. See Figures 5.62 and 5.63.

The next step is to combine the components into the final tank structure. Select Draw > Create Composite Object. Enter R1+CO2+CO3+CO4+CO5+R2. Important: This time, verify that the Keep interior boundaries check box is checked. See Figure 5.64.
Click OK. See Figure 5.65.

Now, to save time and effort on the next model, save the present insulated tank configuration. Select File > Export > Geometry Objects to File. Enter TC_1_Geometry in the Save As edit window. Select DXF file (*.dxf) from the File Format pull-down list. See Figure 5.66. Click Save.
FIGURE 5.65 2D axisymmetric Thermos_Container_1 model tank

FIGURE 5.66 2D axisymmetric Thermos_Container_1 model tank Export Geometry Objects, Save As window
Having established the geometry for the 2D axisymmetric Thermos_Container_1 model, the next step is to define the fundamental Physics conditions. In the Subdomain edit windows, load or enter the information shown in Tables 5.21 through 5.24. See also corresponding Figures 5.67 through 5.70.

Enter $p_0$ in place of $p$ in the density expression to yield $\rho(p_0^{1/Pa},T^{1/K})^{[kg/m^3]}$ in the Density edit window.

**Table 5.21** Subdomain Edit Window (1, 3, 6, 8)

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 3, 6, 8</td>
<td>Enter</td>
<td>$k$</td>
<td>$k_{304ss}$</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td>1, 3, 6, 8</td>
<td>Enter</td>
<td>$\rho$</td>
<td>$\rho_{304ss}$</td>
<td>Density</td>
</tr>
<tr>
<td>1, 3, 6, 8</td>
<td>Enter</td>
<td>$C_p$</td>
<td>$C_{p_{304ss}}$</td>
<td>Heat capacity</td>
</tr>
</tbody>
</table>

**Table 5.22** Subdomain Edit Window (2, 7)

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2, 7</td>
<td>Enter</td>
<td>$k$</td>
<td>$k_{foam}$</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td>2, 7</td>
<td>Enter</td>
<td>$\rho$</td>
<td>$\rho_{foam}$</td>
<td>Density</td>
</tr>
<tr>
<td>2, 7</td>
<td>Enter</td>
<td>$C_p$</td>
<td>$C_{p_{foam}}$</td>
<td>Heat capacity</td>
</tr>
</tbody>
</table>

**Table 5.23** Subdomain Edit Window (5, 9)

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>5, 9</td>
<td>Load</td>
<td>Basic Materials Properties &gt; Air, 1 atm</td>
</tr>
</tbody>
</table>

**Table 5.24** Subdomain Edit Window (4)

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Load</td>
<td>Basic Materials Properties &gt; Water, liquid</td>
</tr>
</tbody>
</table>

**Physics Subdomain Settings: General Heat Transfer**

Having established the geometry for the 2D axisymmetric Thermos_Container_1 model, the next step is to define the fundamental Physics conditions. In the Subdomain edit windows, load or enter the information shown in Tables 5.21 through 5.24. See also corresponding Figures 5.67 through 5.70.

Enter $p_0$ in place of $p$ in the density expression to yield $\rho(p_0^{1/Pa},T^{1/K})^{[kg/m^3]}$ in the Density edit window.
**FIGURE 5.67** 2D axisymmetric Thermos_CONTAINER_1 model Subdomain Settings (1, 3, 6, 8) edit window

**FIGURE 5.68** 2D axisymmetric Thermos_CONTAINER_1 model Subdomain Settings (2, 7) edit window
FIGURE 5.69 2D axisymmetric Thermos_Container_1 model Subdomain Settings (5, 9) edit window

FIGURE 5.70 2D axisymmetric Thermos_Container_1 model Subdomain Settings (4) edit window
In this model, because of the high thermal conductivity of water, the temperature of the liquid is very close to uniform throughout. Thus uniformity can be assumed and subdomain 4 can be made inactive. The temperature of the liquid is incorporated into the boundary conditions. Also, because this model will calculate only the heat transfer, and not the detailed convection flow in the surrounding air, subdomain 9 can be made inactive. Convection losses are incorporated into the heat transfer coefficient boundary conditions. Incorporating both of these assumptions into the model significantly simplifies the model calculations.

Select subdomain 4. Uncheck the Active in this domain check box.
Select subdomain 9. Uncheck the Active in this domain check box. Click OK.

**Physics Boundary Settings: General Heat Transfer**

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 5.25. Click OK. See Figures 5.71 and 5.72.

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select the boundary condition.

Load the Library coefficient using the path Heat Transfer Coefficients > Air, Ext. Natural Convection as shown in Table 5.26.

Enter \( L_{\text{wall}} \) in the Heat transfer coefficient (h) expression in place of the \( L_{\text{htgh}} \) term for boundary 28:

\[
h_{\text{ave}}(T[1/K],T_{\text{inf htgh}}[1/K],L_{\text{wall}}[1/m])[W/(m^2*K)]
\]

Enter \( T_0 \) in the External temperature (T inf) edit window for boundary 28. See Figure 5.73.

**Table 5.25  Boundary Settings–General Heat Transfer Edit Window**

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Thermal insulation</td>
<td>—</td>
<td>5.71</td>
</tr>
<tr>
<td>8, 14, 21</td>
<td>Temperature</td>
<td>( T_L )</td>
<td>5.72</td>
</tr>
</tbody>
</table>

**Table 5.26  Boundary Settings–General Heat Transfer Edit Window**

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Library Coefficient</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>28</td>
<td>Heat flux</td>
<td>Nat. Vertical wall, ( L=\text{height} )</td>
<td>5.73</td>
</tr>
<tr>
<td>34</td>
<td>Heat flux</td>
<td>Nat. Horiz. plane, Upside, ( L=\text{width} )</td>
<td>5.74</td>
</tr>
</tbody>
</table>
FIGURE 5.71 2D axisymmetric Thermos_Container_1 model Boundary Settings (2) edit window

FIGURE 5.72 2D axisymmetric Thermos_Container_1 model Boundary Settings (8, 14, 21) edit window
Enter $L_{\text{top}}$ in the Heat transfer coefficient ($h$) expression in place of the $L_{\text{htgh}}$ term for boundary 34:

$$h_{\text{ave}}(T[1/K], T_{\text{inf}}[1/K], L_{\text{top}}[1/m])[W/(m^2*K)]$$

Enter $T_0$ in the External temperature ($T_{\text{inf}}$) edit window for boundary 34. See Figure 5.74.

Click OK.

Mesh Generation

From the menu bar, select Mesh > Free Mesh Parameters > Subdomain 1, 2, 3, 6, 7, 8. Enter Maximum element size 0.002. Select Method > Quad. Click the Remesh button. See Figure 5.75.

Click OK. See Figure 5.76.

Solving the 2D Axisymmetric Thermos_Container_1 Model

From the menu bar, select Solve > Solver Parameters > Parametric. Enter $T_L$ in the Parameter name edit window. Enter 273.15:9.5:368.15 in the Parameter values edit window. See Figure 5.77. Click OK.
**CHAPTER 5  2D AXISYMMETRIC MODELING**

**FIGURE 5.74** 2D axisymmetric Thermos_CONTAINER_1 model Boundary Settings (34) edit window

**FIGURE 5.75** 2D axisymmetric Thermos_CONTAINER_1 model Free Mesh Parameters edit window
**FIGURE 5.76** 2D axisymmetric Thermos Container 1 model mesh

**FIGURE 5.77** 2D axisymmetric Thermos Container 1 model Solver Parameters edit window
From the menu bar, select Solve > Solve Problem. See Figure 5.78.

**Postprocessing**

Select Postprocessing > Plot Parameters > Surface. Select “°C [degC]” in the Unit pull-down list. See Figure 5.79.

Click OK. See Figure 5.80.

Given that our main interest in creating the 2D axisymmetric Thermos_Container_1 model is to examine the heat transfer, the next step is to determine the heat loss. Select Postprocessing > Boundary Integration. Select boundaries 28 and 34 (the wall and top of the tank, respectively). Select “Normal total heat flux” in the Predefined quantities pull-down list. Check the Compute surface integral (for axisymmetric modes) check box. See Figure 5.81.

Click OK. The result of the Boundary Integration (~82 W) is displayed as Value of surface integral: xx.xxxxx [W], Expression: ntflux_htgh, Boundaries: 28, 34 in the display window at the bottom of the COMSOL user interface. See Figure 5.82.
FIGURE 5.79 2D axisymmetric Thermos_Container_1 model Plot Parameters window

FIGURE 5.80 2D axisymmetric Thermos_Container_1 model surface temperature (°C)
**FIGURE 5.81**
2D axisymmetric Thermos_Container_1 model Boundary Integration edit window

**FIGURE 5.82**
2D axisymmetric Thermos_Container_1 model user interface display window
Postprocessing Animation

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 5.83.

Click the Start Animation button. See Figure 5.84.

Alternatively, you can play the file Movie5_TC_1.avi that was supplied with this book.

First Variation on the 2D Axisymmetric Thermos_Container Model

In this model, Thermos_Container_2, the walls of the flask (e.g., bottle, tank) are formed of stainless steel. In the 2D axisymmetric Thermos_Container_1 model, the selected thermal insulating solid was rigid urethane foam. In this model, the first variation on the 2D axisymmetric Thermos_Container model, a vacuum cavity replaces the urethane foam.
To start building the Thermos_Container_2 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select Heat Transfer Module > General Heat Transfer > Steady-state analysis. See Figure 5.85. Click OK.

**Constants**

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 5.27; also see Figure 5.86. Click OK.

**NOTE** When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.
When building a model, it is usually best to choose a name for modeler-defined parameters (e.g., constants, scalar functions) that are easily recalled and associated with the function that they provide in the model (e.g., p_vac, L_wall).
Select File > Save as. Enter Thermos_Container_2. Click the Save button.

**Importing the 2D Axisymmetric Thermos Container**

The actual sequence of steps required in the building of the 2D axisymmetric Thermos_Container was presented in the discussion of the 2D axisymmetric Thermos_Container_1 model. Now the modeler can use the import function to utilize the same physical model configuration and explore the influence of different materials and materials properties on the overall model design behavior.

Using the menu bar, select File > Import > CAD Data From File. Select “TC_1_Geometry.dxf.” See Figure 5.87. Click the Import button.

<table>
<thead>
<tr>
<th>Table 5.27 Constants Edit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>k_304ss</td>
</tr>
<tr>
<td>rho_304ss</td>
</tr>
<tr>
<td>Cp_304ss</td>
</tr>
<tr>
<td>p_0</td>
</tr>
<tr>
<td>p_vac</td>
</tr>
<tr>
<td>T_0</td>
</tr>
<tr>
<td>T_L</td>
</tr>
<tr>
<td>L_wall</td>
</tr>
<tr>
<td>L_top</td>
</tr>
</tbody>
</table>

**FIGURE 5.87** 2D axisymmetric Thermos_Container_2 model import
Because the Geometry.dxf file contains only boundary information, the modeler needs to create a domain to which the boundary information can be applied.

Using the menu bar, select Draw > Specify Objects > Rectangle, as indicated in Table 5.28. Click OK. See Figure 5.88.

**Physics Subdomain Settings: General Heat Transfer**

Having established the geometry for the 2D axisymmetric Thermos_Container_2 model, the next step is to define the fundamental Physics conditions. Select Physics > Subdomain Settings. In the Subdomain edit windows, enter the information shown in Table 5.29. See Figure 5.89.

### Table 5.28 Rectangle Edit Window

<table>
<thead>
<tr>
<th>Object Number</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>r</th>
<th>z</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle 1</td>
<td>0.25</td>
<td>0.55</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

**FIGURE 5.88** 2D axisymmetric Thermos_Container_2 model import and rectangle R1
<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 3, 6, 8</td>
<td>Enter</td>
<td>$k$</td>
<td>$k_{304ss}$</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td>1, 3, 6, 8</td>
<td>Enter</td>
<td>$\rho$</td>
<td>$\rho_{304ss}$</td>
<td>Density</td>
</tr>
<tr>
<td>1, 3, 6, 8</td>
<td>Enter</td>
<td>$C_p$</td>
<td>$C_p_{304ss}$</td>
<td>Heat capacity</td>
</tr>
</tbody>
</table>

In the Subdomain edit windows, enter the information shown in Table 5.30. Enter $p_{\text{vac}}$ in place of $p$ in the density expression $\rho(p[1\text{ Pa}], T[1\text{ K}])[\text{ kg/m}^3]$, so that it reads $\rho(p_{\text{vac}}[1\text{ Pa}], T[1\text{ K}])[\text{ kg/m}^3]$ in the Density edit window. Select “Transparent” from the Opacity pull-down list. See Figure 5.90.

In the Subdomain edit windows, enter the information shown in Table 5.31. Enter $p_0$ in place of $p$ in the density expression to yield $\rho(p_0[1\text{ Pa}], T[1\text{ K}])[\text{ kg/m}^3]$ in the Density edit window. Select “Transparent” from the Opacity pull-down list. See Figure 5.91.

In the Subdomain edit windows, enter the information shown in Table 5.32. See Figure 5.92.
### Table 5.30  Subdomain Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>2, 7</td>
<td>Load</td>
<td>Basic Materials Properties &gt; Air, 1 atm</td>
</tr>
</tbody>
</table>

### Table 5.31  Subdomain Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>5, 9</td>
<td>Load</td>
<td>Basic Materials Properties &gt; Air, 1 atm</td>
</tr>
</tbody>
</table>

### Table 5.32  Subdomain Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Load</td>
<td>Basic Materials Properties &gt; Water, liquid</td>
</tr>
</tbody>
</table>

![Figure 5.90](#) 2D axisymmetric Thermos_Container_2 model Subdomain Settings (2, 7) edit window
**FIGURE 5.91** 2D axisymmetric Thermos_Container_2 model Subdomain Settings (5, 9) edit window

**FIGURE 5.92** 2D axisymmetric Thermos_Container_2 model Subdomain Settings (4) edit window
In this model, because of the high thermal conductivity of water, the temperature of the liquid is very close to uniform throughout. Thus uniformity can be assumed and subdomain 4 can be made inactive. The temperature of the liquid is incorporated into the boundary conditions. Also, because this model will calculate only the heat transfer, and not the detailed convection flow in the surrounding air, subdomain 9 can be made inactive. Convection losses are incorporated into the heat transfer coefficient boundary conditions. Incorporating both of these assumptions into the model significantly simplifies the model calculations.

Select subdomain 4. Uncheck the Active in this domain check box. Select subdomain 9. Uncheck the Active in this domain check box. Click OK.

Physics Boundary Settings: General Heat Transfer

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 5.33. Click OK. See Figures 5.93 and 5.94.

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Thermal insulation</td>
<td>—</td>
<td>5.93</td>
</tr>
<tr>
<td>8, 14, 21</td>
<td>Temperature</td>
<td>$T_L$</td>
<td>5.94</td>
</tr>
</tbody>
</table>

NOTE In this model, because of the high thermal conductivity of water, the temperature of the liquid is very close to uniform throughout. Thus uniformity can be assumed and subdomain 4 can be made inactive. The temperature of the liquid is incorporated into the boundary conditions. Also, because this model will calculate only the heat transfer, and not the detailed convection flow in the surrounding air, subdomain 9 can be made inactive. Convection losses are incorporated into the heat transfer coefficient boundary conditions. Incorporating both of these assumptions into the model significantly simplifies the model calculations.
Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select the boundary condition.

Load the Library coefficient using the path Heat Transfer Coefficients > Air, Ext. Natural Convection as shown in Table 5.34.

Enter \( L_{\text{wall}} \) in the Heat transfer coefficient \( (h) \) expression in place of the \( L_{\text{htgh}} \) term for boundary 28:

\[
h_{\text{ave}}(T[1/K], T_{\text{inf}}[1/K], L_{\text{wall}}[1/m])[W/(m^2*K)]
\]

Table 5.34  Boundary Settings--General Heat Transfer Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Library Coefficient</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>28</td>
<td>Heat flux</td>
<td>Nat. Vertical wall, ( L=\text{height} )</td>
<td>5.95</td>
</tr>
<tr>
<td>34</td>
<td>Heat flux</td>
<td>Nat. Horiz. plane, Upside, ( L=\text{width} )</td>
<td>5.96</td>
</tr>
</tbody>
</table>
FIGURE 5.95 2D axisymmetric Thermos_Container_2 model Boundary Settings (28) edit window

FIGURE 5.96 2D axisymmetric Thermos_Container_2 model Boundary Settings (34) edit window
Enter \( T_0 \) in the External temperature \((T_{\text{inf}})\) edit window for boundary 28. See Figure 5.95.

Enter \( L_{\text{top}} \) in the Heat transfer coefficient \((h)\) expression in place of the \( L_{\text{htgh}} \) term for boundary 34:

\[
h_{\text{ave}}(T[1/K], T_{\text{inf}}[1/K], L_{\text{top}}[1/m])[W/(m^2*K)]
\]

Enter \( T_0 \) in the External temperature \((T_{\text{inf}})\) edit window for boundary 34. See Figure 5.96.

Click OK.

Mesh Generation

From the menu bar, select Mesh > Free Mesh Parameters > Subdomain 1, 2, 3, 6, 7, 8. Enter Maximum element size 0.002. Select Method > Quad. Click the Remesh button. See Figure 5.97.

Click OK. See Figure 5.98.

Solving the 2D Axisymmetric Thermos_Container_2 Model

From the menu bar, select Solve > Solver Parameters > Parametric. Enter \( T_L \) in the Parameter name edit window. Enter 273.15:9.5:368.15 in the Parameter values edit window. See Figure 5.99. Click OK.
**FIGURE 5.98** 2D axisymmetric Thermos_Container_2 model mesh

**FIGURE 5.99** 2D axisymmetric Thermos_Container_2 model Solver Parameters edit window
From the menu bar, select Solve > Solve Problem. See Figure 5.100.

**Postprocessing**

Select Postprocessing > Plot Parameters > Surface. Select “°C [degC]” in the Unit pull-down list. See Figure 5.101.

Click OK. See Figure 5.102.

Given that our main interest in creating the 2D axisymmetric Thermos_CONTAINER_2 model is to examine the heat transfer, the next step is to determine the heat loss. Select Postprocessing > Boundary Integration. Select boundaries 28 and 34 (the wall and top of the tank, respectively). Select “Normal total heat flux” in the Predefined quantities pull-down list. Check the Compute surface integral (for axisymmetric modes) check box. See Figure 5.103.

Click OK. The result of the Boundary Integration (~37 W) is displayed as Value of surface integral: xx.xxxx [W], Expression: ntrflux_htgh, Boundaries: 28, 34 in the display window at the bottom of the COMSOL user interface. The amount of energy lost is approximately 45% of that lost using the urethane foam insulation (~82 W) in the 2D axisymmetric Thermos_CONTAINER_1 model. See Figure 5.104.
FIGURE 5.101 2D axisymmetric Thermos_Container_2 model Plot Parameters window

FIGURE 5.102 2D axisymmetric Thermos_Container_2 model surface temperature (°C)
**FIGURE 5.103** 2D axisymmetric Thermos\_Container\_2 model Boundary Integration edit window

**FIGURE 5.104** 2D axisymmetric Thermos\_Container\_2 model user interface display window
Postprocessing Animation

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 5.105.

Click the Start Animation button. See Figure 5.106.

Alternatively, you can play the file Movie5_TC_2.avi that was supplied with this book.

Second Variation on the 2D Axisymmetric Thermos_Container Model

In this model, the second variation on the 2D axisymmetric Thermos_Container model, a glass material replaces the stainless steel walls and a vacuum cavity replaces the urethane foam.
To start building the Thermos_Container_3 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select Heat Transfer Module > General Heat Transfer > Steady-state analysis. See Figure 5.107. Click OK.

**Constants**

When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 5.35; also see Figure 5.108. Click OK.
Table 5.35  Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>p_0</td>
<td>1.0[atm]</td>
<td>Air pressure</td>
</tr>
<tr>
<td>p_vac</td>
<td>1.33e-7[Pa]</td>
<td>Pressure in vacuum</td>
</tr>
<tr>
<td>T_0</td>
<td>2.7315e2[K]</td>
<td>Boundary temperature</td>
</tr>
<tr>
<td>T_L</td>
<td>9.5e1[degC]</td>
<td>Liquid temperature</td>
</tr>
<tr>
<td>L_wall</td>
<td>0.35[m]</td>
<td>Projected height of tank wall</td>
</tr>
<tr>
<td>L_top</td>
<td>0.15[m]</td>
<td>Width of top</td>
</tr>
</tbody>
</table>

FIGURE 5.107  2D axisymmetric Thermos_Container_3 Model Navigator setup

FIGURE 5.108  2D axisymmetric Thermos_Container_3 model Constants edit window
When building a model, it is usually best to choose a name for modeler-defined parameters (e.g., constants, scalar functions) that are easily recalled and associated with the function that they provide in the model (e.g., $p_{\text{vac}}$, $L_{\text{wall}}$).

Select File > Save as. Enter Thermos_Container_3. Click the Save button.

**Importing the 2D Axisymmetric Thermos Container**

The actual sequence of steps required in the building of the 2D axisymmetric Thermos_Container was presented in the discussion of the 2D axisymmetric Thermos_Container_1 model. Now the modeler can use the import function to utilize the same physical model configuration and explore the influence of different materials and materials properties on the overall model design behavior.

Using the menu bar, select File > Import > CAD Data From File. Select “TC_1_Geometry.dxf.” See Figure 5.109. Click the Import button.

Because the Geometry.dxf file contains only boundary information, the modeler needs to create a domain to which the boundary information can be applied.

Using the menu bar, select Draw > Specify Objects > Rectangle, as indicated in Table 5.36.

Click OK. See Figure 5.110.
Physics Subdomain Settings: General Heat Transfer

Having established the geometry for the 2D axisymmetric Thermos_Container_3 model, the next step is to define the fundamental Physics conditions. Select Physics > Subdomain Settings. In the Subdomain edit windows, enter the information shown in Table 5.37. See Figure 5.111.

In the Subdomain edit windows, enter the information shown in Table 5.38.

### Table 5.36  Rectangle Edit Window

<table>
<thead>
<tr>
<th>Object Number</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>r</th>
<th>z</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle 1</td>
<td>0.25</td>
<td>0.55</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

### Table 5.37  Subdomain Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 3, 6, 8</td>
<td>Load</td>
<td>Basic Materials Properties &gt; Silica Glass</td>
</tr>
</tbody>
</table>

### Table 5.38  Subdomain Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Operation</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>2, 7</td>
<td>Load</td>
<td>Basic Materials Properties &gt; Air, 1 atm</td>
</tr>
</tbody>
</table>
Enter $p_{\text{vac}}$ in place of $p$ in the density expression $\rho(p[\text{Pa}], T[\text{K}])[\text{kg/m}^3]$, so that it reads $\rho(p_{\text{vac}}[\text{Pa}], T[\text{K}])[\text{kg/m}^3]$ in the Density edit window. Select “Transparent” from the Opacity pull-down list. See Figure 5.112.

In the Subdomain edit windows, enter the information shown in Table 5.39. See Figure 5.113.

Enter $p_0$ in place of $p$ in the density expression to yield $\rho(p_0[\text{Pa}], T[\text{K}])[\text{kg/m}^3]$ in the Density edit window. Select “Transparent” from the Opacity pull-down list. See Figure 5.113.

In the Subdomain edit windows, enter the information shown in Table 5.40. See Figure 5.114.

| Table 5.39  Subdomain Edit Window |
|-----------------|---------------------|
| Subdomain       | Operation          | Name                                      |
| 5, 9            | Load               | Basic Materials Properties > Air, 1 atm    |

![Figure 5.111](image-url) 2D axisymmetric Thermos_Container_3 model Subdomain Settings (1, 3, 6, 8) edit window
FIGURE 5.112 2D axisymmetric Thermos_Container_3 model Subdomain Settings (2, 7) edit window

FIGURE 5.113 2D axisymmetric Thermos_Container_2 model Subdomain Settings (5, 9) edit window
In this model, because of the high thermal conductivity of water, the temperature of the liquid is very close to uniform throughout. Thus uniformity can be assumed and subdomain 4 can be made inactive. The temperature of the liquid is incorporated into the boundary conditions. Also, because this model will calculate only the heat transfer, and not the detailed convection flow in the surrounding air, subdomain 9 can be made inactive. Convection losses are incorporated into the heat transfer coefficient boundary conditions. Incorporating both of these assumptions into the model significantly simplifies the model calculations.

Select Subdomain 4. Uncheck the Active in this domain check box. Select Subdomain 9. Uncheck the Active in this domain check box. Click OK.

| Table 5.40   Subdomain Edit Window |
|--------------|-----------------------------------|
| Subdomain    | Operation | Name                                           |
| 4            | Load      | Basic Materials Properties > Water, liquid     |

In this model, because of the high thermal conductivity of water, the temperature of the liquid is very close to uniform throughout. Thus uniformity can be assumed and subdomain 4 can be made inactive. The temperature of the liquid is incorporated into the boundary conditions. Also, because this model will calculate only the heat transfer, and not the detailed convection flow in the surrounding air, subdomain 9 can be made inactive. Convection losses are incorporated into the heat transfer coefficient boundary conditions. Incorporating both of these assumptions into the model significantly simplifies the model calculations.

Select Subdomain 4. Uncheck the Active in this domain check box. Select Subdomain 9. Uncheck the Active in this domain check box. Click OK.
Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 5.41. Click OK. See Figures 5.115 and 5.116.

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select the Boundary condition.

Load the Library coefficient using the path Heat Transfer Coefficients > Air, Ext. Natural Convection as shown in Table 5.42.

### Table 5.41 Boundary Settings–General Heat Transfer Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Thermal insulation</td>
<td>—</td>
<td>5.115</td>
</tr>
<tr>
<td>8, 14, 21</td>
<td>Temperature</td>
<td>$T_L$</td>
<td>5.116</td>
</tr>
</tbody>
</table>

### Physics Boundary Settings: General Heat Transfer

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 5.41. Click OK. See Figures 5.115 and 5.116.

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select the Boundary condition.

Load the Library coefficient using the path Heat Transfer Coefficients > Air, Ext. Natural Convection as shown in Table 5.42.
Enter L_wall in the Heat transfer coefficient (h) expression in place of the L_htgh term for boundary 28:

$$h_{ave}(T[1/K], T_{inf htgh}[1/K], L_{wall}[1/m])[W/(m^2*K)]$$

Enter T_0 in the External temperature (T_{inf}) edit window for boundary 28. See Figure 5.117.

Enter L_top in the Heat transfer coefficient (h) expression in place of the L_htgh term for boundary 34:

$$h_{ave}(T[1/K], T_{inf htgh}[1/K], L_{top}[1/m])[W/(m^2*K)]$$

Enter T_0 in the External temperature (T_{inf}) edit window for boundary 34. See Figure 5.118.

Click OK.

---

**Table 5.42  Boundary Settings–General Heat Transfer Edit Window**

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Library Coefficient</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>28</td>
<td>Heat flux</td>
<td>Nat. Vertical wall, L=height</td>
<td>5.117</td>
</tr>
<tr>
<td>34</td>
<td>Heatflux</td>
<td>Nat. Horiz. plane, Upside, L=width</td>
<td>5.118</td>
</tr>
</tbody>
</table>
FIGURE 5.117 2D axisymmetric Thermos_CONTAINER_3 model Boundary Settings (28) edit window

FIGURE 5.118 2D axisymmetric Thermos_CONTAINER_3 model Boundary Settings (34) edit window
CHAPTER 5  2D AXISYMMETRIC MODELING

Mesh Generation
From the menu bar, select Mesh > Free Mesh Parameters > Subdomain 1, 2, 3, 6, 7, 8. Enter Maximum element size 0.002. Select Method > Quad. Click the Remesh button. See Figure 5.119.

Click OK. See Figure 5.120.

Solving the 2D Axisymmetric Thermos_Container_3 Model
From the menu bar, select Solve > Solver Parameters > Parametric. Enter T_L in the Parameter name edit window. Enter 273.15:9.5:368.15 in the Parameter values edit window. See Figure 5.121. Click OK.

From the menu bar, select Solve > Solve Problem. See Figure 5.122.

Postprocessing
Select Postprocessing > Plot Parameters > Surface. Select “°C [degC]” in the Unit pull-down list. See Figure 5.123.
FIGURE 5.120 2D axisymmetric Thermos_Container_3 model mesh

FIGURE 5.121 2D axisymmetric Thermos_Container_3 model Solver Parameters edit window
FIGURE 5.122 2D axisymmetric Thermos_Container_3 model using the Parametric Solver (UMFPACK)

FIGURE 5.123 2D axisymmetric Thermos_Container_3 model Plot Parameters window
Click OK. See Figure 5.124.

Given that our main interest in creating the 2D axisymmetric Thermos_Container_3 model is to examine the heat transfer, the next step is to determine the heat loss. Select Postprocessing > Boundary Integration. Select boundaries 28 and 34 (the wall and top of the tank, respectively). Select “Normal total heat flux” in the Predefined quantities pull-down list. Check the Compute surface integral (for axisymmetric modes) check box. See Figure 5.125.
Click OK. The result of the Boundary Integration (~34 W) is displayed as Value of surface integral: xx.xxxx [W], Expression: nflu_hgh, Boundaries: 28, 34 in the display window at the bottom of the COMSOL user interface. The amount of energy lost is approximately 41% of that lost using the urethane foam insulation in the 2D axisymmetric Thermos_Container_1 model (~82 W). See Figure 5.126.

Postprocessing Animation
Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 5.127.

Click the Start Animation button. See Figure 5.128.

Alternatively, you can play the file Movie5_TC_3.avi that was supplied with this book.

2D Axisymmetric Thermos_CONTAINER Models: Summary and Conclusions
The models presented in this section of Chapter 5 have introduced the following concepts: two-dimensional axisymmetric modeling (Axial symmetry [2D]), cylindrical coordinates, conductive media DC, Heat Transfer Module, heat conduction theory, opaque and transparent thermally conductive materials, export and import of CAD
drawings (.dxf files), heat transfer coefficients, and vacuum. Previously introduced concepts employed in this section include the triangular mesh, free mesh parameters, subdomain mesh, maximum element size, and quadrilateral mesh (quad).

A comparison of the calculated results for the three thermos container models is shown in Table 5.43. As can be readily observed, the presence of a vacuum cavity significantly reduces the rate of heat flow through the model and the associated heat loss.

| Table 5.43  Thermos Container Modeling Results Summary |
|-------------|-------------|------------|---------|--------|
| Model Number | Materials Used | Vacuum  | Heat Loss | ΔW (%) |
| 1            | 304ss, urethane foam | No      | ~82 W     | —      |
| 2            | 304ss        | Yes     | ~37 W     | ~45%   |
| 3            | Silica glass | Yes     | ~34 W     | ~41%   |
References


### Exercises

1. Build, mesh, and solve the COMSOL 2D axisymmetric cylinder conduction model problem presented in this chapter.
2. Build, mesh, and solve the first variation of the 2D axisymmetric cylinder conduction model problem presented in this chapter.
3. Build, mesh, and solve the second variation of the 2D axisymmetric cylinder conduction model problem presented in this chapter.
4. Build, mesh, and solve the 2D axisymmetric Thermos_CONTAINER model presented in this chapter.
5. Build, mesh, and solve the first variation of the 2D axisymmetric Thermos_CONTAINER model presented in this chapter.
6. Build, mesh, and solve the second variation of the 2D axisymmetric Thermos_CONTAINER model presented in this chapter.
7. Explore other variations of the arguments in the COMSOL 2D axisymmetric cylinder conduction models.
8. Explore other variations of the arguments in the 2D axisymmetric Thermos_CONTAINER models.
9. Explore how an increase in the pressure modifies the behavior of the COMSOL 2D axisymmetric cylinder conduction model.
10. Explore how changes in the tank geometry affect the heat loss in the 2D axisymmetric Thermos_CONTAINER model.
6
2D Simple Mixed-Mode Modeling

In This Chapter

2D Mixed-Mode Guidelines for New COMSOL® Multiphysics® Modelers
  2D Mixed-Mode Modeling Considerations
  2D Coordinate System
  2D Axisymmetric Coordinate System
  Joule Heating and Heat Conduction Theory
  Heat Conduction Theory
2D Resistive Heating Modeling
  2D Resistive Heating Model
  First Variation on the 2D Resistive Heating Model
  Second Variation on the 2D Resistive Heating Model, Including Alumina Isolation
  2D Resistive Heating Models: Summary and Conclusions
2D Inductive Heating Considerations
  2D Axisymmetric Coordinate System
  2D Axisymmetric Inductive Heating Model
  First Variation on the 2D Axisymmetric Inductive Heating Model
  Second Variation on the 2D Axisymmetric Inductive Heating Model
  2D Axisymmetric Inductive Heating Models: Summary and Conclusions

2D Mixed-Mode Guidelines for New COMSOL® Multiphysics® Modelers

2D Mixed-Mode Modeling Considerations

It is assumed, at this point, that the reader has been exposed, at least briefly, to the information contained in Chapters 4 and 5. In this chapter, the basic material from Chapters 4 and 5 is utilized and somewhat expanded. In the earlier chapters, models were built and then solved using a quasi-static approach. In this chapter, the transient (time-dependent) method of solution is introduced. Transient models are intrinsically more difficult than quasi-static models. Transient models require a firmer understanding of the underlying physics and a more complete characterization of the materials employed in the model.
In transient or time-dependent (e.g., dynamic, unsteady) models, at least one of the dependent variables changes as a function of time.

These 2D models implicitly assume, in compliance with the laws of physics, that the energy flow, the materials properties, the environment, and any other conditions and variables that are of interest are homogeneous, isotropic, and constant unless otherwise specified (e.g., time dependent) throughout the entire domain of interest, both within the model and, through the boundary conditions, in the environs of the model.

In the two models presented in this chapter, the resistive heating model and the inductive heating model, heat is generated within the body of the modeled materials through the same mechanism, Ohm’s law (i.e., Joule heating), by two fundamentally different, but similar methods. In the resistive heating models, heat is generated by the flow of direct current (DC) through the body in the models, resulting in Joule heating. As the body heats, the temperature rises. Because the resistivity depends on the temperature, the resistivity (conductivity) changes and consequently the amount of heat generated within the body changes, and so on.

In the inductive heating model, eddy currents (alternating currents [AC]) are induced within the material of the modeled body. Heat is generated by the flow of the induced alternating current within the body, generating Joule heating. As the body heat increases, the temperature rises. Similarly, because the resistivity depends on the temperature, the resistivity (conductivity) changes and consequently the amount of heat generated within the body changes, the temperature rises, and so on.

As mentioned in previous chapters, it is always preferable for the modeler to be able to accurately anticipate the expected behavior (results) of the model and to understand how those results should be presented. Never assume that the default values that are initially present when the model is first created will suit the needs of a new model. Always verify that the values employed in the model are the correct ones needed for that model. Calculated solution values that significantly deviate from the expected values or from comparison values measured in experimentally derived realistic models are probably indicative of one or more modeling errors either in the original model design, in the earlier model analysis, or in the understanding of the underlying physics, or are simply due to human error.

2D Coordinate System

Two different 2D coordinate systems are employed in the models that are built in this chapter. In the first set of models (resistive heating), the basic 2D coordinate system plus time is employed. The second set of models (inductive heating) employs the 2D axisymmetric coordinate system plus time. Each of the coordinate systems was chosen
to facilitate the modeler building the least difficult model necessary to achieve a reasonably accurate demonstration of the principles involved and achieve a good first approximation result.

Because it is completely impossible to accommodate all variable factors into any scientific or engineering problem larger than the two-body problem, each scientific or engineering calculation yields an approximate result. A good first approximation result is derived from a calculation that yields an answer that allows the modeler to determine the degree of feasibility of an adequate solution to the problem in question, within the limits of tolerable variance (error). All of the nonmodeling parameters need to be estimated either by the modeler, his or her power structure, or his or her accountant.

The purpose of the models presented here is to demonstrate the application of the chosen modeling techniques to applied physical prototypes, using measured materials properties for commercially available materials. These first approximation result models can be modified and used by the modeler to build other exploratory candidate models to determine the feasibility of similar devices as part of a more complex development or analysis project.

In a steady-state solution to a 2D model, parameters can vary only as a function of position in space \((x)\) and space \((y)\) coordinates. Such a 2D model represents the parametric condition of the model in a time-independent mode (quasi-static). In a transient solution model, parameters can vary both by position in space \((x)\) and space \((y)\) and in time \((t)\); see Figure 6.1.

The transient solution model is essentially a sequential collection of (quasi-static) solutions, except that one or more of the dependent variables \((f(T, t))\) has changed with time. The space coordinates \((x)\) and \((y)\) typically represent a distance coordinate throughout which the model is to calculate the change of the specified observables (i.e., temperature, heat flow, pressure, voltage, current) over the range of values \((x_{\text{min}} <= x <= x_{\text{max}})\) and \((y_{\text{min}} <= y <= y_{\text{max}})\). The time coordinate \((t)\) represents the range of values \((t_{\text{min}} <= t <= t_{\text{max}})\) from the beginning of the observation period \((t_{\text{min}})\) to the end of the observation period \((t_{\text{max}})\).
2D Axisymmetric Coordinate System

In the steady-state solution to any 2D axisymmetric model, parameters can vary only as a function of the radial position in space \( r \) and the axial position space \( z \) coordinates. Such a model represents the parametric condition of the model in a time-independent mode (quasi-static). In a transient solution model, parameters can vary both by position in space \( r \) and space \( z \) and in time \( t \); see Figure 6.2.

The transient solution model is essentially a sequential collection of steady-state (quasi-static) solutions. The space coordinates \( r \) and \( z \) typically represent a distance coordinate throughout which the model is to calculate the change of the specified observables (i.e., temperature, heat flow, pressure, voltage, current) over the range of values \( r_{\text{min}} <= r <= r_{\text{max}} \) and \( z_{\text{min}} <= z <= z_{\text{max}} \). The time coordinate \( t \) represents the range of values \( t_{\text{min}} <= t <= t_{\text{max}} \) from the beginning of the observation period \( t_{\text{min}} \) to the end of the observation period \( t_{\text{max}} \).

Joule Heating and Heat Conduction Theory

Joule heating techniques are extremely important in device design considerations. Joule heating is applied to tasks as varied as heating houses (AC) and baking potatoes (microwave AC). It accounts for some of the most widely utilized technologies employed for research, design, and application in engineering and physics. Most modern products or processes require an understanding of Joule heating techniques either during development or during the use of the product or process (e.g., automobiles, plate glass fabrication, plastic extrusion, plastic products, houses, baked potatoes, ice cream).

Heating and heat transfer concerns have existed since the beginning of prehistory. There have been many contributors to our present understanding of the interaction of electric currents and solids. In this particular area, however, two scientists made especially notable contributions: Georg Ohm\(^6\) and James Prescott Joule.\(^7\) Ohm discovered Ohm’s law: \(^8\)

\[
I = \frac{V}{R}
\]  

(6.1)
where

\( I \) = current in amperes (A)
\( V \) = voltage (electromotive force) in volts (V)
\( R \) = resistance in ohms

Joule discovered Joule’s law:9

\[
Q = I^2 \cdot R \cdot t
\]  
(6.2)

where

\( Q \) = heat generated in joules (J)
\( I \) = current in amperes (A)
\( R \) = resistance in ohms
\( t \) = time in seconds (S)

The first example presented in this chapter, the resistive heating model, explores the 2D electro-thermal interaction modeling of Joule heating using transient analysis. The model is solved for a material that is both electrically and thermally conductive. This model is implemented using the COMSOL® Multiphysics® Electro-Thermal Application Mode.

In the first variation on the resistive heating model, the new model is built to explore a common configurational change and is solved using the same COMSOL Multiphysics Application Mode. In the second variation on this model, a model is built that incorporates materials modifications in addition to the configurational changes; it is solved using the COMSOL Multiphysics AC/DC Electro-Thermal Application Mode. The second variation also explores the influence of a low-pressure gas/vacuum environment on the model’s properties. The calculated modeling results are then compared.

The second example, the induced heating model, explores the use of induced AC eddy currents to create Joule heating in a 2D axisymmetric model. The first and second variations on the induced heating model explore the effects of materials and parametric changes.

**Heat Conduction Theory**

Heat conduction is a naturally occurring process that is readily observed in many aspects of modern life (e.g., refrigerators, freezers, microwave ovens, thermal ovens, engines). The heat transfer process allows both linear and rotational work to be done in the generation of electricity and the movement of vehicles. The initial understanding of transient heat transfer was developed by Newton10 and started with Newton’s law of cooling:11

\[
\frac{dQ}{dt} = h^*A^*(T_S - T_E)
\]  
(6.3)
where \( \frac{dQ}{dt} \) = incremental energy lost in joules per unit time (J/s)

- \( A \) = energy transmission surface area (m²)
- \( h \) = heat transfer coefficient [W/(m²*K)]
- \( T_s \) = surface temperature of the object losing heat (K)
- \( T_e \) = temperature of the environment gaining heat (K)

Subsequent work by Jean Baptiste Joseph Fourier, based on Newton’s law of cooling, developed the law for steady-state heat conduction (known as Fourier’s law). Fourier’s law is expressed here in differential form:

\[
q = -k\nabla T
\]

where

- \( q \) = heat flux in watts per square meter (W/m²)
- \( k \) = thermal conductivity of the material [W/(m*K)]
- \( \nabla T \) = temperature gradient (K/m)

## 2D Resistive Heating Modeling

### 2D Resistive Heating Model

The following numerical solution model (Resistive_Heating_1) is derived from a model that was originally developed by COMSOL as a Multiphysics demonstration model for distribution with the Multiphysics software in the basic Multiphysics Model Library. This model introduces the coupling of two important basic Application Modes: Joule Heating in the Conductive Media DC Application Mode and the Heat Transfer by Conduction Application Mode. The coupling of these two modes in this model demonstrates the interactions normally found in typical engineering materials.

**Note**

It is important for the new modeler to personally build each model presented in this text. There is no substitute in the path to understanding of the modeling process for the hands-on experience of actually building, meshing, solving, and postprocessing a model. Many times the inexperienced modeler will make and subsequently correct errors, thereby adding to his or her experience and fund of modeling knowledge. Even building the simplest model will expand the modeler’s store of knowledge.

Modeling Joule heating is important in a wide variety of physical design and applied engineering problems. Typically, the modeler desires to understand Joule heat generation during a process and either add heat or remove heat to achieve or maintain a desired temperature. Figure 6.3 shows a 3D rendition of the 2D resistive heating geometry, as will be modeled in this section.
To start building the Resistive_Heating_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” (default setting) from the Space dimension pull-down list. Select COMSOL Multiphysics > Electro-Thermal Interaction > Joule Heating > Transient analysis. See Figure 6.4. Click OK.

FIGURE 6.3 3D rendition of the 2D resistive heating model

FIGURE 6.4 2D Resistive_Heating_1 Model Navigator setup
When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 6.1; also see Figure 6.5. Click OK.

When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 1.0 and a height of 1.0. Select “Base: Center” and set x equal to 0 and y equal to 0 in the Rectangle edit window. See Figure 6.6.

| Table 6.1 Constants Edit Window |

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>r_Cu</td>
<td>1.754e-8[ohm*m]</td>
<td>Resistivity of copper at T_ref</td>
</tr>
<tr>
<td>T_ref</td>
<td>20[degC]</td>
<td>Reference temperature</td>
</tr>
<tr>
<td>alpha_Cu</td>
<td>3.9e-3[1/K]</td>
<td>Temperature coefficient copper</td>
</tr>
<tr>
<td>V_0</td>
<td>1e-1[V]</td>
<td>Electric potential (voltage)</td>
</tr>
<tr>
<td>T_air</td>
<td>300[K]</td>
<td>Air temperature</td>
</tr>
<tr>
<td>k_Cu</td>
<td>3.94e2[W/(m*K)]</td>
<td>Thermal conductivity copper</td>
</tr>
<tr>
<td>rho_Cu</td>
<td>8.96e3[kg/m^3]</td>
<td>Density copper</td>
</tr>
<tr>
<td>Cp_Cu</td>
<td>3.8e2[J/(kg*K)]</td>
<td>Heat capacity copper</td>
</tr>
</tbody>
</table>

**NOTE**

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 1.0 and a height of 1.0. Select “Base: Center” and set x equal to 0 and y equal to 0 in the Rectangle edit window. See Figure 6.6.
Click OK, and then click the Zoom Extents button. See Figure 6.7.

Using the menu bar, select Draw > Specify Objects > Circle. In the Circle edit window, enter a radius of 0.1 and a base of “Center.” Set x equal to 0 and y equal to 0. See Figure 6.8.

Click OK. See Figure 6.9.
The rectangle is the 2D representation of a cube in cross section. The circle is added to the 2D geometry to allow the creation of a hole through the cube, as shown in Figure 6.3.

Using the menu bar, select Draw > Create Composite Object. In the Set formula edit window, enter $R_1 - C_1$. See Figure 6.10.
Click OK. See Figure 6.11.

This model introduces the coupling of two basic Application Modes: Joule Heating in the Conductive Media DC Application Mode and the Heat Transfer by Conduction Application Mode. The Physics subdomain and boundary settings will
need to be specified in each mode separately. Figure 6.12 shows an overview of the boundary conditions for the combination of both modes.

First, however, the subdomain settings values need to be specified.

**Physics Subdomain Settings: Heat Transfer by Conduction (ht)**

Having established the geometry for the 2D Resistive Heating_1 model of a block with a hole, the next step is to define the fundamental Physics conditions. Using the menu bar, select Multiphysics > Heat Transfer by Conduction (ht).

Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain). In the Subdomain edit windows, enter the information shown in Table 6.2. See Figure 6.13.

**NOTE** For transient calculations, all of the physical property values are required for the conduction calculation. If $C_p$ and $\rho$ are set to zero, the implication is that the material is a perfect vacuum, which is logically inconsistent with the stated value of $k$.

Select the Init tab. Enter $T_{\text{ref}}$ in the Initial value edit window. See Figure 6.14. Click OK.

<table>
<thead>
<tr>
<th><strong>Table 6.2 Subdomain Edit Window</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>$k$ (isotropic)</td>
</tr>
<tr>
<td>$\rho$</td>
</tr>
<tr>
<td>$C_p$</td>
</tr>
</tbody>
</table>
2D Resistive Heating Modeling

**FIGURE 6.13** 2D Resistive_Heating_1 model Subdomain Settings edit window

**FIGURE 6.14** 2D Resistive_Heating_1 model Subdomain Settings, Init edit window
Physics Boundary Settings: Heat Transfer by Conduction (ht)
Using the menu bar, select Physics > Boundary Setting. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 6.3. Click OK. See Figures 6.15 and 6.16.

Physics Subdomain Settings: Conductive Media DC (dc)
Using the menu bar, in the Model Navigator menu, select Multiphysics > Conductive Media DC (dc). Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain). Select “Linear temperature relation” from the Conductivity relation pull-down list. In the Subdomain edit windows, enter the information as shown in Table 6.4. See Figure 6.17.

### Table 6.3  Boundary Settings–Heat Transfer by Conduction (ht) Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 4–8</td>
<td>Temperature</td>
<td>T_air</td>
<td>6.15</td>
</tr>
<tr>
<td>2, 3</td>
<td>Thermal insulation</td>
<td>—</td>
<td>6.16</td>
</tr>
</tbody>
</table>

**Physics Boundary Settings: Heat Transfer by Conduction (ht)**

Using the menu bar, select Physics > Boundary Setting. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 6.3. Click OK. See Figures 6.15 and 6.16.

**Physics Subdomain Settings: Conductive Media DC (dc)**

Using the menu bar, in the Model Navigator menu, select Multiphysics > Conductive Media DC (dc). Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain). Select “Linear temperature relation” from the Conductivity relation pull-down list. In the Subdomain edit windows, enter the information as shown in Table 6.4. See Figure 6.17.

**NOTE** At this point in the model, the generation of heat is coupled to the resistivity through the temperature change.

---

![Figure 6.15](image)  
**Figure 6.15** 2D Resistive_Heating_1 model Boundary Settings (1, 4–8) edit window
Select the Init tab. Enter $V_0(1-x[1/m])$ in the $V(t_0)$ edit window. See Figure 6.18. Click OK.

NOTE: The initial conditions assume a linear voltage drop across the body of the model. This is reflected in the initialization equation ($V(t_0) = V_0(1-x[1/m])$).

Physics Boundary Settings: Conductive Media DC (dc)

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 6.5. Click OK. See Figures 6.19, 6.20, and 6.21.

Table 6.4  Subdomain Settings–Conductive Media DC (dc) Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\rho_0$</td>
<td>$r_{\text{Cu}}$</td>
<td>Resistivity at reference temperature</td>
</tr>
<tr>
<td>$\alpha$</td>
<td>$\alpha_{\text{Cu}}$</td>
<td>Temperature coefficient</td>
</tr>
<tr>
<td>$T_0$</td>
<td>$T_{\text{ref}}$</td>
<td>Reference temperature</td>
</tr>
</tbody>
</table>
CHAPTER 6  2D SIMPLE MIXED-MODE MODELING

**FIGURE 6.17** 2D Resistive_Heating_1 model Subdomain Settings edit window

**FIGURE 6.18** 2D Resistive_Heating_1 model Subdomain Settings Init edit window
Table 6.5  Boundary Settings–Conductive Media DC (dc) Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Electric potential</td>
<td>$V_0$</td>
<td>6.19</td>
</tr>
<tr>
<td>2, 3, 5–8</td>
<td>Electric insulation</td>
<td>—</td>
<td>6.20</td>
</tr>
<tr>
<td>4</td>
<td>Ground</td>
<td>—</td>
<td>6.21</td>
</tr>
</tbody>
</table>

**FIGURE 6.19** 2D Resistive_Heating_1 model Boundary Settings (1) edit window

**FIGURE 6.20** 2D Resistive_Heating_1 model Boundary Settings (2, 3, 5–8) edit window
Figure 6.22 shows the 2D Resistive_Heating_1 model with all the boundary settings.

Mesh Generation
On the toolbar, click the Initialize Mesh button once. Click the Refine Mesh button once. This results in a mesh of approximately 4300 elements. See Figure 6.23.
Solving the 2D Resistive_Heating_1 Model

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver.

Enter 0:50:2000 in the Times edit window. See Figure 6.24. Click OK.

Time-Dependent Solving of the 2D Resistive_Heating_1 Model

Select Solve > Solve Problem. See Figure 6.25.

Postprocessing and Visualization

The default plot shows the temperature distribution in Kelvin. The temperature distribution can also be shown in degrees Centigrade. To do so, select Postprocessing > Plot
CHAPTER 6  2D SIMPLE MIXED-MODE MODELING

![Solver Parameters](image1)

**FIGURE 6.24** 2D Resistive_Heating_1 model Solver Parameters edit window

![Model Solution](image2)

**FIGURE 6.25** 2D Resistive_Heating_1 model solution
Parameters > Surface. Verify that the Surface plot check box is checked and that the Predefined quantities pulldown list shows “Temperature.” Select “degC” or “°C” from the Unit pull-down list. See Figure 6.26.

Click OK. See Figure 6.27.

It is relatively simple to demonstrate the heat flux. Select Postprocessing > Plot Parameters > Arrow. Check the Arrow plot check box. Select Heat Transfer by Conduction (ht) > Heat flux from the Predefined quantities pull-down list. Click the Color button and select a color such as “black.” Click OK. See Figure 6.28.

Click OK. See Figure 6.29.

Next, because this is a transient analysis model, the modeler can test how close the solution is to the steady-state value. Select Postprocessing > Cross-Section Plot Parameters > General > Point plot. Verify that all of the Solutions to use are selected. See Figure 6.30.
FIGURE 6.27 2D Resistive Heating_1 model, degrees Centigrade

FIGURE 6.28 2D Resistive Heating_1 model, Plot Parameters, Arrow edit window
FIGURE 6.29 2D Resistive_Heating_1 model, temperature and heat flux

FIGURE 6.30 2D Resistive_Heating_1 model, Cross-Section Plot Parameters, General edit window
Click the Point tab. Select “°C” from the Unit pull-down list. Enter $x = 0$, $y = 0.4$ in the Coordinates edit windows. See Figure 6.31.

Click OK. Figure 6.32 shows the temperature versus time plot for the point $x = 0$, $y = 0.4$. It is easily seen that the temperature is close to the steady-state value (the curve approaches the horizontal, small $\Delta T$) at the end of the modeling calculation.

**Postprocessing Animation**

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 6.33.
FIGURE 6.32 2D Resistive_Heating_1 model, temperature versus time at $x = 0, y = 0.4$

Click the Start Animation button. See Figure 6.34.

Alternatively, you can play the file Movie6_RH_1.avi that was supplied with this book.

First Variation on the 2D Resistive Heating Model

The following numerical solution model (Resistive_Heating_2) is derived from the model Resistive_Heating_1. In this model, geometric and materials composition changes are introduced, such as might be used in a general industrial application. It is a multielement heating unit with Nichrome (a nickel–chromium alloy) heating bars and copper connecting bars.

---

NOTE The Resistive_Heating_2 model demonstrates materials and a configuration as might be employed in heat sealers, soldering heads, packaging equipment, and printed circuit board processing equipment.
Modeling Joule heating is important in a wide variety of physical design and applied engineering problems. Typically, the modeler desires to understand Joule heat generation during a process and either add heat or remove heat so as to achieve or maintain a desired temperature. Figure 6.35 shows a 3D rendition of the 2D resistive heating geometry, as will be modeled here.

To start building the Resistive_Heating_2 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” (the default setting) from
FIGURE 6.34  2D Resistive_Heating_1 model animation, final frame

the Space dimension pull-down list. Select COMSOL Multiphysics > Electro-Thermal Interaction > Joule Heating > Transient analysis. See Figure 6.36. Click OK.

**Constants**

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 6.6; see also Figure 6.37. Click OK.

FIGURE 6.35  3D rendition of the 2D Resistive_Heating_2 model (not to scale)
FIGURE 6.36 2D Resistive_Heating_2 Model Navigator setup

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>V_0</td>
<td>1 [V]</td>
<td>Electric potential (voltage)</td>
</tr>
<tr>
<td>T_ref</td>
<td>20[degC]</td>
<td>Reference temperature</td>
</tr>
<tr>
<td>T_air</td>
<td>300[K]</td>
<td>Air temperature</td>
</tr>
<tr>
<td>r_Cu</td>
<td>1.754e-8[ohm*m]</td>
<td>Resistivity Cu at T_0</td>
</tr>
<tr>
<td>alpha_Cu</td>
<td>3.9e-3[1/K]</td>
<td>Temperature coefficient Cu</td>
</tr>
<tr>
<td>k_Cu</td>
<td>3.94e2[W/(m*K)]</td>
<td>Thermal conductivity Cu</td>
</tr>
<tr>
<td>rho_Cu</td>
<td>8.96e3[kg/m^3]</td>
<td>Density Cu</td>
</tr>
<tr>
<td>Cp_Cu</td>
<td>3.8e2[J/(kg*K)]</td>
<td>Heat capacity Cu</td>
</tr>
<tr>
<td>r_NiCr</td>
<td>1.08e-6[ohm*m]</td>
<td>Resistivity NiCr at T_0</td>
</tr>
<tr>
<td>alpha_NiCr</td>
<td>1.7e-3[1/K]</td>
<td>Temperature coefficient NiCr</td>
</tr>
<tr>
<td>k_NiCr</td>
<td>1.13e1[W/(m*K)]</td>
<td>Thermal conductivity NiCr</td>
</tr>
<tr>
<td>rho_NiCr</td>
<td>8.4e3[kg/m^3]</td>
<td>Density NiCr</td>
</tr>
<tr>
<td>Cp_NiCr</td>
<td>4.5e2[J/(kg*K)]</td>
<td>Heat capacity NiCr</td>
</tr>
</tbody>
</table>
In building this model, the calculational parameters (e.g., constants, scalar expressions) have been consolidated into a convenient location (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

Using the menu bar, select Draw > Specify Objects > Rectangle. Create each of the rectangles indicated in Table 6.7. See Figure 6.38.

Using the menu bar, select Draw > Create Composite Object. Enter: R1+R7+R8−R2−R3−R4−R5−R6. See Figure 6.39.
Click OK, and then click the Zoom Extents button. See Figure 6.40.

In building this model, the same geometry has been built that will be used in the next model. To save the modeler some time, select File > Export > Geometry Objects to File. Enter RH2_Geometry in the Save As edit window. Click the Save button.
This model introduces the coupling of two basic Application Modes: Joule Heating in the Conductive Media DC Application Mode and the Heat Transfer by Conduction Application Mode. The Physics subdomain and boundary settings will need to be specified in each mode separately. Figure 6.41 shows an overview of the boundary conditions for the combination of both modes.

First, however, the subdomain settings values need to be specified.
Physics Subdomain Settings: Heat Transfer by Conduction (ht)

Having established the geometry for the 2D Resistive_Heating_2 model of a heater bar assembly, the next step is to define the fundamental Physics conditions. Using the menu bar, select Multiphysics > Heat Transfer by Conduction (ht). Using the menu bar, select Physics > Subdomain Settings. In the Subdomain edit windows, enter the information shown in Table 6.8. Click the Apply button. See Figure 6.42.

In the Subdomain edit windows, enter the information shown in Table 6.9. Click the Apply button. See Figure 6.43.

<table>
<thead>
<tr>
<th>Subdomain Number</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 8</td>
<td>$k$ (isotropic)</td>
<td>$k_{\text{Cu}}$</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td></td>
<td>$\rho$</td>
<td>$\rho_{\text{Cu}}$</td>
<td>Density</td>
</tr>
<tr>
<td></td>
<td>$C_p$</td>
<td>$C_p_{\text{Cu}}$</td>
<td>Heat capacity</td>
</tr>
</tbody>
</table>
For transient calculations, all of the physical property values are required for the conduction calculation. In this case, the properties of both copper (Cu) and Nichrome (NiCr) are required.

Select the Init tab. Select subdomains 1–8. Enter \( T_{\text{ref}} \) in the Initial value edit window. See Figure 6.44. Click OK.

**Physics Boundary Settings: Heat Transfer by Conduction (ht)**

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 6.10. See Figures 6.45 and 6.46.

### Table 6.9 Subdomain Settings Edit Window

<table>
<thead>
<tr>
<th>Subdomain Number</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2–7</td>
<td>( k ) (isotropic)</td>
<td>( k_{\text{NiCr}} )</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td></td>
<td>( \rho )</td>
<td>( \rho_{\text{NiCr}} )</td>
<td>Density</td>
</tr>
<tr>
<td></td>
<td>( C_p )</td>
<td>( C_{p_{\text{NiCr}}} )</td>
<td>Heat capacity</td>
</tr>
</tbody>
</table>

**NOTE** For transient calculations, all of the physical property values are required for the conduction calculation. In this case, the properties of both copper (Cu) and Nichrome (NiCr) are required.

Select the Init tab. Select subdomains 1–8. Enter \( T_{\text{ref}} \) in the Initial value edit window. See Figure 6.44. Click OK.

**Physics Boundary Settings: Heat Transfer by Conduction (ht)**

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 6.10. See Figures 6.45 and 6.46.
Click OK. Figure 6.47 shows the final combined Heat Transfer by Conduction (ht) boundary settings.

**Physics Subdomain Settings: Conductive Media DC (dc)**

Using the menu bar, select Multiphysics > Conductive Media DC (dc). Using the menu bar, select Physics > Subdomain Settings. Select Subdomains 1–8 in the Subdomain

| Table 6.10 Boundary Settings–Heat Transfer by Conduction (ht) Edit Window |
|---|---|---|---|---|
| Boundary | Boundary Condition | Value/Expression | Click | Apply | Figure Number |
| 1, 40 | Temperature | $T_{air}$ | Yes | | 6.45 |
FIGURE 6.45 2D Resistive Heating model Boundary Settings (1, 40) edit window

FIGURE 6.46 2D Resistive Heating model Boundary Settings (2, 3...) edit window
selection window (all of the subdomains). Enter 0.01 in the Thickness (d) edit window. Select “Linear temperature relation” from the Conductivity relation pull-down list. Click the Apply button.

In the Subdomain edit windows, enter the information shown in Table 6.11. Click the Apply button. See Figure 6.48.

In the Subdomain edit windows, enter the information shown in Table 6.12. Click the Apply button. See Figure 6.49.

At this point in the model, the generation of heat is coupled to the resistivity in each different material (Cu, NiCr) through the temperature change.

<table>
<thead>
<tr>
<th>Subdomain Number</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 8</td>
<td>$\rho_0$</td>
<td>$r_{Cu}$</td>
<td>Resistivity at reference temperature</td>
</tr>
<tr>
<td></td>
<td>$\alpha$</td>
<td>$\alpha_{Cu}$</td>
<td>Temperature coefficient</td>
</tr>
<tr>
<td></td>
<td>$T_0$</td>
<td>$T_{ref}$</td>
<td>Reference temperature</td>
</tr>
</tbody>
</table>
2D Resistive Heating Modeling

**FIGURE 6.48** 2D Resistive_Heating_2 model Subdomain Settings (1, 8) edit window

**FIGURE 6.49** 2D Resistive_Heating_2 model Subdomain Settings (2–7) edit window
Select the Init tab. Select subdomains 1–8 in the Subdomain selection window (all of the subdomains). Enter \( V_0(1 - x[1/m]) \) in the \( V(t_0) \) edit window. See Figure 6.50. Click OK.

**NOTE** The initial conditions assume a linear voltage drop across the body of the model. This is reflected in the initialization equation \( (V(t_0) = V_0(1 - x[1/m])) \).

**Physics Boundary Settings: Conductive Media DC (dc)**

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 6.13. See Figures 6.51, 6.52, and 6.53.
Table 6.13  Boundary Settings–Conductive Media DC (dc) Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Electric potential</td>
<td>$V_0$</td>
<td>6.51</td>
</tr>
<tr>
<td>40</td>
<td>Ground</td>
<td>—</td>
<td>6.53</td>
</tr>
</tbody>
</table>
Click OK. Figure 6.54 shows the 2D Resistive_Heating_2 model with all the boundary settings.

Mesh Generation

On the toolbar, click the Initialize Mesh button once. Click the Refine Mesh button once. This results in a mesh of approximately 2200 elements. See Figure 6.55.
Solving the 2D Resistive Heating_2 Model

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver.

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Enter 0:50:2000 in the Times edit window. See Figure 6.56. Click OK.

Time-Dependent Solving of the 2D Resistive Heating_2 Model

Select Solve > Solve Problem. See Figure 6.57.

Postprocessing and Visualization

The default plot shows the temperature distribution in kelvins. The temperature distribution can also be shown in degrees Centigrade. To do so, select Postprocessing > Plot
**FIGURE 6.56** 2D Resistive_Heating_2 model Solver Parameters edit window

**FIGURE 6.57** 2D Resistive_Heating_2 model solution
Parameters > Surface. Verify that the Surface plot check box is checked and that the Predefined quantities pull-down list shows “Temperature.” Select “degC” or “°C” from the Unit pull-down list. See Figure 6.58.

Click OK. See Figure 6.59.

Next, because this is a transient analysis model, the modeler can test how close the solution is to the steady-state value. Select Postprocessing > Cross-Section Plot Parameters > General > Point plot. Verify that all of the Solutions to use are selected. See Figure 6.60.

Click the Point tab. Enter $x = 0$, $y = 0.1$ in the Coordinates edit windows. See Figure 6.61.

Click OK. Figure 6.62 shows the temperature versus time plot for the point $x = 0$, $y = 0.1$. It is easily seen that the temperature is not close to the steady-state value (the curve is still rising, an almost linear $\Delta T$) at the end of the modeling calculation.
\section*{FIGURE 6.59} 2D Resistive\_Heating\_2 model, degrees centigrade

\section*{FIGURE 6.60} 2D Resistive\_Heating\_2 model, Cross-Section Plot Parameters, General edit window
FIGURE 6.61 2D Resistive_Heating_2 model, Cross-Section Plot Parameters, Point edit window

FIGURE 6.62 2D Resistive_Heating_2 model, temperature versus time at $x = 0, y = 0.1$
Postprocessing Animation

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 6.63.

Click the Start Animation button. See Figure 6.64.

Alternatively, you can play the file Movie6_RH_2.avi that was supplied with this book.

Second Variation on the 2D Resistive Heating Model, Including Alumina Isolation

The following numerical solution model (Resistive_Heating_3) is derived from the model Resistive_Heating_2. In this model, geometric and materials composition changes are introduced, such as might be used in a general industrial application. This model introduces Alumina as the thermal and electrical insulator and employs the
Heat Transfer Module. It is a multielement heating unit with Nichrome (a nickel–chromium alloy) heating bars and copper connecting bars.

The Resistive_Heating_3 model demonstrates materials and a configuration as might be employed in vacuum heat sealers, soldering heads, packaging equipment, and other vacuum processing equipment.

Modeling Joule heating is important in a wide variety of physical design and applied engineering problems. Typically, the modeler desires to understand Joule heat generation during a process and either add heat or remove heat so as to achieve or maintain a desired temperature. Figure 6.65 shows a 3D rendition of the 2D resistive heating geometry, as will be modeled here.

To start building the Resistive_Heating_3 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” (the default setting) from the Space dimension pull-down list. Select Heat Transfer Module > Electro-Thermal Interaction > Joule Heating > Transient analysis. See Figure 6.66. Click OK.
Using the menu bar, select Options > Constants. In the Constants edit window, enter the information as shown in Table 6.14; also see Figure 6.67. Click OK.

In building this model, the calculational parameters (e.g., constants, scalar expressions) have been consolidated into a convenient location (e.g., a Constants File, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the
settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

At this point, three alternate paths can taken. If the geometry was built and exported by building the Resistive_Heating_2 model, then the RH2_Geometry.dxf file can be imported. If not, then the modeler can use the file that comes with the book. However, if the geometry has never been built, then follow the instructions given here.

If one of the import paths is taken, then jump to the next Note.
Using the menu bar, select Draw > Specify Objects > Rectangle. Create each of the rectangles indicated in Table 6.15. See Figure 6.68.

Using the menu bar, select Draw > Create Composite Object. Enter R1+R7+R82−R2−R3−R4−R5−R6. See Figure 6.69.

Click OK, and then click the Zoom Extents button.
Using the menu bar, select File > Import > CAD Data From File > RH2_Geometry.dxf. Using the menu bar, select Draw > Specify Objects > Rectangle. Create the rectangle indicated in Table 6.16. Click the Zoom Extents button. See Figure 6.70.

This model introduces the coupling of two basic Application Modes: Joule Heating in the Conductive Media DC Application Mode and the Heat Transfer by Conduction Application Mode. The Physics subdomain and boundary settings will need to be specified in each mode separately. Figure 6.71 shows an overview of the boundary conditions for the combination of both modes.

First, however, the subdomain settings values need to be specified.

Physics Subdomain Settings: General Heat Transfer (htgh)

Having established the geometry for the 2D Resistive_Heating_3 model of a heater bar assembly, the next step is to define the fundamental Physics conditions. Using the menu bar, select Multiphysics > General Heat Transfer (htgh). Using the menu bar, select Physics > Subdomain Settings. Select Subdomains (3, 5, 7, 9, 11) > Load >

**Table 6.16  Rectangle Edit Window**

<table>
<thead>
<tr>
<th>R Number</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>x</th>
<th>y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1.0</td>
<td>1.1</td>
<td>Center</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
Basic Materials Properties > Alumina. Click OK, and then click the Apply button. See Figure 6.72.

In the Subdomain edit windows, enter the information shown in Table 6.17. Click the Apply button. See Figure 6.73.

In the Subdomain edit windows, enter the information shown in Table 6.18. Click the Apply button. See Figure 6.74.
### FIGURE 6.72  2D Resistive Heating_3 model Subdomain Settings (3, 5, 7, 9, 11) edit window

#### Table 6.17  Subdomain Settings Edit Window

<table>
<thead>
<tr>
<th>Subdomain Number</th>
<th>Name</th>
<th>Location</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 13</td>
<td>$k$ (isotropic)</td>
<td>$k_{\text{Cu}}$</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td></td>
<td>$\rho$</td>
<td>$\rho_{\text{Cu}}$</td>
<td>Density</td>
</tr>
<tr>
<td></td>
<td>$C_p$</td>
<td>$C_{p\text{Cu}}$</td>
<td>Heat capacity</td>
</tr>
</tbody>
</table>

#### Table 6.18  Subdomain Settings Edit Window

<table>
<thead>
<tr>
<th>Subdomain Number</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2, 4, 6, 8, 10, 12</td>
<td>$k$ (isotropic)</td>
<td>$k_{\text{NiCr}}$</td>
<td>Thermal conductivity</td>
</tr>
<tr>
<td></td>
<td>$\rho$</td>
<td>$\rho_{\text{NiCr}}$</td>
<td>Density</td>
</tr>
<tr>
<td></td>
<td>$C_p$</td>
<td>$C_{p\text{NiCr}}$</td>
<td>Heat capacity</td>
</tr>
</tbody>
</table>
FIGURE 6.73 2D Resistive_Heating_3 model Subdomain Settings (1, 13) edit window

FIGURE 6.74 2D Resistive_Heating_3 model Subdomain Settings (2, 4, 6, 8, 10, 12) edit window
For transient calculations, all of the physical property values are required for the conduction calculation. In this case, the properties of copper (Cu), Nichrome (NiCr), and Alumina (Al₂O₃) are required.

Select the Init tab. Select subdomains 1–13. Enter T_ref in the Initial value edit window. See Figure 6.75. Click OK.

**Physics Boundary Settings: General Heat Transfer (htgh)**

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 6.19. See Figures 6.76 and 6.77.

<table>
<thead>
<tr>
<th>Table 6.19</th>
<th>Boundary Settings–Heat Transfer by Conduction (ht) Edit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary</td>
<td>Boundary Condition</td>
</tr>
<tr>
<td>1, 40</td>
<td>Temperature</td>
</tr>
<tr>
<td>2, 3, 5, 26, 28, 39</td>
<td>Thermal insulation</td>
</tr>
</tbody>
</table>
**FIGURE 6.76** 2D Resistive_Heating_3 model Boundary Settings (1, 40) edit window

**FIGURE 6.77** 2D Resistive_Heating_3 model Boundary Settings (2, 3, 5, 26, 28, 39) edit window
Physics Subdomain Settings: Conductive Media DC (emdc)

Using the menu bar, select Multiphysics > Conductive Media DC (dc). Using the menu bar, select Physics > Subdomain Settings. Select subdomains 1–13 in the Subdomain selection window (all of the subdomains). Enter 0.01 in the Thickness (d) edit window. Select “Linear temperature relation” from the Conductivity relation pull-down list. Click the Apply button.

Select Subdomains (3, 5, 7, 9, 11) > Load > Basic Materials Properties > Alumina. Select “Conductivity” from the Conductivity relation pull-down list. Enter 0.001 in the Electric conductivity edit window. Click the Apply button.

In the Subdomain edit windows, enter the information shown in Table 6.20. Click the Apply button. See Figure 6.78.

![Subdomain Settings - Conductive Media DC (emdc)](image)

**FIGURE 6.78** 2D Resistive_Heating_3 model Subdomain Settings (1, 13) edit window

<table>
<thead>
<tr>
<th>Table 6.20</th>
<th>Subdomain Settings–Conductive Media DC (emdc) Edit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Subdomain Number</strong></td>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>1, 13</td>
<td>( \rho_0 )</td>
</tr>
<tr>
<td></td>
<td>( \alpha )</td>
</tr>
<tr>
<td></td>
<td>( T_0 )</td>
</tr>
</tbody>
</table>
In the Subdomain edit windows, enter the information shown in Table 6.21. Click the Apply button. See Figure 6.79.

<table>
<thead>
<tr>
<th>Subdomain Number</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2, 4, 6, 8, 10, 12</td>
<td>(\rho_0)</td>
<td>(r_{\mathrm{NiCr}})</td>
<td>Resistivity at reference temperature</td>
</tr>
<tr>
<td></td>
<td>(\alpha)</td>
<td>(\alpha_{\mathrm{NiCr}})</td>
<td>Temperature coefficient</td>
</tr>
<tr>
<td></td>
<td>(T_0)</td>
<td>(T_{\mathrm{ref}})</td>
<td>Reference temperature</td>
</tr>
</tbody>
</table>

In the Subdomain edit windows, enter the information shown in Table 6.21. Click the Apply button. See Figure 6.79.

At this point in the model, the generation of heat is coupled to the resistivity in each different material (Cu, NiCr) through the temperature change.

Select the Init tab. Select subdomains 1–13 in the Subdomain selection window (all of the subdomains). Enter \(V_0*(1 - x[1/m])\) in the \(V(t_0)\) edit window. See Figure 6.80. Click OK.

**FIGURE 6.79** 2D Resistive_Heating_3 model Subdomain Settings (2, 4, 6, 8, 10, 12) edit window
The initial conditions assume a linear voltage drop across the body of the model. This is reflected in the initialization equation \( V(t_0) = V_0(1 - x[1/m]) \).

**Physics Boundary Settings: Conductive Media DC (emdc)**

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 6.22. Check the Interior boundaries check box. See Figures 6.81, 6.82, and 6.83.

**Table 6.22 Boundary Settings—Conductive Media DC (emdc) Edit Window**

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Electric potential</td>
<td>( V_0 )</td>
<td>6.81</td>
</tr>
<tr>
<td>2, 3, 5, 26, 28, 39</td>
<td>Electric insulation</td>
<td>–</td>
<td>6.82</td>
</tr>
<tr>
<td>40</td>
<td>Ground</td>
<td>–</td>
<td>6.83</td>
</tr>
</tbody>
</table>
Click OK. See Figure 6.84.

Mesh Generation

On the toolbar, click Mesh > Free Mesh Parameters. Select the Subdomain tab. Select subdomains 1–13. Enter 0.02 in the Maximum element size edit window. Select “Quad” from the Method pull-down list. See Figure 6.85.
FIGURE 6.83  2D Resistive_Heating_3 model Boundary Settings (40) edit window

FIGURE 6.84  2D Resistive_Heating_3 model with all the boundary settings
Click the Remesh button. Click OK. See Figure 6.86.

Solving the 2D Resistive_Heating_3 Model

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver.
The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Enter 0:50:2000 in the Times edit window. See Figure 6.87. Click OK.

**Time-Dependent Solving of the 2D Resistive_Heating_3 Model**

Select Solve > Solve Problem. See Figure 6.88.

**Postprocessing and Visualization**

The default plot shows the temperature distribution in kelvins. The temperature distribution can also be shown in degrees Centigrade. To do so, select Postprocessing > Plot
Parameters > Surface. Verify that the Surface plot check box is checked and that the Predefined quantities pull-down list shows “Temperature.” Select “degC” or “°C” from the Unit pull-down list. See Figure 6.89.

Click OK. See Figure 6.90.

Next, because this is a transient analysis model, the modeler can test how close the solution is to the steady-state value. Select Postprocessing > Cross-Section Plot Parameters > General > Point plot. Verify that all of the Solutions to use are selected. See Figure 6.91.

Click the Point tab. Enter \( x = 0, y = 0.1 \) in the Coordinates edit windows. See Figure 6.92.

Click OK. Figure 6.93 shows the temperature versus time plot for the point \( x = 0, y = 0.1 \). It is easily seen that the temperature is somewhat close to the steady-state value (the curve is still rising, at a decreasing \( \Delta T \)) at the end of the modeling calculation.

It is interesting to see how the heat flux moves in this array. Select Postprocessing > Plot Parameters > Arrow. Check the Arrow plot check box. Select “Total heat flux.”
Click the Color button and select a color (black). Click OK, and then click OK again. See Figure 6.94.

**Postprocessing Animation**

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 6.95.
FIGURE 6.90 2D Resistive_Heating_3 model, degrees Centigrade

FIGURE 6.91 2D Resistive_Heating_3 model, Cross-Section Plot Parameters, General edit window
2D Resistive Heating Modeling

FIGURE 6.92 2D Resistive_Heating_3 model, Cross-Section Plot Parameters, Point edit window

FIGURE 6.93 2D Resistive_Heating_3 model, temperature versus time at $x = 0, y = 0.1$
Click the Start Animation button. See Figure 6.96.
Alternatively, you can play the file Movie6_RH_3.avi that was supplied with this book.

**2D Resistive Heating Models: Summary and Conclusions**

The models presented in this section of Chapter 6 have introduced the following new concepts: Ohm’s law, Joule heating, mixed-mode modeling, mixed-materials modeling, transient analysis, and the good first approximation. Previously introduced concepts employed include the triangular mesh, free mesh parameters, subdomain mesh, maximum element size, and quadrilateral mesh (quad).

The three resistive heating models are more illustrative of the mixed-mode modeling concept than they are directly amenable to the comparison of calculated values. They present different examples of the diversity of applied scientific and engineering model designs that can be explored using electro-thermal coupling and transient analysis. These models also demonstrate the significant power of relatively simple physical principles, such as Ohm’s law and Joule’s law.
2D Inductive Heating Considerations

2D Axisymmetric Coordinate System

In this part of Chapter 6, the concepts of interest are most easily explored using the 2D axisymmetric coordinate system. Reviewing briefly the 2D axisymmetric coordinate system basics, parameters in steady-state solutions to any 2D axisymmetric model can vary only as a function of the radial position in space \((r)\) and the axial position in space \((z)\) coordinates. Such models represent the parametric condition of the model in a time-independent mode (quasi-static). In transient solution models, as
presented in this section, parameters can vary both by position in space ($r$) and space ($z$) and by time ($t$); see Figure 6.97.

The transient solution model is essentially a sequential collection of steady-state (quasi-static) solutions, except that the condition has been added that at least one of the dependent variables changes as a function of time.

NOTE In transient or time-dependent (e.g., dynamic, unsteady) models, at least one of the dependent variables changes as a function of time. The change in the dependent variable is a direct result of the coupling inherent in the physical properties of the materials involved in the model.
For example, the resistance of a material typically changes (±) as a function of temperature. When heat is generated in a material through current flow (Joule’s law), the temperature of the material changes. Hence, as the temperature changes over time, the resistance changes.

The space coordinates \((r)\) and \((z)\) typically represent a distance coordinate throughout which the model is to calculate the change of the specified observables (i.e., temperature, heat flow, pressure, voltage, current) over the range of values \((r_{\text{min}} \leq r \leq r_{\text{max}})\) and \((z_{\text{min}} \leq z \leq z_{\text{max}})\). The time coordinate \((t)\) represents the range of values \((t_{\text{min}} \leq t \leq t_{\text{max}})\) from the beginning of the observation period \((t_{\text{min}})\) to the end of the observation period \((t_{\text{max}})\).

Joule heating techniques are extremely important in device design considerations. Joule heating is applied to tasks as varied as heating houses (AC) and baking potatoes (microwave AC). It accounts for some of the most widely utilized technologies employed for research, design, and application in engineering and physics. Most modern products or processes require an understanding of Joule heating techniques either during development or during the use of the product or process (e.g., automobiles, plate glass fabrication, plastic extrusion, plastic products, houses, baked potatoes, ice cream).

Heating and heat transfer concerns have existed since the beginning of prehistory. There have been many contributors to the present understanding of the interaction of electric currents and solids. Three scientists especially stand out in this regard: Georg Ohm, James Prescott Joule, and Leon Foucault.

Ohm published his discovery of Ohm’s law in 1827:\(^{14}\)

\[
I = \frac{V}{R}
\]  

(6.5)

where

- \(I\) = current in amperes (A)
- \(V\) = voltage (electromotive force) in volts (V)
- \(R\) = resistance in ohms

Joule discovered Joule’s law in 1843:\(^{15,16}\)

\[
Q = I^2 \cdot R \cdot t
\]  

(6.6)

where

- \(Q\) = heat generated in joules (J)
- \(I\) = current in amperes (A)
- \(R\) = resistance in ohms
- \(t\) = time in seconds (S)
In 1851, Foucault discovered eddy currents (also called Foucault currents). Eddy currents result when a conductor is in the presence of a changing magnetic field.

\[(j\omega\sigma - \omega^2\varepsilon)A + \nabla \times (\mu^{-1}\nabla \times A) = J^e\]  

(6.7)

where

- \(A\) = magnetic vector potential
- \(\omega\) = angular frequency
- \(\sigma\) = conductivity
- \(\varepsilon\) = permittivity
- \(\mu\) = permeability
- \(J^e\) = current density due to an external source

The induced eddy currents interact with the resistance of the conductor (Ohm’s law) through Joule’s law, causing heat. The net effect of these interactions is induction heating. In this model, the equations are as follows:

\[j\omega\sigma(T)A + \nabla \times (\mu^{-1}\nabla \times A) = 0\]  

(6.8)

where

- \(A\) = magnetic vector potential
- \(\omega\) = angular frequency
- \(\sigma(T)\) = conductivity
- \(\mu\) = permeability

and

\[\rho C_p \frac{\partial T}{\partial t} - \nabla \cdot k\nabla T = Q(T, A)\]  

(6.9)

where

- \(\rho\) = density
- \(C_p\) = specific heat capacity
- \(T\) = temperature
- \(t\) = time
- \(k\) = thermal conductivity
- \(A\) = magnetic vector potential

and

\[\sigma(T) = (\rho_{ref}(1 + \alpha(T - T_{ref}))^{-1}\]  

(6.10)

where

- \(\sigma(T)\) = electrical conductivity
- \(\rho_{ref}\) = resistivity at the reference temperature
- \(T\) = temperature
- \(T_{ref}\) = reference temperature
- \(\alpha\) = thermal coefficient of the resistivity
and

\[ Q(T) = \frac{1}{2} \sigma(T) |E_p|^2 \]  \hspace{1cm} (6.11)

where

- \( Q(T) \) = heat generated per period for a sinusoidal wave function
- \( \sigma(T) \) = conductivity at the present temperature
- \( T \) = temperature
- \( E_p \) = electric field, peak value

The first example presented in this section, the Inductive_Heating_1 model, explores 2D axisymmetric electro-thermal interaction modeling of Joule heating using transient analysis. The model is solved for a material that is both electrically and thermally conductive. The model is implemented using the COMSOL AC/DC Module Electro-Thermal Application Mode. This model demonstrates the principle of induction heating.

In the first variation on the inductive heating model, the new model is built to explore a common configurational change and is solved using the same COMSOL Multiphysics AC/DC Module Application Mode. In the second variation on this model, a model is built that incorporates materials modifications in addition to the configurational changes and is again solved using the COMSOL Multiphysics AC/DC Electro-Thermal Application Mode. The second variation also explores the influence of an insulating environment on the model’s properties. The calculated modeling results are then compared.

### 2D Axisymmetric Inductive Heating Model

The following numerical solution model (Inductive_Heating_1) is derived from a model that was originally developed by COMSOL as a Multiphysics demonstration model for distribution with the Multiphysics software in the basic Multiphysics Model Library. This model continues the introduction of the coupling of two important basic physical materials properties: Joule heating and heat transfer. The coupling of these two properties in this model demonstrates one of the interactions normally found in typical engineering materials.

**NOTE** The new modeler should personally build each model. There is no better method to obtain a rapid understanding of the modeling process than to employ the process of gaining the hands-on experience of actually building, meshing, solving, and postprocessing a model. Many times the inexperienced modeler will make and correct errors, thereby adding to his or her experience and fund of modeling knowledge. Even building the simplest model will expand the modeler’s store of knowledge.
Modeling Joule heating is important in a wide variety of physical design and applied engineering problems. Typically, the modeler desires to understand Joule heat generation during a process and either adds heat or removes heat so as to achieve or maintain a desired temperature. Figure 6.98 shows a 3D rendition of the 2D inductive heating geometry, as will be modeled here.

To start building the Inductive_Heating_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select AC/DC Module > Electro-Thermal Interaction > Azimuthal Induction Heating > Transient analysis. See Figure 6.99. Click OK.
There are two mode names in the Application mode name window (htgh emqa). The names in the window show which applications are coupled in this application: General Heat Transfer (htgh) and Azimuthal Induction Currents, Vector Potential (emqa).

### Options and Settings

Using the menu bar, select Options > Axes/Grid Settings. In the Axis edit windows, enter the information shown in Table 6.23; see Figure 6.100.

Select the Grid tab. Uncheck the Auto check box. In the Grid edit windows, enter the information shown in Table 6.24; See Figure 6.101. Click OK.

![Axes/Grid Settings](image)

**FIGURE 6.100** 2D axisymmetric Inductive Heating 1 model Axis edit window

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>r min</td>
<td>−0.05</td>
</tr>
<tr>
<td>r max</td>
<td>0.5</td>
</tr>
<tr>
<td>z min</td>
<td>−0.3</td>
</tr>
<tr>
<td>z max</td>
<td>0.3</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>r spacing</td>
<td>0.05</td>
</tr>
<tr>
<td>Extra r</td>
<td>0.03</td>
</tr>
<tr>
<td>z spacing</td>
<td>0.05</td>
</tr>
<tr>
<td>Extra z</td>
<td>−0.01 0.01</td>
</tr>
</tbody>
</table>

**Table 6.23** Axis Edit Window

**Table 6.24** Grid Edit Windows
The “extra” $r$ and $z$ grid points are defined points on the grid that are used to aid the modeler in creating the designs needed to build this model. The model can also be built on a standard grid by using the Specify Object commands.

When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

### Constants

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 6.25; also see Figure 6.102. Click OK.

Using the menu bar, select Draw > Specify Objects > Circle. Enter a radius of 0.01. Select “Base: Center” and set $r$ equal to 0.05 and $z$ equal to 0 in the Circle edit window. See Figure 6.103. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.2 and a height of 0.5. Select “Base: Corner” and set $r$ equal to 0 and $z$ equal to $-0.25$ in the Rectangle edit window. See Figure 6.104. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.03 and a height of 0.1. Select “Base: Corner” and set $r$ equal to 0 and $z$ equal to $-0.05$ in the Rectangle edit window. See Figure 6.105.
<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$I_0$</td>
<td>$1e3[A]$</td>
<td>Coil current</td>
</tr>
<tr>
<td>$d_0$</td>
<td>$2e-2[m]$</td>
<td>Coil diameter</td>
</tr>
<tr>
<td>$c_0$</td>
<td>$\pi*d_0$</td>
<td>Coil circumference</td>
</tr>
<tr>
<td>$J_s_0$</td>
<td>$I_0/c_0$</td>
<td>Coil surface current density</td>
</tr>
<tr>
<td>$T_{ref}$</td>
<td>$20[degC]$</td>
<td>Reference temperature</td>
</tr>
<tr>
<td>$r_{Cu}$</td>
<td>$1.67e-8[ohm*m]$</td>
<td>Resistivity copper</td>
</tr>
<tr>
<td>$\alpha_{Cu}$</td>
<td>$3.9e-3[1/K]$</td>
<td>Resistivity coefficient copper</td>
</tr>
<tr>
<td>$\rho_{air}$</td>
<td>$1.293[kg/m^3]$</td>
<td>Density air STP</td>
</tr>
<tr>
<td>$C_{p_{air}}$</td>
<td>$1.01e3[J/(kg*K)]$</td>
<td>Heat capacity air</td>
</tr>
<tr>
<td>$k_{air}$</td>
<td>$2.6e-2[W/(m*K)]$</td>
<td>Thermal conductivity air</td>
</tr>
<tr>
<td>$\rho_{Cu}$</td>
<td>$8.96e3[kg/m^3]$</td>
<td>Density copper</td>
</tr>
<tr>
<td>$C_{p_{Cu}}$</td>
<td>$3.8e2[J/(kg*K)]$</td>
<td>Heat capacity copper</td>
</tr>
<tr>
<td>$k_{Cu}$</td>
<td>$3.94e2[W/(m*K)]$</td>
<td>Thermal conductivity copper</td>
</tr>
</tbody>
</table>

**FIGURE 6.102** 2D axisymmetric Inductive Heating_1 model Constants edit window

**FIGURE 6.103** 2D axisymmetric Inductive Heating_1 model Circle edit window
Click OK, and then click the Zoom Extents button. See Figure 6.106.

The rectangle (R2) is the 2D representation of a cylinder in cross section. The circle is the cross-section profile of the current loop (coil), as was shown earlier in Figure 6.98.

**Physics Settings**

Select Physics > Scalar Variables. Enter 500 in the nu_emqa edit window. See Figure 6.107. Click OK.

Select Options > Expressions > Scalar Expressions. Enter the scalar expression for sigma_T as shown in Table 6.26; also see Figure 6.108. Click OK.
### FIGURE 6.106
2D axisymmetric Inductive Heating model

#### Table 6.26 Scalar Expressions Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigma_T</td>
<td>( \frac{1}{r_Cu \cdot (1 + \alpha_Cu \cdot (T-T_{\text{ref}}))} )</td>
<td>Electrical conductivity copper</td>
</tr>
</tbody>
</table>
The scalar expression for \( \sigma_T \) couples the resistivity of copper \( (\rho_{\text{Cu}}) \) and the temperature \( (T) \).

**Physics Subdomain Settings: Azimuthal Induction Currents, Vector Potential (emqa)**

Using the menu bar, select Multiphysics > Azimuthal Induction Currents, Vector Potential (emqa). Using the menu bar, select Physics > Subdomain Settings > Electric Parameters. In the Subdomain edit windows, enter the information shown in Table 6.27; also see Figure 6.109. Click OK.

![Figure 6.108](image1.png)

![Figure 6.109](image2.png)
Physics Boundary Settings: Azimuthal Induction Currents, Vector Potential (emqa)

Using the menu bar, select Physics > Boundary Settings. In the Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa) edit windows, enter the information shown in Table 6.28. Check the Interior boundaries check box. See Figures 6.110 and 6.111.

### Table 6.27 Subdomain Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>(\sigma)</td>
<td>0</td>
<td>Electric conductivity</td>
</tr>
<tr>
<td>2</td>
<td>(\sigma)</td>
<td>sigma_T</td>
<td>Electric conductivity</td>
</tr>
<tr>
<td>3</td>
<td>(\sigma)</td>
<td>0</td>
<td>Electric conductivity</td>
</tr>
</tbody>
</table>

### Table 6.28 Boundary Settings Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 3, 5</td>
<td>Axial symmetry</td>
<td>6.110</td>
</tr>
<tr>
<td>2, 7, 9</td>
<td>Magnetic insulation</td>
<td>6.111</td>
</tr>
</tbody>
</table>

**Physics Boundary Settings: Azimuthal Induction Currents, Vector Potential (emqa)**

Using the menu bar, select Physics > Boundary Settings. In the Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa) edit windows, enter the information shown in Table 6.28. Check the Interior boundaries check box. See Figures 6.110 and 6.111.
In the Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa) edit windows, enter the information shown in Table 6.29. Click OK. See Figure 6.112.

**Table 6.29  Boundary Settings Edit Window**

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>10–13</td>
<td>Surface current</td>
<td>Js_0</td>
<td>6.112</td>
</tr>
</tbody>
</table>

**FIGURE 6.111**  2D axisymmetric Inductive_Heating_1 model Boundary Settings (2, 7, 9) edit window

In the Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa) edit windows, enter the information shown in Table 6.29. Click OK. See Figure 6.112.

**FIGURE 6.112**  2D axisymmetric Inductive_Heating_1 model Boundary Settings (10–13) edit window
Table 6.30 Subdomain Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>$k$ (isotropic)</td>
<td>$k_{\text{air}}$</td>
<td>Thermal conductivity</td>
<td>6.113</td>
</tr>
<tr>
<td></td>
<td>$\rho$</td>
<td>$\rho_{\text{air}}$</td>
<td>Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$C_p$</td>
<td>$C_{p_{\text{air}}}$</td>
<td>Heat capacity</td>
<td></td>
</tr>
<tr>
<td>2, 3</td>
<td>$k$ (isotropic)</td>
<td>$k_{\text{Cu}}$</td>
<td>Thermal conductivity</td>
<td>6.114</td>
</tr>
<tr>
<td></td>
<td>$\rho$</td>
<td>$\rho_{\text{Cu}}$</td>
<td>Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$C_p$</td>
<td>$C_{p_{\text{Cu}}}$</td>
<td>Heat capacity</td>
<td></td>
</tr>
</tbody>
</table>

**Physics Subdomain Settings: General Heat Transfer (htgh)**

Using the menu bar, select Multiphysics > General Heat Transfer (htgh). Using the menu bar, select Physics > Subdomain Settings > Conduction. In the Subdomain edit windows, enter the information shown in Table 6.30. See Figures 6.113 and 6.114.
Select the Init tab. Select all subdomains (1–3). Enter T_ref in the T(t_0) edit window. See Figure 6.115. Click OK.

**Physics Boundary Settings: General Heat Transfer (htgh)**

Using the menu bar, select Physics > Boundary Settings. In the Boundary Settings – General Heat Transfer (htgh) edit windows, enter the information shown in Table 6.31. Click OK. See Figures 6.116 and 6.117.

| Table 6.31  Boundary Settings Edit Window |
|-----------------------------|---------------------------------|---------|----------------|
| Boundary | Boundary Condition | Value | Figure Number |
| 1, 3, 5    | Axial symmetry        | —      | 6.116          |
| 2, 7, 9    | Temperature           | T_ref  | 6.117          |
FIGURE 6.115 2D axisymmetric Inductive_Heating_1 model Subdomain Settings (1–3), Init edit window

FIGURE 6.116 2D axisymmetric Inductive_Heating_1 model Boundary Settings (1, 3, 5) edit window
Mesh Generation

On the toolbar, click the Initialize Mesh button once. This results in a mesh of approximately 1200 elements. See Figure 6.118.

Solving the 2D Axisymmetric Inductive_Heating_1 Model

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver.

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Enter linspace(0,1200,21) in the Times edit window. See Figure 6.119.
Click the Advanced tab. Check the Use complex functions with real input check box. See Figure 6.120. Click OK.
2D Inductive Heating Considerations

**FIGURE 6.118** 2D axisymmetric Inductive Heating_1 model mesh window

**FIGURE 6.119** 2D axisymmetric Inductive Heating_1 model Solver Parameters edit window
Time-Dependent Solving of the 2D Inductive_Heating_1 Model
Select Solve > Solve Problem. See Figure 6.121.

Postprocessing and Visualization
The default plot shows the temperature distribution in kelvins. The temperature distribution can also be shown in degrees Centigrade. To do so, select Postprocessing > Plot Parameters > Surface. Verify that the Surface plot check box is checked and that the Predefined quantities pull-down list shows “Temperature.” Select “degC” or “°C” from the Unit pull-down list. See Figure 6.122.

Click OK. See Figure 6.123.

Postprocessing Animation
Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 6.124.
FIGURE 6.121 2D axisymmetric Inductive_Heating_1 model solution

FIGURE 6.122 2D axisymmetric Inductive_Heating_1 model Plot Parameters edit window
**FIGURE 6.123** 2D axisymmetric Inductive Heating 1 model, degrees Centigrade

**FIGURE 6.124** 2D axisymmetric Inductive Heating 1 model Plot Parameters edit window
Click the Start Animation button. See Figure 6.125.

Alternatively, you can play the file Movie6_IH_1.avi that was supplied with this book.

**First Variation on the 2D Axisymmetric Inductive Heating Model**

The following numerical solution model (Inductive_Heating_2) is derived from the Inductive_Heating_1 model. This variation continues the introduction of the coupling of two important basic physical materials properties—Joule heating and heat transfer—and expands on these concepts. The coupling of these two properties in this model demonstrates one of the applications normally found in typical engineering or process research.

This model is similar to the Inductive_Heating_1 model in the use of the induction heating method. However, in this case, the modeler will build an inductively heated crucible.

Modeling Joule heating is important in a wide variety of physical design and applied engineering problems. Typically, the modeler desires to understand Joule heat generation during a process and either adds heat or removes heat so as to achieve or
maintain a desired temperature. Figure 6.126 shows a 3D rendition of the 2D axisymmetric Inductive_Heating_2 model geometry, as will be modeled here.

To start building the Inductive_Heating_2 Model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select AC/DC Module > Electro-Thermal Interaction > Azimuthal Induction Heating > Transient analysis. See Figure 6.127. Click OK.
There are two mode names in the Application mode name window (htgh emqa). The names in the window show which applications are coupled in this application: General Heat Transfer (htgh) and Azimuthal Induction Currents, Vector Potential (emqa).

Options and Settings

When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

Constants

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 6.32; also see Figure 6.128. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.2 and a height of 0.5. Select “Base: Corner” and set r equal to 0 and z equal to −0.1 in the Rectangle edit window. Click OK.

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I_0</td>
<td>2.5e2[A]</td>
<td>Coil current</td>
</tr>
<tr>
<td>d_0</td>
<td>1e-2[m]</td>
<td>Coil diameter</td>
</tr>
<tr>
<td>c_0</td>
<td>pi*d_0</td>
<td>Coil circumference</td>
</tr>
<tr>
<td>J_s_0</td>
<td>l_0/c_0</td>
<td>Coil surface current density</td>
</tr>
<tr>
<td>T_ref</td>
<td>20[degC]</td>
<td>Reference temperature</td>
</tr>
<tr>
<td>r_Cu</td>
<td>1.67e-8[ohm*m]</td>
<td>Resistivity copper</td>
</tr>
<tr>
<td>alpha_Cu</td>
<td>3.9e-3[1/K]</td>
<td>Resistivity coefficient copper</td>
</tr>
<tr>
<td>rho_air</td>
<td>1.293[kg/m^3]</td>
<td>Density air STP</td>
</tr>
<tr>
<td>Cp_air</td>
<td>1.01e3[J/(kg*K)]</td>
<td>Heat capacity air</td>
</tr>
<tr>
<td>k_air</td>
<td>2.6e-2[W/(m*K)]</td>
<td>Thermal conductivity air</td>
</tr>
<tr>
<td>rho_Cu</td>
<td>8.96e3[kg/m^3]</td>
<td>Density copper</td>
</tr>
<tr>
<td>Cp_Cu</td>
<td>3.8e2[J/(kg*K)]</td>
<td>Heat capacity copper</td>
</tr>
<tr>
<td>k_Cu</td>
<td>3.94e2[W/(m*K)]</td>
<td>Thermal conductivity copper</td>
</tr>
</tbody>
</table>
Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.1 and a height of 0.25. Select “Base: Corner” and set r equal to 0 and z equal to 0.05 in the Rectangle edit window. Click OK.

Using the menu bar, select Draw > Specify Objects > Ellipse. Enter A-semiaxes of 0.1 and B-semiaxes of 0.05. Select “Base: Center” and set r equal to 0 and z equal to 0.05 in the Ellipse edit window. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.1 and a height of 0.30. Select “Base: Corner” and set r equal to 0 and z equal to 0 in the Rectangle edit window. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter E1–R3 in the Set formula edit window. See Figure 6.129. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter R2+CO1 in the Set formula edit window. Uncheck the Keep interior boundaries check box. See Figure 6.130.

Click OK. See Figure 6.131.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter width of 0.1–0.005 and a height of 0.25. Select “Base: Corner” and set r equal to 0 and z equal to 0.05 in the Rectangle edit window. Click OK.

Using the menu bar, select Draw > Specify Objects > Ellipse. Enter A-semiaxes of 0.1–0.005 and B-semiaxes of 0.05–0.005. Select “Base: Corner” and set r equal to 0 and z equal to 0.05 in the Ellipse edit window. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.1 and a height of 0.30. Select “Base: Corner” and set r equal to −0.1 and z equal to 0 in the Rectangle edit window. Click OK.

FIGURE 6.128 2D axisymmetric Inductive_Heating_2 model Constants edit window
Using the menu bar, select Draw > Create Composite Object. Enter E1–R3 in the Set formula edit window. See Figure 6.132. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter R2+CO2 in the Set formula edit window. Uncheck the Keep interior boundaries check box. See Figure 6.133.
Click OK. See Figure 6.134.
Using the menu bar, select Draw > Create Composite Object. Enter: CO1–CO3 in the Set formula edit window. Uncheck the Keep interior boundaries check box. See Figure 6.135.
FIGURE 6.133  2D axisymmetric Inductive_Heating_2 model Create Composite Object edit window

FIGURE 6.134  2D axisymmetric Inductive_Heating_2 model (CO1, CO3)
Click OK. See Figure 6.136.

Having built the crucible, the next step is to build the first layer of the heating coil. Using the menu bar, select Draw > Specify Objects > Circle. Create each of the circles shown in Table 6.33.
Building the second layer of the heating coil is easier than building the first layer. Select circles C1–C16. Using the menu bar, select Edit > Copy. Using the menu bar, select Edit > Paste. Enter \( r = 0.01 \) and \( z = 0.006 \). Click OK.

Using the menu bar, select Edit > Paste. Enter \( r = 0.02 \) and \( z = 0 \). Click OK. See Figure 6.137.

**Physics Settings**

Select Physics > Scalar Variables. Enter 500 in the nu_emqa edit window. See Figure 6.138. Click OK.

Select Options > Expressions > Scalar Expressions. Enter the scalar expression for \( \sigma_{Cu_T} \) as shown in Table 6.34; also see Figure 6.139. Click OK.

The scalar expression for \( \sigma_{Cu_T} \) couples the resistivity of copper (\( r_{Cu} \)) and the temperature (\( T \)).

The final geometric step is to create a composite object. Using the menu bar, select Draw > Create Composite Object. Select all of the objects. Check the Keep interior boundaries check box. See Figure 6.140.

<table>
<thead>
<tr>
<th>Name</th>
<th>Radius</th>
<th>Base</th>
<th>( r )</th>
<th>( z )</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.260</td>
</tr>
<tr>
<td>C2</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.248</td>
</tr>
<tr>
<td>C3</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.236</td>
</tr>
<tr>
<td>C4</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.224</td>
</tr>
<tr>
<td>C5</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.212</td>
</tr>
<tr>
<td>C6</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.200</td>
</tr>
<tr>
<td>C7</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.188</td>
</tr>
<tr>
<td>C8</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.176</td>
</tr>
<tr>
<td>C9</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.164</td>
</tr>
<tr>
<td>C10</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.152</td>
</tr>
<tr>
<td>C11</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.140</td>
</tr>
<tr>
<td>C12</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.128</td>
</tr>
<tr>
<td>C13</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.116</td>
</tr>
<tr>
<td>C14</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.104</td>
</tr>
<tr>
<td>C15</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.092</td>
</tr>
<tr>
<td>C16</td>
<td>0.005</td>
<td>Center</td>
<td>0.11</td>
<td>0.080</td>
</tr>
</tbody>
</table>

Table 6.33 Circle Edit Window
FIGURE 6.137 2D axisymmetric Inductive_Heating_2 model, crucible and coil

![Application Scalar Variables](image)

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Unit</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigma_high</td>
<td>5.67e-8</td>
<td>W/(m²·K)</td>
<td>Stefan-Boltzmann constant</td>
</tr>
<tr>
<td>Rg_high</td>
<td>8.31451</td>
<td>J/(mol·K)</td>
<td>Universal gas constant</td>
</tr>
<tr>
<td>eq_Str0_emga</td>
<td>8.854187817e-12</td>
<td>F/m</td>
<td>Permittivity of vacuum</td>
</tr>
<tr>
<td>mu0_emga</td>
<td>4π*1e-7</td>
<td>H/m</td>
<td>Permeability of vacuum</td>
</tr>
<tr>
<td>f0_emga</td>
<td>500</td>
<td>Hz</td>
<td>Frequency</td>
</tr>
</tbody>
</table>

FIGURE 6.138 2D axisymmetric Inductive_Heating_2 model Application Scalar Variables edit window
Table 6.34  Scalar Expressions Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigma_Cu_T</td>
<td>(1/(r_{\text{Cu}} + (1 + \alpha_{\text{Cu}}(T-T_{\text{ref}})))</td>
<td>Electrical conductivity, Cu</td>
</tr>
</tbody>
</table>

Click OK. See Figure 6.141.

Now that the 2D axisymmetric Inductive_Heating_2 model geometry is built, export it to a file for future use. Select File > Export > Geometry Objects to File. Enter IH_2_Geometry in the Save as window. Select “DXF File” from the File Format pull-down list. Click OK.
Physics Subdomain Settings: Azimuthal Induction Currents, Vector Potential (emqa)

Using the menu bar, select Multiphysics > Azimuthal Induction Currents, Vector Potential (emqa). Using the menu bar, select Physics > Subdomain Settings > Electric Parameters. In the Subdomain edit windows, enter the information shown in Table 6.35. Click OK. See Figures 6.142, 6.143, and 6.144.
**Table 6.35 Subdomain Edit Window**

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>$\sigma$</td>
<td>0</td>
<td>Electric conductivity</td>
<td>6.142</td>
</tr>
<tr>
<td>2</td>
<td>$\sigma$</td>
<td>$\sigma_{Cu_T}$</td>
<td>Electric conductivity</td>
<td>6.143</td>
</tr>
<tr>
<td>3–50</td>
<td>$\sigma$</td>
<td>0</td>
<td>Electric conductivity</td>
<td>6.144</td>
</tr>
</tbody>
</table>

**Physics Boundary Settings: Azimuthal Induction Currents, Vector Potential (emqa)**

Using the menu bar, select Physics > Boundary Settings. In the Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa) edit windows, enter the information shown in Table 6.36. Check the Interior boundaries check box. See Figures 6.145 and 6.146.

**Table 6.36 Boundary Settings Edit Window**

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 3, 4</td>
<td>Axial symmetry</td>
<td>6.145</td>
</tr>
<tr>
<td>2, 5, 9</td>
<td>Magnetic insulation</td>
<td>6.146</td>
</tr>
</tbody>
</table>
FIGURE 6.143 2D axisymmetric Inductive_Heating_2 model Subdomain Settings (2), Electric Parameters edit window

FIGURE 6.144 2D axisymmetric Inductive_Heating_2 model Subdomain Settings (3–50), Electric Parameters edit window
**FIGURE 6.145** 2D axisymmetric Inductive_Heating_2 model Boundary Settings (1, 3, 4) edit window

**FIGURE 6.146** 2D axisymmetric Inductive_Heating_2 model Boundary Settings (2, 5, 9) edit window
In the Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa) edit windows, enter the information shown in Table 6.37. See Figure 6.147. Click OK. See Figure 6.148.

**Physics Subdomain Settings: General Heat Transfer (htgh)**

Using the menu bar, select Multiphysics > General Heat Transfer (htgh). Using the menu bar, select Physics > Subdomain Settings > Conduction. In the Subdomain edit windows, enter the information shown in Table 6.38. See Figures 6.149 and 6.150.

---

**Table 6.37  Boundary Settings Edit Window**

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>12–203</td>
<td>Surface current</td>
<td>Js_0</td>
<td>6.147</td>
</tr>
</tbody>
</table>

---

**FIGURE 6.147  2D axisymmetric Inductive_Heating_2 model Boundary Settings (12–203) edit window**

In the Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa) edit windows, enter the information shown in Table 6.37. See Figure 6.147. Click OK. See Figure 6.148.

**Physics Subdomain Settings: General Heat Transfer (htgh)**

Using the menu bar, select Multiphysics > General Heat Transfer (htgh). Using the menu bar, select Physics > Subdomain Settings > Conduction. In the Subdomain edit windows, enter the information shown in Table 6.38. See Figures 6.149 and 6.150.

**Table 6.38  Subdomain Edit Window**

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>( k ) (isotropic)</td>
<td>( k_{\text{air}} )</td>
<td>Thermal conductivity</td>
<td>6.149</td>
</tr>
<tr>
<td></td>
<td>( \rho )</td>
<td>( \rho_{\text{air}} )</td>
<td>Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>( C_p )</td>
<td>( C_{p_{\text{air}}} )</td>
<td>Heat capacity</td>
<td></td>
</tr>
<tr>
<td>2–50</td>
<td>( k ) (isotropic)</td>
<td>( k_{\text{Cu}} )</td>
<td>Thermal conductivity</td>
<td>6.150</td>
</tr>
<tr>
<td></td>
<td>( \rho )</td>
<td>( \rho_{\text{Cu}} )</td>
<td>Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>( C_p )</td>
<td>( C_{p_{\text{Cu}}} )</td>
<td>Heat capacity</td>
<td></td>
</tr>
</tbody>
</table>
Select the Init tab. Select subdomains 1–50. Enter $T_{\text{ref}}$ in the $T(t_0)$ edit window. See Figure 6.151. Click OK.

**Physics Boundary Settings: General Heat Transfer (htgh)**

Using the menu bar, select Physics > Boundary Settings. In the Boundary Settings – General Heat Transfer (htgh) edit windows, enter the information shown in Table 6.39. Click OK. See Figures 6.152 and 6.153.

**Table 6.39**  Boundary Settings Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 3, 4</td>
<td>Axial symmetry</td>
<td>—</td>
<td>6.152</td>
</tr>
<tr>
<td>2, 5, 9</td>
<td>Temperature</td>
<td>$T_{\text{ref}}$</td>
<td>6.153</td>
</tr>
</tbody>
</table>
FIGURE 6.149 2D axisymmetric Inductive_Heating_2 model Subdomain Settings (1) edit window

FIGURE 6.150 2D axisymmetric Inductive_Heating_2 model Subdomain Settings (2–50) edit window
FIGURE 6.151 2D axisymmetric Inductive_Heating_2 model Subdomain Settings (1–50), Init edit window

FIGURE 6.152 2D axisymmetric Inductive_Heating_2 model Boundary Settings (1, 3, 4) edit window
Mesh Generation

On the toolbar, click the Initialize Mesh button once. This mesh yields approximately 14,000 elements. See Figure 6.154.

Solving the 2D Axisymmetric Inductive_Heating_2 Model

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver.

\[ T = T_0 \]

**FIGURE 6.153** 2D axisymmetric Inductive_Heating_2 model Boundary Settings (2, 5, 9) edit window

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.
Enter linspace(0,1200,21) in the Times edit window. See Figure 6.155.
Click the Advanced tab. Check the Use complex functions with real input check box. See Figure 6.156. Click OK.

**Time-Dependent Solving of the 2D Resistive Heaing 2 Model**
Select Solve > Solve Problem. See Figure 6.157.

**Postprocessing and Visualization**
The default plot shows the temperature distribution in kelvins. The temperature distribution can also be shown in degrees Centigrade. To do so, select Postprocessing > Plot Parameters > Surface. Verify that the Surface plot check box is checked and that
**FIGURE 6.155** 2D axisymmetric Inductive_Heating_2 model Solver Parameters edit window

**FIGURE 6.156** 2D axisymmetric Inductive_Heating_2 model Solver Parameters, Advanced edit window
the Predefined quantities pull-down list shows “Temperature.” Select “degC” or “°C” from the Unit pull-down list. See Figure 6.158.

Click OK. See Figure 6.159.

Postprocessing Animation

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 6.160.

Click the Start Animation button. See Figure 6.161.

Alternatively, you can play the file Movie6_IH_2.avi that was supplied with this book.

Second Variation on the 2D Axisymmetric Inductive Heating Model

The following numerical solution model (Inductive_Heating_3) is derived from the Inductive_Heating_2 model. It continues the introduction of the coupling of two
important basic physical materials properties—Joule heating and heat transfer—and expands on these concepts. The coupling of these two properties in this model demonstrates one of the applications normally found in typical engineering or process research.

**NOTE** This model is similar to the Inductive_Heating_2 model in the use of the induction heating method. However, in this case, the modeler will build a filled (loaded) inductively heated crucible. Here, bismuth\(^{21,22}\) is the material of choice. Additionally, the crucible will be surrounded by nitrogen\(^{23}\) to prevent oxidation of the heated bismuth.

Modeling Joule heating is important in a wide variety of physical design and applied engineering problems. Typically, the modeler desires to understand Joule heat
generation during a process and either adds heat or removes heat so as to achieve or maintain a desired temperature. Figure 6.162 shows a 3D rendition of the 2D axisymmetric Inductive_Heating_3 model geometry, as will be modeled here.

To start building the Inductive_Heating_3 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select AC/DC Module > Electro-Thermal Interaction > Azimuthal Induction Heating > Transient analysis. See Figure 6.163. Click OK.

| FIGURE 6.159 2D axisymmetric Inductive_Heating_2 model, degrees Centigrade |

There are two mode names in the Application mode name window (htgh emqa). The names in the window show which applications are coupled in this application: General Heat Transfer (htgh) and Azimuthal Induction Currents, Vector Potential (emqa).
**FIGURE 6.160** 2D axisymmetric Inductive_Heating_2 model Plot Parameters window

**FIGURE 6.161** 2D axisymmetric Inductive_Heating_2 model animation, final frame
Options and Settings

Constants

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 6.40; see also Figure 6.164. Click OK.

Select File > Import > CAD Data From File > IH_2_Geometry.dxf. Click the Import button.
### Table 6.40 Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I_0</td>
<td>4e2[A]</td>
<td>Coil current</td>
</tr>
<tr>
<td>d_0</td>
<td>1e-2[m]</td>
<td>Coil diameter</td>
</tr>
<tr>
<td>c_0</td>
<td>pi*d_0</td>
<td>Coil circumference</td>
</tr>
<tr>
<td>Js_0</td>
<td>I_0/c_0</td>
<td>Coil surface current density</td>
</tr>
<tr>
<td>T_refCu</td>
<td>20[degC]</td>
<td>Reference temperature Cu</td>
</tr>
<tr>
<td>T_refBi</td>
<td>0[degC]</td>
<td>Reference temperature Bi</td>
</tr>
<tr>
<td>r_Cu</td>
<td>1.67e-8[ohm*m]</td>
<td>Resistivity copper</td>
</tr>
<tr>
<td>alpha_Cu</td>
<td>3.9e-3[1/K]</td>
<td>Resistivity coefficient copper</td>
</tr>
<tr>
<td>rho_N2</td>
<td>1.25[kg/m^3]</td>
<td>Density nitrogen STP</td>
</tr>
<tr>
<td>Cp_N2</td>
<td>1.03e3[J/(kg*K)]</td>
<td>Heat capacity N2</td>
</tr>
<tr>
<td>k_N2</td>
<td>2.512e-2[W/(m*K)]</td>
<td>Thermal conductivity N2</td>
</tr>
<tr>
<td>rho_Cu</td>
<td>8.96e3[kg/m^3]</td>
<td>Density copper</td>
</tr>
<tr>
<td>Cp_Cu</td>
<td>3.8e2[J/(kg*K)]</td>
<td>Heat capacity copper</td>
</tr>
<tr>
<td>k_Cu</td>
<td>3.94e2[W/(m*K)]</td>
<td>Thermal conductivity copper</td>
</tr>
<tr>
<td>r_Bi</td>
<td>1.068e-6[ohm*m]</td>
<td>Resistivity Bi at T_refBi</td>
</tr>
<tr>
<td>alpha_Bi</td>
<td>1.7e-3[1/K]</td>
<td>Temperature coefficient Bi</td>
</tr>
<tr>
<td>k_Bi</td>
<td>8.374[W/(m*K)]</td>
<td>Thermal conductivity Bi</td>
</tr>
<tr>
<td>rho_Bi</td>
<td>9.8e3[kg/m^3]</td>
<td>Density Bi</td>
</tr>
<tr>
<td>Cp_Bi</td>
<td>1.23e2[J/(kg*K)]</td>
<td>Heat capacity Bi</td>
</tr>
</tbody>
</table>

**FIGURE 6.164** 2D axisymmetric Inductive_Heating_3 model Constants edit window
Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.2 and a height of 0.5. Select “Base: Corner” and set r equal to 0 and z equal to \(-0.1\) in the Rectangle edit window. Click OK. See Figure 6.165.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.1–0.005 and a height of 0.25–0.05. Select “Base: Corner” and set r equal to 0 and z equal to 0.05 in the Rectangle edit window. Click OK.

Using the menu bar, select Draw > Specify Objects > Ellipse. Enter A-semiaxes of 0.1–0.005 and B-semiaxes of 0.05–0.005. Select “Base: Corner” and set r equal to 0 and z equal to 0.05 in the Ellipse edit window. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.1 and a height of 0.30. Select “Base: Corner” and set r equal to \(-0.1\) and z equal to 0 in the Rectangle edit window. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter E1–R3 in the Set formula edit window. Click OK.
Using the menu bar, select Draw > Create Composite Object. Enter R2+CO1 in the Set formula edit window. Verify that the Keep interior boundaries check box is not checked. Click OK.

Select Physics > Subdomain Settings. Select subdomain 3 to verify that the bismuth subdomain has been properly added. Click OK. See Figure 6.166.

**Physics Settings**

Select Physics > Scalar Variables. Enter 500 in the nu_emqa edit window. See Figure 6.167. Click OK.

Select Options > Expressions > Scalar Expressions. Enter the scalar expressions for sigma_Cu_T and sigma_Bi_T as shown in Table 6.41; also see Figure 6.168. Click OK.
The scalar expression for $\sigma_{\text{Cu}_T}$ couples the resistivity of copper ($r_{\text{Cu}}$) and the temperature ($T$). The scalar expression for $\sigma_{\text{Bi}_T}$ couples the resistivity of bismuth ($r_{\text{Bi}}$) and the temperature ($T$).

**Physics Subdomain Settings: Azimuthal Induction Currents, Vector Potential (emqa)**

Using the menu bar, select Multiphysics > Azimuthal Induction Currents, Vector Potential (emqa). Using the menu bar, select Physics > Subdomain Settings > Electric
Parameters. In the Subdomain edit windows, enter the information shown in Table 6.42. Click OK. See Figures 6.169–6.172.

Physics Boundary Settings: Azimuthal Induction Currents, Vector Potential (emqa)

Using the menu bar, select Physics > Boundary Settings. In the Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa) edit windows, enter the information shown in Table 6.43. Check the Interior boundaries check box. See Figures 6.173 and 6.174.

---

**Table 6.42  Subdomain Edit Window**

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>$\sigma$</td>
<td>0</td>
<td>Electric conductivity</td>
<td>6.169</td>
</tr>
<tr>
<td>2</td>
<td>$\sigma$</td>
<td>sigma_Cu_T</td>
<td>Electric conductivity</td>
<td>6.170</td>
</tr>
<tr>
<td>3</td>
<td>$\sigma$</td>
<td>sigma_Bi_T</td>
<td>Electric conductivity</td>
<td>6.171</td>
</tr>
<tr>
<td>4–51</td>
<td>$\sigma$</td>
<td>0</td>
<td>Electric conductivity</td>
<td>6.172</td>
</tr>
</tbody>
</table>

---

[FIGURE 6.169  2D axisymmetric Inductive_Heating_3 model Subdomain Settings (1), Electric Parameters edit window]
2D Inductive Heating Considerations

FIGURE 6.170 2D axisymmetric Inductive_Heating_3 model Subdomain Settings (2), Electric Parameters edit window

FIGURE 6.171 2D axisymmetric Inductive_Heating_3 model Subdomain Settings (3), Electric Parameters edit window
Table 6.43  Boundary Settings Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 3–7</td>
<td>Axial symmetry</td>
<td>6.173</td>
</tr>
<tr>
<td>2, 9, 14</td>
<td>Magnetic insulation</td>
<td>6.174</td>
</tr>
</tbody>
</table>

**FIGURE 6.172** 2D axisymmetric Inductive_Heating_3 model Subdomain Settings (4–51), Electric Parameters edit window

**FIGURE 6.173** 2D axisymmetric Inductive_Heating_3 model Boundary Settings (1, 3–7) edit window
In the **Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa)** edit windows, enter the information shown in Table 6.44. See Figure 6.175. Click OK. See Figure 6.176.

### Table 6.44 Boundary Settings Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>17–208</td>
<td>Surface current</td>
<td>Js_0</td>
<td>6.175</td>
</tr>
</tbody>
</table>

**FIGURE 6.174** 2D axisymmetric Inductive Heating 3 model Boundary Settings (2, 9, 14) edit window

In the **Boundary Settings – Azimuthal Induction Currents, Vector Potential (emqa)** edit windows, enter the information shown in Table 6.44. See Figure 6.175. Click OK. See Figure 6.176.

**FIGURE 6.175** 2D axisymmetric Inductive Heating 3 model Boundary Settings (17–208) edit window
Physics Subdomain Settings: General Heat Transfer (htgh)

Using the menu bar, select Multiphysics > General Heat Transfer (htgh). Using the menu bar, select Physics > Subdomain Settings > Conduction. In the Subdomain edit windows, enter the information shown in Table 6.45. See Figures 6.177, 6.178, and 6.179.

Table 6.45  Subdomain Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>$k$ (isotropic)</td>
<td>$k_{N2}$</td>
<td>Thermal conductivity</td>
<td>6.177</td>
</tr>
<tr>
<td></td>
<td>$\rho$</td>
<td>$\rho_{N2}$</td>
<td>Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$C_p$</td>
<td>$C_p_{N2}$</td>
<td>Heat capacity</td>
<td></td>
</tr>
<tr>
<td>2, 4–51</td>
<td>$k$ (isotropic)</td>
<td>$k_{Cu}$</td>
<td>Thermal conductivity</td>
<td>6.178</td>
</tr>
<tr>
<td></td>
<td>$\rho$</td>
<td>$\rho_{Cu}$</td>
<td>Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$C_p$</td>
<td>$C_p_{Cu}$</td>
<td>Heat capacity</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>$k$ (isotropic)</td>
<td>$k_{Bi}$</td>
<td>Thermal conductivity</td>
<td>6.179</td>
</tr>
<tr>
<td></td>
<td>$\rho$</td>
<td>$\rho_{Bi}$</td>
<td>Density</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$C_p$</td>
<td>$C_p_{Bi}$</td>
<td>Heat capacity</td>
<td></td>
</tr>
</tbody>
</table>
**FIGURE 6.177** 2D axisymmetric Inductive_Heating_3 model Subdomain Settings (1) edit window

**FIGURE 6.178** 2D axisymmetric Inductive_Heating_3 model Subdomain Settings (2, 4–51) edit window
Select the Init tab. Select subdomains 1–51. Enter T\_refCu in the T(t_0) edit window. See Figure 6.180. Click OK.

**Physics Boundary Settings: General Heat Transfer (htgh)**

Using the menu bar, select Physics > Boundary Settings. In the Boundary Settings – General Heat Transfer (htgh) edit windows, enter the information shown in Table 6.46. Click OK. See Figures 6.181 and 6.182.

<table>
<thead>
<tr>
<th>Table 6.46 Boundary Settings Edit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Boundary</strong></td>
</tr>
<tr>
<td>1, 3–7</td>
</tr>
<tr>
<td>2, 9, 14</td>
</tr>
</tbody>
</table>
FIGURE 6.180  2D axisymmetric Inductive_Heating_3 model Subdomain Settings (1–51), Init edit window

FIGURE 6.181  2D axisymmetric Inductive_Heating_3 model Boundary Settings (1, 3–7) edit window
Mesh Generation

On the toolbar, click the Initialize Mesh button once. This mesh yields approximately 13,500 elements. See Figure 6.183.

Solving the 2D Axisymmetric Inductive_Heating_3 Model

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Time dependent solver.

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Enter linspace(0,1200,21) in the Times edit window. See Figure 6.184.
2D Inductive Heating Considerations

**FIGURE 6.183** 2D axisymmetric Inductive Heating_3 model mesh window

**FIGURE 6.184** 2D axisymmetric Inductive Heating_3 model Solver Parameters edit window
Click the Advanced button. Check the Use complex functions with real input check box. See Figure 6.185. Click OK.

**Time-Dependent Solving of the 2D Resistive_Heating_3 Model**
Select Solve > Solve Problem. See Figure 6.186.

**Postprocessing and Visualization**
The default plot shows the temperature distribution in kelvins. The temperature distribution can also be shown in degrees Centigrade. To do so, select Postprocessing > Plot Parameters > Surface. Verify that the Surface plot check box is checked and that the Predefined quantities pull-down list shows “Temperature.” Select “degC” or “°C” from the Unit pull-down list. See Figure 6.187.
Click OK. See Figure 6.188.

**Postprocessing Animation**

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 6.189.

Click the Start Animation button. See Figure 6.190.

Alternatively, you can play the file Movie6_IH_3.avi that was supplied with this book.

**2D Axisymmetric Inductive Heating Models: Summary and Conclusions**

The models presented in this section of Chapter 6 have introduced the following new concepts: AC induction and mixed-materials modeling. Previously introduced
concepts included Ohm’s law, Joule heating, mixed-mode modeling, triangular mesh, transient analysis, the good first approximation, and 2D axisymmetric coordinates.

The three 2D axisymmetric inductive heating models demonstrate the difference in level of complexity between single-coil and multi-coil models. In the Inductive Heating_1 model, the concept of inductively produced heating was introduced. In the Inductive Heating_2 model, the concept of inductively
produced heating as applied to a practical application (a heated crucible) was used to present one example of the diverse applied scientific and engineering model designs that can be explored using electro-thermal coupling and transient analysis. In the Inductive_Heating_3 model, the crucible was filled with a commonly used metal for melting.

These models are examples of the good first approximation type of model. They demonstrate the significant power of relatively simple physical principles, such as Ohm’s law and Joule’s law, when applied in the COMSOL Multiphysics modeling environment. They could, of course, be modified by the addition of calculations insulating materials and heat loss through convection, among other changes.
FIGURE 6.189 2D axisymmetric Inductive_Heating_3 model Plot Parameters window

FIGURE 6.190 2D axisymmetric Inductive_Heating_3 model animation, final frame
References

18. file:///Applications/COMSOL34/doc/acdc/wwhelp/wwimpl/common/html/wwhelp.htm?context=acdc&file=modeling_acdc.3.4.html#142268

Exercises

1. Build, mesh, and solve the COMSOL 2D resistive heating model problem presented in this chapter.
2. Build, mesh, and solve the first variation of the 2D resistive heating model problem presented in this chapter.
3. Build, mesh, and solve the second variation of the 2D resistive heating model problem presented in this chapter.
4. Build, mesh, and solve the 2D axisymmetric inductive heating model presented in this chapter.

5. Build, mesh, and solve the first variation of the 2D axisymmetric inductive heating model presented in this chapter.

6. Build, mesh, and solve the second variation of the 2D axisymmetric inductive heating model presented in this chapter.

7. Explore other materials as applied in the 2D resistive heating models.

8. Explore other heater geometries similar to those seen in the 2D resistive heating models.

9. Explore how a change of the gas (e.g., N₂ → He) modifies the behavior of the 2D axisymmetric inductive heating model.

10. Explore how changes in the crucible geometry affect the heating rate of the 2D axisymmetric inductive heating model.
2D Complex Mixed-Mode Guidelines for New COMSOL® Multiphysics® Modelers

2D Complex Mixed-Mode Modeling Considerations

2D Coordinate System

Electrical Impedance Theory

2D Electric Impedance Sensor Model: Basic
Basic 2D Electric Impedance Sensor Model: Summary and Conclusions
2D Electric Impedance Sensor Model: Advanced
2D Electric Impedance Sensor Models: Summary and Conclusions

Generator and Power Distribution Basics

2D AC Generators: Static and Transient
2D AC Generator Model (2D_ACG_1): Static
2D AC Generator Model (2D_ACG_2): Transient
2D AC Generators, Static and Transient Models:
Summary and Conclusions

2D AC Generator: Sector—Static and Transient
2D AC Generator Sector Model (2D_ACGS_1): Static
2D AC Generators, Static Sector Model: Summary and Conclusions
2D AC Generator Sector Model (2D_ACGS_2): Transient
2D AC Generators, Static and Transient Models:
Summary and Conclusions

In this chapter, the basic material on 2D modeling presented in Chapters 4, 5, and 6 will be utilized and expanded. In the earlier chapters, models were built and solved using static, quasi-static, and transient methods. In this chapter, all of those methods of solution will be employed. The physics of transient models is intrinsically more difficult
than that for either the static or quasi-static models. Transient models require a firmer understanding of the underlying physical principles being modeled and a more complete (better) characterization of the materials employed in the model.

In transient or time-dependent (e.g., dynamic, unsteady) models, at least one of the dependent variables changes as a function of time.

The 2D models in this chapter implicitly assume, in compliance with the laws of physics, that the energy flow, the materials properties, the environment, and any other conditions and variables of interest are homogeneous, isotropic, or constant, unless otherwise specified (e.g., time dependent), throughout the entire domain of interest, both within the model and, through the boundary conditions, in the environs of the model.

The three models presented in this chapter—the 2D electric impedance sensor model, the 2D generator model, and the 2D generator sector model—are developed using the AC/DC Module. Each of these three models introduces the modeler to different modeling aspects in the employment of the AC/DC Module to explore a range of similar design, test, and engineering problems.

Electrical resistance tomography is a sensing technology that applies currents, measures the resulting voltages on the surface of a body (e.g., inanimate, animate) and infers impedances from those data. This technology was developed independently in several diverse areas of study (geophysics, industrial process imaging, and medical imaging, to name a few). As a result, substantially the same technology has come to be known by different names in the literature (e.g., electrical resistivity tomography, electrical resistance tomography, electrical impedance tomography). This technology is widely used in the previously mentioned areas and is one of the most promising noninvasive measurement techniques available.

The 2D electric impedance sensor models, both basic and advanced, employ the high-frequency currents (1 MHz alternating currents AC). These currents are applied to the material of the modeled body to locate volumes that differ in impedance from the impedance of the bulk material by monitoring the local impedance. The basic 2D electric impedance sensor model detects the location of a fixed volume difference area. The advanced 2D electric impedance sensor model detects the location of a fluctuating difference volume, such as might be seen in a medical application measuring lung function. 2D electric impedance tomography research is exploring the application of this measurement technology to the detection of breast cancer, lung function, brain function, and numerous other areas.

The 2D generator model introduces the modeler to rotary motion and the conversion of mechanical energy to electrical energy. The 2D generator sector model employs symmetry to reduce the geometric difficulty of building the generator model and adds an ordinary differential equation to handle the mechanical dynamics and calculate the torque caused by magnetic forces.
2D Coordinate System

In a steady-state solution to a 2D model, parameters can vary only as a function of position in space (x) and space (y) coordinates. Such a 2D model represents the parametric condition of the model in a time-independent mode (quasi-static). In a transient solution model, parameters can vary both by position in space (x), and space (y) and in time (t); see Figure 7.1.

The transient solution model is essentially a sequential collection of (quasi-static) solutions, except that one or more of the dependent variables [f(x, y, t)] has changed with time. The space coordinates (x) and (y) typically represent a distance coordinate throughout which the model is to calculate the change of the specified observables (i.e., temperature, heat flow, pressure, voltage, current) over the range of values (x_min <= x <= x_max) and (y_min <= y <= y_max). The time coordinate (t) represents the range of values (t_min <= t <= t_max) from the beginning of the observation period (t_min) to the end of the observation period (t_max).

Electrical Impedance Theory

The concept of electrical impedance,\(^\text{10}\) as used in alternating current (AC) theory, is an expansion of the basic concept of resistance as exemplified by Ohm’s law,\(^\text{11}\) in direct current theory.

\[ I = \frac{V}{R} \]  

(7.1)

where

- \( I \) = current in amperes (A)
- \( V \) = voltage (electromotive force) in volts (V)
- \( R \) = resistance in ohms

---

Having discovered the basic laws of electricity, and his work having been the foundation upon which others have built their theories, the German physicist Georg Ohm (1787-1854) was a giant of the early science of electricity. His law was discovered in 1827.
In AC theory, both voltage (\(V\)) and current (\(I\)) alternate periodically as a function of time. Typically, the alternating behavior—frequency \((f)\)—of the voltage and current are separately represented either as a single sinusoidal wave or as a sum of several sinusoidal waves.

The analysis of complex waveforms is handled by Fourier analysis.\(^{12}\) That topic will not be presented here. However, modelers are encouraged to expand their technological horizons by exploring the subject of waveform analysis further.

In this case, for clarity, the exploration of the concept of impedance will be confined to single frequency analysis. The concept of impedance was developed and named by Oliver Heaviside\(^{12}\) in 1886. Impedance was reformulated in the currently used complex number formulation by Arthur E. Kennelley\(^{13}\) in 1893.

The first factor that needs to be considered, when expanding modeling calculations from the DC realm [frequency equals zero \((f = 0)\)] to the AC realm [frequency greater than zero \((f > 0)\)], is that the resistance \((R)\) maps into the impedance \((Z)\) as follows:\(^{14}\)

\[
Z = R + j \left( \omega L - \frac{1}{\omega C} \right) = R + jX = (R^2 + X^2)^{1/2}e^{j\tan^{-1}(X/R)} \tag{7.2}
\]

where
- \(Z\) = complex impedance (A)
- \(R\) = resistance (ohm)
- \(j = (-1)^{1/2}\)
- \(\omega = 2\pi f\) = angular frequency\(^{15}\)
- \(X\) = reactance (ohm)\(^{16}\)
- \(L\) = inductance (henry)
- \(C\) = capacitance (farad)

The relative vector-phase relationship of an AC voltage applied to a simple series circuit containing resistance, inductance, and capacitance is shown in Figure 7.2.

\[E = I \cdot R + j \cdot I \left[ \omega \cdot L - 1/(\omega \cdot C) \right] \]

**FIGURE 7.2** AC voltage resistive/reactive vector phase diagram
A second factor that needs to be considered by the modeler, when modeling in the AC realm, is the skin depth ($\delta$).\(^{17}\) In any material, as a function of the complex permittivity, electromagnetic waves (AC) will be attenuated (i.e., dissipated, turned into heat) and shifted in phase as a function of the distance (depth) traveled in that material. As an example, for a transverse electromagnetic wave propagating in the $z$ direction, the voltage relationship would be expressed as follows:

$$E_x = E_0 e^{-kz} = E_0 e^{-\alpha z} e^{-j\beta z}$$  \hspace{1cm} (7.3)

where $E_x =$ transverse electromagnetic propagating in the $z$ direction

$E_0 =$ scalar voltage amplitude

$k =$ complex propagation constant

$j = (-1)^{1/2}$

$e =$ base of natural logarithms

$\alpha =$ attenuation constant

$\beta =$ wave solution constant

where $\alpha$ is

$$\alpha = \omega \left( \frac{\mu \varepsilon}{2} \left( 1 + \left( \frac{\sigma}{\varepsilon \omega} \right)^2 \right)^{1/2} \right)^{1/2}$$

and where

$\varepsilon =$ permittivity

$\mu =$ permeability

$\omega =$ angular frequency

$\sigma =$ conductivity

For a good conductor, where $1 \ll \sigma/\omega \varepsilon$, the $1$‘s in the preceding equation can be ignored and $\alpha$ becomes

$$\alpha = \sqrt{\frac{\omega \mu \sigma}{2}}$$  \hspace{1cm} (7.4)

The skin depth ($\delta$) is the point at which the amplitude decreases to $E_0 e^{-1}$ and, therefore, is

$$\delta = \frac{1}{\alpha}$$  \hspace{1cm} (7.5)

The first example presented in this chapter, the basic 2D electric impedance sensor model (2D_EIS_1 model), explores the sensing of multiple small-volume differential conductivity regions. The model is solved for a material that has a bulk conductivity of $1 \text{e}^{-3} \text{S/m}$. The model is implemented using the AC/DC Module Small In-Plane Currents Application Mode and solved using a Stationary solver.
In the advanced 2D electric impedance sensor model (2D_EIS_2 model), a new quasi-static model is built to explore a configurational change using the AC/DC Module Small In-Plane Currents Application Mode and solved using a Parametric solver.

**2D Electric Impedance Sensor Model: Basic**

The following numerical solution model (2D_EIS_1) is derived from a model that was originally developed by COMSOL® as a Multiphysics® General Industrial Applications demonstration model. That model was developed for distribution with the Multiphysics software as a COMSOL Multiphysics model in the AC/DC Module Model Library.

As mentioned earlier in this chapter, knowing the skin depth ($\delta$) model limitations is important. For this model, the parameters are as follows:

\[
\omega = 2\pi f = 2 \times 3.14159 \times 1E6 = 9.9892E7 \quad (7.6)
\]

\[
\mu = 4\pi E - 7[H/m] = 1.2566E - 6[H/m] \quad (7.7)
\]

\[
\sigma = 1E - 3[S/m] \quad (7.8)
\]

\[
\delta = \left(\frac{2}{\omega \mu \sigma}\right)^{\frac{1}{2}} = \left(\frac{2}{9.9892E7 \times 1.2566E - 6*1E - 3}\right)
\]

\[
= 15.933 [m] \quad (7.9)
\]

Because the largest dimensions in the model are approximately 1 meter (m), the skin depth ($\delta$) consideration will pose no problem and will not have to be factored into the calculation. (This is a first principles observation.)

To start building the 2D_EIS_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” (the default setting) from the Space dimension pull-down list. Select AC/DC Module > Quasi-Statics, Electric > In-Plane Electric Currents > Time-harmonic analysis. See Figure 7.3. Click OK.

**Constants**

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 7.1; see also Figure 7.4. Click OK.

When building a model, it is usually best to consolidate the calculational parameters (e.g., constants, scalar expressions) in a small number of appropriate, convenient locations (e.g., a Constants file, a Scalar Expressions file) so that they are easy to find and modify as needed. Because the settings in the Constants and Scalar
Expressions edit windows can be imported and exported as text files, the appropriate text file can be modified in a text editor and then reimported into the correct Constants or Scalar Expressions edit window.

| Table 7.1 Constants Edit Window |

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sig_bulk</td>
<td>1[mS/m]</td>
<td>Bulk conductivity</td>
</tr>
<tr>
<td>eps_r_bulk</td>
<td>5</td>
<td>Relative permittivity in bulk</td>
</tr>
<tr>
<td>x_0</td>
<td>-0.35[m]</td>
<td>x position of cavity center</td>
</tr>
<tr>
<td>y_0</td>
<td>-0.15[m]</td>
<td>y position of cavity center</td>
</tr>
<tr>
<td>r_0</td>
<td>0.09[m]</td>
<td>Cavity radius</td>
</tr>
<tr>
<td>x_1</td>
<td>0.0[m]</td>
<td>x position of cavity center</td>
</tr>
<tr>
<td>y_1</td>
<td>-0.3[m]</td>
<td>y position of cavity center</td>
</tr>
<tr>
<td>r_1</td>
<td>0.12[m]</td>
<td>Cavity radius</td>
</tr>
<tr>
<td>x_2</td>
<td>0.35[m]</td>
<td>x position of cavity center</td>
</tr>
<tr>
<td>y_2</td>
<td>-0.15[m]</td>
<td>y position of cavity center</td>
</tr>
<tr>
<td>r_2</td>
<td>0.06[m]</td>
<td>Cavity radius</td>
</tr>
</tbody>
</table>
Select File > Save As. Enter 2D_EIS_1 in the Save As edit window. See Figure 7.5. Click the Save button.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 1.0 and a height of 0.5. Select “Base: Corner” and set x equal to −0.5 and y equal to −0.5 in the Rectangle edit window. See Figure 7.6.

Click OK, and then click the Zoom Extents button. See Figure 7.7.

Using the menu bar, select Draw > Specify Objects > Point. In the Point edit window, enter x: −0.01 space 0.01, y: 0 space 0. See Figure 7.8.

Click OK. See Figure 7.9.
The rectangle is the 2D representation of a 3D rectangular body in cross section. The points are added to the 2D rectangle to define the location of the electrode (between the points) on the boundary of the rectangle.

**NOTE** The rectangle is the 2D representation of a 3D rectangular body in cross section. The points are added to the 2D rectangle to define the location of the electrode (between the points) on the boundary of the rectangle.

**FIGURE 7.6** 2D_EIS_1 model Rectangle edit window

**FIGURE 7.7** 2D_EIS_1 model rectangle
Physics Settings: Scalar Expressions

Using the menu bar, select Options > Expressions > Scalar Expressions. In the Scalar Expressions edit window, enter the information shown in Table 7.2; see Figure 7.10. Click OK.

Physics Settings: Scalar Variables

Select Physics > Scalar Variables. Enter 1e6 in the nu_emqvw Application Scalar Variables edit window. See Figure 7.11. Click OK.
### Table 7.2 Scalar Expressions Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \sigma_0 )</td>
<td>( \sigma_{\text{bulk}} \times \left( \left( \frac{x-x_0}{H_{11002}} \right)^2 + \left( \frac{y-y_0}{H_{11002}} \right)^2 \right) &gt; r_0^2 )</td>
<td>Conductivity bulk</td>
</tr>
<tr>
<td>( \varepsilon_r_0 )</td>
<td>( 1 + (\varepsilon_{\text{r,bulk}} - 1) \times \left( \left( \frac{x-x_0}{H_{11001}} \right)^2 + \left( \frac{y-y_0}{H_{11001}} \right)^2 \right) &gt; r_0^2 )</td>
<td>Permittivity relative</td>
</tr>
<tr>
<td>( \sigma_1 )</td>
<td>( \sigma_{\text{bulk}} \times \left( \left( \frac{x-x_1}{H_{11002}} \right)^2 + \left( \frac{y-y_1}{H_{11002}} \right)^2 \right) &gt; r_1^2 )</td>
<td>Conductivity bulk</td>
</tr>
<tr>
<td>( \varepsilon_r_1 )</td>
<td>( 1 + (\varepsilon_{\text{r,bulk}} - 1) \times \left( \left( \frac{x-x_1}{H_{11001}} \right)^2 + \left( \frac{y-y_1}{H_{11001}} \right)^2 \right) &gt; r_2^2 )</td>
<td>Permittivity relative</td>
</tr>
<tr>
<td>( \sigma_2 )</td>
<td>( \sigma_{\text{bulk}} \times \left( \left( \frac{x-x_2}{H_{11002}} \right)^2 + \left( \frac{y-y_2}{H_{11002}} \right)^2 \right) &gt; r_2^2 )</td>
<td>Conductivity bulk</td>
</tr>
<tr>
<td>( \varepsilon_r_2 )</td>
<td>( 1 + (\varepsilon_{\text{r,bulk}} - 1) \times \left( \left( \frac{x-x_2}{H_{11001}} \right)^2 + \left( \frac{y-y_2}{H_{11001}} \right)^2 \right) &gt; r_2^2 )</td>
<td>Permittivity relative</td>
</tr>
<tr>
<td>( \sigma_{\text{tot}} )</td>
<td>( \frac{(\sigma_0 + \sigma_1 + \sigma_2)}{3} )</td>
<td>Conductivity total</td>
</tr>
<tr>
<td>( \varepsilon_r_{\text{tot}} )</td>
<td>( \frac{(\varepsilon_r_0 + \varepsilon_r_1 + \varepsilon_r_2)}{3} )</td>
<td>Permittivity total</td>
</tr>
</tbody>
</table>

**FIGURE 7.10** 2D_EIS_1 model Scalar Expressions edit window

**FIGURE 7.11** 2D_EIS_1 model Application Scalar Variables edit window
Physics Subdomain Settings: In-Plane Electric Currents (emqvw)

Having established the geometry for the 2D_EIS_1 model of a block with an electrode, the next step is to define the fundamental Physics conditions. Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain). In the Subdomain edit windows, enter the information shown in Table 7.3.

Click the $D = \varepsilon_0 \varepsilon_r E$ radio button. See Figure 7.12. Click OK.

Physics Boundary Settings: In-Plane Electric Currents (emqvw)

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 7.4. See Figures 7.13, 7.14, and 7.15.

---

### Table 7.3 Subdomain Edit Windows

<table>
<thead>
<tr>
<th>Name (isotropic)</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$</td>
<td>sigma_tot</td>
<td>Electrical conductivity</td>
</tr>
<tr>
<td>$\varepsilon_r$</td>
<td>epsilon_r_tot</td>
<td>Relative permittivity</td>
</tr>
</tbody>
</table>

---

**Physics Subdomain Settings: In-Plane Electric Currents (emqvw)**

**Physics Boundary Settings: In-Plane Electric Currents (emqvw)**
Table 7.4  Boundary Settings – In-Plane Electric Currents (emqvw) Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 2, 6</td>
<td>Ground</td>
<td>7.13</td>
</tr>
<tr>
<td>3, 5</td>
<td>Electrical insulation</td>
<td>7.14</td>
</tr>
<tr>
<td>4</td>
<td>Port</td>
<td>7.15</td>
</tr>
</tbody>
</table>

**FIGURE 7.13**  2D_EIS_1 model Boundary Settings (1, 2, 6) edit window

**FIGURE 7.14**  2D_EIS_1 model Boundary Settings (3, 5) edit window
Select the Port tab. Check Use port as input. Select “Fixed current density” from the input property pull-down list. See Figure 7.16. Click OK.

Mesh Generation

From the toolbar, select Mesh > Free Mesh Parameters > Global. Select Predefined mesh sizes > Normal (from the pull-down list). Select “Custom mesh size.” Enter 0.01 in the Maximum element size edit window. See Figure 7.17.

Click the Remesh button, and then click OK. See Figure 7.18.
**FIGURE 7.17** 2D_EIS_1 model Free Mesh Parameters edit window

**FIGURE 7.18** 2D_EIS_1 model mesh
Solving the 2D_EIS_1 Model

Using the menu bar, select Solve > Solver Parameters.

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Select “Stationary Solver.” See Figure 7.19. Click OK.

Using the menu bar, select Solve > Solve Problem. See Figure 7.20.

Postprocessing and Visualization

The default plot shows a surface plot of the electric potential (V) distribution in volts. To visualize the detected regions of differential conductivity, the plot parameters will need to be modified.
Select Postprocessing > Plot Parameters > Surface. Select “Total current density, norm” from the Predefined quantities pull-down list. Change the expression in the edit window from normJ_emqvw to 20*log10(normJ_emqvw). Click the Range button. Unselect the Auto check box. Enter $-35$ in the Min edit window and 35 in the Max edit window; see Figure 7.21. Click OK.

Select “wave” from the Colormap pull-down list. See Figure 7.22.

Click OK. See Figure 7.23.

**Basic 2D Electric Impedance Sensor Model: Summary and Conclusions**

The basic 2D electric impedance sensor model has been built and operated. This model employs a high-frequency current (1 MHz alternating current AC) to explore the differential impedance within the body of a material in a noninvasive manner. Such 1 MHz currents are applied to the material of the modeled body to locate volumes that differ in impedance from the impedance of the bulk material by monitoring the local impedance, as shown in Figure 7.23. The basic model shows the location of three areas of fixed-volume impedance difference.
FIGURE 7.21 2D_EIS_1 model solution, Color Range edit window

FIGURE 7.22 2D_EIS_1 model solution Plot Parameters edit window
2D Electric Impedance Sensor Model: Advanced

To start building the 2D_EIS_2 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” (the default setting) from the Space dimension pull-down list. Select AC/DC Module > Quasi-Static, Electric > In-Plane Electric Currents > Time-harmonic analysis. See Figure 7.24. Click OK.

Constants

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 7.5; see also Figure 7.25. Click OK.

Select File > Save As. Enter 2D_EIS_2 in the Save As edit window. See Figure 7.26. Click the Save button.
### Table 7.5 Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sig_bulk</td>
<td>1[mS/m]</td>
<td>Bulk conductivity</td>
</tr>
<tr>
<td>eps_r_bulk</td>
<td>5</td>
<td>Relative permittivity in bulk</td>
</tr>
<tr>
<td>x_0</td>
<td>-0.12[m]</td>
<td>x position of cavity center</td>
</tr>
<tr>
<td>y_0</td>
<td>0[m]</td>
<td>y position of cavity center</td>
</tr>
<tr>
<td>r_0</td>
<td>0.07[m]</td>
<td>Cavity radius</td>
</tr>
<tr>
<td>x_1</td>
<td>0.12[m]</td>
<td>x position of cavity center</td>
</tr>
<tr>
<td>y_1</td>
<td>0[m]</td>
<td>y position of cavity center</td>
</tr>
<tr>
<td>r_1</td>
<td>0.07[m]</td>
<td>Cavity radius</td>
</tr>
<tr>
<td>t_0</td>
<td>0</td>
<td>Time init</td>
</tr>
</tbody>
</table>
Using the menu bar, select Draw > Specify Objects > Ellipse. Enter A-semiaxes of 0.3 and B-semiaxes of 0.15. Select “Base: Center” and set x equal to 0 and y equal to 0 in the Ellipse edit window. See Figure 7.27.

Click OK, and then click the Zoom Extents button. See Figure 7.28.
FIGURE 7.27 2D_EIS_2 model Ellipse edit window

FIGURE 7.28 2D_EIS_2 model rectangle
Using the menu bar, select Draw > Specify Objects > Rectangle. Enter a width of 0.04 and a height of 0.001. Select “Base: Corner” and set x equal to −0.02 and y set equal to 0.15–0.001 in the Rectangle edit window. See Figure 7.29. Click OK.

The purpose of adding the rectangle to the ellipse is to provide a known placement location for the points that will define the edges of the electrode.

Using the menu bar, select Draw > Create Composite Object. Enter E1+R1 in the Set formula edit window. Uncheck the Keep interior boundaries check box. See Figure 7.30.

Click OK. See Figure 7.31.
Using the menu bar, select Draw > Specify Objects > Point. In the Point edit window, enter $-0.02 \ 0.02$ for $x$ and $0.15 \ 0.15$ for $y$. See Figure 7.32.

Click OK. See Figure 7.33.

The ellipse is the 2D representation of a 3D elliptical body in cross section (e.g., similar to the cross section that might be seen in the examination of a reclining human body). The points are added to the 2D ellipse to define the location of the electrode (between the points) on the boundary of the ellipse.
**Physics Settings: Scalar Expressions**

Using the menu bar, select Options > Expressions > Scalar Expressions. In the Scalar Expressions edit window, enter the information shown in Table 7.6; also see Figure 7.34. Click OK.

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sigma_0</td>
<td>sig bulk*(((x-x_0)^2+(y-y_0)^2)&gt;r_00^2)</td>
<td>Conductivity bulk</td>
</tr>
<tr>
<td>epsilon_r_0</td>
<td>1+(eps_r_bulck-1)*(((x-x_0)^2+(y-y_0)^2)&gt;r_00^2)</td>
<td>Permittivity relative</td>
</tr>
<tr>
<td>sigma_1</td>
<td>sig bulk*(((x-x_1)^2+(y-y_1)^2)&gt;r_01^2)</td>
<td>Conductivity bulk</td>
</tr>
<tr>
<td>epsilon_r_1</td>
<td>1+(eps_r_bulck-1)*(((x-x_1)^2+(y-y_1)^2)&gt;r_01^2)</td>
<td>Permittivity relative</td>
</tr>
<tr>
<td>sigma_tot</td>
<td>(sigma_0+sigma_1)/2</td>
<td>Conductivity total</td>
</tr>
<tr>
<td>epsilon_r_tot</td>
<td>(epsilon_r_0+epsilon_r_1)/2</td>
<td>Permittivity total</td>
</tr>
<tr>
<td>r_00</td>
<td>r_0*(1.6-cos(t_0*pi)/8))/2</td>
<td>Radius ratio</td>
</tr>
<tr>
<td>r_01</td>
<td>r_1*(1.6-cos(t_0*pi)/8))/2</td>
<td>Radius ratio</td>
</tr>
</tbody>
</table>
Physics Settings: Scalar Variables

Select Physics > Scalar Variables. Enter 1e6 in the nu_emqvw Application Scalar Variables edit window. See Figure 7.35. Click OK.

Physics Subdomain Settings: In-Plane Electric Currents (emqvw)

Having established the geometry for the 2D_EIS_2 model of an elliptical block with an electrode, the next step is to define the fundamental Physics conditions. Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window (the only available subdomain). In the Subdomain edit windows, enter the information shown in Table 7.7.

Click the D = e_0 E radio button. See Figure 7.36. Click OK.

Physics Boundary Settings: In-Plane Electric Currents (emqvw)

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 7.8. See Figures 7.37, 7.38, and 7.39.
Table 7.7 Subdomain Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$</td>
<td>sigma_tot</td>
<td>Electrical conductivity</td>
</tr>
<tr>
<td>$\varepsilon_r$</td>
<td>epsilon_r_tot</td>
<td>Relative permittivity</td>
</tr>
</tbody>
</table>

Table 7.8 Boundary Settings – In-Plane Electric Currents (emqvw) Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 4, 5, 8</td>
<td>Electric Insulation</td>
<td>7.37</td>
</tr>
<tr>
<td>2, 3</td>
<td>Port</td>
<td>7.38</td>
</tr>
<tr>
<td>6, 7</td>
<td>Ground</td>
<td>7.39</td>
</tr>
</tbody>
</table>

FIGURE 7.36 2D_EIS_2 model Subdomain Settings edit window
**FIGURE 7.37** 2D_EIS_2 model Boundary Settings (1, 4, 5, 8) edit window

**FIGURE 7.38** 2D_EIS_2 model Boundary Settings (2, 3) edit window
Select boundaries 2 and 3 in the Boundary selection window. Select the Port tab. Check “Use port as input.” Select “Fixed current density” from the input property pull-down list; see Figure 7.40. Click OK.
Mesh Generation

From the toolbar, select Mesh > Free Mesh Parameters > Global. Select Predefined mesh sizes > Normal (from the pull-down list). Select “Custom mesh size.” Enter 0.01 in the Maximum element size edit window. See Figure 7.41.

Click the Remesh button, and then click OK. See Figure 7.42.

Solving the 2D_EIS_2 Model

Using the menu bar, select Solve > Solver Parameters. The COMSOL Multiphysics software automatically selects the Stationary solver.

**NOTE** The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. In this case, the modeler will need to change the chosen solver and the parametric settings.

Select “Parametric.” Enter t_0 in the Parameter name edit window. Enter linspace(0.0,32,32) in the Parameter values edit window. See Figure 7.43. Click OK.
The `linspace(0.0, 32, 32)` command causes the solver to step the value of t_0 32 times between 0.0 and 32. For later versions of COMSOL Multiphysics software use the command `range(0, 32/32, 32)` in place of the `linspace` command.

In COMSOL Multiphysics software version 3.5a, the `linspace(x_1, x_2, x_3)` function (where `x_1` = start value, `x_2` = end value, and `x_3` = number of intervals) has been changed to the range `(y_1, y_2, y_3)` function (where `y_1` = start value, `y_2` = interval width, and `y_3` = end value).

Using the menu bar, Select Solve > Solve Problem. See Figure 7.44.

**Postprocessing and Visualization**

The default plot shows a surface plot of the electric potential (V) distribution in volts. To visualize the detected regions of differential conductivity, the plot parameters will need to be modified.

Select Postprocessing > Plot Parameters > Surface. Select “Total current density, norm” from the Predefined quantities pull-down list. Change the expression in the edit window from `normJ_emqvw` to `20*log10(normJ_emqvw)`. Click the Range button.
**FIGURE 7.43** 2D_EIS_2 model Solver Parameters edit window

**FIGURE 7.44** 2D_EIS_2 model solution
Unselect the Auto check box. Enter $-35$ in the Min edit window and 35 in the Max edit window. See Figure 7.45. Click OK.

Select “wave” from the Colormap pull-down list. See Figure 7.46. Click OK. See Figure 7.47.
Postprocessing Animation

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 7.48.

Click the Start Animation button. See Figure 7.49.

Alternatively, you can play the file Movie7_EIS_2.avi that was supplied with this book.

2D Electric Impedance Sensor Models: Summary and Conclusions

In this part of the chapter two 2D electric impedance sensor models, basic and advanced, were built and operated. These models employ a high-frequency current, (1 MHz alternating current AC) to explore the differential impedance within a body of material in a noninvasive manner. Such currents may be applied to the material of the modeled body to locate volumes that differ in impedance from the impedance of the bulk material by monitoring the local impedance. The basic 2D electric impedance sensor model shows the location of a fixed-volume impedance difference. The advanced 2D electric impedance sensor model shows the location of a fluctuating difference volume.
as might be seen in a medical application measuring lung function. 2D electric impedance tomography research is currently exploring the application of this impedance-sensing measurement technology to the detection of breast cancer, lung function, brain function, and numerous other areas.

The new concepts introduced in this section of Chapter 7 are complex AC theory, complex impedance, and skin depth.

**Generator and Power Distribution Basics**

Shortly after Georg Ohm discovered and published Ohm’s law in 1827, Michael Faraday\(^1\) discovered and published the basic operating principle of both DC and AC generators, known as electromagnetic induction.\(^2\)
Ohm’s law is:

\[ I = \frac{E}{R} \]  \hspace{1cm} (7.10)

where

- \( I \) = current in amperes (A)
- \( E \) = electromotive force in volts (V)
- \( R \) = resistance in ohms

Thomas Alva Edison\(^2\) took the initial lead in the development and commercialization of DC electrical power generation and distribution systems. During approximately the same time period, George Westinghouse\(^2\) and Nikola Tesla\(^\) were developing and commercializing AC electrical power generation and distribution systems. The resulting intense industrial competition led to what has been called the “War of Currents.”\(^3\)

Independent of all the rhetoric exchanged during the “War of Currents,” two fundamental physical factors would mandate that the ultimate winner of this intense contest was to be AC power, even before the first battle was fought. Those basic physical factors were (1) the intrinsic nature of DC (steady) and (2) Joule’s first law.\(^4\) It is the
intrinsic nature of DC that it is, by definition, a steady, fixed voltage. Thus it is by
definition not transformable to a different voltage. For DC to be transformable, it must
be converted to AC, transformed, and then converted back to DC. Therefore, when dif-
ferent voltages were needed, different dynamos (DC generators) had to be built to gen-
erate the different voltage.

Joule’s first law, published in 1841, states that the power dissipated in a resistor
can be expressed as follows:

\[ P = I^2R \]  \hspace{1cm} (7.11)

By Ohm’s law

\[ R = \frac{E}{I} \]  \hspace{1cm} (7.12)

Thus

\[ P = I^2 \left( \frac{E}{I} \right) = IE \]

It is the intrinsic nature of AC that both the current and the voltage normally
fluctuate. Hence, AC can be converted (transformed) from one voltage to a differ-
ent voltage.\(^{26}\) Because AC can be transformed to the first order (assuming no sys-
temic losses) and assuming conservation of energy (no sources or sinks in the
transformation process), then

\[ P_p = I_p^*E_p \]  \hspace{1cm} (7.13)

\[ P_s = I_s^*E_s \]  \hspace{1cm} (7.14)

\[ P_p = P_s \]  \hspace{1cm} (7.15)

where

\[ P_p = \text{power input to the transformer in watts (W)} \]
\[ E_p = \text{electromotive force input to the transformer in volts (V)} \]
\[ I_p = \text{current input to the transformer in amperes (A)} \]
\[ P_s = \text{power output from the transformer in watts (W)} \]
\[ E_s = \text{electromotive force output from the transformer in volts (V)} \]
\[ I_s = \text{current output from the transformer in amperes (A)} \]
Assuming a lossless transformer,

$$E_S = \frac{N_S}{N_P} E_P$$  \hspace{1cm} (7.16)

where

- $E_P$ = electromotive force at the primary input of the transformer in volts (V)
- $E_S$ = electromotive force at the secondary output of the transformer in volts (V)
- $N_P$ = number of turns in the primary winding of the transformer
- $N_S$ = number of turns in the secondary winding of the transformer

Because the input power equals the output power, the current ($I$) and the electromotive force ($E$) have an inverse relationship. As $E$ goes up, $I$ goes down, in a direct proportionality.

Thus

$$I_S = \frac{N_P}{N_S} I_P$$  \hspace{1cm} (7.17)

where

- $I_P$ = current in the primary winding of the transformer in amperes (A)
- $I_S$ = current in the secondary winding of the transformer in amperes (A)
- $N_P$ = number of turns in the primary winding of the transformer
- $N_S$ = number of turns in the secondary winding of the transformer

In the case of a DC distribution system, as shown in Figure 7.50, the transmission line has losses.

In the case of DC power, all of the load current flows through the transmission line resistance and generates thermal losses:

$$P_{\text{DCLoss}} = I_{\text{DCLoad}}^2 R_{\text{TL}}$$  \hspace{1cm} (7.18)
If the AC power transmission system were configured in the same manner as a DC power transmission system, then the systems would be equivalent. See Figure 7.51.

However, when transformers are employed, the physics changes significantly. See Figure 7.52.

In the case of transformed AC power, for example, raising the AC electromotive force (EMF) of the transmission line by transforming the EMF by a factor of 100 causes the current in the transmission line to be lowered by a factor of 100:

\[
\frac{E_S}{E_P} = \frac{N_S}{N_P} = 100
\]  

(7.19)

Then

\[
I_{ACTL} = \frac{1}{100} \ast I_{ACLoad}
\]  

(7.20)

and

\[
P_{ACLoss} = \left( \frac{I_{ACLoad}}{100} \right)^2 \ast R_{TL}
\]  

(7.21)
where

\[ P_{DS} = \text{dissipated power in watts (W)} \]
\[ E_p = \text{electromotive force at the primary input of the transformer in volts (V)} \]
\[ E_s = \text{electromotive force at the secondary output of the transformer in volts (V)} \]
\[ N_p = \text{number of turns in the primary winding of the transformer} \]
\[ N_s = \text{number of turns in the secondary winding of the transformer} \]
\[ I_{AC\_TL} = \text{transmission line current} \]
\[ I_{AC\_Load} = \text{AC load current} \]
\[ P_{AC\_Loss} = \text{transmission line current} \]
\[ R_{TL} = \text{transmission line resistance} \]

Assuming that the load currents are equivalent

\[ I_{DC\_Load} = I_{AC\_Load} \quad (7.22) \]

then the relative transmission line power loss for AC compared to DC is

\[ \frac{P_{AC\_Loss}}{P_{DC\_Loss}} = \left( \frac{1}{100} \right)^2 = 1 \times 10^{-4} \quad (7.23) \]

Thus transformed AC became the obvious choice for power line transmission, based both on versatility and on reduced power losses.

**2D AC Generators: Static and Transient**

In the following subsections of Chapter 7, models are developed that provide an analysis of the rotating machines (AC generators) that convert mechanical energy into electrical energy (AC power). The generation of AC power is accomplished through the application of Faraday’s law of induction. In the following models, a magnetic vector potential (\(A\)) is employed that has only a \(z\) component.

Rotation is modeled using the deformed Mesh Application Mode (ALE). The rotor and the stator are drawn separately and then combined as an assembly.\(^{27}\)

The materials employed in this model are high-energy samarium–cobalt magnets with nonlinear soft iron pole pieces.

A pole piece is the magnetically soft (easily altered) material that is inserted in the magnet circuit to guide the path of the magnetic flux to a desired location.

**2D AC Generator Model (2D_ACG_1): Static**

The numerical solution model developed in this section (2D_ACG_1) is derived from a model that was originally developed by COMSOL as an AC/DC Module Motors and Drives Library Model. Here, the 2D generator model (2D_ACG_1) will be built as a
static (stationary) model. In the next subsection, the static model will be used as the starting point for the transient (rotating) model (2D_ACG_2).

To start building the 2D_ACG_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” (the default setting) from the Space dimension pull-down list. Select AC/DC Module > Rotating Machinery > Rotating Perpendicular Currents. See Figure 7.53. Click OK.

The Model Navigator shows two names in the Application Mode name edit window: emqa and ale.

### Constants

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 7.9; see also Figure 7.54. Click OK.

When the modeler enters the constant $t$, the text will become red in color to indicate that the modeler has entered a reserved variable name ($t =$ time, in COMSOL Multiphysics software). However, because the first model is stationary, $t$ needs to be assigned a value (in this case, 0). Once the transient model is built, the transient solver will override the assigned value during the solving process.
Select File > Save As. Enter 2D_ACG_1 in the Save As edit window. See Figure 7.55. Click the Save button.

Generator Geometry

The 2D_ACG_1 geometry is very complex. Be sure to follow the steps carefully and in sequence. After completion of all of the geometry and assembly steps, there should be a total of 152 boundaries.

Using the menu bar, select Draw > Specify Objects > Circle and create the circles indicated in Table 7.10.

Select File > Save. See Figure 7.56.

Table 7.9 Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>t</td>
<td>0[s]</td>
<td>Time equals zero (stationary solution)</td>
</tr>
<tr>
<td>rpm</td>
<td>60[1/min]</td>
<td>Revolutions per minute</td>
</tr>
<tr>
<td>A</td>
<td>π*(0.02[m])^2</td>
<td>Area, stator wire</td>
</tr>
<tr>
<td>L</td>
<td>0.4[m]</td>
<td>Length, generator</td>
</tr>
<tr>
<td>NN</td>
<td>1</td>
<td>Stator winding turns</td>
</tr>
</tbody>
</table>

Table 7.10 Stator Geometry Circles Creation

<table>
<thead>
<tr>
<th>Name</th>
<th>Radius</th>
<th>Base</th>
<th>X</th>
<th>Y</th>
<th>Rotation Angle</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.3</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>C2</td>
<td>0.235</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>C3</td>
<td>0.225</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>C4</td>
<td>0.4</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
**FIGURE 7.55** 2D_ACG_1 model Save As edit window

**FIGURE 7.56** 2D_ACG_1 model created circles
Using the menu bar, select Draw > Specify Objects > Rectangle and create the rectangles indicated in Table 7.11.

Select File > Save. See Figure 7.57.

Select Draw > Create Composite Object. Uncheck the Keep interior boundaries check box. Enter $C2+C1*(R1+R2+R3+R4)$ in the Set formula edit window. See Figure 7.58.

**NOTE** The commands $+, *,$ and $-$ equal union, intersection, and difference, respectively. Enter the formulas *exactly* as indicated, or the resulting geometry will be incorrect.

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>X</th>
<th>Y</th>
<th>Rotation Angle</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.1</td>
<td>1.0</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>R2</td>
<td>0.1</td>
<td>1.0</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>45</td>
</tr>
<tr>
<td>R3</td>
<td>0.1</td>
<td>1.0</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>90</td>
</tr>
<tr>
<td>R4</td>
<td>0.1</td>
<td>1.0</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>135</td>
</tr>
</tbody>
</table>

**FIGURE 7.57** 2D_ACG_1 model created circles and rectangles
Click OK. See Figure 7.59.
Select Draw > Create Composite Object. Check the Keep interior boundaries check box. Enter C4+CO1–C3 in the Set formula edit window. See Figure 7.60.
Click OK. See Figure 7.61.

![Image of Create Composite Object dialog box]

**FIGURE 7.58** 2D_ACG_1 model Create Composite Object edit window

![Image of 2D_ACG_1 model CO1]

**FIGURE 7.59** 2D_ACG_1 model CO1
FIGURE 7.60  2D_ACG_1 model Create Composite Object edit window

FIGURE 7.61  2D_ACG_1 model CO2
Click the Zoom Extents button. Using the menu bar, select Draw > Specify Objects > Circle and create the two new circles indicated in Table 7.12.

Click the Save button. See Figure 7.62.

Select C1 and C2. Using the menu bar, select Edit > Copy. Using the menu bar, select Edit > Paste. Verify that the displacements are X:0 and Y:0. See Figure 7.63. Click OK.

Using the menu bar, select Draw > Modify > Rotate. Enter 45 in the Rotation angle edit window. See Figure 7.64. Click OK.

Select C1 and C2. Using the menu bar, select Edit > Copy. Using the menu bar, select Edit > Paste. Verify that the displacements are X:0 and Y:0. Click OK.

<table>
<thead>
<tr>
<th>Table 7.12  Geometry Circles Creation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>C1</td>
</tr>
<tr>
<td>C2</td>
</tr>
</tbody>
</table>
Using the menu bar, select Draw > Modify > Rotate, for the indicated angles for each circle pair shown in Table 7.13. See Figure 7.65.

Select Edit > Select All. Select Draw > Create Composite Object. Click the Union button and then click OK. See Figure 7.66.

The stationary portion (stator) of the generator has now been created. The rotating portion (rotor) will be created next.

Using the menu bar, select Draw > Specify Objects > Circle and create the circles indicated in Table 7.14.

Click the Save button. See Figure 7.67.

Table 7.13  Geometry Circles: Copy, Rotate, and Paste

<table>
<thead>
<tr>
<th>Name</th>
<th>Rotation Angle</th>
</tr>
</thead>
<tbody>
<tr>
<td>C5, C6</td>
<td>90</td>
</tr>
<tr>
<td>C7, C8</td>
<td>135</td>
</tr>
<tr>
<td>C9, 10</td>
<td>180</td>
</tr>
<tr>
<td>C11, C12</td>
<td>−45</td>
</tr>
<tr>
<td>C9, 10</td>
<td>−90</td>
</tr>
<tr>
<td>C11, C12</td>
<td>−135</td>
</tr>
</tbody>
</table>
**FIGURE 7.65** 2D_ACG_1 model rotated, pasted circles

**FIGURE 7.66** 2D_ACG_1 model union of all objects, C01
Using the menu bar, select Draw > Specify Objects > Rectangle and create the rectangles indicated in Table 7.15.

Click the Save button. See Figure 7.68.

| Table 7.14  Rotor Geometry Circles Creation |

<table>
<thead>
<tr>
<th>Name</th>
<th>Radius</th>
<th>Base</th>
<th>X</th>
<th>Y</th>
<th>Rotation Angle</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>0.215</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>C2</td>
<td>0.15</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>C3</td>
<td>0.15</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>C4</td>
<td>0.225</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
Table 7.15  Rotor Geometry Rectangles Creation

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>X</th>
<th>Y</th>
<th>Rotation Angle</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.1</td>
<td>1.0</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>22.5</td>
</tr>
<tr>
<td>R2</td>
<td>0.1</td>
<td>1.0</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>−22.5</td>
</tr>
<tr>
<td>R3</td>
<td>0.1</td>
<td>1.0</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>67.5</td>
</tr>
<tr>
<td>R4</td>
<td>0.1</td>
<td>1.0</td>
<td>Center</td>
<td>0</td>
<td>0</td>
<td>−67.5</td>
</tr>
</tbody>
</table>

Select Draw > Create Composite Object. Uncheck the Keep interior boundaries check box. Enter C2+C1*(R1+R2+R3+R4) in the Set formula edit window. See Figure 7.69. Click OK.

NOTE The commands +, *, and – equal union, intersection, and difference, respectively. Enter the formulas exactly as indicated, or the resulting geometry will be incorrect.
Select Draw > Create Composite Object. Check the Keep interior boundaries check box. Enter CO2+C3+C4 in the Set formula edit window. See Figure 7.70. Click OK. See Figure 7.71.

The names Stator and Rotor can be assigned to the appropriate created composite objects by clicking on the composite object (selecting) and selecting Draw > Object Properties. You can then enter the chosen name (Stator, Rotor) in the Name edit window.

Select File > Export > Geometry Objects to File. Enter 2D_ACG_1_Geometry in the Save As edit window. Select “COMSOL Multiphysics binary file (*.mphbin)” from the File Format pull-down list. Click the Save button. See Figure 7.72.
**FIGURE 7.71** 2D_ACG_1 model composite objects

**FIGURE 7.72** 2D_ACG_1 model stator and rotor composite objects
Assemble the Generator Geometry (Stator and Rotor)

Using the menu bar, select Draw > Create Pairs. Select both objects (Rotor and Stator). Select “Identity pair” from the pair type pull-down list. See Figure 7.73. Click OK. See Figure 7.74.
The pairing of the rotor and stator couples the boundaries of the two separately created geometric elements. This pairing facilitates the use of the sliding mesh at the boundary between the rotor and the stator, which would otherwise be discontinuous.

**Physics Settings: Subdomain Integration Variables**

Using the menu bar, select Options > Integration Coupling Variables > Subdomain Variables. In the Subdomain Integration Variables edit window, enter the information shown in Table 7.16; also see Figure 7.75. Click OK.

The integration variable expressions for Vi are summed to yield the voltage induced into the windings of the generator.

Select Options > Materials/Coefficients Library. Verify that the Electric (AC/DC) Materials Properties Library is loaded. If not, you will need to load that library to complete this model. See Figure 7.76. Click OK.

**Physics Subdomain Settings: Perpendicular Induction Currents, Vector Potential (emqa)**

Having established the geometry for the 2D_ACG_1 model, the next step is to define the fundamental Physics conditions. Using the menu bar, select Multiphysics >
Perpendicular Induction Currents, Vector Potential (emqa). Using the menu bar, select Physics > Properties. In the Application Mode Properties dialog box, choose “On” from the Weak constraints pull-down list. See Figure 7.77. Click OK.

Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window. Click the Load button.

**FIGURE 7.76** Materials/Coefficients Library window

**FIGURE 7.77** 2D_ACG_1 model Application Mode Properties dialog box
Select Electric (AC/DC) Materials Properties Library > Soft Iron (without losses). Click the Apply button.

Select Electric (AC/DC) Materials Properties Library > Samarium Cobalt (Radial, inward). Click the Apply button.

Select Electric (AC/DC) Materials Properties Library > Samarium Cobalt (Radial, outward). Click the Apply button. See Figure 7.78. Click the Cancel button.

The last three commands added the three selected materials to the Model (0) Library for use in this model.

In the Subdomain edit windows, enter the information shown in Table 7.17. Click OK. See Figures 7.79–7.82.

**Physics Subdomain Settings: Moving Mesh (ALE) (ale)**

Using the menu bar, select Physics > Multiphysics > Moving Mesh (ALE) (ale). Using the menu bar, select Physics > Subdomain Settings. In the Subdomain edit windows, enter the information shown in Table 7.18. Click OK. See Figure 7.83.
**Physics Boundary Settings**

Leave the Boundary Settings at the default conditions. The identity pair couples the stator and the rotor.

---

**Table 7.17 Subdomain Edit Window**

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>$H \leftrightarrow B$ Setting</th>
<th>Material</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 3–19</td>
<td>$B = \mu_0 \mu_r H$</td>
<td>—</td>
<td>7.79</td>
</tr>
<tr>
<td>2, 28</td>
<td>$H = f(</td>
<td>B</td>
<td>) e_B$</td>
</tr>
<tr>
<td>20, 23, 24, 27</td>
<td>$B = \mu_0 \mu_r H + B_i$</td>
<td>Samarium cobalt (radial, inward)</td>
<td>7.81</td>
</tr>
<tr>
<td>21, 22, 25, 26</td>
<td>$B = \mu_0 \mu_r H + B_i$</td>
<td>Samarium cobalt (radial, outward)</td>
<td>7.82</td>
</tr>
</tbody>
</table>

**Table 7.18 Subdomain Settings – Moving Mesh Edit Window**

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Group</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>19–28</td>
<td>rotate_CCW</td>
<td>7.83</td>
</tr>
</tbody>
</table>

---

**Physics Boundary Settings**

Leave the Boundary Settings at the default conditions. The identity pair couples the stator and the rotor.
**FIGURE 7.80** 2D_ACG_1 model Subdomain Settings (2, 28) edit window

**FIGURE 7.81** 2D_ACG_1 model Subdomain Settings (20, 23, 24, 27) edit window
Mesh Generation

From the toolbar, select Mesh > Free Mesh Parameters > Global. Select Predefined mesh sizes > Finer (from the pull-down list). Select “Custom mesh size.” Enter 2 in the Resolution of narrow regions edit window. See Figure 7.84.

Click the Remesh button, and then click OK. See Figure 7.85.
FIGURE 7.84 2D_ACG_1 model Free Mesh Parameters edit window

FIGURE 7.85 2D_ACG_1 model mesh
Solving the Static 2D_ACG_1 Model

Using the menu bar, select Solve > Solver Parameters.

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Select “Static” from the Analysis pull-down list. See Figure 7.86. Click OK.

Using the menu bar, select Solve > Solve Problem. See Figure 7.87.

Click the Save button. Select File > Save As. Enter 2D_ACG_2.mph in the Save As edit window. See Figure 7.88. Click OK.

The 2D_ACG_1 model (static) solution was built to gain experience in the creation of a complex geometrical model. It was saved as 2D_ACG_2.mph and will act as the initial estimate for the 2D_ACG_2 model (transient) solution.
**FIGURE 7.87** 2D_ACG_1 model solution

**FIGURE 7.88** 2D_ACG_2 model initial solution
The following numerical solution model (2D_ACG_2) follows directly from the earlier model 2D_ACG_1 model, which was built in the preceding subsection. In this next subsection, the transient 2D generator model (2D_ACG_2) uses the static 2D_ACG_1 model as the initial solution to the transient problem. The transient version avoids all the complex geometrical building by starting with the earlier saved solution.

To start building the 2D_ACG_2 model (transient) solution, activate the COMSOL Multiphysics software. In the Model Navigator, select “Open.” Select “2D_ACG_2.mph.” See Figure 7.89.

Click OK. See Figure 7.90.

Because the initial solution to the transient 2D_ACG_2 model has already been built and verified, the modeler can proceed directly to implementing the necessary transient solver setup parameters.

Solving the Transient 2D_ACG_2 Model

Using the menu bar, select Solve > Solver Parameters. Select “Transient” from the Analysis pull-down list.
The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

In the Times edit window, enter linspace(0,0.25,26). For later versions of COMSOL Multiphysics software enter range(0,0.25/25,0.25). In the Absolute tolerance edit window, enter Az 1e-3 lm1 5e3. Click the Apply button. See Figure 7.91. Click OK.

It is important to enter the Solver Parameters exactly as specified; otherwise, the modeler will see error messages.

Using the menu bar, select Solve > Restart. See Figure 7.92.
FIGURE 7.91  2D_ACG_2 model Solver Parameters edit window

FIGURE 7.92  2D_ACG_2 model solution (transient)
Postprocessing and Visualization

The default plot shows a surface plot of the normal magnetic flux density in teslas for the solution at 0.25 second. To visualize the field distribution, the plot parameters will need to be modified.

Select Postprocessing > Plot Parameters > General. Check the Surface and Contour check boxes under Plot type. Uncheck the Geometry edges check box. Select “Solution at time 0.2 seconds” from the Solutions to use pull-down list. See Figure 7.93.

FIGURE 7.93 2D_ACG_2 model Plot Parameters, General tab
Click the Surface tab. Select “Magnetic flux density, norm.” See Figure 7.94.

Click the Contour tab. Enter $Az$ in the Expression edit window. Enter 15 in the Levels edit window. Click the Uniform color radio button. Click the Color button, and select black. See Figure 7.95.
Click OK. See Figure 7.96.

To view the induced voltage as a function of time, select Postprocessing > Domain Plot Parameters > Point. Select point 10. Enter Vi*NN in the expression edit window. See Figure 7.97.

Click OK. See Figure 7.98.
FIGURE 7.96 2D_ACG_2 model magnetic flux density and magnetic potential

FIGURE 7.97 2D_ACG_2 model Domain Plot Parameters edit window
Postprocessing Animation

Select Postprocessing > Plot Parameters > Animate. Select or verify that all of the solutions in the Solutions to use window are selected. See Figure 7.99.

Click the Start Animation button. See Figure 7.100.

Alternatively, you can play the file Movie7_ACG_2.avi that was supplied with this book.

2D AC Generators, Static and Transient Models: Summary and Conclusions

In this section, we built two 2D AC generator models: static and transient. These models generate low-frequency (60 Hz) current and voltage, as would be typically found on the power transmission grid. They demonstrate the use of both hard (not easily magnetized) and soft (easily magnetized) nonlinear magnetic materials in the construction of a rotating machine for the conversion of mechanical energy to electrical energy.

The modeling and physics concepts employed in this section of Chapter 7 are mechanical to electrical energy conversion, hard and soft nonlinear magnetic materials, moving mesh (ALE), and geometric assembly (pair creation across a boundary).
In this section, static and transient sector-based models are developed that are only one-eighth the size of the full-size model. The sector models utilize the inherent basic symmetry employed in AC generators. Additionally, an ordinary differential equation is incorporated into the model to allow the exploration of the torques resulting from the magnet forces inherent in this AC generator design. In these machines, the generation of AC power is accomplished through the application of Faraday's law of induction. In the following models, a magnetic vector potential ($A$) is employed that has only the $z$ component.
Rotation is modeled using deformed Mesh Application Mode (ALE). The rotor and the stator are drawn separately and then combined as an assembly.

The materials employed in this model are high-energy samarium–cobalt magnets with nonlinear soft iron pole pieces.

**2D AC Generator Sector Model (2D_ACGS_1): Static**

The following numerical solution model (2D_ACGS_1) is derived from a model that was originally developed by COMSOL as an AC/DC Module Motors and Drives Library Model. First, this 2D generator model will be built as a static (stationary) model. In the next subsection, the static model will be used as the starting point for the transient (rotating) model (2D_ACGS_2).

To start building the 2D_ACGS_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” (the default setting) from the Space dimension pull-down list. Select AC/DC Module > Rotating Machinery > Rotating Perpendicular Currents. Enter Az X Y Z in the Dependent variables edit window. See Figure 7.101. Click OK.
Be sure to change the dependent variables from lowercase x, y, z to uppercase X, Y, Z. This demonstrates that the modeler can alter the Reference Frame in COMSOL Multiphysics Software, if needed. Also note that the Model Navigator shows two names in the Application mode name edit window: emqa and ale. Those names—emqa (Rotating Perpendicular Currents) and ale (Moving Mesh)—indicate the Application Modes employed in this modeling analysis.

Select File > Save As. Enter 2D_ACGS_1.mph in the Save As edit window. Click the Save button.

**Constants**

Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 7.19; also see Figure 7.102. Click OK.

**Generator Sector Geometry**

Select File > Import > CAD Data From File > 2D_ACG_1_Geometry.mphbin. See Figure 7.103.
Table 7.19 Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>π*(0.02[m])^2</td>
<td>Area of wires in stator</td>
</tr>
<tr>
<td>L</td>
<td>0.4[m]</td>
<td>Length of generator</td>
</tr>
<tr>
<td>NN</td>
<td>1</td>
<td>Number of turns in stator winding</td>
</tr>
<tr>
<td>M</td>
<td>1400[N*m]</td>
<td>Externally applied torque</td>
</tr>
<tr>
<td>Rc</td>
<td>1e-4[ohm]</td>
<td>Resistance of winding</td>
</tr>
<tr>
<td>I0</td>
<td>100[kg*m^2]</td>
<td>External moment of inertia</td>
</tr>
</tbody>
</table>

**FIGURE 7.102** 2D_ACGS_1 model Constants edit window

**FIGURE 7.103** Import CAD Data From File select window
Click the Import button. See Figure 7.104.

Now that the geometry for the entire 2D generator has been imported, the modeler needs to create the 2D generator sector. Carefully enter exactly the following construction, to create the 2D generator sector.

Using the menu bar, select Draw > Specify Objects > Line. Select “Closed polyline (solid)” from the Style pull-down list. Enter the following formula in the x edit window:

\[ 0 \ 0.4\cos(67.5\times\text{pi}/180) \ 0.4 \ 0.4\cos(22.5\times\text{pi}/180) \ 0 \]

Enter the following formula in the y edit window:

\[ 0 \ 0.4\sin(67.5\times\text{pi}/180) \ 0.4 \ 0.4\sin(22.5\times\text{pi}/180) \ 0 \]

See Figure 7.105.
Click OK. See Figure 7.106.

Select the newly created solid (CO3) only. Using the menu bar, select Edit > Copy. Using the menu bar, select Draw > Create Composite Object. Enter CO1*CO3 in the Set formula window. See Figure 7.107. Click OK.

Using the menu bar, select Edit > Paste. Click OK on the x = 0, y = 0 Displacements dialog box.

![Figure 7.105](image)

**FIGURE 7.105** Line, Closed polyline (solid) edit window

![Figure 7.106](image)

**FIGURE 7.106** 2D generator geometry and closed polyline (solid)
CHAPTER 7  2D COMPLEX MIXED-MODE MODELING

FIGURE 7.107  Create Composite Object, intersection (CO1, CO3)

Using the menu bar, select Draw > Create Composite Object. Enter CO2*CO1 in the Set formula window. See Figure 7.108.

Click OK, and then click the Zoom Extents button. See Figure 7.109.

Assemble the Geometry (Stator and Rotor)
Select both objects (CO3, CO4). Locate the Create Pairs button on the Draw toolbar. See Figure 7.110.

Click the Create Pairs button on the Draw toolbar. See Figure 7.111.

FIGURE 7.108  Create Composite Object, intersection (CO2, CO1)
FIGURE 7.109 Created one-eighth generator sector (CO3, CO4)

FIGURE 7.110 Create Pairs button on Draw toolbar

FIGURE 7.111 2D_ACGS_1 model paired stator (CO3) and rotor (CO4)
The pairing of the rotor and the stator couples the boundaries of the two separately created geometric elements. This pairing facilitates the use of the sliding mesh at the boundary between the rotor and the stator, which would otherwise be discontinuous.

Using the menu bar, select Physics > Identity Pairs > Identity Boundary Pairs. Select Pair 1. See Figure 7.112.

Click the Interchange source and destination button, which is located between the Source boundaries and Destination boundaries fields. See Figure 7.113. Click OK.

**Options: Global Expressions**

Using the menu bar, select Options > Expressions > Global Expressions. In the Global Expressions edit window, enter the information shown in Table 7.20; also see Figure 7.114. Click OK.

![Figure 7.112 Identity Boundary Pairs window](image)

![Figure 7.113 Interchange source and destination button](image)

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tz</td>
<td>8*L[1/m]*F_torquez_emqa</td>
<td>Total torque for the entire device</td>
</tr>
</tbody>
</table>
The insertion of \([1/m]\) in the expression for \(T_z\) converts \(L\) into a unitless number. Because of the use of coupling variables, COMSOL Multiphysics software cannot determine the units of other variables that depend either directly or indirectly on the coupling variables. This may cause inconsistent unit warnings to appear. Such warnings can be ignored.

Options: Subdomain Expressions

Using the menu bar, select Options > Expressions > Subdomain Expressions. In the Subdomain Expressions edit window, enter the information shown in Table 7.21. Click OK. See Figures 7.115 and 7.116.

Using the menu bar, select Options > Expressions > Subdomain Expressions. In the Subdomain Expressions edit window, enter the information shown in Table 7.22. Click OK. See Figures 7.117 and 7.118.

Options: Subdomain Integration Variables

Using the menu bar, select Options > Integration Coupling Variables > Subdomain Variables. In the Subdomain Integration Variables edit window, enter the information shown in Table 7.23. Click OK. See Figures 7.119 and 7.120.

| Table 7.21 | Subdomain Expressions Edit Window |
|---|---|---|---|
| Subdomain | Name | Expression | Figure Number |
| 1–4 | \(u\) | \(-y\cdot\alpha\) | 7.115 |
| 1–4 | \(v\) | \(x\cdot\alpha\) | 7.115 |
| 5–8 | \(u\) | 0 | 7.116 |
| 5–8 | \(v\) | 0 | 7.116 |
Table 7.22 Subdomain Expressions Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Name</th>
<th>Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>rho</td>
<td>7870[kg/m^3]</td>
<td>7.117</td>
</tr>
<tr>
<td>2, 4</td>
<td>rho</td>
<td>8400[kg/m^3]</td>
<td>7.118</td>
</tr>
</tbody>
</table>

Table 7.23 Subdomain Integration Variables Edit Window

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Name</th>
<th>Expression</th>
<th>Integration Order</th>
<th>Global</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 2, 4</td>
<td>I</td>
<td>8<em>L</em>rho*(x^2+y^2)</td>
<td>4</td>
<td>Yes</td>
<td>7.119</td>
</tr>
<tr>
<td>7, 8</td>
<td>V_{i}</td>
<td>8<em>L</em>NN*E_{z_{emqa}}/A</td>
<td>4</td>
<td>Yes</td>
<td>7.120</td>
</tr>
</tbody>
</table>
FIGURE 7.117 2D_ACGS_1 model Subdomain Expressions (1) edit window

FIGURE 7.118 2D_ACGS_1 model Subdomain Expressions (2, 4) edit window

FIGURE 7.119 2D_ACGS_1 model Subdomain Integration Variables (1, 2, 4) edit window
Because of the use of coupling variables, COMSOL Multiphysics software cannot determine the units of other variables that depend either directly or indirectly on the coupling variables. This may cause inconsistent unit warnings to appear. Such warnings can be ignored.

**Physics Subdomain Settings: Moving Mesh (ALE) (ale)**

Using the menu bar, select Multiphysics > Moving Mesh (ALE) (ale). Select Physics > Subdomain Settings. Select subdomains 1–4. Select “angle_CCW” from the Group pull-down list. See Figure 7.121. Click OK.

**NOTE** The selection of “angle_CCW” makes the variable omega available for use in the ODE, once defined later.

**Application Mode Properties: Perpendicular Induction Currents, Vector Potential (emqa)**

Using the menu bar, select Multiphysics > Perpendicular Induction Currents, Vector Potential (emqa). Select Physics > Properties. Select “Frame (ref)” from the Frame pull-down list. Select “On” from the Weak constraints pull-down list. See Figure 7.122. Click OK.

**Physics Subdomain Settings: Perpendicular Induction Currents, Vector Potential (emqa)**

Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 in the Subdomain selection window. Click the Load button.
Select Electric (AC/DC) Materials Properties Library > Soft Iron (without losses). Click the Apply button.

Select Electric (AC/DC) Materials Properties Library > Samarium Cobalt (Radial, inward). Click the Apply button.

Select Electric (AC/DC) Materials Properties Library > Samarium Cobalt (Radial, outward). Click the Apply button. See Figure 7.123. Click the Cancel button.

Select Electric (AC/DC) Materials Properties Library > Soft Iron (without losses). Click the Apply button.

Select Electric (AC/DC) Materials Properties Library > Samarium Cobalt (Radial, inward). Click the Apply button.

Select Electric (AC/DC) Materials Properties Library > Samarium Cobalt (Radial, outward). Click the Apply button. See Figure 7.123. Click the Cancel button.
In the Subdomain edit windows, enter the information shown in Table 7.24. Click the Apply button. See Figures 7.124–7.127.

Table 7.24  Subdomain Edit Windows

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>H ↔ B Setting</th>
<th>Material</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 6</td>
<td>$H = f(</td>
<td>B</td>
<td>)e_B$</td>
</tr>
<tr>
<td>2</td>
<td>$B = \mu_0\mu_r H + B_r$</td>
<td>Samarium cobalt (radial, outward)</td>
<td>7.125</td>
</tr>
<tr>
<td>4</td>
<td>$B = \mu_0\mu_r H + B_r$</td>
<td>Samarium cobalt (radial, inward)</td>
<td>7.126</td>
</tr>
<tr>
<td>3, 5, 7, 8</td>
<td>$B = \mu_0\mu_r H$</td>
<td>—</td>
<td>7.127</td>
</tr>
</tbody>
</table>
2D AC Generator: Sector—Static and Transient

**FIGURE 1.124** 2D_ACGS_1 model Subdomain Settings (1, 6) edit window

**FIGURE 7.125** 2D_ACGS_1 model Subdomain Settings (2) edit window
Select subdomains 7 and 8. Enter $NN*Vi/(Rc*A)$ in the External current density edit window. See Figure 7.128. Click the Apply button.

Click the Forces tab. Select subdomains 1, 2, and 4. Enter $F$ as the name of the variable. Click the Apply button. See Figure 7.129. Click OK.
Physics Boundary Settings: Perpendicular Induction Currents, Vector Potential (emqa)

Using the menu bar, Select Physics > Boundary Settings. Select boundaries 1–4, 7, 8, 15, 16, 19, and 20 in the Boundary selection window.
On the Conditions page, select “Periodic condition” from the Boundary condition pull-down list. Also select “Antiperiodicity” from the Type of periodicity pull-down list. See Figure 7.130.

Click the Weak Constr. tab. Select boundaries 1–4, 7, 8, 15, 16, 19–21, and 23 in the Boundary selection window. Uncheck the Use weak constraints check box. Click the Apply button. See Figure 7.131.
Click the Pairs tab. Select Pair 1. Select “Sector antisymmetry” from the Boundary condition pull-down list. Enter 8 in the Number of sectors edit window. See Figure 7.132. Click OK.

Physics Settings: Periodic Point Conditions
Using the menu bar, select Physics > Periodic Conditions > Periodic Point Conditions. Select point 4 in the Point selection window. On the Source page, enter lm1 (Lagrange Multiplier 1) in the first row of the Expression edit window. Press Return. See Figure 7.133.
When the modeler presses the Return key, pconstr1 appears in the Constraint name window.

Click the Source Vertices tab. Click the >> button to select point 4 as a source vertex. See Figure 7.134.

Click the Destination tab. Select point 11. Check the Use selected points as destination check box. Enter -lm1. See Figure 7.135.
Click the Destination Vertices tab. Click the >> button to select point 11 as a destination vertex. See Figure 7.136. Click OK.

Physics Settings: Global Equations

Using the menu bar, select Physics > Global Equations. In the Global Equations edit windows, enter the information shown in Table 7.25. Click OK. See Figure 7.137.

Table 7.25 Global Equations Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Equation f(u,ut,utt,t)</th>
<th>Init (u)</th>
<th>Init (ut)</th>
<th>Description</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>omega</td>
<td>omegatt-(M+Tz)/(I+I0)</td>
<td>0</td>
<td>0</td>
<td>Rotation angle</td>
<td>7.137</td>
</tr>
</tbody>
</table>

FIGURE 7.136 2D_ACGS_1 model Periodic Point Conditions, Destination Vertices (11) page

FIGURE 7.137 2D_ACGS_1 model Global Equations edit window
Mesh Generation

From the toolbar, select Mesh > Free Mesh Parameters > Global. Select Predefined mesh sizes > Finer (from the pull-down list). See Figure 7.138.

Click the Boundary tab. Select boundaries 2, 5–8, 10–12, 14, 19–21. Enter 0.005 in the Maximum element size window. See Figure 7.139.
Click the Mesh Selected button.
Select boundaries 1 and 2. Click the Copy Mesh button on the Mesh toolbar. See Figure 7.140.

The purpose of copying the mesh from one edge to the other edge is to ensure that the proper phase relationship is maintained across the mesh. Otherwise, there might be a mismatch between the edges, which would distort the mesh and possibly result in solution problems.

Select boundaries 3 and 7. Click the Copy Mesh button.
Select boundaries 4 and 8. Click the Copy Mesh button.
Select boundaries 15 and 19. Click the Copy Mesh button.
Select boundaries 16 and 20. Click the Copy Mesh button, and then click OK. See Figure 7.141.
Click the Mesh Remaining (Free) button on the Mesh toolbar. See Figure 7.142. Figure 7.143 shows the meshed model.

Solving the Static 2D_ACGS_1 Model

Using the menu bar, Select Solve > Solver Parameters.

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.
Select Stationary in the Solver selection window. See Figure 7.144. Click OK. Using the menu bar, select Solve > Solver Manager > Solve For. Unselect the variable omega under ODE(OD). See Figure 7.145. Click OK.

Select Solve > Solve Problem. Click the Save button.

Select File > Save As. Enter 2D_ACGS_2.mph in the Save As edit window. See Figure 7.146.

Click the Save button. See Figure 7.147.

The 2D_ACGS_1 model (static) solution was built to gain experience in the creation of a complex geometrical sector model. It was saved as 2D_ACGS_2.mph and will act as the initial estimate for the 2D_ACGS_2 model (transient) solution.

2D AC Generators, Static Sector Model: Summary and Conclusions

The static 2D AC generator sector models has now been built. This model allows the modeler to solve the AC generator model through the use of a simpler geometric representation. It avoids some of the potential problems that might be observed at run
FIGURE 7.145 2D_ACGS_1 model with omega unselected

FIGURE 7.146 2D_ACGS_2 model Save As edit window
time. This model generates low-frequency (60 Hz) current and voltage, as would be typically found on the power transmission grid. This model demonstrates the use of both hard (not easily magnetized) and soft (easily magnetized) nonlinear magnetic materials in the construction of a rotating machine for the conversion of mechanical energy to electrical energy.

2D AC Generator Sector Model (2D_ACGS_2): Transient

The numerical solution model presented in this subsection (2D_ACGS_2) follows directly from the earlier 2D_ACGS_1 model, which we just built. In this subsection, the transient 2D generator sector model (2D_ACGS_2) utilizes the static 2D_ACGS_1 model as the initial solution to the transient problem. The new version avoids all the complex geometrical building by starting with the earlier saved solution.

To start building the 2D_ACGS_2 model (transient) solution, activate the COMSOL Multiphysics software. In the Model Navigator, click the Open tab. Select “2D_ACGS_2.mph.” See Figure 7.148.

Click OK. See Figure 7.149.
\textbf{FIGURE 7.148} 2D_ACGS_2 Model Navigator, initial solution selection

\textbf{FIGURE 7.149} 2D_ACGS_2 Model Navigator, initial solution
Because the initial solution to the 2D_ACG_2 model (transient) has already been built and verified, the modeler can proceed directly to implementing the necessary transient solver setup parameters.

Solving the Transient 2D_ACGS_2 Model

Using the menu bar, select Solve > Solver Parameters. select “Transient” from the Analysis pull-down list.

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Select “Time dependent” in the Solver selection window. In the Times edit window, enter linspace(0,2.6,131). For later versions of COMSOL Multiphysics software enter range(0,2.6/130,2.6). In the Absolute tolerance edit window, enter Az 1e-3 lm1 5e3 omega 0.015. Click the Apply button. See Figure 7.150.

![Figure 7.150](FIGURE 7.150 2D_ACGS_2 model Solver Parameters edit window)
It is important to enter the solver parameters *exactly* as specified: otherwise, the modeler will see error messages.

Click OK. Using the menu bar, select Solve > Solver Manager > Solve For. See Figure 7.151.

Select all variables. Click OK.
Using the menu bar, select Solve > Restart. See Figure 7.152.
Postprocessing and Visualization

Select Postprocessing > Plot Parameters > General. Check the Surface and Contour check boxes under Plot type. Select “Solution at time 0.2 seconds” from the Solutions to use pull-down list. See Figure 7.153.
Click the Surface tab. Select “Magnetic flux density, norm.” See Figure 7.154.
Click the Contour tab. Enter Az in the Expression edit window. Enter 15 in the Levels edit window. Click the Uniform color radio button. Click the Color button, and select black. See Figure 7.155.
FIGURE 7.154  2D_ACGS_2 model Plot Parameters, Surface tab
Click OK. See Figure 7.156.

To view the rotation angle as a function of time, select Postprocessing > Global Variables Plot. Select “Rotation angle” from the Predefined quantities list. Click the > button. See Figure 7.157.
**FIGURE 7.156** 2D_ACGS_2 model magnetic flux density and magnetic potential, z component

**FIGURE 7.157** 2D_ACGS_2 model Global Variables Plot edit window
Click the Apply button. See Figure 7.158. Click OK.

**Postprocessing Animation**

Select Postprocessing > Plot Parameters > Animate. Select the solutions from 0.0 to 0.7 in the Solutions to use window. See Figure 7.159.

Click the Start Animation button. See Figure 7.160.

Alternatively, you can play the file Movie7_ACGS_2.avi that was supplied with this book.
FIGURE 7.159 2D_ACGS_2 model Plot Parameters, Animate tab
2D AC Generators, Static and Transient Models: Summary and Conclusions

The two 2D AC generator sector models—static and transient—have now been built. These models generate low-frequency (60 Hz) current and voltage, as would be typically found on the power transmission grid. These models demonstrate the use of both hard (not easily magnetized) and soft (easily magnetized) nonlinear magnetic materials in the construction of a rotating machine for the conversion of mechanical energy to electrical energy.

The modeling and physics concepts employed in this section of Chapter 7 include addition of an ordinary differential equation (ODE), mechanical to electrical energy conversion, hard and soft nonlinear magnetic materials, mesh mapping, moving mesh (ale), and geometric assembly (pair creation across a boundary).
References


### Exercises

1. Build, mesh, and solve the basic 2D electric impedance sensor model problem presented in this chapter.
2. Build, mesh, and solve the advanced 2D electric impedance sensor model problem presented in this chapter.
3. Build, mesh, and solve the static 2D AC generator model (2D_ACG_1) problem presented in this chapter.
4. Build, mesh, and solve the transient 2D AC generator model (2D_ACG_2) presented in this chapter.
5. Build, mesh, and solve the static 2D AC generator sector model (2D_ACGS_1) presented in this chapter.
6. Build, mesh, and solve the transient 2D AC generator sector model (2D_ACGS_2) presented in this chapter.
7. Explore other materials as applied in the 2D electric impedance sensor models.
8. Explore other materials as applied in the 2D AC generator models.
9. Explore adding more turns to the 2D AC generator models.
10. Explore how the 2D electric impedance sensor model might be used to discover voids in boats, airplanes, bridges, and other areas.
In This Chapter

3D Modeling Guidelines for New COMSOL® Multiphysics® Modelers
   3D Modeling Considerations
   3D Coordinate System
   Electrical Resistance Theory
Thin Layer Resistance Modeling Basics
   3D Thin Layer Resistance Model: Thin Layer Approximation
   3D Thin Layer Resistance Model, Thin Layer Approximation:
      Summary and Conclusions
   3D Thin Layer Resistance Model: Thin Layer Subdomain
   3D Thin Layer Resistance Models: Summary and Conclusions
Electrostatic Modeling Basics
   3D Electrostatic Potential Between Two Cylinders
   3D Electrostatic Potential Between Two Cylinders: Summary and Conclusions
   3D Electrostatic Potential Between Five Cylinders
   3D Electrostatic Potential Between Five Cylinders: Summary and Conclusions
Magnetostatic Modeling Basics
   3D Magnetic Field of a Helmholtz Coil
   3D Magnetic Field of a Helmholtz Coil: Summary and Conclusions
   3D Magnetic Field of a Helmholtz Coil with a Magnetic Test Object
   3D Magnetic Field of a Helmholtz Coil with a Magnetic Test Object:
      Summary and Conclusions

3D Modeling Guidelines for New COMSOL® Multiphysics® Modelers

3D Modeling Considerations

In this chapter on 3D modeling, all the basic material on 2D modeling presented in the earlier chapters will be assumed, utilized, and expanded. In the earlier chapters, models were built and solved using static, quasi-static, and transient methods. In this chapter,
the methods employed will be either static or quasi-static. The level of model solution complexity (difficulty) is increased through the development of models that explore applied physics at a more realistic and difficult level. In the three 3D models developed in this chapter, three modeling concept areas are explored: large dimensional differences, electrostatic field mapping, and magnetostatic field mapping. Each of these areas has broad industrial and scientific modeling applicability and potential levels of complexity.

The 3D models in this chapter implicitly assume, in compliance with the laws of physics, that the energy flow, the materials properties, the environment, and any other conditions and variables of interest are homogeneous, isotropic, or constant, unless otherwise specified (e.g., time dependent), throughout the entire domain of interest, both within the model and, through the boundary conditions, in the environs of the model.

Three models and variations are presented here: the 3D thin layer resistance models, the 3D electrostatic potential between cylinders models, and the 3D magnetic field of a helmholtz coil models. The first two models are developed using application modes from the basic COMSOL® Multiphysics® software. The Helmholtz coil model requires the AC/DC Module. Each of these three models introduces the modeler to different modeling aspects in the employment of the basic COMSOL Multiphysics software and the AC/DC Module to explore a range of diverse design, test, and engineering problems.

The 3D thin layer resistance models explore the modeling of a technology that is widely employed in both research and applied development for science and industry. Both thin\(^1,2\) and thick\(^3\) layers (coatings) are widely applied. Layers, such as those modeled here or other layers that may inadvertently or unknowingly form, can significantly modify the overall performance (behavior) of a device structure.

\[ \text{NOTE} \] When building a model, the modeler should perform at least a first estimate review of the conditions to which the modeled structure will be exposed under the normal (extreme) conditions of use. In that review, a variety of questions should be asked, including these possibilities: Will corrosion films form? Will any of the structure melt? Will any of the films exhibit a structural transition? Will any of the films exhibit an electronic/magnetic properties shift?

**3D Coordinate System**

In a steady-state solution to a 3D model, parameters can vary only as a function of position in space \((x)\), space \((y)\), and space \((z)\) coordinates. Such a 3D model represents the parametric condition of the model in a time-independent mode (quasi-static).
In a transient solution model, parameters can vary both by position in space \((x)\), space \((y)\), space \((z)\) and in time \((t)\). See Figure 8.1.

The transient solution model is essentially a sequential collection of (quasi-static) solutions, except that one or more of the dependent variables \(f(x, y, z, t)\) has changed with time. The space coordinates \((x), (y), \text{and} (z)\) typically represent a distance coordinate throughout which the model is to calculate the change of the specified observables (i.e., temperature, heat flow, pressure, voltage, current) over the range of values \((x_{\min} \leq x \leq x_{\max})\), \((y_{\min} \leq y \leq y_{\max})\), and \((z_{\min} \leq z \leq z_{\max})\). The time coordinate \((t)\) represents the range of values \((t_{\min} \leq t \leq t_{\max})\) from the beginning of the observation period \((t_{\min})\) to the end of the observation period \((t_{\max})\).

**Electrical Resistance Theory**

A well-known example of the application of thin layer technology is the touch screen, which is widely used in computers, personal digital assistants (PDAs), electronic lock pads, and other devices. The fundamental concept of the touch screen is relatively simple. The underlying touch screen principle starts with Ohm’s law.

Ohm’s law was discovered by Georg Ohm and published in 1827:

\[
I = \frac{V}{R}
\]  

(8.1)

where

- \(I\) = current in amperes (A)
- \(V\) = voltage (electromotive force) in volts (V)
- \(R\) = resistance in ohms
This technology utilizes the concept of an electrical resistance divider (voltage divider) to locate the point of contact (touch). When implemented in four-wire touch screen technology, this technology employs two thin layer orthogonal voltage dividers. In the touch screen technology, the thin layer resistive sheets are coated onto an insulating glass or plastic substrate. The substrates are mounted with the thin resistive layers facing each other and separated by an array of thin insulating dots, insulating bars, or a similar porous insulating spacer array. See Figure 8.2.

When pressure (touch) is applied to the screen, a point of contact forms at that location. See Figure 8.3.

The voltage $V_{XT}$ is measured as shown in Figure 8.3 (measurement circuitry not shown). $V_{YT}$ is similarly measured sequentially. The $X$ location of the contact point is
determined as follows:

\[ V_{XT} = I_x \cdot R_{X1}, \quad V_{TOTAL} = I_x \cdot (R_{X1} + R_{X2}) \]  

(8.2)

where

- \( I_x \) = current in amperes (A)
- \( V_{XT} \) = voltage drop (electromotive force) in volts (V)
- \( V_{TOTAL} \) = total voltage (electromotive force) along \( X \) in volts (V)
- \( R_{X1} \) = divider resistance 1 in ohms
- \( R_{X2} \) = divider resistance 2 in ohms

since

\[ R = \frac{\rho L}{A} \]  

(8.3)

where

- \( R \) = resistance in ohms
- \( \rho \) = resistivity in ohm∗m
- \( L \) = length of the resistive material (m)
- \( A \) = cross-sectional area in meters squared (m²)

Thus the length (distance) to the contact point is

\[ \frac{V_{XT}}{V_{TOTAL}} \cdot (L) = \frac{R_{X1}}{R_{X1} + R_{X2}} \cdot (L) = \frac{L_{X1}}{L_{X1} + L_{X2}} \cdot (L) \]  

(8.4)

where

- \( V_{XT} \) = voltage drop (electromotive force) in volts (V)
- \( V_{TOTAL} \) = total voltage (electromotive force) along \( X \) in volts (V)
- \( R_{X1} \) = divider resistance 1 in ohms
- \( R_{X2} \) = divider resistance 2 in ohms
- \( L_{X1} \) = resistor length 1 in meters (m)
- \( L_{X2} \) = resistor length 2 in meters (m)
- \( L = L_{X1} + L_{X2} \) in meters (m)

**Thin Layer Resistance Modeling Basics**

The first example presented here, the 3D thin layer resistance model, thin layer approximation (3D_TLR_1 model), explores the use of the thin layer approximation in the solution of a direct current conduction model. In the problem explored in both this model and the model to follow, the current balance throughout the domains is described as follows:

\[ V \cdot (-\sigma \nabla V) = 0 \]  

(8.5)
where \( V \) = electric potential (electromotive force) in volts (V) 
\( \Delta \) = gradient 
\( \sigma \) = electrical conductivity in siemens per meter (S/m)

In the thin layer approximation model, it is assumed that the \( x \) and \( y \) components of the current density vector are sufficiently small in the thin layer that only the \( z \) component makes a contribution. Thus

\[
-\sigma \frac{dV}{dz^2} = 0 \tag{8.6}
\]

where \( V \) = electric potential (electromotive force) in volts (V) 
\( \sigma \) = electrical conductivity in siemens per meter (S/m)

By substitution, it can be seen that

\[
V = \alpha z + \beta \tag{8.7}
\]

where \( \alpha \) = constant (V/m) 
\( \beta \) = constant (V)

Equation 8.7 is one possible solution for Equation 8.6.

---

Considering the following:

\[
\frac{dV}{dz} = \alpha \cdot \frac{d^2V}{dz^2} = 0 \tag{8.8}
\]

Assuming that

\[
V_{\text{lower}} = V_1, V_{\text{upper}} = V_2 \tag{8.9}
\]

then for \( z = 0 \):

\[
\beta = V_1 \tag{8.10}
\]

For \( z = \delta \):

\[
\alpha = \frac{V_2 - V_1}{\delta} \tag{8.11}
\]

where \( \delta \) = thickness of the thin layer in meters (m).

Because

\[
J_z = -\sigma \frac{dV}{dz} = -\sigma \alpha = -\sigma \left( \frac{V_2 - V_1}{\delta} \right) \tag{8.12}
\]

and there are no sources or sinks, \( J_z \) is the current flow through the system.
The use of the thin layer approximation is applicable to any problem in which flow is described by the divergence of a gradient flux (i.e., diffusion, heat conduction, flow through porous media under Darcy’s law).

The application of the thin layer approximation is especially valuable to the modeler when the differences in domain thickness are so great that the mesh generator is unable to properly mesh the model or creates more elements than the modeling platform can handle (the “run out of memory” problem). In those cases, this approximation may enable a model to be solved that would otherwise fail.

3D Thin Layer Resistance Model: Thin Layer Approximation

The following numerical solution model (3D_TLR_1 model) is derived from a model that was originally developed by COMSOL as a Multiphysics Electromagnetics demonstration model. That model was developed for distribution with the Multiphysics software as a COMSOL Multiphysics Model Library.

To start building the 3D_TLR_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “3D” from the Space dimension pull-down list. Select COMSOL Multiphysics > Electromagnetics > Conductive Media DC. See Figure 8.4. Click OK.
Geometry Modeling

Using the menu bar, select Draw > Block. In the Block edit window, enter the information shown in Table 8.1. Click OK after filling in the parameters of each separate block in the Block edit window. See Figures 8.5 and 8.6.

<table>
<thead>
<tr>
<th>Name</th>
<th>Style</th>
<th>Base</th>
<th>Length (X, Y, Z)</th>
<th>Axis Base Point (X, Y, Z)</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLK1</td>
<td>Solid</td>
<td>Corner</td>
<td>(1, 1, 0.1)</td>
<td>(0, 0, 0)</td>
<td>8.5</td>
</tr>
<tr>
<td>BLK2</td>
<td>Solid</td>
<td>Corner</td>
<td>(1, 1, 0.1)</td>
<td>(0, 0, 0.1)</td>
<td>8.6</td>
</tr>
</tbody>
</table>

**FIGURE 8.5** 3D_TLR_1 model BLK1 edit window

**FIGURE 8.6** 3D_TLR_1 model BLK2 edit window
Click the Zoom Extents button. See Figure 8.7.
Select File > Save As. Enter 3D_TLR_1 in the Save As edit window. See Figure 8.8.
Click the Save button.
Using the menu bar, select Draw > Work-Plane Settings. See Figure 8.9.
The use of the Work-Plane Settings is intended to make specific 2D planes available to the modeler to facilitate the creation of essentially 2D objects in the 3D geometry.

Click OK, using the default settings. Click the Zoom Extents button. See Figure 8.10.
Using the menu bar, select Draw > Specify Objects > Circle. Enter a radius of 0.6, set the Base as Center, and set x equal to 0 and y equal to 1. See Figure 8.11. Click OK.

Using the menu bar, select Draw > Specify Objects > Square. Enter a width of 1, set the Base as Corner, and set x equal to 0 and y equal to 0. See Figure 8.12. Click OK.

Using the menu bar, select Draw > Create Composite Object.

Enter C1*SQ1 in the Set formula edit window. See Figure 8.13.

Using the menu bar, select Draw > Specify Objects > Circle. Enter a radius of 0.6, set the Base as Center, and set x equal to 0 and y equal to 1. See Figure 8.11. Click OK.

Using the menu bar, select Draw > Specify Objects > Square. Enter a width of 1, set the Base as Corner, and set x equal to 0 and y equal to 0. See Figure 8.12. Click OK.

Using the menu bar, select Draw > Create Composite Object.

Enter C1*SQ1 in the Set formula edit window. See Figure 8.13.
The formula $X \ast Y$ creates the intersection of $X$ and $Y$.

Click OK. See Figure 8.14.

Using the menu bar, select Draw > Embed. See Figure 8.15. Click OK.
As is obvious, the quarter-circle electrode needs to be moved to the upper surface of the upper block. Using the menu bar, select Draw > Modify > Move. Enter $x = 0$, $y = 0$, and $z = 0.2$. See Figure 8.16.

Click OK. See Figure 8.17.

Select EMB1 and BLK2 (click on EMB1 and then Shift-click on BLK2). See Figure 8.18. Using the menu bar, select Draw > Coerce To > Solid.

Using the menu bar, select Draw > Create Pairs. Select BLK1 and CO1. See Figure 8.19.

Click OK. See Figure 8.20.

**Physics Subdomain Settings: Conductive Media DC (dc)**

Having established the geometry for the 3D_TLR_1 model of two blocks, an electrode, and an identity paired interface, the next step is to define the fundamental
Physics conditions. Using the menu bar, select Physics > Subdomain Settings. Select subdomains 1 and 2 in the Subdomain selection window (the only available subdomains). In the Subdomain edit windows, enter the information shown in Table 8.2; also see Figure 8.21. Click OK.
### Table 8.2  Subdomain Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$</td>
<td>1</td>
<td>Electrical conductivity</td>
</tr>
</tbody>
</table>

**FIGURE 8.20**  3D_TLR_1 model identity pair

**FIGURE 8.21**  3D_TLR_1 model Subdomain Settings edit window
Table 8.3  Boundary Settings – Conductive Media DC (dc) Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 2, 4–10, 12, 13</td>
<td>Electric insulation</td>
<td>—</td>
<td>8.22</td>
</tr>
<tr>
<td>3</td>
<td>Inward current flow</td>
<td>0.3</td>
<td>8.23</td>
</tr>
<tr>
<td>11</td>
<td>Ground</td>
<td>—</td>
<td>8.24</td>
</tr>
</tbody>
</table>

**Physics Boundary Settings: Conductive Media DC (dc)**

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 8.3. See Figures 8.22, 8.23, and 8.24.

Click the Pairs tab. Select “Contact resistance” from the Boundary condition pull-down list. For the indicated quantity, select or enter the given value as shown in Table 8.4; also see Figure 8.25. Click OK.

Table 8.4  Boundary Settings – Conductive Media DC (dc) Edit Window, Pairs

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Value/Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\sigma$</td>
<td>1e-2</td>
<td>Electrical conductivity</td>
</tr>
<tr>
<td>d</td>
<td>0.02</td>
<td>Thickness in meters</td>
</tr>
</tbody>
</table>
This is the most important step in this model, as it implements the thin layer approximation. By using the identity pair–contact resistance approximation in this model, the modeler has eliminated the necessity of building and using a third domain as the interface layer.
Mesh Generation
From the toolbar, select Mesh > Initialize Mesh. See Figure 8.26.

Solving the 3D_TLR_1 Model
Using the menu bar, select Solve > Solve Problem. See Figure 8.27.

The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Postprocessing and Visualization
The default plot shows a slice plot of the electric potential (V) distribution in volts. To visualize the solution as a boundary plot, the Plot Parameters will need to be modified.

Select Postprocessing > Plot Parameters > General. In the Plot type list, unselect the Slice check box. In the Plot type list, select the Boundary check box.

Click the Boundary tab. Select Conductive Media DC (dc) > Electric potential (V). Unselect the Smooth check box. See Figure 8.28.
**FIGURE 8.26** 3D_TLR_1 model mesh

**FIGURE 8.27** 3D_TLR_1 model solution, default slice plot
Click OK. See Figure 8.29.

**TLR Voltage Measured Across the Layer**

To visualize the voltage across the thin layer resistance, select Postprocessing > Cross-Section Plot Parameters > General. Click the Line/Extrusion plot radio button among the Plot type selection choices. Click the Line/Extrusion tab. Select “Electric Potential” from the y-axis data pull-down list. Click the Expression radio button. Click the Expression button and enter z in the edit window. See Figure 8.30.
Click OK. For the cross-section line data, select or enter the given value as shown in Table 8.5. See Figure 8.31.

Click OK. See Figure 8.32.

**3D Thin Layer Resistance Model, Thin Layer Approximation: Summary and Conclusions**

The 3D thin layer resistance model, thin layer approximation, has now been built and solved. This model employs the thin layer approximation to solve a model by replacing the center domain with a contact resistance identity pair. Such an approximation
has a broad applicability: It can be used in any problem in which flow is described by the divergence of a gradient flux (i.e., diffusion, heat conduction, flow through porous media under Darcy’s law).

The application of the thin layer approximation is especially valuable to the mod-  
eler when the differences in domain thickness are so great that the mesh generator fails to properly mesh the model or creates more elements than the modeling platform can

### Table 8.5  Cross-Section Line Data Parameters

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Value/Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>x0</td>
<td>0.5</td>
</tr>
<tr>
<td>y0</td>
<td>0.5</td>
</tr>
<tr>
<td>z0</td>
<td>0.0</td>
</tr>
<tr>
<td>x1</td>
<td>0.5</td>
</tr>
<tr>
<td>y1</td>
<td>0.5</td>
</tr>
<tr>
<td>z1</td>
<td>0.2</td>
</tr>
</tbody>
</table>

![Figure 8.31](3D_TLR_1 model, Cross-Section Plot Parameters edit window)
handle (the “run out of memory” problem). In those cases, this approximation may enable a model to be solved that would otherwise fail.

3D Thin Layer Resistance Model: Thin Layer Subdomain

The following numerical solution model (3D_TLR_2 model) is similar to the previous model. However, in this case, the center layer is a full domain.

To start building the 3D_TLR_2 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “3D” from the Space dimension pull-down list. Select COMSOL Multiphysics > Electromagnetics > Conductive Media DC. See Figure 8.33. Click OK.

Geometry Modeling

Using the menu bar, select Draw > Block. In the Block edit window, enter the information shown in Table 8.6. Click OK after filling in the parameters of each separate block in the Block edit window. See Figures 8.34, 8.35, and 8.36.
### Table 8.6  Geometry Components

<table>
<thead>
<tr>
<th>Name</th>
<th>Style</th>
<th>Base</th>
<th>Length (X, Y, Z)</th>
<th>Axis Base Point (X, Y, Z)</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLK1</td>
<td>Solid</td>
<td>Corner</td>
<td>(1, 1, 0.1)</td>
<td>(0, 0, 0)</td>
<td>8.34</td>
</tr>
<tr>
<td>BLK2</td>
<td>Solid</td>
<td>Corner</td>
<td>(1, 1, 0.02)</td>
<td>(0, 0, 0.1)</td>
<td>8.35</td>
</tr>
<tr>
<td>BLK3</td>
<td>Solid</td>
<td>Corner</td>
<td>(1, 1, 0.1)</td>
<td>(0, 0, 0.12)</td>
<td>8.36</td>
</tr>
</tbody>
</table>

**FIGURE 8.33** 3D_TLR_2 Model Navigator setup

**FIGURE 8.34** 3D_TLR_2 model BLK1 edit window
Click the Zoom Extents button. See Figure 8.37.
Select File > Save As. Enter 3D_TLR_2 in the Save As edit window. See Figure 8.38. Click the Save button.
Using the menu bar, select Draw > Work-Plane Settings. See Figure 8.39.

**NOTE** As noted earlier, the use of the Work-Plane Settings is intended to make specific 2D planes available to the modeler to facilitate the creation of essentially 2D objects in the 3D geometry.
Click OK, using the default settings. Click the Zoom Extents button. See Figure 8.40.

Using the menu bar, select Draw > Specify Objects > Circle. Enter a radius of 0.6, set the base to Center, and set x equal to 0 and y equal to 1. See Figure 8.41. Click OK.
FIGURE 8.39 3D_TLR_2 model Work-Plane Settings edit window

FIGURE 8.40 3D_TLR_2 model Geom2 work-plane
Using the menu bar, select Draw > Specify Objects > Square. Enter a width of 1, set the base as Corner, and set x equal to 0 and y equal to 0. See Figure 8.42. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter C1*SQ1 in the Set formula edit window. See Figure 8.43.
The formula $X \times Y$ creates the intersection of $X$ and $Y$.

Click OK. See Figure 8.44.

Using the menu bar, select Draw > Embed. See Figure 8.45. Click OK.

As is obvious, the quarter-circle electrode needs to be moved to the upper surface of the upper block. Using the menu bar, select Draw > Modify > Move. Enter $x = 0$, $y = 0$, and $z = 0.22$. See Figure 8.46.
Click OK. See Figure 8.47.

Select EMB1 and BLK3 (click on EMB1 and then shift-click on BLK3). See Figure 8.48. Using the menu bar, select Draw > Coerce To > Solid.

**Physics Subdomain Settings: Conductive Media DC (dc)**

Having established the geometry for the 3D_TLR_2 model of three blocks and an electrode, the next step is to define the fundamental Physics conditions. Using the menu bar, select Physics > Subdomain Settings. In the Subdomain edit windows, enter the information shown in Table 8.7. Click OK. See Figures 8.49 and 8.50.
Physics Boundary Settings: Conductive Media DC (dc)

Using the menu bar, select Physics > Boundary Settings. For the indicated boundaries, select or enter the given boundary condition and value as shown in Table 8.8. Click OK. See Figures 8.51, 8.52, and 8.53.

Table 8.8  Boundary Settings – Conductive Media DC (dc) Edit Window

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 2, 4, 5, 7, 8, 10, 12–17</td>
<td>Electric insulation</td>
<td>—</td>
<td>8.51</td>
</tr>
<tr>
<td>3</td>
<td>Inward current flow</td>
<td>0.3</td>
<td>8.52</td>
</tr>
<tr>
<td>11</td>
<td>Ground</td>
<td>—</td>
<td>8.53</td>
</tr>
</tbody>
</table>
FIGURE 8.49 3D_TLR_2 model Subdomain Settings (1, 3) edit window

FIGURE 8.50 3D_TLR_2 model Subdomain Settings (2) edit window
In this model, the thin layer approximation has been replaced by subdomain 2.

**Mesh Generation**

From the toolbar, select Mesh > Free Mesh Parameters > Subdomain. Select subdomain 2. Enter 0.02 in the Maximum element size edit window. See Figure 8.54. Click the Mesh Selected button.
Click the Select Remaining button. (Subdomains 1 and 3 will be highlighted.) Click the Mesh Selected button. Click OK. See Figure 8.55.

**Solving the 3D_TLR_2 Model**

Using the menu bar, select Solve > Solve Problem. See Figure 8.56.
FIGURE 8.55 3D_TLR_2 model mesh

FIGURE 8.56 3D_TLR_2 model solution, default slice plot
The COMSOL Multiphysics software automatically selects the solver best suited for the particular model based on the overall evaluation of the model. The modeler can, of course, change the chosen solver and the parametric settings. It is usually best to try the selected solver and default settings first to determine how well they work. Then, once the model has been run, the modeler can do a variation on the model parameter space to seek improved results.

Postprocessing and Visualization

The default plot shows a slice plot of the electric potential \( V \) distribution in volts. To visualize the solution as a boundary plot, the Plot Parameters will need to be modified.

Select Postprocessing > Plot Parameters > General. In the Plot type list, unselect the Slice check box. In the Plot type list, select the Boundary check box. See Figure 8.57.
Click the Boundary tab. Select Conductive Media DC (dc) > Electric potential (V).
Unselect the Smooth check box. See Figure 8.58.
Click OK. See Figure 8.59.

**TLR Voltage Measured Across the Layer**

To visualize the voltage across the thin layer resistance (subdomain 2), select Postprocessing > Cross-Section Plot Parameters > General. Click the Line/Extrusion plot radio button among the Plot type selection choices.

Click the Line/Extrusion tab. Select “Electric Potential” from the y-axis data pull-down list. Click the Expression radio button. Click the Expression button and enter $z$ in the edit window. See Figure 8.60. Click OK.
For the cross-section line data, select or enter the given value as shown in Table 8.9. See Figure 8.61.
Click OK. See Figure 8.62.

3D Thin Layer Resistance Models: Summary and Conclusions
The 3D thin layer resistance model, thin layer approximation, and the 3D thin layer resistance model, thin layer subdomain, have now been built and solved. A direct
Table 8.9  Cross-Section Line Data Parameters

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Value/Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>x₀</td>
<td>0.5</td>
</tr>
<tr>
<td>y₀</td>
<td>0.5</td>
</tr>
<tr>
<td>z₀</td>
<td>0.0</td>
</tr>
<tr>
<td>x₁</td>
<td>0.5</td>
</tr>
<tr>
<td>y₁</td>
<td>0.5</td>
</tr>
<tr>
<td>z₁</td>
<td>0.2</td>
</tr>
</tbody>
</table>

A comparison can be made of the model solutions by comparing the results obtained from the cross-section plots. See Figures 8.63 and 8.64.

As can be seen from the examination of the plots, the only substantial difference between the two solutions is the electrical potential difference across subdomain 2. Thus the modeler can choose the implementation that best suits his or her system and time constraints, without suffering excessive inaccuracies based on the approximation method.
**FIGURE 8.62** 3D_TLR_2 model, cross-section electric potential plot

**FIGURE 8.63** 3D_TLR_1 model, cross-section electric potential plot, thin layer approximation
The study of static electricity, a well-known and widely observed phenomenon, has a long history. Thales of Miletus recorded the first known scientific observations using amber in approximately the sixth century BC. Additional serious documented scientific work on static electricity did not occur until Otto von Guericke invented the first electrostatic generator around 1663.

The physics of static electricity was not well understood until the work of Charles-Augustin de Coulomb, Johann Carl Friedrich Gauss, and others explored electrostatics and mathematics of physics in the late 1700s to early 1800s AD. Based on that work, the electrostatic scalar potential (\(V\)) is known to be related to the electric field vector (\(\mathbf{E}\)) as follows:

\[
\mathbf{E} = -\nabla V
\]  

where
- \(\mathbf{E}\) = electric field vector (V/m)
- \(\nabla\) = divergence operator (1/m)
- \(V\) = scalar electric potential (V)
The divergence operator is as follows:
\[ \nabla = \hat{i} \frac{\partial}{\partial x} + \hat{j} \frac{\partial}{\partial y} + \hat{k} \frac{\partial}{\partial z} \]
where \( \hat{i}, \hat{j}, \hat{k} \) are the unit vectors in the \( x, y, z \) directions, respectively.

Using Gauss’s law,\(^{13}\)
\[ \nabla \cdot (\varepsilon \mathbf{E}) = \rho \quad (8.14) \]
where \( \mathbf{E} \) = electric field vector (V/m)
\( \nabla \) = divergence operator (1/m)
\( \varepsilon \) = permittivity
\( \rho \) = space charge density

Substituting for \( \mathbf{E} \) gives
\[ -\nabla \cdot (\varepsilon \nabla V) = \rho \quad (8.15) \]
and
\[ -\nabla \cdot (\varepsilon \nabla V) = -\varepsilon \nabla^2 V = \rho \quad (8.16) \]
where \( \nabla^2 \) is the Laplacian operator.

The Laplacian operator\(^{14,15}\) is as follows:
\[ \nabla^2 = \frac{\partial^2}{\partial x^2} + \frac{\partial^2}{\partial y^2} + \frac{\partial^2}{\partial z^2} \]
It is a differential operator, shown above in the scalar form, named after Pierre-Simon de Laplace.\(^{16}\) The Laplacian operator is widely employed in the physics of electromagnetics, wave propagation, heat flow, fluid flow, and quantum mechanics, to name a few areas.

A large body of subsequent work has led to both scientific and engineering applications (e.g., ranging from X-ray tubes and particle accelerators to paint sprayers and dust precipitators).

The 3D electrostatic potential models presented in this section are examples of methods that can be used by the modeler to explore electrostatic potentials in different geometric configurations.
3D Electrostatic Potential Between Two Cylinders

The following numerical solution model (3D_ESP_1 model) is derived from a model that was originally developed by COMSOL as a Multiphysics Electromagnetics demonstration model. That model was developed for distribution with the Multiphysics software as a COMSOL Multiphysics Model Library.

To start building the 3D_ESP_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “3D” from the Space dimension pull-down list. Select COMSOL Multiphysics > Electromagnetics > Electrostatics. See Figure 8.65. Click OK.

Geometry Modeling

Using the menu bar, select Draw > Sphere. In the Sphere edit window, enter the information shown in Table 8.10. Click OK after filling in the parameters of each separate solid in the appropriate edit window. See Figures 8.66, 8.67, and 8.68.

<table>
<thead>
<tr>
<th>Solid</th>
<th>Name</th>
<th>Style</th>
<th>Radius</th>
<th>Height</th>
<th>Axis Base Point (X, Y, Z)</th>
<th>Axis Direction Vector (X, Y, Z)</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sphere</td>
<td>SPH1</td>
<td>Solid</td>
<td>2</td>
<td></td>
<td>(0, 0, 0)</td>
<td>(0, 0, 1)</td>
<td>8.66</td>
</tr>
<tr>
<td>Cylinder</td>
<td>CYL1</td>
<td>Solid</td>
<td>0.1</td>
<td>0.4</td>
<td>(−0.4, 0, −0.2)</td>
<td>(0, 0, 1)</td>
<td>8.67</td>
</tr>
<tr>
<td>Cylinder</td>
<td>CYL2</td>
<td>Solid</td>
<td>0.1</td>
<td>0.4</td>
<td>(0.4, 0, −0.2)</td>
<td>(0, 0, 1)</td>
<td>8.68</td>
</tr>
</tbody>
</table>
Click the Zoom Extents button. Select File > Save As. Enter 3D_ESP_1.mph in the Save As edit window. See Figure 8.69. Click the Save button.

Using the menu bar, select Draw > Create Composite Object. Enter SPH1-CYL1-CYL2 in the Set formula edit window. See Figure 8.70. Click OK.
Physics Subdomain Settings: Electrostatics (es)

Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 (the only subdomain available). Click the radio button \( D = \varepsilon_0 \varepsilon_r E \). Enter 0 in the Space charge density (\( \rho \)) edit window. Enter 1 in the Relative permittivity (\( \varepsilon_r \)) edit window. See Figure 8.71. Click OK.

\[ \text{NOTE} \] The numerical value of the permittivity for free space (\( \varepsilon_0 \)) in SI units is \( 8.854 \times 10^{12} \) F/m. That value is the default value for permittivity incorporated into the COMSOL Multiphysics software. The permittivity of a material is the product of \( \varepsilon_0 \) and \( \varepsilon_r \), which in this case is 1.

Physics Boundary Settings: Electrostatics (es)

Using the menu bar, select Physics > Boundary Settings. Select or enter the settings as indicated in Table 8.11. Click OK. See Figures 8.72, 8.73, and 8.74.

<table>
<thead>
<tr>
<th>Table 8.11</th>
<th>Boundary Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Boundary</strong></td>
<td><strong>Settings</strong></td>
</tr>
<tr>
<td>1–4, 11–14</td>
<td>Zero charge/symmetry</td>
</tr>
<tr>
<td>5–10</td>
<td>Electric potential</td>
</tr>
<tr>
<td>15–20</td>
<td>Electric potential</td>
</tr>
</tbody>
</table>
Mesh Generation

Using the menu bar, select Mesh > Free Mesh Parameters. Select “Coarser” from the Predefined mesh sizes pull-down list. See Figure 8.75. Click OK.

Using the menu bar, select Mesh > Initialize Mesh. See Figure 8.76.
Solving the 3D_ESP_1 Model

Electrostatics problems can be complex and difficult. The modeler can, of course, accept the COMSOL software default settings. However, in this case, depending on the modeler’s platform, it will probably be best to choose an iterative solver (GMRES) and an appropriate preconditioner (Algebraic multigrid). These choices will reduce both the memory required and the time to solution.
Select Solve > Solver Parameters. Select “GMRES” from the Linear system solver pull-down list. Select “Algebraic multigrid” from the Preconditioner pull-down list. See Figure 8.77.

Click OK. Select Solve > Solve Problem.

Postprocessing and Visualization

The default solution plot is the slice plot. See Figure 8.78.

Using the menu bar, select Postprocessing > Plot Parameters > General. Uncheck the Slice check box, and check the Boundary and Streamline check boxes. See Figure 8.79.

Click the Boundary tab. Click the Apply button.

Click the Streamline tab. Enter 30 in the Number of start points window. Click OK.

To see the streamline plot, the modeler will need to suppress the boundaries of the sphere. Using the menu bar, select Options > Suppress > Suppress Boundaries. Select boundaries 1–4 and 11–14. See Figure 8.80. Click OK.
CHAPTER 8  3D MODELING

**FIGURE 8.77** 3D_ESP_1 model Solver Parameters edit window

**FIGURE 8.78** 3D_ESP_1 model default solution plot
FIGURE 8.79  3D_ESP_1 model Plot Parameters selection window

FIGURE 8.80  3D_ESP_1 model Suppress Boundaries selection window
Using the menu bar, select Postprocessing > Plot Parameters > Streamline. Click the Apply button, and then click OK. See Figure 8.81.

### 3D Electrostatic Potential Between Two Cylinders: Summary and Conclusions

The 3D electrostatic potential model presented here demonstrates one of the methods that can be used by the modeler to explore electrostatic potentials in different geometric configurations. This technique can be applied to both scientific and engineering applications (e.g., ranging from X-ray tubes and particle accelerators to paint sprayers and dust precipitators).

### 3D Electrostatic Potential Between Five Cylinders

To start building the 3D_ESP_2 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “3D” from the Space dimension pull-down list. Select COMSOL Multiphysics > Electromagnetics > Electrostatics. See Figure 8.82. Click OK.
Geometry Modeling

Using the menu bar, select Draw > Sphere. In the Sphere edit window, enter the information shown in Table 8.12. Click OK after filling in the parameters of each separate solid in the appropriate edit window. See Figures 8.83–8.88.

| Table 8.12  Geometry Components |
|-----------------|-----------------|-----------------|-----------------|
| **Solid** | **Name** | **Style** | **Radius** | **Height** | **Axis Base Point (X, Y, Z)** | **Axis Direction Vector (X, Y, Z)** | **Figure Number** |
| Sphere | SPH1 | Solid | 4 | | (0, 0, 0) | (0, 0, 1) | 8.83 |
| Cylinder | CYL1 | Solid | 0.1 | 0.4 | (-0.4, 0, -0.2) | (0, 0, 1) | 8.84 |
| Cylinder | CYL2 | Solid | 0.1 | 0.4 | (0, 0, -0.2) | (0, 0, 1) | 8.85 |
| Cylinder | CYL3 | Solid | 0.1 | 0.4 | (0.4, 0, -0.2) | (0, 0, 1) | 8.86 |
| Cylinder | CYL4 | Solid | 0.1 | 0.4 | (0, -0.4, -0.2) | (0, 0, 1) | 8.87 |
| Cylinder | CYL5 | Solid | 0.1 | 0.4 | (0, 0.4, -0.2) | (0, 0, 1) | 8.88 |
FIGURE 8.83  3D_ESP_2 model Sphere SPH1 edit window

FIGURE 8.84  3D_ESP_2 model Cylinder CYL1 edit window

FIGURE 8.85  3D_ESP_2 model Cylinder CYL2 edit window
FIGURE 8.86  3D_ESP_2 model Cylinder CYL3 edit window

FIGURE 8.87  3D_ESP_2 model Cylinder CYL4 edit window

FIGURE 8.88  3D_ESP_2 model Cylinder CYL5 edit window
Click the Zoom Extents button. Select File > Save As. Enter 3D_ESP_2.mph in the Save As edit window. See Figure 8.89. Click the Save button.

Using the menu bar, select Draw > Create Composite Object. Enter SPH1-CYL1-CYL2-CYL3-CYL4-CYL5 in the Set formula edit window. See Figure 8.90. Click OK.
Physics Subdomain Settings: Electrostatics (es)

Using the menu bar, select Physics > Subdomain Settings. Select subdomain 1 (the only subdomain available). Click the radio button $D = \varepsilon_0 \varepsilon_r E$. Enter 0 in the Space charge density ($\rho$) edit window. Enter 1 in the Relative permittivity ($\varepsilon_r$) edit window. See Figure 8.91. Click OK.

The numerical value of the permittivity for free space ($\varepsilon_0$) in SI units is $8.854 \times 10^{12}$ F/m. That value is the default value for permittivity incorporated into the COMSOL Multiphysics software. The permittivity of a material is the product of $\varepsilon_0$ and $\varepsilon_r$, which in this case is 1.

Physics Boundary Settings: Electrostatics (es)

Using the menu bar, select Physics > Boundary Settings. Select or enter the settings as indicated in Table 8.13. Click OK. See Figures 8.92, 8.93, and 8.94.

<table>
<thead>
<tr>
<th>Table 8.13</th>
<th>Boundary Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary</td>
<td>Settings</td>
</tr>
<tr>
<td>1–4, 23,</td>
<td>Zero charge/symmetry</td>
</tr>
<tr>
<td>24, 28, 29</td>
<td></td>
</tr>
<tr>
<td>5–14, 19–22,</td>
<td>Electric potential</td>
</tr>
<tr>
<td>25, 26, 31–38</td>
<td></td>
</tr>
<tr>
<td>15–18,</td>
<td>Electric potential</td>
</tr>
<tr>
<td>27, 30</td>
<td></td>
</tr>
</tbody>
</table>
Mesh Generation
Using the menu bar, select Mesh > Free Mesh Parameters. Select “Coarser” from the Predefined mesh sizes pull-down list. See Figure 8.95. Click OK.
Using the menu bar, select Mesh > Initialize Mesh. See Figure 8.96.
FIGURE 8.94  3D_ESP_2 model Boundary Settings (15–18, 27, 30) edit window

FIGURE 8.95  3D_ESP_2 model Free Mesh Parameters edit window
Solving the 3D_ESP_2 Model

Electrostatics problems can be complex and difficult. The modeler can, of course, accept the COMSOL software default settings. However, in this case, depending on the modeler’s platform, it will probably be best to choose an iterative solver (GMRES) and an appropriate preconditioner (Algebraic multigrid). These choices will reduce both the memory required and the time to solution.

Select Solve > Solver Parameters. Select “GMRES” from the Linear system solver pull-down list. Select “Algebraic multigrid” from the Preconditioner pull-down list. See Figure 8.97.

Click OK. Select Solve > Solve Problem.

Postprocessing and Visualization

The default solution plot is the slice plot. See Figure 8.98.
FIGURE 8.97 3D_ESP_2 model Solver Parameters edit window

FIGURE 8.98 3D_ESP_2 model default solution plot
Using the menu bar, select Postprocessing > Plot Parameters > General. Uncheck the Slice check box, and check the Boundary and Streamline check boxes. See Figure 8.99.

Click the Boundary tab. Click the Apply button.

Click the Streamline tab. Enter 29 in the Number of start points window. Click OK.

To see the streamline plot, the modeler will need to suppress the boundaries of the sphere. Using the menu bar, select Options > Suppress > Suppress Boundaries. Select boundaries 1–4, 23, 24, 28, and 29. See Figure 8.100. Click OK.

Using the menu bar, select Postprocessing > Plot Parameters > Streamline. Click the Apply button, and then click OK. See Figure 8.101.
The 3D electrostatic potential models presented here demonstrate one of the methods that can be used by the new modeler to explore electrostatic potentials in different geometric configurations. The 3D_ESP_2 model is typical of those that might be found in a particle beam analyzer or similar engineering or scientific device. This modeling technique can be applied widely to both scientific and engineering applications (e.g., ranging from X-ray tubes and particle accelerators to paint sprayers and dust precipitators).
Magnetostatic Modeling Basics

The fundamental equations governing electromagnetic phenomena are Maxwell’s equations, first published in 1873 by James Clerk Maxwell. Maxwell’s equations, as written for free charge and as commonly seen in scientific papers and textbooks, in SI units are

\[ \nabla \cdot \mathbf{D} = \rho \]
\[ \nabla \cdot \mathbf{B} = 0 \]
\[ \nabla \times \mathbf{E} = -\frac{\partial \mathbf{B}}{\partial t} \]
\[ \nabla \times \mathbf{H} = \mathbf{J} + \frac{\partial \mathbf{D}}{\partial t} \]

where:
- \( \mathbf{E} \) = electric field vector in volts per meter (V/m)
- \( \mathbf{D} \) = electric flux density vector in coulombs per square meter (C/m²)
- \( \mathbf{B} \) = magnetic field vector in tesla (T)
- \( \mathbf{H} \) = magnetizing field vector in amperes per meter (A/m)
- \( \mathbf{J} \) = free current density in amperes per square meter (A/m²)
- \( \rho \) = free charge density in coulombs per cubic meter (C/m³)

To solve any of the potential electromagnetic problems, the modeler also needs to assume continuity (no sinks or sources—that is, “What goes in, comes out”). The equation of continuity is

\[ \nabla \cdot \mathbf{J} = -\frac{\partial \rho}{\partial t} \]

The modeler also needs to define the properties of the medium(s) throughout which the electromagnetic wave is traveling. These equations are called the constitutive relationships for the medium:

\[ \mathbf{D} = \varepsilon_0 \mathbf{E} + \mathbf{P} \]
\[ \mathbf{B} = \mu_0 (\mathbf{H} + \mathbf{M}) \]
\[ \mathbf{J} = \sigma \mathbf{E} \]

where:
- \( \mathbf{E} \) = electric field vector in volts per meter (V/m)
- \( \mathbf{D} \) = electric flux density vector in coulombs per square meter (C/m²)
\[ P = \text{electric polarization vector in coulombs per square meter (C/m}^2) \]
\[ B = \text{magnetic field vector in tesla (T)} \]
\[ H = \text{magnetizing field vector in amperes per meter (A/m)} \]
\[ M = \text{magnetization vector in amperes per meter (A/m)} \]
\[ J = \text{free current density in amperes per square meter (A/m}^2) \]
\[ \varepsilon_0 = \text{permittivity of vacuum in farads per meter (F/m)} \]
\[ \mu_0 = \text{permeability of vacuum in henries per meter (H/m)} \]
\[ \sigma = \text{electric conductivity in siemens per meter (S/m)} \]

In a magnetostatic model, such as the Helmholtz coil, all parameters are stable and do not fluctuate. If they do fluctuate, it is at a slow rate.

**NOTE** If the parameters of the model do fluctuate, a good measure of the validity of the model is that the dimensions of the model should be at least 10 times smaller than the wavelength of the fluctuation. Consider, for example, 60 Hz. The wavelength is calculated as follows:

\[ \lambda = \frac{c}{f} = \frac{3 \times 10^8}{60} = 5 \times 10^6 \text{ m} \quad (8.25) \]

where
- \( \lambda \) = wavelength in meters (m)
- \( c \) = speed of light in meters per second (m/s)
- \( f \) = frequency in cycles per second (cycle/s)

In the case of a magnetostatic model, the relationships between the potentials and the fields are as follows:

\[ \nabla \times (\mu^{-1} \nabla \times A) = J^e \quad (8.26) \]

\[ B = \nabla \times A \quad (8.27) \]

\[ H = \mu^{-1} B \quad (8.28) \]

\[ \mu = \mu_0 \mu_r \quad (8.29) \]

where
- \( A \) = magnetic vector potential in volt-seconds per meter (V \cdot s/m)
- \( B \) = magnetic field vector in tesla (T)
- \( H \) = magnetizing field vector in amperes per meter (A/m)
- \( J^e \) = externally applied current density in amperes per square meter (A/m\(^2\))
- \( \mu_0 \) = permeability of vacuum in henries per meter (H/m)
- \( \mu_r \) = relative permeability
The numerical value of the permeability for free space ($\mu_0$) in SI units is exactly $4\pi \times 10^{-7}$ H/m. That value is the default value for permeability incorporated into the COMSOL Multiphysics software. The permeability of a material is the product of $\mu_0$ and $\mu_r$, which in this case is 1.

Because the electromagnetic potentials do not uniquely define a solution, within a gauge transformation it is necessary to choose a gauge (transformation). This technique is called gauge fixing. In this case, the gauge chosen is called the Coulomb gauge. The condition of the Coulomb gauge is that $\nabla \cdot \mathbf{A} = 0$.

To avoid numerical instability in the model, $\nabla \cdot \mathbf{A}$ is numerically adjusted to zero by using a type of special pre- and post-smoother called an SOR gauge.

**3D Magnetic Field of a Helmholtz Coil**

The following numerical solution model (3D_HC_1 model) is derived from a model that was originally developed by COMSOL as an AC/DC Module Electrical Components demonstration model. That model was developed for distribution with the Multiphysics software as a COMSOL AC/DC Module Model Library.

To start building the 3D_HC_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “3D” from the Space dimension pull-down list. Select AC/DC Module > Statics > Magnetostatics. See Figure 8.102. Click OK.

![Figure 8.102 3D_HC_1 Model Navigator setup](image)
Table 8.14  Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>J0</td>
<td>1[A/m^2]</td>
<td>Coil current density</td>
<td>8.103</td>
</tr>
</tbody>
</table>

Constants

Using the menu bar, select Options > Constants. Enter the constant shown in Table 8.14. Click OK. See Figure 8.103.

Select File > Save As. Enter 3D_HC_1.mph in the Save As edit window. See Figure 8.104. Click the Save button.

FIGURE 8.103  3D_HC_1 model Constants edit window

FIGURE 8.104  3D_HC_1 model Save As edit window
Geometry Modeling

Each Helmholtz coil is created in cross section by drawing squares in the 2D work-plane. The modeler then creates a solid coil by revolution (revolve) of the 2D work-plane geometry into the 3D geometry.

Using the menu bar, select Draw > Work-Plane Settings. See Figure 8.105. Click OK.

Using the menu bar, select Draw > Specify Objects > Square. In the Square edit window, enter the information shown in Table 8.15. Click OK after filling in the parameters of each separate square in the appropriate edit window. See Figures 8.106 and 8.107.

| Table 8.15  Geometry Components |
|----------------------|-----------------|-----------------|-----------------|-----------------|-----------------|
| Name   | Width | Base  | x    | y    | Figure Number |
| SQ1    | 0.05  | Corner | -0.425 | 0.175 | 8.106          |
| SQ2    | 0.05  | Corner | -0.425 | -0.225 | 8.107          |

FIGURE 8.105  3D_HC_1 model Work-Plane Settings edit window

FIGURE 8.106  3D_HC_1 model Square SQ1 edit window
Click the Zoom Extents button. Select SQ1 and SQ2. Using the menu bar, select Draw > Revolve. See Figure 8.108.

Click OK. See Figure 8.109.

Using the menu bar, select Draw > Sphere. Enter 1 in the Radius edit window. See Figure 8.110.

Click OK, and then click the Zoom Extents button. Click on the display window background outside the sphere. See Figure 8.111.

\[ \text{FIGURE 8.107 3D_HC_1 model Square SQ2 edit window} \]

\[ \text{FIGURE 8.108 3D_HC_1 model Revolve edit window} \]
FIGURE 8.109  3D_HC_1 model Helmholtz coil pair

FIGURE 8.110  3D_HC_1 model Sphere edit window
Physics Subdomain Settings: Magnetostatics (emqa)

Using the menu bar, select Physics > Subdomain Settings. Select the subdomain(s) and enter the expression indicated in Table 8.16. Click OK. See Figures 8.112 and 8.113.

The numerical value of the permeability for free space ($\mu_0$) in SI units is exactly $4\pi \times 10^{-7}$ H/m. That value is the default value for permeability incorporated into the COMSOL Multiphysics software. The permeability of a material is the product of $\mu_0$ and $\mu_r$, which in this case is 1.

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Quantity</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>$J^e$</td>
<td>0 0 0</td>
<td>8.112</td>
</tr>
<tr>
<td>2, 3</td>
<td>$J^e$</td>
<td>$-J0^x z / \sqrt{x^2 + z^2}$, $0$ [J0^x z / \sqrt{x^2 + z^2}]</td>
<td>8.113</td>
</tr>
</tbody>
</table>
Physics Boundary Settings: Magnetostatics (emqa)

Using the menu bar, select Physics > Boundary Settings. Verify or enter the default boundary setting (Magnetic insulation) for spherical boundaries 1–4, 21, 22, 31, and 32. See Figure 8.114. Click OK.
Mesh Generation

Using the menu bar, select Mesh > Free Mesh Parameters. Select “Coarser” from the Predefined mesh sizes pull-down list. See Figure 8.115.

Click the Subdomain tab. Select subdomains 2 and 3. Enter 0.05 in the Maximum element size edit window. See Figure 8.116.
Click the Remesh button, and then click OK. See Figure 8.117.

**Solving the 3D_HC_1 Model**

Using the menu bar, select Solve > Solve Problem.
Postprocessing and Visualization

The default solution plot is the slice plot. See Figure 8.118.

To see the model solution inside the sphere, the modeler needs to suppress the boundaries of the sphere. Using the menu bar, select Options > Suppress > Suppress Boundaries. Select boundaries 1–4, 21, 22, 31, and 32 in the Boundary selection window. See Figure 8.119. Click OK.
Using the menu bar, select Postprocessing > Plot Parameters > General. Check the Slice, Boundary, and Arrow check boxes. Uncheck the Geometry edges check box. See Figure 8.120. Click the Apply button.

Click the Slice tab. Select or verify the Predefined quantities: Magnetic flux density, norm. Enter 0 in the x and y levels edit windows and 1 in the z levels edit window. See Figure 8.121. Click the Apply button.
Click the Boundary tab. Enter 1 in the Boundary data Expression edit window. Click the Uniform color radio button and choose black. Click OK. See Figure 8.122. Click the Apply button.

Click the Arrow tab. Select “Magnetic field” from the Predefined quantities pull-down list. Enter 24 in the x points window, 10 in the y points window, and 1 in the z points window. Uncheck the Scale factor Auto check box. Enter 0.5 in the Scale factor edit window. See Figure 8.123. Click the Apply button.
Click OK. See Figure 8.124.

Cross-Section Field Analysis
To obtain a graphical plot of the magnetic field, use the Cross-Section Plot feature. Using the menu bar, select Postprocessing > Cross-Section Plot Parameters > General. Click the Line/Extrusion plot radio button in the Plot type selection window. Click the Line/Extrusion tab. Select “Magnetic flux density, norm” from the Predefined quantities pull-down list in the y-axis data selection window. Select “x” from the x-axis data...
pull-down list. In the Cross-section line data edit windows, enter \( -0.8 \) for \( x_0 \) and \( 0.8 \) for \( x_1 \). See Figure 8.125.

Click the Apply button. See Figure 8.126.

Click OK. See Figure 8.127.

3D Magnetic Field of a Helmholtz Coil: Summary and Conclusions

The 3D magnetic field of a Helmholtz coil model demonstrates the magnetic field uniformity of a Helmholtz coil pair. The magnetostatic modeling technique can be applied to a diverse collection of scientific and engineering applications (e.g., ranging from magnetometers and Hall effect sensors to biomagnetic and medical studies).
**FIGURE 8.124** 3D_HC_1 model solution plot

**FIGURE 8.125** 3D_HC_1 model Cross-Section Plot Parameters edit window
FIGURE 8.126  3D_HC_1 model cross-section plot

FIGURE 8.127  3D_HC_1 model solution plot with cross-section plot line
3D Magnetic Field of a Helmholtz Coil with a Magnetic Test Object

The following numerical solution model (3D_HC_2 model) is derived from a model that was originally developed by COMSOL as an AC/DC Module Electrical Components demonstration model. That model was developed for distribution with the Multiphysics software as a COMSOL AC/DC Module Model Library.

To start building the 3D_HC_2 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “3D” from the Space dimension pull-down list. Select AC/DC Module > Statics > Magnetostatics. See Figure 8.128. Click OK.

Constants

Using the menu bar, select Options > Constants. Enter the constant shown in Table 8.17. Click OK. See Figure 8.129.

<table>
<thead>
<tr>
<th>Table 8.17</th>
<th>Constants Edit Window</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Expression</td>
</tr>
<tr>
<td>J0</td>
<td>1[A/m^2]</td>
</tr>
</tbody>
</table>
Select File > Save As. Enter 3D_HC_2.mph in the Save As edit window. See Figure 8.130. Click the Save button.

**Geometry Modeling**

Each Helmholtz coil is created in cross section by drawing squares in the 2D work-plane. The modeler then creates a solid coil by revolution (revolve) of the 2D work-plane geometry into the 3D geometry.
Using the menu bar, select Draw > Work-Plane Settings. See Figure 8.131. Click OK.

Using the menu bar, select Draw > Specify Objects > Square. In the Square edit window, enter the information shown in Table 8.18. Click OK after filling in the parameters of each separate square in the appropriate edit window. See Figures 8.132 and 8.133.

Table 8.18  Geometry Components

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Base</th>
<th>x</th>
<th>y</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQ1</td>
<td>0.05</td>
<td>Corner</td>
<td>−0.425</td>
<td>0.175</td>
<td>8.132</td>
</tr>
<tr>
<td>SQ2</td>
<td>0.05</td>
<td>Corner</td>
<td>−0.425</td>
<td>−0.225</td>
<td>8.133</td>
</tr>
</tbody>
</table>
Click the Zoom Extents button. Select SQ1 and SQ2. Using the menu bar, select Draw > Revolve. See Figure 8.134.
Click OK. See Figure 8.135.
Using the menu bar, select Draw > Ellipsoid. Enter $x = 0.05, y = 0.3, z = 0.05$ in the Length semiaxes edit windows. Enter $x = 0, y = 0$ and $z = 1$ in the Cartesian coordinates edit windows. See Figure 8.136. Click OK.
Using the menu bar, select Draw > Sphere. Enter 1 in the Radius edit window. See Figure 8.137. Click OK.
Click the Zoom Extents button. Click on the display window background outside the sphere. See Figure 8.138.

![FIGURE 8.134 3D_HC_2 model Revolve edit window](image)
FIGURE 8.135 3D_HC_2 model Helmholtz coil pair

FIGURE 8.136 3D_HC_2 model Ellipsoid edit window
FIGURE 8.137 3D_HC_2 model Sphere edit window

FIGURE 8.138 3D_HC_2 model, sphere, Helmholtz coil pair, and magnetic ellipsoid
Physics Subdomain Settings: Magnetostatics (emqa)

Using the menu bar, select Physics > Subdomain Settings. Select the Subdomain(s) and enter the expression indicated in Table 8.19. Click OK. See Figures 8.139, 8.140, and 8.141.

The numerical value of the permeability for free space ($\mu_0$) in SI units is exactly $4\pi \times 10^{-7}$ H/m. That value is the default value for permeability incorporated into the COMSOL Multiphysics software. The permeability of a material is the product of $\mu_0$ and $\mu_r$, which in this case is 1.

---

**Table 8.19 Subdomain Settings**

<table>
<thead>
<tr>
<th>Subdomain</th>
<th>Quantity</th>
<th>Value/Expression</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>$J^e$</td>
<td>0 0 0</td>
<td>8.139</td>
</tr>
<tr>
<td></td>
<td>$\mu_r$</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>2, 3</td>
<td>$J^e$</td>
<td>$-J0^*z/sqrt(x^2+z^2)$ 0 $J0^*x/sqrt(x^2+z^2)$</td>
<td>8.140</td>
</tr>
<tr>
<td></td>
<td>$\mu_r$</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>$J^e$</td>
<td>0 0 0</td>
<td>8.141</td>
</tr>
<tr>
<td></td>
<td>$\mu_r$</td>
<td>15000</td>
<td></td>
</tr>
</tbody>
</table>
Physics Boundary Settings: Magnetostatics (emqa)

Using the menu bar, select Physics > Boundary Settings. Verify or enter the default boundary setting (Magnetic insulation) for spherical boundaries 1–4, 25, 26, 37, and 40. See Figure 8.142. Click OK.

**FIGURE 8.140** 3D_HC_2 model Subdomain Settings (2, 3) edit window

**FIGURE 8.141** 3D_HC_2 model Subdomain Settings (4) edit window
Mesh Generation

Using the menu bar, select Mesh > Free Mesh Parameters. Select “Coarser” from the Predefined mesh sizes pull-down list. See Figure 8.143.

Click the Subdomain tab. Select subdomains 2 and 3. Enter 0.05 in the Maximum element size edit window. See Figure 8.144.
Select subdomain 4. Enter 0.03 in the Maximum element size edit window. See Figure 8.145.

Click the Remesh button, and then click OK. See Figure 8.146.
Solving the 3D_HC_2 Model

Using the menu bar, select Solve > Solve Problem.

Postprocessing and Visualization

The default solution plot is the slice plot. See Figure 8.147.

To see the model solution inside the sphere, the modeler needs to suppress the boundaries of the sphere. Using the menu bar, select Options > Suppress > Suppress Boundaries. Select boundaries 1–4, 25, 26, 37, and 40 in the Boundary selection window. See Figure 8.148. Click OK.

Using the menu bar, select Postprocessing > Plot Parameters > General. Check the Slice, Boundary, and Arrow check boxes. Uncheck the Geometry edges check box. See Figure 8.149. Click the Apply button.
FIGURE 8.147 3D_HC_2 model default solution plot

FIGURE 8.148 3D_HC_2 model plot Suppress Boundaries selection window
Click the Slice tab. Select or verify the Predefined quantities: Magnetic flux density, norm. Enter 0 in the x levels edit window, 0 in the y levels edit window, and 1 in the z levels edit window. See Figure 8.150. Click the Apply button.

Click the Boundary tab. Enter 1 in the Boundary data Expression edit window. Click the Uniform color radio button, and choose black. Click OK. See Figure 8.151. Click the Apply button.

Click the Arrow tab. Select “Magnetic field” from the Predefined quantities pull-down list. Enter 24 in the x points window, 10 in the y points window, and 1 in the z points window. Uncheck the Scale factor Auto check box. Enter 0.5 in the Scale factor edit window. See Figure 8.152. Click the Apply button.
Click OK. See Figure 8.153.

**Cross-Section Field Analysis**

To obtain a graphical plot of the magnetic field, use the Cross-Section Plot feature. Using the menu bar, select Postprocessing > Cross-Section Plot Parameters > General. Click the Line/Extrusion plot radio button in the Plot type selection window. Click the Line/Extrusion tab. Select “Magnetic flux density, norm” from the Predefined quantities pull-down list in the y-axis data selection window. Select “x” from the x-axis data
3D Magnetic Field of a Helmholtz Coil with a Magnetic Test Object: Summary and Conclusions

The 3D magnetic field of a Helmholtz coil with a magnetic test object model demonstrates the magnetic field concentration, when a high relative permeability object lies within the field of the Helmholtz coil. This magnetostatic modeling technique can be applied to a diverse collection of scientific and engineering test, measurement, and design applications.
FIGURE 8.152 3D_HC_2 model Plot Parameters selection window, Arrow tab

FIGURE 8.153 3D_HC_2 model solution plot
**FIGURE 8.154** 3D_HC_2 model Cross-Section Plot Parameters edit window

**FIGURE 8.155** 3D_HC_2 model cross-section plot
References

17. http://en.wikipedia.org/wiki/Maxwell%27s_Equations

## Exercises

1. Build, mesh, and solve the 3D thin layer resistance model, thin layer approximation problem presented in this chapter.
2. Build, mesh, and solve the 3D thin layer resistance model, thin layer subdomain problem presented in this chapter.
3. Build, mesh, and solve the 3D electrostatic potential between two cylinders problem presented in this chapter.
4. Build, mesh, and solve the 3D electrostatic potential between five cylinders problem presented in this chapter.
5. Build, mesh, and solve the 3D magnetic field of a Helmholtz coil (static) problem presented in this chapter.
6. Build, mesh, and solve the 3D magnetic field of a Helmholtz coil with a magnetic test object problem presented in this chapter.
7. Explore other materials as applied in the 3D thin layer resistance models.
8. Explore other materials as applied in the model of a 3D magnetic field of a Helmholtz coil with a magnetic test object.
9. Explore adding more and/or different magnetic test objects to the 3D magnetic field of a Helmholtz coil model.
10. Explore the different geometries in the 3D thin layer resistance models.
Perfectly Matched Layer Models

In This Chapter

Perfectly Matched Layer Modeling Guidelines and Coordinate Considerations
PML Theory
PML Models
  2D Dielectric Lens Model, with PMLs
  2D Dielectric Lens Model, with PMLs: Summary and Conclusions
  2D Dielectric Lens Model, without PMLs
  2D Dielectric Lens Model, with and without PMLs: Summary and Conclusions
  2D Concave Mirror Model, with PMLs
  2D Concave Mirror Model, with PMLs: Summary and Conclusions
  2D Concave Mirror Model, without PMLs
  2D Concave Mirror Model, with and without PMLs: Summary and Conclusions

Perfectly Matched Layer Modeling Guidelines and Coordinate Considerations

PML Theory

One of the underlying fundamental difficulties in electromagnetic wave equation calculations (Maxwell’s equations) is dealing with a propagating wave interacting with boundaries (reflections). If the boundary of the model domain is terminated in the typical fashion, unwanted reflections are typically incorporated into the solution. Fortunately, there is a methodology that works sufficiently well to essentially eliminate reflection problems at the domain boundary. That methodology is the perfectly matched layer (PML).

The PML is an approximation methodology originally developed in 1994 by Jean-Pierre Berenger for use with FDTD (finite-difference time-domain) electromagnetic modeling calculations. The PML technique has since been adapted and applied to other calculational methodologies that have similar domain mediated needs (e.g., FEM and others). This methodology can be applied to a large variety of diverse wave equation problems. In this chapter, however, it is applied only to electromagnetic problems within the context of the COMSOL RF Module.
For a broader detailed application of the PML methodology to other types of wave problems, refer to the literature.

In the COMSOL® Multiphysics® software, the PML technique is explicitly available in the RF Module, for application to electromagnetics modeling problems. The function of the PML methodology is to add anisotropic attenuating domains (layers) outside the modeled domain, so that the modeled domain has substantially reflection-less boundaries. Examples of modeling domains with PMLs include a 2D Cartesian domain with PMLs (Figure 9.1), a 3D Cartesian domain with PMLs (Figure 9.2), a 3D spherical domain with PMLs (Figure 9.3), and a 3D cylindrical domain with PMLs (Figure 9.4). The coordinate systems employed with the domain structures are those that are associated with their respective geometries.

To achieve the desired behavior of the wave equation PDE, the entire model domain, including the perfectly matched layers, is transformed to a complex coordinate system. For a Cartesian system \((x, y, z)\), the transformation occurs as follows:

\[
\frac{\partial}{\partial x} \rightarrow \frac{1}{1 + \frac{i\sigma(x)}{\omega}} \frac{\partial}{\partial x}, \quad \frac{\partial}{\partial y} \rightarrow \frac{1}{1 + \frac{i\sigma(y)}{\omega}} \frac{\partial}{\partial y}, \quad \frac{\partial}{\partial z} \rightarrow \frac{1}{1 + \frac{i\sigma(z)}{\omega}} \frac{\partial}{\partial z}
\]

where \(\sigma(x, y, z)\) is a step function that is zero inside the solution domain and a positive real number or an appropriate function of the designated coordinate variable \((x, y, z)\) outside the solution domain and inside the PML.
FIGURE 9.2  3D Cartesian domain with PMLs

FIGURE 9.3  3D spherical domain with PMLs
The transformation of the PDE in this fashion results in a solution with a multiplicative term that is, in general, as follows:

\[
F(x, y, z) = f(x, y, z)e^{-\frac{\omega(x,y,z)}{v}}
\]  (9.2)

where \( F(x, y, z) = f(x, y, z)e^{-0} \) (the solution inside the domain)
\( F(x, y, z) = f(x, y, z)e^{-\kappa r(x,y,z)\omega} \) (the decaying solution within the PML domain)

At the outer PML boundary, the preferred boundary condition is the scattering boundary. However, if the attenuation of the propagating wave at the outer boundary of the PML is sufficient, then the particular boundary condition invoked is largely irrelevant. In such a case, the amplitude of the reflected wave will be sufficiently small as not to contribute to the final solution.
Figures 9.5 and 9.6 show examples of wave equation solutions. For an example of the wave equation solution inside the modeling domain, see Figure 9.5. For an example of the wave equation solution inside the PML domain, see Figure 9.6.
PML Models

2D Dielectric Lens Model, with PMLs

The dielectric lens is a concept borrowed from optical physics. In this application, the principles of optics are applied to lower-frequency electromagnetic waves to focus the impinging wavefront into the region of a sensor. The act of focusing the wavefront effectively amplifies the magnitude of the impinging signal.

The following numerical solution model (2D_PML_DL_1 model) is derived from a model that was originally developed by COMSOL as an RF Module tutorial model for the demonstration of the PML methodology. That model was developed for distribution with the RF Module software as part of the COMSOL RF Module Model Library.

To start building the 2D_PML_DL_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select RF Module > In-Plane Waves > TE Waves > Scattered harmonic propagation. See Figure 9.7. Click OK.
**Table 9.1 Geometry Components**

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>X</th>
<th>Y</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>2.4</td>
<td>0.2</td>
<td>Corner</td>
<td>-1.2</td>
<td>1.0</td>
<td>9.8</td>
</tr>
<tr>
<td>R2</td>
<td>2.4</td>
<td>0.2</td>
<td>Corner</td>
<td>-1.2</td>
<td>-1.2</td>
<td>9.9</td>
</tr>
<tr>
<td>R3</td>
<td>0.2</td>
<td>2.4</td>
<td>Corner</td>
<td>-1.2</td>
<td>-1.2</td>
<td>9.10</td>
</tr>
<tr>
<td>R3</td>
<td>0.2</td>
<td>2.4</td>
<td>Corner</td>
<td>1.0</td>
<td>-1.2</td>
<td>9.11</td>
</tr>
</tbody>
</table>

*NOTE* The Model Navigator command sequence (In-Plane Waves > TE Waves > Scattered harmonic propagation) selects a transverse electric field ($z$-direction) wave traveling in the plane ($x$, $y$-plane) of the modeling domain.

**Geometry Modeling**

Using the menu bar, select Draw > Specify Objects > Rectangle. In the Rectangle edit window, enter the information shown in Table 9.1. Click OK after filling in the parameters of each separate rectangle in the Rectangle edit window. See Figures 9.8–9.11.

![Figure 9.8](image1)

**FIGURE 9.8** 2D_PML_DL_1 model Rectangle (R1) edit window

![Figure 9.9](image2)

**FIGURE 9.9** 2D_PML_DL_1 model Rectangle (R2) edit window
Click the Zoom Extents button before drawing the next rectangle. Figure 9.12 shows the PML rectangles of model 2D_PML_DL_1.

Select File > Save As. Enter 2D_PML_DL_1.mph in the Save As edit window. See Figure 9.13. Click the Save button.

Using the menu bar, select Draw > Specify Objects > Circle. Enter Radius = 0.5, Base = Center, x = −0.5, and y = 0. See Figure 9.14. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter Width = 0.5, Height = 1.0, Base = Corner, x = −1.0, and y = −0.5. See Figure 9.15. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter C1-R5 in the Set formula edit window. See Figure 9.16.
**FIGURE 9.12** 2D_PML_DL_1 model PML rectangles

**FIGURE 9.13** 2D_PML_DL_1 model Save As edit window
FIGURE 9.14  2D_PML_DL_1 model Circle (C1) edit window

FIGURE 9.15  2D_PML_DL_1 model Rectangle (R5) edit window

FIGURE 9.16  2D_PML_DL_1 model Create Composite Object edit window
FIGURE 9.17 2D_PML_DL_1 model dielectric lens (C01)

Click OK. See Figure 9.17.

Using the menu bar, select Draw > Specify Objects > Square. Enter Width = 2, Base = Center, x = 0, and y = 0. See Figure 9.18. Click OK.

Figure 9.19 shows the model domain plus PMLs. Having established the geometry for the 2D_PML_DL_1 model, the next step is to define the fundamental Physics properties.
Physics Application Mode Properties: In-Plane TE Waves (rfweh)
Select Physics > Properties. Select “Free space wavelength” from the Specify wave using pull-down list. See Figure 9.20. Click OK.
Physics Application Scalar Variables: In-Plane TE Waves (rfweh)
Select Physics > Application Scalar Variables. Enter 0.5 in the \( \lambda_{0\_rfweh} \) edit window. See Figure 9.21. Click OK.

Physics Subdomain Settings: In-Plane TE Waves (rfweh)
Having established the basic Physics settings for the 2D_PML_DL_1 model, the next step is to define the fundamental Physics subdomain settings. Select Physics > Subdomain Settings. Click the PML tab. Select subdomains 1–4, 6, and 8–10 (the PMLs). Select “Cartesian” from the Type of PML pull-down list. Click the Apply button. See Figure 9.22.
Select subdomains 1–3, and 8–10 (the vertical PMLs). Check the Absorbing in x direction check box. Click the Apply button. See Figure 9.23.

Select subdomains 1, 3, 4, 6, 8, and 10 (the horizontal PMLs). Check the Absorbing in y direction check box. Click the Apply button. See Figure 9.24.
Click the Physics tab. Select subdomain 5 (the model domain). Enter $\varepsilon_r = 1$, $\sigma = 0$, and $\mu_r = 1$. Click the Apply button. See Figure 9.25.

Select subdomain 7 (the dielectric lens). Enter $\varepsilon_r = 3$, $\sigma = 0$, and $\mu_r = 1$. Click the Apply button. See Figure 9.26. Click OK.
Physics Boundary Settings: In-Plane TE Waves (rfweh)

Having established the subdomain settings for the 2D_PML_DL_1 model, the next step is to define the fundamental Physics boundary settings. Using the menu bar, select Physics > Boundary Settings. Select boundary 1. Check the Select by Group check box to select all the outer edges of the PMLs (boundaries). Select “Scattering boundary condition” from the Boundary condition pull-down list. See Figure 9.27. Click OK.

Mesh Generation

Using the menu bar, select Mesh > Free Mesh Parameters. Click the Subdomain tab. Select subdomain 7 (the dielectric lens). Enter 0.05 in the Maximum element size edit window. Select “Quad” from the Method pull-down list. See Figure 9.28.

Click the Mesh Selected button. Click the Select Remaining button. Click the Mesh Selected button. Click OK. See Figure 9.29.

Solving the 2D_PML_DL_1 Model

Using the menu bar, select Solve > Solver Parameters. Select “Parametric” in the Solver list. Enter lambda0_rfweh in the Parameter name edit window. Enter linspace(0.5,1.5,11) in the Parameter values edit window. (For later versions of the COMSOL Multiphysics software, enter range(0.5,1/10,1.5) in the Parameter values edit window.) See Figure 9.30.

Click OK. Using the menu bar, select Solve > Solve Problem.
FIGURE 9.28  2D_PML_DL_1 model subdomain Free Mesh Parameters

FIGURE 9.29  2D_PML_DL_1 model mesh
Postprocessing and Visualization

The default plot shows a surface plot of the scattered electric field, $z$-component (V/m). See Figure 9.31.

An alternative approach to viewing the effect of the dielectric lens on the plane wave within the modeling domain is to suppress the plot within the PMLs and visualize the electric field, $z$-component. Using the menu bar, select Options > Suppress > Suppress Subdomains. Select subdomains 1–4, 6, and 8–10. Click the Apply button. See Figure 9.32. Click OK.

Using the menu bar, select Postprocessing > Plot Parameters > Surface. Select “Electric field, $z$ component” from the Predefined quantities pull-down list. See Figure 9.33.
FIGURE 9.31  2D_PML_DL_1 model solution, scattered electric field, $z$-component (V/m)

FIGURE 9.32  2D_PML_DL_1 model Suppress Subdomains
Click OK. See Figure 9.34.

Using the menu bar, select Postprocessing > Plot Parameters > Animate. Verify that all the Solutions to use are selected. See Figure 9.35. Click the Start Animation button.

**2D Dielectric Lens Model, with PMLs: Summary and Conclusions**

The 2D dielectric lens model, with PMLs (2D_PML_DL_1 model), has been built and solved. This model employs PMLs and a dielectric lens to explore the geometric behavior of transverse electric field RF waves in the presence of a focusing element. It can easily be observed by watching the animation that the position and
FIGURE 9.34  2D_PML_DL_1 model electric field, z-component

intensity of the electric field, z-component varies greatly as a function of the free space wavelength.

2D Dielectric Lens Model, without PMLs

The following numerical solution model (2D_NoPML_DL_1 model) is derived from the immediately preceding model in this chapter (2D_PML_DL_1). The purpose in building this model is to empirically demonstrate the differences that are seen when PMLs are not employed.

To start building the 2D_NoPML_DL_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select RF Module > In-Plane Waves > TE Waves > Scattered harmonic propagation. See Figure 9.36. Click OK.
FIGURE 9.35  2D_PML_DL_1 model Plot Parameters, Animate tab

FIGURE 9.36  2D_NoPML_DL_1 Model Navigator setup
The Model Navigator command sequence (In-Plane Waves > TE Waves > Scattered harmonic propagation) selects a transverse electric field (z-direction) wave traveling in the plane (x, y-plane) of the modeling domain.

Select File > Save As. Enter 2D_NoPML_DL_1.mph in the Save As edit window. See Figure 9.37. Click the Save button.

**Geometry Modeling**

Using the menu bar, select Draw > Specify Objects > Circle. Enter Radius = 0.5, Base = Center, x = -0.5, and y = 0. See Figure 9.38. Click OK.
Using the menu bar, select Draw > Specify Objects > Rectangle. Enter Width = 0.5, Height = 1.0, Base = Corner, x = -1.0, and y = -0.5. See Figure 9.39. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter C1-R1 in the Set formula edit window. See Figure 9.40. Click OK. See Figure 9.41.

Using the menu bar, select Draw > Specify Objects > Square. Enter Width = 2, Base = Center, x = 0, and y = 0. See Figure 9.42.

Click OK, and then click the Zoom Extents button. See Figure 9.43.

Having established the geometry for the 2D_NoPML_DL_1 model, the next step is to define the fundamental Physics properties.
FIGURE 9.41  2D_NoPML_DL_1 model dielectric lens (CO1)

FIGURE 9.42  2D_NoPML_DL_1 model Square (SQ1) edit window
Physics Application Mode Properties: In-Plane TE Waves (rfweh)
Select Physics > Properties. Select “Free space wavelength” from the Specify wave using pull-down list. See Figure 9.44. Click OK.
Physics Application Scalar Variables: In-Plane TE Waves (rfweh)

Select Physics > Scalar Variables. Enter 0.5 in the lambda0_rfweh edit window. See Figure 9.45. Click OK.

Physics Subdomain Settings: In-Plane TE Waves (rfweh)

Having established the basic Physics settings for the 2D_NoPML_DL_1 model, the next step is to define the fundamental Physics subdomain settings. Select Physics > Subdomain Settings. Select subdomain 1 (the model domain). Enter ε_r = 1, σ = 0, and μ_r = 1. Click the Apply button. See Figure 9.46.
Select subdomain 2 (the dielectric lens). Enter $\varepsilon_r = 3$, $\sigma = 0$, and $\mu_r = 1$. Click the Apply button. See Figure 9.47. Click OK.

**Physics Boundary Settings: In-Plane TE Waves (rfweh)**

Having established the subdomain settings for the 2D_NoPML_DL_1 model, the next step is to define the fundamental Physics boundary settings. Using the menu bar, select Physics > Boundary Settings. Select boundaries 1, 2, 3, and 5 (the outer edges of the model domain). Select “Scattering boundary condition” from the Boundary condition pull-down list. See Figure 9.48. Click OK.

**Mesh Generation**

Using the menu bar, select Mesh > Free Mesh Parameters. Click the Subdomain tab. Select subdomain 2 (the dielectric lens). Enter 0.05 in the Maximum element size edit window. Select “Quad” from the Method pull-down list. See Figure 9.49.

Click the Mesh Selected button. Click the Select Remaining button. Click the Mesh Selected button. Click OK. See Figure 9.50.

**Solving the 2D_NoPML_DL_1 Model**

Using the menu bar, select Solve > Solver Parameters. Select “Parametric” in the Solver list. Enter $\lambda_{0\_rfweh}$ in the Parameter name edit window. Enter linspace(0.5,1.5,11) in the Parameter values edit window. (For later versions of the COMSOL Multiphysics software enter range(0.5,1/10,1.5) in the Parameter values edit window.) See Figure 9.51.
**FIGURE 9.48** 2D_NoPML_DL_1 model Boundary Settings

**FIGURE 9.49** 2D_NoPML_DL_1 model subdomain Free Mesh Parameters
FIGURE 9.50 2D_NoPML_DL_1 model mesh

FIGURE 9.51 2D_NoPML_DL_1 model Solver Parameters edit window
Click OK. Using the menu bar, select Solve > Solve Problem.

**Postprocessing and Visualization**

The default plot shows a surface plot of the scattered electric field, z-component (V/m). See Figure 9.52.

An alternative approach to viewing the effect of the dielectric lens on the plane wave within the modeling domain is to view the electric field, z-component. Using the menu bar, select Postprocessing > Plot Parameters > Surface. Select “Electric field, z component” from the Predefined quantities pull-down list. See Figure 9.53.
Click OK. See Figure 9.54.

Using the menu bar, select Postprocessing > Plot Parameters > Animate. Verify that all the Solutions to use are selected. See Figure 9.55. Click the Start Animation button.

2D Dielectric Lens Model, with and without PMLs: Summary and Conclusions

The 2D dielectric lens models, with and without PMLs (2D_PML_DL_1 and 2D_NoPML_DL_1, respectively) have been built and solved. The best method of comparison between the two models is to view visualizations for the electric field,
z-component for the same wavelength from each model together. Figures 9.56 through 9.61 show visualizations for 0.5 m (Figures 9.56 and 9.57), 1.0 m (Figures 9.58 and 9.59), and 1.5 m (Figures 9.60 and 9.61).

The differences in the electric field, z-component visualizations between the PML and no-PML models amount to approximately 2%. Depending on the nature of the problem, such differences may or may not be significant. What these differences show the modeler is that he or she needs to understand the application environment well to build the best model. The PML model best approximates a free space environment (no reflections). For other environments, the modeler needs to determine the best boundary condition approximation using standard practices and a first principles approach. When all else fails (or even before), do a first principles analysis of the environment before building the model.
**FIGURE 9.55** 2D_NoPML_DL_1 model Plot Parameters, Animate tab

**FIGURE 9.56** 2D_PML_DL_1 model plot electric field, z-component, 0.5 m
FIGURE 9.57  2D_NoPML_DL_1 model plot electric field, z-component, 0.5 m

FIGURE 9.58  2D_PML_DL_1 model plot electric field, z-component, 1.0 m
FIGURE 9.59  2D_NoPML_DL_1 model plot electric field, z-component, 1.0 m

FIGURE 9.60  2D_PML_DL_1 model plot electric field, z-component, 1.5 m
FIGURE 9.61 2D_NoPML_DL_1 model plot electric field, z-component, 1.5 m

2D Concave Mirror Model, with PMLs

The following numerical solution model (2D_PML_CM_1 model) is derived from the preceding dielectric lens model (2D_PML_DL_1 model). In this case, however, the electromagnetic waves interact with a fixed, curved metallic mirror. The purpose of this model (2D_PML_CM_1) and the following model (2D_NoPML_CM_1) is to demonstrate empirically the difference between having or not having PMLs at the model boundaries.

To start building the 2D_PML_CM_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select RF Module > In-Plane Waves > TE Waves > Scattered harmonic propagation. See Figure 9.62. Click OK.

The Model Navigator command sequence (In-Plane Waves > TE Waves > Scattered harmonic propagation) selects a transverse electric field (z-direction) wave traveling in the plane (x, y-plane) of the modeling domain.

Geometry Modeling

Using the menu bar, select Draw > Specify Objects > Rectangle. In the Rectangle edit window, enter the information shown in Table 9.2. Click OK after filling in the parameters.
Table 9.2  Geometry Components

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>X</th>
<th>Y</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>2.4</td>
<td>0.2</td>
<td>Corner</td>
<td>−1.2</td>
<td>1.0</td>
<td>9.63</td>
</tr>
<tr>
<td>R2</td>
<td>2.4</td>
<td>0.2</td>
<td>Corner</td>
<td>−1.2</td>
<td>−1.2</td>
<td>9.64</td>
</tr>
<tr>
<td>R3</td>
<td>0.2</td>
<td>2.4</td>
<td>Corner</td>
<td>−1.2</td>
<td>−1.2</td>
<td>9.65</td>
</tr>
<tr>
<td>R3</td>
<td>0.2</td>
<td>2.4</td>
<td>Corner</td>
<td>1.0</td>
<td>−1.2</td>
<td>9.66</td>
</tr>
</tbody>
</table>

**FIGURE 9.62**  2D_PML_CM_1 Model Navigator setup

**FIGURE 9.63**  2D_PML_CM_1 model Rectangle (R1) edit window
FIGURE 9.64 2D_PML_CM_1 model Rectangle (R2) edit window

FIGURE 9.65 2D_PML_CM_1 model Rectangle (R3) edit window

FIGURE 9.66 2D_PML_CM_1 model Rectangle (R4) edit window
of each separate rectangle in the Rectangle edit window. See Figures 9.63–9.66. Click the Zoom Extents button before drawing the next rectangle. Figure 9.67 shows the PML rectangles of model 2D_PML_CM_1.

Select File > Save As. Enter 2D_PML_CM_1.mph in the Save As edit window. See Figure 9.68. Click the Save button.

Using the menu bar, select Draw > Specify Objects > Ellipse. Enter A-semiaces = 0.3, B-semiaces = 0.5, Base = Center, x = 0, and y = 0. See Figure 9.69. Click OK.

Using the menu bar, select Draw > Specify Objects > Ellipse. Enter A-semiaces = 0.29, B-semiaces = 0.49, Base = Center, x = 0, and y = 0. See Figure 9.70. Click OK.
FIGURE 9.68 2D_PML_CM_1 model Save As edit window

FIGURE 9.69 2D_PML_CM_1 model Ellipse (E1) edit window

FIGURE 9.70 2D_PML_CM_1 model Ellipse (E2) edit window
Using the menu bar, select Draw > Specify Objects > Rectangle. Enter Width = 0.5, Height = 1.0, Base = Corner, x = −0.5, and y = −0.5. See Figure 9.71. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter E1-E2-R5 in the Set formula edit window. See Figure 9.72. Click OK. See Figure 9.73.

Using the menu bar, select Draw > Specify Objects > Square. Enter Width = 2.0, Base = Center, x = 0, and y = 0. See Figure 9.74. Click OK.

Using the menu bar, select Edit > Select All. See Figure 9.75.

Having established the geometry for the 2D_PML_CM_1 model, the next step is to define the fundamental Physics properties.
FIGURE 9.73  2D_PML_CM_1 model concave mirror (C01)

FIGURE 9.74  2D_PML_CM_1 model Square (SQ1) edit window
Physics Application Mode Properties: In-Plane TE Waves (rfweh)
Select Physics > Properties. Select “Free space wavelength” from the Specify wave using pull-down list. See Figure 9.76. Click OK.

Physics Application Scalar Variables: In-Plane TE Waves (rfweh)
Select Physics > Scalar Variables. Enter 0.5 in the lambda0_rfweh edit window. See Figure 9.77. Click OK.

Physics Subdomain Settings: In-Plane TE Waves (rfweh)
Having established the basic Physics settings for the 2D_PML_CM_1 model, the next step is to define the fundamental Physics subdomain settings. Select Physics > Subdomain Settings. Click the PML tab. Select subdomains 1–4, 6, and 8–10 (the PMLs). Select “Cartesian” from the Type of PML pull-down list. Click the Apply button. See Figure 9.78.
**FIGURE 9.76** 2D_PML_CM_1 model Application Mode Properties edit window

**FIGURE 9.77** 2D_PML_CM_1 model Application Scalar Variables (lambda0_rfweh) edit window

**FIGURE 9.78** 2D_PML_CM_1 model Subdomain Settings, PML type selection
Select subdomains 1–3, and 8–10 (the vertical PMLs). Check the Absorbing in x direction check box. Click the Apply button. See Figure 9.79.

Select subdomains 1, 3, 4, 6, 8, and 10 (the horizontal PMLs). Check the Absorbing in y direction check box. Click the Apply button. See Figure 9.80.
Click the Physics tab. Select subdomain 5 (the model domain). Enter $\varepsilon_r = 1$, $\sigma = 0$, and $\mu_r = 1$. Click the Apply button. See Figure 9.81.

Select subdomain 7 (the concave mirror). Click the Load button. Select Basic Material Properties > Copper. See Figure 9.82. Click OK.
Physics Boundary Settings: In-Plane TE Waves (rfweh)

Having established the subdomain settings for the 2D_PML_CM_1 model, the next step is to define the fundamental Physics boundary settings. Using the menu bar, select Physics > Boundary Settings. Select boundary 1. Check the Select by Group check box to select the outer edge of the PMLs (boundaries). Select “Scattering boundary condition” from the Boundary condition pull-down list. See Figure 9.84. Click OK.

Mesh Generation

Using the menu bar, select Mesh > Free Mesh Parameters. Click the Subdomain tab. Select subdomain 7 (the concave mirror). Enter 0.05 in the Maximum element size edit window. Select “Quad” from the Method pull-down list. See Figure 9.85.

Click the Mesh Selected button. Click the Select Remaining button. Click the Mesh Selected button. Click OK. See Figure 9.86.

Solving the 2D_PML_CM_1 Model

Using the menu bar, select Solve > Solver Parameters. Select “Parametric” in the Solver list. Enter lambda0_rfweh in the Parameter name edit window. Enter linspace(0.5,1.5,11) in the Parameter values edit window. (For later versions of the COMSOL Multiphysics software enter range(0.5,1/10,1.5) in the Parameter values edit window.) See Figure 9.87.

Click OK. Using the menu bar, select Solve > Solve Problem.
**FIGURE 9.84** 2D_PML_CM_1 model Boundary Settings

**FIGURE 9.85** 2D_PML_CM_1 model subdomain Free Mesh Parameters
FIGURE 9.86 2D_PML_CM_1 model mesh

FIGURE 9.87 2D_PML_CM_1 model Solver Parameters
Postprocessing and Visualization

The default plot shows a surface plot of the scattered electric field, z-component (V/m). See Figure 9.88.

An alternative approach to viewing the effect of the dielectric lens on the plane wave within the modeling domain is to suppress the plot within the PMLs and visualize the electric field, z-component. Using the menu bar, select Options > Suppress > Suppress Subdomains. Select subdomains 1–4, 6, and 8–10 (the PMLs). Click the Apply button. See Figure 9.89. Click OK.

Using the menu bar, select Postprocessing > Plot Parameters > Surface. Select “Electric field, z component” from the Predefined quantities pull-down list. See Figure 9.90.
FIGURE 9.89 2D_PML_CM_1 model Suppress Subdomains

FIGURE 9.90 2D_PML_CM_1 model Plot Parameters, Surface tab
Click OK. See Figure 9.91.

Using the menu bar, select Postprocessing > Plot Parameters > Animate. Verify that all the Solutions to use are selected. See Figure 9.92. Click the Start Animation button.

**2D Concave Mirror Model, with PMLs: Summary and Conclusions**

The 2D concave mirror model, with PMLs (2D_PML_CM_1), has been built and solved. This model employs PMLs and a concave mirror to explore the geometric behavior of transverse electric field RF waves in the presence of a metallic focusing element (concave mirror). It can easily be observed by watching the animation that the position and intensity of the electric field, \( z \)-component varies greatly as a function of the free space wavelength.
2D Concave Mirror Model, without PMLs

The following numerical solution model (2D_NoPML_CM_1 model) is derived from the preceding concave mirror model (2D_PML_CM_1 model). In this case, however, the electromagnetic waves interact with a fixed, curved metallic mirror without PMLs at the boundaries of the modeling domain. The purpose of this model (2D_NoPML_CM_1) is to demonstrate empirically the difference between having or not having PMLs at the model boundaries.

To start building the 2D_NoPML_CM_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “2D” from the Space dimension pull-down list. Select RF Module > In-Plane Waves > TE Waves > Scattered harmonic propagation. See Figure 9.93. Click OK.
The Model Navigator command sequence (In-Plane Waves > TE Waves > Scattered harmonic propagation) selects a transverse electric field ($z$-direction) wave traveling in the plane ($x, y$-plane) of the modeling domain.

Select File > Save As. Enter 2D_NoPML_CM_1.mph in the Save As edit window. See Figure 9.94. Click the Save button.

**Geometry Modeling**

Using the menu bar, select Draw > Specify Objects > Ellipse. Enter A-semiaxes = 0.3, B-semiaxes = 0.5, Base = Center, $x = 0$, and $y = 0$. See Figure 9.95. Click OK.

Using the menu bar, select Draw > Specify Objects > Ellipse. Enter A-semiaxes = 0.29, B-semiaxes = 0.49, Base = Center, $x = 0$, and $y = 0$. See Figure 9.96. Click OK.

Using the menu bar, select Draw > Specify Objects > Rectangle. Enter Width = 0.5, Height = 1.0, Base = Corner, $x = -0.5$, and $y = -0.5$. See Figure 9.97. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter E1-E2-R1 in the Set formula edit window. See Figure 9.98.
FIGURE 9.94 2D_NoPML_CM_1 model Save As edit window

FIGURE 9.95 2D_NoPML_CM_1 model Ellipse (E1) edit window

FIGURE 9.96 2D_NoPML_CM_1 model Ellipse (E2) edit window
Click OK. See Figure 9.99.

Using the menu bar, select Draw > Specify Objects > Square. Enter Width = 2.0, Base = Center, x = 0, and y = 0. See Figure 9.100.

Click OK, and then click the Zoom Extents button. See Figure 9.101.

Having established the geometry for the 2D_NoPML_CM_1 model, the next step is to define the fundamental Physics properties.

**Physics Application Mode Properties: In-Plane TE Waves (rfweh)**

Select Physics > Properties. Select “Free space wavelength” from the Specify wave using pull-down list. See Figure 9.102. Click OK.
**FIGURE 9.99** 2D_NoPML_CM_1 model concave mirror (C01)

**FIGURE 9.100** 2D_NoPML_CM_1 model Square (SQ1) edit window
**FIGURE 9.101** 2D_NoPML_CM_1 model domain

**FIGURE 9.102** 2D_NoPML_CM_1 model Application Mode Properties edit window
Physics Application Scalar Variables: In-Plane TE Waves (rfweh)

Select Physics > Scalar Variables. Enter 0.5 in the lambda0_rfweh edit window. See Figure 9.103. Click OK.

Physics Subdomain Settings: In-Plane TE Waves (rfweh)

Having established the basic Physics settings for the 2D_NoPML_CM_1 model, the next step is to define the fundamental Physics subdomain settings. Select Physics > Subdomain Settings. Click the Physics tab. Select subdomain 1 (the model domain). Enter $\varepsilon_r = 1$, $\sigma = 0$, and $\mu_r = 1$. Click the Apply button. See Figure 9.104.
Select subdomain 2 (the concave mirror). Click the Load button. Select Basic Material Properties > Copper. See Figure 9.105. Click OK.
See Figure 9.106. Click OK.
Physics Boundary Settings: In-Plane TE Waves (rfweh)
Having established the subdomain settings for the 2D_PML_CM_1 model, the next step is to define the fundamental Physics boundary settings. Using the menu bar, select Physics > Boundary Settings. Select boundaries 1, 2, 3, and 6 (the outer edges of the model domain). Select “Scattering boundary condition” from the Boundary condition pull-down list. See Figure 9.107. Click OK.

Mesh Generation
Using the menu bar, select Mesh > Free Mesh Parameters. Click the Subdomain tab. Select subdomain 2 (the concave mirror). Enter 0.05 in the Maximum element size edit window. Select “Quad” from the Method pull-down list. See Figure 9.108.

Click the Mesh Selected button. Click the Select Remaining button. Click the Mesh Selected button. Click OK. See Figure 9.109.

Solving the 2D_NoPML_CM_1 Model
Using the menu bar, select Solve > Solver Parameters. Select “Parametric” in the Solver list. Enter lambda0_rfweh in the Parameter name edit window. Enter linspace(0.5,1.5,11) in the Parameter values edit window. (For later versions of the
**FIGURE 9.108** 2D_NoPML_CM_1 model subdomain Free Mesh Parameters

**FIGURE 9.109** 2D_NoPML_CM_1 model mesh
COMSOL Multiphysics software enter range(0.5, 1.5) in the Parameter values edit window.) See Figure 9.110.

Click OK. Using the menu bar, select Solve > Solve Problem.

Postprocessing and Visualization

The default plot shows a surface plot of the scattered electric field, $z$-component (V/m). See Figure 9.111.

An alternative approach to viewing the effect of the dielectric lens on the plane wave within the modeling domain is to visualize the electric field, $z$-component.
Using the menu bar, select Postprocessing > Plot Parameters > Surface. Select “Electric field, z component” from the Predefined quantities pull-down list. See Figure 9.112.

Click OK. See Figure 9.113.

Using the menu bar, select Postprocessing > Plot Parameters > Animate. Verify that all the Solutions to use are selected. See Figure 9.114. Click the Start Animation button.

![FIGURE 9.111 2D_NoPML_CM_1 model solution, scattered electric field, z-component (V/m)](image-url)
2D Concave Mirror Model, with and without PMLs: Summary and Conclusions

The 2D concave mirror models, with and without PMLs (2D_PML_CM_1 and 2D_NoPML_CM_1, respectively), have been built and solved. The best method of comparison between the two models is to view visualizations for the electric field, $z$-component for the same wavelength from each model together. Figures 9.115 through 9.120 show visualizations for 0.5 m (Figures 9.115 and 9.116), 1.0 m (Figures 9.117 and 9.118), and 1.5 m (Figures 9.119 and 9.120).

In comparison to the dielectric lens models presented in the first half of this chapter, it is apparent that there are also only small differences in the electric field, $z$-component visualizations between the PML and no-PML models for the concave mirror. This lack of large differences between the PML and no-PML models shows
the modeler that he or she needs to understand the relative importance of the modeled values needed to evaluate the application and the application environment so as to build the best model. The PML model best approximates a free space environment (no reflections). For other environments, the modeler needs to determine the best boundary condition approximation using standard practices and a first principles approach. When all else fails (or even before), do a first principles analysis of the environment before building the model.

**FIGURE 9.113** 2D_NoPML_CM_1 model electric field, z-component

Why do the solutions of the two dielectric lens models differ significantly and the solutions of the two concave mirror models converge to similar solutions? Consider the fact that a lossless dielectric is electromagnetically transparent and a metal mirror (e.g., copper) is electromagnetically opaque. Then a first principles analysis should answer the question.
FIGURE 9.114  2D_NoPML_CM_1 model Plot Parameters, Animate tab
FIGURE 9.115 2D_PML_CM_1 model plot electric field, z-component, 0.5 m
FIGURE 9.116 2D_NoPML_CM_1 model plot electric field, z-component, 0.5 m
FIGURE 9.117 2D_PML_CM_1 model plot electric field, z-component, 1.0 m
FIGURE 9.118 2D_NoPML_CM_1 model plot electric field, z-component, 1.0 m
**FIGURE 9.119** 2D_PML_CM_1 model plot electric field, z-component, 1.5 m
References


### Exercises

1. Build, mesh, and solve the 2D dielectric lens model, with PMLs, problem presented in this chapter.

2. Build, mesh, and solve the 2D dielectric lens model, without PMLs, problem presented in this chapter.

3. Build, mesh, and solve the 2D concave mirror model, with PMLs, problem presented in this chapter.

4. Build, mesh, and solve the 2D concave mirror model, without PMLs, problem presented in this chapter.

5. Explore other materials as applied in the 2D dielectric lens model, with PMLs.

6. Explore other materials as applied in the 2D dielectric lens model, without PMLs.

7. Explore other materials as applied in the 2D concave mirror model, with PMLs.

8. Explore other materials as applied in the 2D concave mirror model, without PMLs.

9. Explore the different geometries in the 2D dielectric lens model, with PMLs.

10. Explore the different geometries in the 2D concave mirror model, with PMLs.
Bioheat Models

In This Chapter

Bioheat Modeling Guidelines and Coordinate Considerations
  Bioheat Equation Theory
Tumor Laser Irradiation Theory
  2D Axisymmetric Tumor Laser Irradiation Model
  2D Axisymmetric Tumor Laser Irradiation Model: Summary and Conclusions
Microwave Cancer Therapy Theory
  2D Axisymmetric Microwave Cancer Therapy Model
  2D Axisymmetric Microwave Cancer Therapy Model: Summary and Conclusions

Bioheat Modeling Guidelines and Coordinate Considerations

Bioheat Equation Theory

For the new modeler or those readers unfamiliar with this topic, bioheat modeling is the development of models for the analysis of heat transfer in materials (e.g., tissues, fluids) and systems derived from or related to currently or previously living organisms. The solution of the bioheat equation as applied to particular models is most important, obviously, when those models are developed to explore potential techniques for critical therapeutic applications (e.g., destroying cancer cells, killing tumors).

In August 1948, Harry H. Pennes published his landmark paper “Analysis of Tissue and Arterial Blood Temperatures in the Resting Human Forearm.” In that paper, he proposed that heat flow is proportional to the difference in temperature between the arterial blood and the local tissue. Pennes’s work is considered fundamental in this area of study and has since been cited extensively.

In the COMSOL® Multiphysics® software, the bioheat equation (Pennes equation) takes the form of an application mode within the Heat Transfer Module. In the Bioheat Equation Application Mode, the bioheat equation is formulated as follows:

\[
\delta_{ts} \rho C \frac{\partial T}{\partial t} + \nabla \cdot (-k \nabla T) = \rho_b c_b \omega_b (T_b - T) + Q_{met} + Q_{ext} \quad (10.1)
\]
where

- \( \delta_{ts} \) = time-scaling coefficient (default value = 1; dimensionless)
- \( \rho \) = tissue density (kg/m\(^3\))
- \( C \) = tissue heat capacity [J/(kg \cdot K)]
- \( T \) = temperature (K)
- \( k \) = tissue thermal conductivity tensor [W/(m \cdot K)]
- \( \rho_b \) = blood density (kg/m\(^3\))
- \( C_b \) = blood heat capacity [J/(kg \cdot K)]
- \( \omega_b \) = blood perfusion rate [m\(^3\)/(m\(^3\) \cdot s)]
- \( T_b \) = temperature, arterial blood (K)
- \( Q_{met} \) = metabolic heat source (W/m\(^3\))
- \( Q_{ext} \) = external environmental heat source (W/m\(^3\))

### Note

The perfusion rate is the rate at which a fluid (e.g., blood) flows through a type of tissue (e.g., muscle, heart, liver). It is, of course, very important to know the correct perfusion value for the tissue/fluid type in question.

Even though equation 10.1 is shown as formulated for blood flow, it can be equally well employed for other fluids or fluid compositions under the appropriate circumstances (e.g., artificial blood, different animal-life fluids). When employing variations of the formulation of the bioheat equation, modelers need to carefully verify the underlying assumptions employed in their particular model.

The bioheat equation is similar to the conduction heat equation. In the case of steady-state heat flow, the first term on the left vanishes:

\[
\delta_{ts}\rho C \frac{\partial T}{\partial t} = 0
\]  

(10.2)

In the bioheat equation, what would normally be the single heat source term on the left side of the heat conduction equation \( Q \) is now separated into three terms.

The perfusion term: \( \rho_b C_b \omega_b (T_b - T) \)  
(10.3)

The metabolic term: \( Q_{met} \)  
(10.4)

The external source term: \( Q_{ext} \)  
(10.5)

### Note

The division of the normally single heat source term in the bioheat equation into three terms is done to facilitate a conceptual linkage and to ease the formulation of the PDE when creating models for this type of problem (biological).

The bioheat equation, as constructed by Pennes, constitutes a good first-order approximation to the physical processes (thermal conduction) involved in the solution...
of the heat transfer problem for biological specimens. This formulation is typically adequate for the modeling of most biological problems. More terms can, of course, be added if perceived as necessary, albeit at the risk of increased complexity, associated model size, and computational time.

However, because the bioheat equation already serves the needed level of accuracy for a typical decision point, little additional beneficial knowledge will be gained from the addition of second-order effects to the equation, considering the intrinsic fundamental limits of most biological system model problems.

### Tumor Laser Irradiation Theory

The optical coefficient of absorption for laser photons (irradiation) of tumors does not generally differ significantly from the optical coefficient of absorption for the surrounding tissue. To develop this laser irradiation therapeutic methodology, it is necessary to raise the local absorption coefficient by artificial means. The change in absorption coefficient is accomplished by injection into the tumor of a designed high-absorption material.

This type of procedure is usually designated as a minimally invasive procedure.

The laser beam energy contributes a heat source to the bioheat equation as follows:

\[
Q_{\text{laser}} = I_0 a e^{a z - \frac{r^2}{2\sigma^2}}
\]

(10.6)

where

- \( I_0 \) = irradiation intensity (W/m²)
- \( a \) = absorptivity (1/m)
- \( \sigma \) = irradiated region width parameter (m)

### 2D Axisymmetric Tumor Laser Irradiation Model

The following numerical solution model (2D_Bio_TLI_1 model) is derived from a model that was originally developed by COMSOL as a Heat Transfer Module tutorial model for the demonstration of the solution of a bioheat equation model. That model was developed for distribution with the Heat Transfer Module software as part of the COMSOL Heat Transfer Module Model Library.

The bioheat equation is a valuable approach for calculating the efficacy of potential treatment methodologies. The guiding principle needs to be that tumor cells die at elevated temperatures. The literature cites temperatures that range from 42 °C (315.15 K) to 60 °C (333.15 K). If the postulated method raises the local temperature of the tumor cells, without excessively raising the temperature of the normal cells, then the proposed method will probably be successful.
This first model takes advantage of the transparency of human tissue in certain infrared (IR) wavelengths. Figure 10.1 shows the structure of the modeling domain. Because the model is created as a 2D axisymmetric model, only the right half of the structure will be used in the calculations.

To start building the 2D_Bio_TLI_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select Heat Transfer Module > Bioheat Equation > Transient analysis. See Figure 10.2. Click OK.

Constants
Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 10.1; see also Figure 10.3. Click OK.

Geometry Modeling
Using the menu bar, select Draw > Specify Objects > Rectangle. In the Rectangle edit window, enter the information shown in Table 10.2. Click OK after filling in the parameters of each separate rectangle in the Rectangle edit window. See Figures 10.4 and 10.5.
Table 10.1 Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rho_blood</td>
<td>1000[kg/m^3]</td>
<td>Density blood</td>
</tr>
<tr>
<td>C_blood</td>
<td>4200[J/(kg*K)]</td>
<td>Heat capacity blood</td>
</tr>
<tr>
<td>T_blood</td>
<td>37[degC]</td>
<td>Temperature blood</td>
</tr>
<tr>
<td>k_skin</td>
<td>0.2[W/(m*K)]</td>
<td>Thermal conductivity skin</td>
</tr>
<tr>
<td>rho_skin</td>
<td>1200[kg/m^3]</td>
<td>Density skin</td>
</tr>
<tr>
<td>C_skin</td>
<td>3600[J/(kg*K)]</td>
<td>Heat capacity skin</td>
</tr>
<tr>
<td>wb_skin</td>
<td>3e-3[1/s]</td>
<td>Blood perfusion rate skin</td>
</tr>
<tr>
<td>k_tissue</td>
<td>0.5[W/(m*K)]</td>
<td>Thermal conductivity tissue</td>
</tr>
<tr>
<td>rho_tissue</td>
<td>1050[kg/m^3]</td>
<td>Density tissue</td>
</tr>
<tr>
<td>C_tissue</td>
<td>3600[J/(kg*K)]</td>
<td>Heat capacity tissue</td>
</tr>
<tr>
<td>wb_tissue</td>
<td>6e-3[1/s]</td>
<td>Blood perfusion rate tissue</td>
</tr>
<tr>
<td>k_tumor</td>
<td>0.5[W/(m*K)]</td>
<td>Thermal conductivity tumor</td>
</tr>
<tr>
<td>rho_tumor</td>
<td>1050[kg/m^3]</td>
<td>Density tumor</td>
</tr>
<tr>
<td>C_tumor</td>
<td>3600[J/(kg*K)]</td>
<td>Heat capacity tumor</td>
</tr>
<tr>
<td>wb_tumor</td>
<td>6e-3[1/s]</td>
<td>Blood perfusion rate tumor</td>
</tr>
<tr>
<td>Q_met</td>
<td>400[W/m^3]</td>
<td>Metabolic heat generation</td>
</tr>
<tr>
<td>T0</td>
<td>37[degC]</td>
<td>Temperature reference blood</td>
</tr>
<tr>
<td>h_conv</td>
<td>10[W/(m^2*K)]</td>
<td>Heat transfer coefficient skin</td>
</tr>
<tr>
<td>T_inf</td>
<td>10[degC]</td>
<td>Temperature domain boundary</td>
</tr>
<tr>
<td>I0</td>
<td>1.4[W/mm^2]</td>
<td>Laser irradiation power</td>
</tr>
<tr>
<td>sigma</td>
<td>5[mm]</td>
<td>Laser beam width coefficient</td>
</tr>
</tbody>
</table>
CHAPTER 10  BIOHEAT MODELS

FIGURE 10.3  2D_Bio_TLI_1 model Constants (R1) edit window

Table 10.2  Geometry Components

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>r</th>
<th>z</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.1</td>
<td>0.09</td>
<td>Corner</td>
<td>-0.05</td>
<td>-0.1</td>
<td>10.4</td>
</tr>
<tr>
<td>R2</td>
<td>0.1</td>
<td>0.01</td>
<td>Corner</td>
<td>-0.05</td>
<td>-0.01</td>
<td>10.5</td>
</tr>
</tbody>
</table>

FIGURE 10.4  2D_Bio_TLI_1 model Rectangle (R1) edit window
Click the Zoom Extents button. See Figure 10.6.
Select File > Save As. Enter 2D_Bio_TLI_1.mph in the Save As edit window. See Figure 10.7. Click the Save button.
Using the menu bar, select Draw > Specify Objects > Circle. Enter Radius = 0.005, Base = Center, r = 0, and z = −0.05. See Figure 10.8. Click OK.
Using the menu bar, select Draw > Specify Objects > Rectangle. Enter Width = 0.05, Height = 0.1, Base = Corner, r = -0.05, and z = -0.1. See Figure 10.9. Click OK.

Using the menu bar, select Draw > Create Composite Object. Enter R1+R2+C1−R3 in the Set formula edit window. Check the Keep interior boundaries check box. See Figure 10.10.
Click OK. See Figure 10.11.

Having established the geometry for the 2D_Bio_TLI_1 model, the next step is to define the fundamental Physics properties.

**Physics Settings: Scalar Expressions**

Select Options > Expressions > Scalar Expressions. Enter Name = Q_laser. Enter Expression = \( I0*a*\exp(a*z-r^2/(2*sigma^2)) \). See Figure 10.12. Click OK.

**Physics Settings: Subdomain Expressions**

Select Options > Expressions > Subdomain Expressions.

**NOTE** In the entries in the Subdomain Expressions window, the variable Name \( a \) needs to be entered only once, as indicated by the following instructions.
FIGURE 10.11 2D_Bio_TLI_1 model domain: skin, tissue, and tumor (CO1)

FIGURE 10.12 2D_Bio_TLI_1 model Scalar Expressions edit window
For subdomain 1, enter Name = \( a \), Expression = \( 0.1 \text{[1/m]} \). See Figure 10.13.
For subdomain 2, enter Expression = \( 4 \text{[1/m]} \). See Figure 10.14.
For subdomain 3, enter Expression = \( 0.1 \text{[1/m]} \). See Figure 10.15.
Click OK.
Table 10.3 Subdomain Settings

<table>
<thead>
<tr>
<th>Name</th>
<th>Subdomain 1</th>
<th>Subdomain 2</th>
<th>Subdomain 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>k (isotropic)</td>
<td>k_tissue</td>
<td>k_tumor</td>
<td>k_skin</td>
</tr>
<tr>
<td>ρ</td>
<td>rho_tissue</td>
<td>rho_tumor</td>
<td>rho_skin</td>
</tr>
<tr>
<td>C</td>
<td>C_tissue</td>
<td>C_tumor</td>
<td>C_skin</td>
</tr>
<tr>
<td>ρ_b</td>
<td>rho_blood</td>
<td>rho_blood</td>
<td>rho_blood</td>
</tr>
<tr>
<td>C_b</td>
<td>C_blood</td>
<td>C_blood</td>
<td>C_blood</td>
</tr>
<tr>
<td>ω_b</td>
<td>wb_tissue</td>
<td>wb_tumor</td>
<td>wb_skin</td>
</tr>
<tr>
<td>T_b</td>
<td>T_blood</td>
<td>T_blood</td>
<td>T_blood</td>
</tr>
<tr>
<td>Q_met</td>
<td>Q_met</td>
<td>Q_met</td>
<td>Q_met</td>
</tr>
<tr>
<td>Q_ext</td>
<td>Q_laser</td>
<td>Q_laser</td>
<td>Q_laser</td>
</tr>
</tbody>
</table>

**Physics Subdomain Settings: Bioheat Equation (htbh)**

Having established the basic Physics settings for the 2D_Bio_TLI_1 model, the next step is to define the fundamental Physics subdomain setting. Using the menu bar, select Physics > Subdomain Settings. In the Subdomain Settings edit window, enter the information shown in Table 10.3 and Figures 10.16, 10.17, and 10.18. Click the Apply button after filling in the parameters of each separate subdomain in the subdomain edit window.
FIGURE 10.17  2D_Bio_TLI_1 model Subdomain Settings (2) edit window

FIGURE 10.18  2D_Bio_TLI_1 model Subdomain Settings (3) edit window
Select subdomains 1, 2, and 3. Click the Init tab. Enter T0 in the Initial value edit window. Click the Apply button. See Figure 10.19. Click OK.

**Physics Boundary Settings: Bioheat Equation (htbh)**

Having established the subdomain settings for the 2D_Bio_TL1_1 model, the next step is to define the fundamental Physics boundary settings. Using the menu bar, Select Physics > Boundary Settings. In the Boundary Settings edit window, enter the information shown in Table 10.4. Click the Apply button after choosing or entering the

<table>
<thead>
<tr>
<th>Table 10.4</th>
<th>Boundary Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary</td>
<td>Boundary Condition</td>
</tr>
<tr>
<td>1, 3–5</td>
<td>Axial symmetry</td>
</tr>
<tr>
<td>2, 8, 9</td>
<td>Thermal insulation</td>
</tr>
<tr>
<td>7</td>
<td>Heat flux</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
parameters of each Boundary Settings group in the Boundary Settings edit window. Click OK. See Figures 10.20, 10.21, and 10.22.

Mesh Generation

Using the menu bar, select Mesh > Free Mesh Parameters. Click the Subdomain tab. Select subdomain 2 (the tumor). Enter 0.005 in the Maximum element size edit window. Select “Quad” from the Method pull-down list. See Figure 10.23.
FIGURE 10.22 2D_Bio_TLI_1 model Boundary Settings (7) edit window

FIGURE 10.23 2D_Bio_TLI_1 model Free Mesh Parameters, subdomain 2 edit window
Click the Mesh Selected button. Click the Select Remaining button. Click the Mesh Selected button. Click OK. See Figure 10.24.

Solving the 2D_Bio_TLI_1 Model
Using the menu bar, select Solve > Solver Parameters. Select “Time dependent” in the Solver list. Enter 0:10:600 in the Times edit window. See Figure 10.25.
  Click OK. Using the menu bar, select Solve > Solve Problem.

Postprocessing and Visualization
The default plot shows a surface plot of the temperature (K). See Figure 10.26.
  Typically, such analytical plots are viewed in degrees Centigrade. The plot can be easily converted through the following steps. Using the menu bar, Select
FIGURE 10.25  2D_Bio_TLI_1 model Solver Parameters edit window

FIGURE 10.26  2D_Bio_TLI_1 model solution, temperature (K)
Postprocessing > Plot Parameters > Surface. Select “degC (°C)” from the Unit pull-down list. See Figure 10.27.

Click OK. See Figure 10.28.

**NOTE** The bioheat equation is a valuable approach for calculating the efficacy of potential treatment methodologies. The guiding principle needs to be that tumor cells die at elevated temperatures. The literature cites temperatures that range from 42 °C (315.15 K) to 60 °C (333.15 K).6 If the postulated method raises the local temperature of the tumor cells, without excessively raising the temperature of the normal cells, then the proposed method will probably be successful.
Now that the 2D_Bio_TLI_1 model has been successfully calculated, the modeler can determine the time to reach the desired temperature for a preliminary estimate of an effective treatment. Final determination of the veracity of the calculation will, of course, need to be made experimentally. The results (estimated time values) from the model calculations will significantly reduce the effort needed to determine an accurate experimental value.

To determine the time to the desired temperature of 60 °C at the boundary of the tumor, proceed as follows. Using the menu bar, select Postprocessing > Domain Plot Parameters. Click the Point tab. Select point 6 in the Point selection window. Select “Temperature” from the Predefined quantities pull-down list. Select “degC (°C)” from the Unit pull-down list. See Figure 10.29.

Click OK. Figure 10.30 shows that the time to 60 (°C at the boundary of the tumor is approximately 220 seconds under the specified conditions of this model).
FIGURE 10.29 2D_Bio_TLI_1 model Domain Plot Parameters, Point tab

FIGURE 10.30 2D_Bio_TLI_1 model, time to temperature
The development of the entire model can be viewed by following these steps. Using the menu bar, select Postprocessing > Plot Parameters > Animate. Select all solutions in the Solutions to use window. See Figure 10.31.

Click the Start Animation button. See Figure 10.32.

**2D Axisymmetric Tumor Laser Irradiation Model: Summary and Conclusions**

The bioheat equation is a valuable approach for calculating the efficacy of potential treatment methodologies. Now that the 2D_Bio_TLI_1 model has been successfully calculated, the modeler can determine the time to reach the desired temperature for a preliminary estimate of an effective treatment. Final determination of the veracity of
the calculation will, of course, need to be made experimentally. The literature cites temperatures that range from $42 \degree C (315.15 K)$ to $60 \degree C (333.15 K)$.\textsuperscript{6}

If the postulated method raises the local temperature of the tumor cells, without excessively raising the temperature of the normal cells, then the proposed method will probably be successful. The results (estimated time values) from the model calculations will significantly reduce the effort needed to determine an accurate experimental value. The guiding principle needs to be that tumor cells die at elevated temperatures.

\section*{Microwave Cancer Therapy Theory}

Hyperthermic (high-temperature) oncology (cancer, tumor)\textsuperscript{8} involves the use of elevated temperatures to kill cancer and other tumor cells. As discussed in the previous model, it is necessary to locally raise the temperature of the cancer/tumor cells, without doing significant damage to the normal (healthy) cells surrounding the tumor. In the previous model, the energy was supplied as photothermal energy using laser irradiation. In this model, the externally applied energy is supplied through the use of a
specialized microwave antenna and the application of Ohm’s and Joule’s Laws. This type of procedure is typically designated as a minimally invasive procedure. Figure 10.33 shows the microwave antenna in cross section.

**2D Axisymmetric Microwave Cancer Therapy Model**

The following numerical solution model (2D_Bio_MCT_1 model) is derived from a model that was originally developed by COMSOL as a Heat Transfer Module tutorial model for the demonstration of the solution of a bioheat equation model. That model was developed for distribution with the Heat Transfer Module software as part of the COMSOL Heat Transfer Module Model Library.

The bioheat equation is a valuable approach for calculating the efficacy of potential treatment methodologies. The guiding principle needs to be that tumor cells die at elevated temperatures. The literature cites temperatures that range from 42 °C (315.15 K) to 60 °C (333.15 K). If the postulated method raises the local temperature of the tumor cells, without excessively raising the temperature of the normal cells, then the proposed method will probably be successful.

This model takes advantage of the conductivity of human tissue. Figure 10.34 shows the microwave antenna in cross section, embedded in the modeling domain (tissue) and radiating power. Because the model is created as a 2D axisymmetric model, only the right half of the structure is used in the calculations.
To start building the 2D_Bio_MCT_1 model, activate the COMSOL Multiphysics software. In the Model Navigator, select “Axial symmetry (2D)” from the Space dimension pull-down list. Select Heat Transfer Module > Bioheat Equation > Steady-state analysis. Click the Multiphysics button, and then click the Add button. See Figure 10.35.
Select RF Module > Electromagnetic Waves > TM Waves > Harmonic propagation. Select “Lagrange-Quartic” from the Element pull-down list. Click the Add button. See Figure 10.36. Click OK.

To verify the Lagrange-Quartic choice, the modeler can at any time go to the menu bar, select “Model Navigator,” select the Application mode of choice, click on the Application Mode Properties button, and then verify the setting of choice.

Constants
Using the menu bar, select Options > Constants. In the Constants edit window, enter the information shown in Table 10.5; see also Figure 10.37. Click OK.

Using the menu bar, select File > Save As. Enter 2D_Bio_MCT_1.mph in the Save As edit window. See Figure 10.38. Click the Save button.

Geometry Modeling
Using the menu bar, select Draw > Specify Objects > Rectangle. In the Rectangle edit window, enter the information shown in Table 10.6. Click OK after filling in the parameters of each separate rectangle in the Rectangle edit window. See Figures 10.39 and 10.40.
Table 10.5  Constants Edit Window

<table>
<thead>
<tr>
<th>Name</th>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>k_liver</td>
<td>0.56 [W/(m*K)]</td>
<td>Thermal conductivity liver</td>
</tr>
<tr>
<td>rho_blood</td>
<td>1.0e3 [kg/m^3]</td>
<td>Density blood</td>
</tr>
<tr>
<td>C_blood</td>
<td>3639 [J/(kg*K)]</td>
<td>Heat capacity blood</td>
</tr>
<tr>
<td>omega_blood</td>
<td>3.6e-3 [1/s]</td>
<td>Blood perfusion rate</td>
</tr>
<tr>
<td>T_blood</td>
<td>37 [degC]</td>
<td>Temperature blood</td>
</tr>
<tr>
<td>P_in</td>
<td>10 [W]</td>
<td>Microwave power input</td>
</tr>
<tr>
<td>nu</td>
<td>2.45 [GHz]</td>
<td>Microwave frequency</td>
</tr>
<tr>
<td>eps_diel</td>
<td>2.03</td>
<td>Dielectric relative permittivity</td>
</tr>
<tr>
<td>eps_cat</td>
<td>2.6</td>
<td>Catheter relative permittivity</td>
</tr>
<tr>
<td>eps_liver</td>
<td>43.03</td>
<td>Liver relative permittivity</td>
</tr>
<tr>
<td>sig_liver</td>
<td>1.69 [S/m]</td>
<td>Conductivity liver</td>
</tr>
</tbody>
</table>

**FIGURE 10.37** 2D_Bio_MCT_1 model Constants edit window

**FIGURE 10.38** 2D_Bio_MCT_1 model Save As edit window
Table 10.6  Geometry Components

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>r</th>
<th>z</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.595e-3</td>
<td>0.01</td>
<td>Corner</td>
<td>0</td>
<td>0</td>
<td>10.39</td>
</tr>
<tr>
<td>R2</td>
<td>29.405e-3</td>
<td>0.08</td>
<td>Corner</td>
<td>0.595e-3</td>
<td>1.25e-30</td>
<td>10.40</td>
</tr>
</tbody>
</table>

Click the Zoom Extents button. See Figure 10.41.

Using the menu bar, select Draw > Create Composite Object. Enter R1+R2 in the Set formula edit window. Uncheck the Keep interior boundaries check box. See Figure 10.42.

Click OK. See Figure 10.43.

The composite object (CO1) created through these steps forms the modeling domain that constitutes the liver tissue.
FIGURE 10.41 2D_Bio_MCT_1 model rectangles (R1, R2)

FIGURE 10.42 2D_Bio_MCT_1 model Create Composite Object edit window
Using the menu bar, select Draw > Specify Objects > Rectangle. In the Rectangle edit window, enter the information shown in Table 10.7. Click OK after filling in the parameters of each separate rectangle in the Rectangle edit window. See Figures 10.44 and 10.45.

Using the menu bar, select Draw > Create Composite Object. Enter R1+R2 in the Set formula edit window. Uncheck the Keep interior boundaries check box. See Figure 10.46. Click OK.

| **Table 10.7  Geometry Components** |

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Height</th>
<th>Base</th>
<th>r</th>
<th>z</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>0.125e-3</td>
<td>1.0e-3</td>
<td>Corner</td>
<td>0.47e-3</td>
<td>0.0155</td>
<td>10.44</td>
</tr>
<tr>
<td>R2</td>
<td>3.35e-4</td>
<td>0.0699</td>
<td>Corner</td>
<td>0.135e-3</td>
<td>0.0101</td>
<td>10.45</td>
</tr>
</tbody>
</table>
Figure 10.44  2D_Bio_MCT_1 model Rectangle (R1) edit window

Figure 10.45  2D_Bio_MCT_1 model Rectangle (R2) edit window

Figure 10.46  2D_Bio_MCT_1 model Create Composite Object edit window
The composite object created through these steps (CO2) forms the modeling domain that constitutes the antenna dielectric.

Next, add a line to the geometry. Using the menu bar, select Draw > Specify Objects > Line. In the r edit window, enter 0 8.95e-4 8.95e-4. In the z edit window, enter 9.5e-3 0.01 0.08. See Figure 10.47. Click OK.

The line created through these steps forms the boundary of the antenna sheath.

Add the last rectangle to the geometry. Using the menu bar, select Draw > Specify Objects > Rectangle. In the Rectangle edit window, enter the information shown in Table 10.8. Click OK after filling in the parameters of the rectangle in the Rectangle edit window. See Figure 10.48.
The rectangle created through these steps forms the modeling domain that constitutes the slot in the coaxial antenna that allows energy to be radiated into the liver tissue.

Click OK. See Figure 10.49.

Having established the geometry for the 2D_Bio_MCT_1 model, the next step is to define the fundamental Physics properties.

**Physics Settings: Bioheat Equation (htbh)**

Using the menu bar, select Multiphysics > 1 Bioheat Equation (htbh). Select Physics > Subdomain Settings. Select subdomains 2, 3, and 4. Uncheck the Active in this domain check box. See Figure 10.50. Click the Apply button.
Select subdomain 1. In the subdomain 1 edit window, enter the information as shown in Table 10.9. Click OK after filling in the parameters of the rectangle in the Rectangle edit window.

The metabolic energy ($Q_{\text{met}}$) is sufficiently small, relative to the microwave energy, that it can be ignored in this model. Thus it is set to zero.

Click the Apply button. See Figure 10.51. Click OK.

<table>
<thead>
<tr>
<th>Table 10.9 Subdomain 1 Settings</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Name</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>$k$ (isotropic)</td>
<td>$k_{\text{Liver}}$</td>
</tr>
<tr>
<td>$\rho_b$</td>
<td>$\rho_{\text{Blood}}$</td>
</tr>
<tr>
<td>$C_b$</td>
<td>$C_{\text{Blood}}$</td>
</tr>
<tr>
<td>$\omega_b$</td>
<td>$\omega_{\text{Blood}}$</td>
</tr>
<tr>
<td>$T_b$</td>
<td>$T_{\text{Blood}}$</td>
</tr>
<tr>
<td>$Q_{\text{met}}$</td>
<td>0</td>
</tr>
<tr>
<td>$Q_{\text{ext}}$</td>
<td>$Q_{\text{av_rfwh}}$</td>
</tr>
</tbody>
</table>
Physics Boundary Settings: Bioheat Equation (htbh)

Having established the bioheat equation subdomain settings for the 2D_Bio_MCT_1 model, the next step is to define the bioheat equation physics boundary settings.

Using the menu bar, select Physics > Boundary Settings. Select boundary 1. Check the Select by group check box.

Select “Thermal insulation” from the Boundary condition pull-down list. See Figure 10.52. Click OK.
The thermal insulation boundary condition can be employed because most of the heat energy is removed by perfusion, rather than by conduction through the boundaries.

Physics Settings: 2 TM Waves (rfwh), Scalar Variables
Using the menu bar, select Multiphysics > 2 TM Waves (rfwh). Using the menu bar, select Physics > Scalar Variables. Enter nu in the nu_rfwh (Frequency) edit window. See Figure 10.53. Click OK.

Physics Settings: 2 TM Waves (rfwh), Subdomain Settings
Using the menu bar, select Physics > Subdomain Settings. In the Subdomain Settings edit window, enter the information shown in Table 10.10 and Figures 10.54 through 10.57. Click the Apply button after filling in the parameters of each separate subdomain in the Subdomain settings edit window. Click OK.

Physics Settings: 2 TM Waves (rfwh), Boundary Settings
Using the menu bar, select Physics > Boundary Settings. In the Boundary Settings edit window, enter the information as shown in Table 10.11. Click the Apply button after choosing or entering the parameters of each Boundary Settings group in the Boundary Settings edit windows. Click OK. See Figures 10.58–10.62.

<table>
<thead>
<tr>
<th>Table 10.10</th>
<th>Subdomain Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>Subdomain 1</td>
</tr>
<tr>
<td>$\varepsilon_r$ (isotropic)</td>
<td>eps_liver</td>
</tr>
<tr>
<td>$\sigma$ (isotropic)</td>
<td>sig_liver</td>
</tr>
<tr>
<td>$\mu_r$</td>
<td>1</td>
</tr>
</tbody>
</table>
### Table 10.11  Boundary Settings

<table>
<thead>
<tr>
<th>Boundary</th>
<th>Boundary Condition</th>
<th>Wave Type</th>
<th>Value</th>
<th>Figure Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>1, 3</td>
<td>Axial symmetry</td>
<td>—</td>
<td>—</td>
<td>10.58</td>
</tr>
<tr>
<td>2, 14, 18, 20, 21</td>
<td>Scattering boundary condition</td>
<td>Spherical</td>
<td>—</td>
<td>10.59</td>
</tr>
<tr>
<td>5–7, 9, 11–13, 15, 17</td>
<td>Perfect electric conductor</td>
<td>—</td>
<td>—</td>
<td>10.60</td>
</tr>
<tr>
<td>8</td>
<td>Port</td>
<td>Wave excitation selected</td>
<td>P_in</td>
<td>10.61</td>
</tr>
<tr>
<td>8</td>
<td>Port tab</td>
<td>—</td>
<td>Coaxial</td>
<td>10.62</td>
</tr>
</tbody>
</table>

**FIGURE 10.54**  2D_Bio_MCT_1 model, Subdomain Settings (1) edit window

**FIGURE 10.55**  2D_Bio_MCT_1 model, Subdomain Settings (2) edit window
Mesh Generation

Using the menu bar, select Mesh > Free Mesh Parameters. Click the Custom mesh size radio button. Enter 3e-3 in the Maximum element size edit window. Click the Apply button. See Figure 10.63.
FIGURE 10.58  2D_Bio_MCT_1 model Boundary Settings (1, 3) edit window

FIGURE 10.59  2D_Bio_MCT_1 model Boundary Settings (2, 14, 18, 20, 21) edit window
FIGURE 10.60  2D_Bio_MCT_1 model Boundary Settings (5–7, 9, 11–13, 15, 17) edit window

FIGURE 10.61  2D_Bio_MCT_1 model Boundary Settings (8) edit window
FIGURE 10.62 2D_Bio_MCT_1 model Boundary Settings (8), Port tab edit window

FIGURE 10.63 2D_Bio_MCT_1 model Free Mesh Parameters, Global tab
Click the Subdomain tab. Select subdomain 3. Enter 1.5e-4 in the Maximum element size edit window. See Figure 10.64.

Click the Remesh button, and then click OK. See Figure 10.65.

Solving the 2D_Bio_MCT_1 Model
Using the menu bar, select Solve > Solver Parameters. Select “Parametric” from the solver list. Enter P_in in the Parameter name edit window. Enter 2:0.5:10 in the Parameter values edit window. Click the Apply button. See Figure 10.66.

Click OK. Using the menu bar, select Solve > Solve Problem.

Postprocessing and Visualization
The default plot shows a surface plot of the temperature (K). See Figure 10.67.

Typically, such analytical plots are viewed in degrees Centigrade. The plot can be easily converted through the following steps. Using the menu bar, select Postprocessing > Plot Parameters > Surface. Select “degC (°C)” from the Unit pull-down list. See Figure 10.68.

Click OK. See Figure 10.69.

The bioheat equation is a valuable approach for calculating the efficacy of potential treatment methodologies. The guiding principle needs to be that tumor cells die at elevated temperatures. The literature cites temperatures that range from 42 °C (315.15 K) to 60 °C (333.15 K). If the postulated method raises the local temperature of
FIGURE 10.65 2D_Bio_MCT_1 model mesh

FIGURE 10.66 2D_Bio_MCT_1 model Solver Parameters
the tumor cells, without excessively raising the temperature of the normal cells, then the proposed method will probably be successful.

Now that the 2D_Bio_MCT_1 model has been successfully calculated, the modeler can determine the temperature for a preliminary estimate of the input power. Final determination of the veracity of the calculation will, of course, need to be made experimentally. The results (solutions at different input powers) from the model calculations will significantly reduce the effort needed to determine an accurate initial experimental value.

It can readily be seen in the solution of the 2D_Bio_MCT_1 model at 10 W that the peak temperature in the region immediately adjacent to the antenna may be higher (approximately 100 °C) than desired. The range of solutions for powers from 2 W to 10 W is easily viewed for selection. Using the menu bar, select Postprocessing >
Cross-Section Plot Parameters > General. Select all of the solutions in the Solutions to use selection window. See Figure 10.70.

Click the Line/Extrusion tab. Select “degC (°C)” from the Unit pull-down list. Select “r” from the x-axis data pull-down list. Enter $r_0 = 0$, and $r_1 = 0.03$. Enter $z_0 = 0.02$, and $z_1 = 0.02$. See Figure 10.71.

Click the Apply button, and then click OK. See Figure 10.72.

Using the cross-section graph, an appropriate power/temperature/distance profile can be chosen for the desired therapy.

*NOTE* The plot lines of temperature on the cross-section graph are arranged in order of ascending power vertically. As more power is supplied to the tissue, more heat is
FIGURE 10.69  2D_Bio_MCT_1 model, surface temperature (°C)

FIGURE 10.70  2D_Bio_MCT_1 model Cross-Section Plot Parameters, General tab
**FIGURE 10.71** 2D_Bio_MCT_1 model Cross-Section Plot Parameters, Line/Extrusion tab

**FIGURE 10.72** 2D_Bio_MCT_1 model, temperature ($T$) as a function of applied power vs. radius ($r$)
dissipated in the tissue; accordingly, the temperature rises. The graphical plots start at 2 W and ascend to 10 W in 0.5-W increments.

### 2D Axisymmetric Microwave Cancer Therapy Model: Summary and Conclusions

The bioheat equation is a valuable approach for calculating the efficacy of potential treatment methodologies. Now that the 2D_Bio_MCT_1 model has been successfully calculated, the modeler can determine the power needed to reach the desired temperature for a preliminary estimate of an effective treatment. Final determination of the veracity of the calculation will, of course, need to be made experimentally. The literature cites temperatures that range from 42 °C (315.15 K)\(^5\) to 60 °C (333.15 K).\(^6\)

If the postulated method raises the local temperature of the tumor cells, without excessively raising the temperature of the normal cells, then the proposed method will probably be successful. The results (estimated power values) from the model calculations will significantly reduce the effort needed to determine an accurate experimental value. The guiding principle needs to be that tumor cells die at elevated temperatures.

### References

Exercises

1. Build, mesh, and solve the 2D axisymmetric tumor laser irradiation model problem presented in this chapter.

2. Build, mesh, and solve the 2D axisymmetric microwave cancer therapy model problem presented in this chapter.

3. Explore other receptor materials as applied in the 2D axisymmetric tumor laser irradiation model.

4. Explore other materials as applied in the 2D axisymmetric microwave cancer therapy model.

5. Explore the different geometries in the 2D axisymmetric tumor laser irradiation model.

6. Explore the different geometries in the 2D axisymmetric microwave cancer therapy model.

7. Explore the different tissues in the 2D axisymmetric tumor laser irradiation model.

8. Explore the different tissues in the 2D axisymmetric microwave cancer therapy model.
Index

Italicized page locators indicate a figure; tables are noted with a t.

A

Absolute tolerance edit window, 559
  2D AC Generator model: transient, 523
AC, intrinsic nature of, 495
AC/DC Module, 221, 572
  Hall effect models and, 171
  mixed-mode models and employment of, 460
AC/DC Module Model Library, 464
AC/DC Module Motors and Drives Library Model, 498, 531
AC/DC Module Small In-Plane Currents Application Mode, 463
AC electrical power generation and distribution systems, development and commercialization of, 494
AC induction, 453
AC power transmission system transformed, 497
  untransformed, 497
AC realm
  expanding modeling calculations from, 462
  skin depth and, 463
AC theory. See Alternate current (AC) theory
AC voltage, resistive/reactive vector phase diagram, 462
ALE. See Arbitrary Lagrangian-Eulerian
Algebraic multigrid, 618, 619, 630
Alternate current (AC) theory, electrical impedance in, 461–462
Alumina, 2D Resistive_Heating_2 and introduction of, 366

“Analysis of Tissue and Arterial Blood Temperatures in the Resting Human Forearm” (Pennes), 747
Angular transform, rotational sense of, 4
Animation. See also Postprocessing animation solution presented as, 75
Animation Plot Parameters window
  2D Hall_Effect_1 model, 187
  2D Hall_Effect_2 model, 204
  2D Hall_Effect_3 model, 221
Anisotropic conductivity, 192, 210, 221
Antenna and model domain,
  2D axisymmetric microwave cancer therapy model, 779
Application Mode, defined, 5
Application Mode Name window
  two mode names in, 395, 413
  2D axisymmetric Inductive_Heating_2 model, second variation on, 435
Application Mode Properties: Perpendicular Induction Currents, Vector Potential (emqa), 2D AC Generator Sector model, static, 542, 543
Application Mode Properties button, 172, 772
Application Mode Properties dialog box,
  2D AC Generator model, static, 514
Application Mode Properties edit window
  2D concave mirror model, without PMLs, 729
  2D concave mirror model, with PMLs, 715
  2D dielectric lens model, without PMLs, 696
  2D dielectric lens model, with PMLs, 682
Application Mode Properties window
2D Hall Effect model, 172
2D Hall Effect model, first variation on, 188
2D Hall Effect model, second variation on, 205
Application Scalar Variables edit window
2D axisymmetric Inductive_Heating_1 model, 399
2D axisymmetric Inductive_Heating_2 model, 420
2D axisymmetric Inductive_Heating_3 model, second variation on, 441
2D concave mirror model, without PMLs, 730
2D concave mirror model, with PMLs, 715
2D dielectric lens model, without PMLs, 697
2D dielectric lens model, with PMLs, 683
2D electric impedance sensor model:
advanced, 484
2D electric impedance sensor model:
basic, 469
Application Scalar Variables window, 2D axisymmetric microwave cancer therapy model, 782
Approximation models, first, most meaningful, 37–38
Arbitrary Lagrangian-Eulerian, 116, 117
Asperity(ies), 145
second variation of 2D electrochemical polishing model, 147
change in position of electrode surface and removal of material from, 164
2D, on electrode, 116
2D electropolishing_1 model electrode with, 122, 135
2D electropolishing_3 model electrode with, 154
.avi extension, for saved animation, 75
Axial position space coordinates, 227
Axial Symmetry coordinate system (1D and 2D), 5
Axis edit window, 2D Axisymmetric Inductive_Heating_1 model, 395, 395t
Axisymmetric geometry (cylindrical) modeling, 229

Azimuthal Induction Currents, Vector Potential (emqa)
physics boundary settings
2D Axisymmetric Inductive_Heating_2 model, 423
2D Inductive_Heating_3 model, second variation on, 442, 445
physics subdomain settings
2D Axisymmetric Inductive_Heating_2 model, 422
2D Inductive_Heating_3 model, second variation on, 441–442

B
Behavior of model, accurate anticipation of, 64
Berenger, Jean-Pierre, 671
Bioheat equation
conduction heat equation and, 748
guiding principle behind, 749, 765, 770, 788, 794
laser beam energy and, 749
physics boundary settings,
2D axisymmetric tumor laser irradiation model, 760–761
physics boundary settings, 2D axisymmetric microwave cancer therapy model, 781
physics settings, 2D axisymmetric microwave cancer therapy model, 779–780
physics subdomain settings, 2D axisymmetric tumor laser irradiation model, 758, 760
value of, 768–769, 794
Bioheat Equation Application Mode, bioheat equation formulation in, 747–748
Bioheat equation theory, 747–749
Bioheat modeling, defining, 747
Bioheat models, 747–794
2D axisymmetric microwave cancer therapy model, 770–794
2D axisymmetric tumor laser irradiation model, 749–769
Biomagnetic studies, magnetostatic modeling applied to, 649
Bismuth, as 2D axisymmetric Inductive_Heating_2 model, second variation, material of choice, 434
Bismuth subdomain 3, 2D axisymmetric
Inductive_Heating_3 model, second variation on, 440
BLK1 edit window, 3D thin layer resistance modeling: thin layer subdomain, 594
BLK2 edit window
3D thin layer resistance model: thin layer approximation, 578, 579
3D thin layer resistance model: thin layer subdomain, 595
BLK3 edit window, 3D thin layer resistance model: thin layer subdomain, 595
Block edit window, 593
Boltzmann, Ludwig, 228
Boundary check box, 606, 619
Boundary conditions
COMSOL 1D telegraph equation model, 93
first variation on COMSOL 1D telegraph equation model, 99
second variation on COMSOL 1D telegraph equation model, 106
settings
Kdv equation model, 70–71
specifications of, 71
Boundary Data Expression edit window, 647
Boundary Integration edit window
2D axisymmetric Thermos_Container_1 model, 284
2D axisymmetric Thermos_Container_2 model, 300
2D axisymmetric Thermos_Container_3 model, 315
Boundary Pairs Value edit window, 3D thin layer resistance model: thin layer approximation, 588
Boundary plot, 3D thin layer resistance model: thin layer approximation, 591
Boundary Settings
Conditions page, 2D AC Generator Sector model, static, 548
Conductive Media DC (dc) edit window, 2D Resistive_Heating_1 model, 337t
General Heat Transfer Heating_1 model, 235t
Inductive_Heating_3 model, second variation on, 440
In_Plane Electric Currents (emqvw) edit window, 2D electric impedance sensor model: basic, 471
1D single-pane heat flow model and, 10–11
1D triple-pane, 32t
physics settings: 2 TM waves (rfwh),
2D axisymmetric microwave cancer therapy model, 782
3D electrostatic potential between two cylinders, 616t
3D electrostatic potential five cylinders model, 627t
2D axisymmetric microwave cancer therapy model, 781, 783t, 785, 786, 787
2D axisymmetric tumor laser irradiation model, 760t
2D concave mirror model, without PMLs, 732
2D concave mirror model, with PMLs, 719
2D dielectric lens model, without PMLs, 699
2D dielectric lens model, with PMLs, 686
2D Hall effect model, 176–180
first variation on, 194–197
second variation on, 211–214, 211t
Weak Constr. page, 2D AC Generator Sector model, static, 548
Boundary Settings, Conductive Media DC (dc) window
2D electrochemical polishing model
first variation on, 137t
second variation on, 156t
Boundary Settings, Moving Mesh (ALE) window
2D electrochemical polishing model, 125t
first variation on, 140t
second variation on, 159, 159t
Boundary Settings Boundary selection window, 1D single-pane heat flow model, 11
Boundary Settings—Conductive Media DC (dc) edit window
3D thin layer resistance model: thin layer approximation, 586t
3D thin layer resistance model: thin layer subdomain, 601t
2D Resistive_Heating_2 model, 359
Boundary Settings—Conductive Media DC
(dc) edit window, pairs, 3D thin layer
resistance model: thin layer
approximation, 586
Boundary Settings—Conductive Media DC
(emdc) edit window, 2D Resistive_ Heating_3 model, second variation
on, 379
Boundary Settings edit window
3D electrostatic potential between five
cylinders model, 628, 629
3D electrostatic potential between two
cylinders model, 617, 618
3D magnetic field of a Helmholtz coil
model, 642, 643
3D magnetic field of a Helmholtz coil
with a magnetic test object
model, 659
3D thin layer resistance model: thin layer
approximation, 586, 587
3D thin layer resistance model: thin layer
subdomain, 603, 604
2D Axisymmetric Cylinder_Conduction_1
model, 237
2D Axisymmetric Inductive_Heating_1
model, 401t, 402t, 404t
2D Axisymmetric Inductive_Heating_2
model, 423t, 426t, 427t
2D Electric Impedance Sensor model:
advanced, 486, 487
2D Electric Impedance Sensor model: basic,
471, 472
2D Inductive_Heating_3 model, second
variation on, 444t, 445, 445t, 448t,
449, 450
Boundary Settings—General Heat Transfer
edit window
2D Axisymmetric Cylinder Conduction
model, second variation on, including
vacuum cavity, 259t
2D Axisymmetric Thermos_Container_1
model, 277t
2D Axisymmetric Thermos_Container_2
model, 293t, 294t
second variation on, 309t, 310t
Boundary Settings—Heat Transfer by
Conduction (ht) edit window, 334t
2D Resistive_Heating_2 model, 354t
2D Resistive_Heating_3 model, second
variation on, 375t
Boundary Settings—In-Plane Electric Currents
(emqvw) edit window, 2D electric
impedance sensor model: advanced, 485t
Boundary Settings window
blank, 1D triple-pane, 31
for boundary 1, filled-in 1D dual-pane, 21
for boundary 1, filled-in 1D triple-pane, 31
for boundary 4, filled-in 1D dual-pane, 22
COMSOL 1D Telegraph Equation model, 93
first variation on, 99t, 100
second variation on, 106, 106t
KdV equation model, 71t
12 Dual-pane, 21
2D axisymmetric Tumor Laser Irradiation
model, 761, 762
Brain function, 2D electric impedance
tomography research on, 460, 493
Breast cancer, 2D electric impedance
tomography research and detection of,
460, 493

C
CAD file, imported, 2D AC Generator Sector
model, static, 534
Calculated temperature
1D dual-pane analysis and, 26
1D single-pane analysis and, 13
Carnot, Nicolas Leonard Sadi, 228
Carrier types, density of, 168
Cartesian coordinate systems, 5
GUI example of, 3
Centigrade degrees
analytical plots viewed in, 788
2D axisymmetric Inductive_Heating_2 model
and temperature distribution in, 431, 435
2D axisymmetric Inductive_Heating_3 model
and temperature distribution in, 452
2D axisymmetric Tumor Laser Irradiation
model and analytical plots viewed
in, 763
2D Inductive_Heating_1 model and temperature distribution in, 408, 410
2D Resistive_Heating_1 model and temperature distribution in, 339, 341, 342
2D Resistive_Heating_2 model and temperature distribution in, 361, 364
2D Resistive_Heating_3 model and temperature distribution in, 383–384, 386
Circle creation, 2D AC Generator model, static, 501
Circle edit window, 151
3D thin layer resistance model: thin layer approximation, 581
3D thin layer resistance model: thin layer subdomain, 598
2D Axisymmetric Inductive_Heating_1 model, 397
2D Axisymmetric Inductive_Heating_2 model, 419
2D Axisymmetric Tumor Laser Irradiation model, 754
2D Dielectric Lens model, without PMLs, 693
2D Dielectric Lens model, with PMLs, 680
2D Resistive_Heating_1 model, 330

Circles
pasted, 2D AC Generator model, static, 507
rotor created, 2D AC Generator model, static, 508
two newly created, 2D AC Generator model, static, 505
Circles and rectangles created, 2D AC Generator model, static, 502

Coil
2D Axisymmetric Inductive_Heating_2 model, 427
2D Inductive_Heating_3 model, 446
CO1 (intersection of circle and square)
3D thin layer resistance model: thin layer approximation, 582
3D thin layer resistance model: thin layer subdomain, 599
Color button, 526, 562
Color difference, determining voltage difference between upper/lower surfaces and, 181
Color expression, 1D dual-pane window solution set to use, 26
Color Expression button, 13
1D dual-pane window, 23
Color Range edit window
2D electric impedance sensor model: advanced, 491
2D electric sensor model: basic and selection of, 476
Color select button, 181
Combined Heat Transfer by Conduction (ht) boundary settings, 2D Resistive_Heating_2 model, 356
Complex AC theory, 493
Complex impedance, 493
Composite Object edit window, 2D dielectric lens model, without PMLs, 694
Composite objects, 2D AC Generator model, static, 511
Computers, 573
COMSOL AC/DC Module Model Library, 636, 652
COMSOL 2D electrochemical polishing model. See 2D electrochemical polishing model
COMSOL Heat Transfer Module Model Library, 749, 770
COMSOL KdV equation model. See KdV equation model
COMSOL Material Library: searchable materials library
Materials/Coefficient Library search and/or selection window, 41, 42
Materials/Coefficient Library search results, 42
Model Navigator, 41
UNS C10100 properties, 43
COMSOL Multiphysics Electro-Thermal Application Mode, 325
COMSOL Multiphysics General Heat Transfer
Application Mode Model, 229
COMSOL Multiphysics modelers
guidelines for, 1–6
coordinate systems, 2–5
hardware considerations, 1–2
implicit assumptions, 5–6
new, 1D guidelines for, 63–64
coordinate system, 64
1D modeling considerations, 63–64
COMSOL Multiphysics Model Library,
577, 613
COMSOL Multiphysics software
basic materials libraries in, 40
default interior boundary conditions
set in, 36
installing, 2
2D modeling modes in, 226
COMSOL Multiphysics telegraph equation
model, 90–92
COMSOL RF Module model library, 676
Concave mirror
2D concave mirror model, without PMLs, 728
2D concave mirror model, with PMLs, 713
Conduction heat equation, bioheat equation
and, 748
Conductive Media DC, 165, 221
physics boundary settings
3D thin layer resistance model: thin layer
approximation, 586
3D thin layer resistance model: thin layer
subdomain, 601
2D Resistive_Heating_1 model, 335, 338
physics subdomain settings
3D thin layer resistance model: thin layer
approximation, 583–584
3D thin layer resistance model: thin layer
subdomain, 600
2D Resistive_Heating_1 model, 334
Conductivity Matrix edit window, closing, 175
Conductivity matrix elements, 2D Hall_Effect_2
model, 194
Conductivity relation pull-down list, 173
Conductivity type pull-down list, 175
Conservation of energy, 495

Constants
1D telegraph equation model, 93
3D magnetic field of a Helmholtz coil with a
magnetic test object model, 652–653
2D AC Generator model, static, 499
2D AC Generator Sector model, static, 532
2D axisymmetric Cylinder Conduction
model, second variation on, including
a vacuum cavity, 253
2D axisymmetric Cylinder_Conduction_1
model, 231
2D axisymmetric Inductive_Heating_1
model, 396, 398
2D axisymmetric Inductive_Heating_3
model, 437, 439–440
2D axisymmetric microwave cancer therapy
model, 772
2D axisymmetric Thermos_Container_1
model, 266
2D axisymmetric Thermos_Container_2
model, 302
2D axisymmetric Tumor Laser Irradiation
model, 750
2D Electric Impedance Sensor model:
advanced, 477, 479, 481–482
2D Electric Impedance Sensor model:
basic, 464, 466
2D Hall effect model, second variation on, 206
2D Resistive_Heating_1 model, 328
2D Resistive_Heating_2 model, 347
2D Resistive_Heating_3 model, 368
Consants edit window
3D magnetic field of a Helmholtz coil model,
637, 637t
with a magnetic test object, 652t, 653
2D AC Generator model
Generator Geometry, 500
static, 500, 500t
Stator Geometry Circles Creation, 500t
2D AC Generator Sector model, static,
533, 533t
2D axisymmetric Cylinder Conduction model
first variation on, 242, 242t
second variation on, including a vacuum
cavity, 253, 253t
2D axisymmetric Cylinder_Conduction_1 model, 231, 231
2D axisymmetric Inductive Heating_1 model, 397, 397
2D axisymmetric Inductive Heating_2 model, 413, 414
2D axisymmetric Inductive Heating_3 model, 438, 438
2D axisymmetric Microwave Cancer Therapy model, 773, 773
2D axisymmetric Thermos Container_1 model, 267, 267
2D axisymmetric Thermos Container_2 model, 287, 288t, 303, 303t
2D axisymmetric Tumor Laser Irradiation model, 751t, 752
2D Electric Impedance Sensor model: advanced, 478t, 479
2D Electric Impedance Sensor model: basic, 465t, 466
2D Electrochemical Polishing model, 118t
  first variation on, 131t
  second variation on, 148t
2D Hall effect model, 172
  first variation on, 189t
  second variation on, 206t
2D Hall Effect_3 model, 206
2D Resistive Heating_1 model, 328, 328t
2D Resistive Heating_2 model, 348t, 349
2D Resistive Heating_3 model, 369, 369t
Consts specification window,
  1D dual pane, 17
Constance window
  1D telegraph equation model, 93t
  first variation on, 99, 99, 105t
  second variation on, 105–111
Constitutive relationships for
  the medium, 634
Constraint name colunm, Periodoc Boundary Conditions window, 67, 67
Contact rectangles
  2D Hall effect model, 191
    second variation on, 208
Contour check box, 561
Contour lines
determining voltage difference between upper/lower surfaces and incremental position of, 181
2D Hall effect model, 181
  first variation on, 200
2D Hall Effect_3 model surface distribution plot with, 219
2D Hall Effect_1 model surface voltage distribution plot with, 184
2D Hall Effect_2 model surface voltage distribution with, 201
Contour tab, 181
Coordinate systems, 2–5
  2D axisymmetric, 227, 227–228
  in 1D models, 64
  in 2D models, 114–115
Copper
  PKS-MPD Composition materials selection page for, 52
  PKS-MPD Composition percentage selection added page for, 51
  PKS-MPD Composition percentage selection page for, 50
  PKS-MPD Composition selection added page for, 50
  PKS-MPD Composition selection page for, 49
  PKS-MPD Materials selected verification page for, 56
  PKS-MPD Materials selection Print Preview page 1 for, 54
  PKS-MPD Materials selection Print Preview page 2 for, 55
  PKS-MPD Materials selection Properties display page for, 53, 55, 56
  PKS-MPD Materials selection properties for, 58
  PKS-MPD Materials selection Tensile Strength display page for, 57
  PKS-MPD Print Materials selection page for, 52
Copper connecting bars, in Resistive Heating_2 model, 345, 367
Copper file, selection of, as library to be added in PKS-MPD, 59
Copy Mesh button, 2D AC Generator Sector model, static, 553
Corrosion films, 572
Coulomb, Charles-Augustin de, 115, 611
Coulomb gauge, 636
Coupling variables, 2D AC Generator Sector model, static, 542
Create Composite Object
intersection (CO1, CO3), 2D AC Generator Sector model, static, 536
intersection (CO2, CO1), 2D AC Generator Sector model, static, 536
Create Composite Object edit window
3D electrostatic potential between five cylinders model, 626
3D electrostatic potential between two cylinders model, 615
2D AC Generator model, static, 503, 504, 510
2D axisymmetric Cylinder Conduction model, second variation on, including a vacuum cavity, 256
2D axisymmetric Inductive_Heating_2 model, 415, 416, 417, 418, 421
2D axisymmetric Microwave Cancer Therapy model, 775, 777
2D axisymmetric Thermos_Container_1 model, 272
2D axisymmetric Tumor Laser Irradiation model, 755
2D Concave Mirror model, without PMLs, 727
2D Concave Mirror model, with PMLs, 712
2D Dielectric Lens model, with PMLs, 680
2D Electric Impedance Sensor model: advanced, 481
2D Resistive_Heating_1 model, 331
2D Resistive_Heating_2 model, 350
2D Resistive_Heating_3 model, 371
Create Composite object result,
2D Electric Impedance Sensor model: advanced, 482
Create Composite Object window
3D thin layer resistance model: thin layer approximation, 581
3D thin layer resistance model: thin layer subdomain, 598
2D Hall_Effect_2 model, 191
2D Hall_Effect_3 model, 208
Create Pairs button, on Draw toolbar, 536, 537
Create Pairs edit window, 3D thin layer resistance model: thin layer approximation, 584
Cross-section field analysis
Slice tab, 665–666
3D magnetic field of a Helmholtz coil model, 648–649
Cross-Section Line Data edit window
2D Hall effect model, first variation on, 202t
2D Hall effect model, second variation on, 217t
Cross-Section Line Data parameters, 609t
Cross-Section Line Data Parameters, 3D thin layer resistance model: thin layer approximation, 592t
Cross-Section Parameters
General page
2D Hall_Effect_1 model, 184
2D Hall_Effect_3 model, 219
Line/Extrusion page
2D Hall effect model, 185
Cross-Section Plot, 649, 665
3D magnetic field of a Helmholtz coil model, 651
Cross-section plot line
solution plot with, 3D magnetic field of a Helmholtz coil with a magnetic test object model, 669
3D magnetic field of a Helmholtz coil model, 651
Cross-Section Plot Parameters
General edit window
2D Resistive_Heating_1 model, 343
2D Resistive_Heating_2 model, 364
2D Resistive_Heating_3 model, 386
General tab
2D axisymmetric Microwave Cancer Therapy model, 792
Line/Extrusion tab
2D axisymmetric Microwave Cancer Therapy model, 793
Point edit window
  2D Resistive_Heating_1 model, 344
  2D Resistive_Heating_2 model, 365
  2D Resistive_Heating_3 model, 387
Cross-Section Plot Parameters
  edit window, 609
  3D magnetic field of a Helmholtz coil with a magnetic test object model, 668
  3D thin layer resistance model: thin layer approximation, 592
Cross-Section Plot Parameters page, exact voltage difference at any point in model and, 183
Crucible
  coil and, 2D axisymmetric
    Inductive_Heating_2 model, 420
  coil with rectangle and, 2D axisymmetric
    Inductive_Heating_3 model, 439
  heated, inductively produced heating applied to, Inductive_Heating_2 model, 454–455
  2D axisymmetric Inductive_Heating_2 model, 418
Cylinder conduction, 229
Cylinder conduction model, 228
Cylinder CYL1 edit window, 614
  3D electrostatic potential between five cylinders model, 624
Cylinder CYL2 edit window, 614
  3D electrostatic potential between five cylinders model, 624
Cylinder CYL3 edit window, 3D electrostatic potential between five cylinders model, 625
Cylinder CYL4 edit window, 3D electrostatic potential between five cylinders model, 625
Cylinder CYL5 edit window, 3D electrostatic potential between five cylinders model, 625
Cylinder rectangle
  2D axisymmetric Cylinder_Conduction_1 model, 232
  2D axisymmetric Cylinder_Conduction_2 model, 243
Cylindrical coordinates, 316

D
Darcy’s law, 577, 592
DC, intrinsic nature of, 494, 495
DC electrical power generation and distribution systems, Edison and development/commercialization of, 494
DC power transmission system, 496
DC realm, expanding modeling calculations from, 462
Default values, 1D dual-pane window solution plotted with, 24
Deformed mesh, 165
  inverted mesh element warning and, 144, 163
Density, heat conduction calculation and, 234
Dependent variables
  case changes, 2D AC Generator Sector model, static, 532
  in 3D transient solution model, 573
  transient (or time-dependent) models, 460
  changes in, 390
de Vries, Gustav, 65
Dewar, Sir James, 265
Dielectric lens, optics principles and, 676
Dielectric lens (CO1), 2D Dielectric Lens model, without PMLs, 695
Difference command, 2D AC Generator model, static, 502, 509
Dirichlet boundary conditions, 71
Domain Plot Parameters, Point tab,
  2D axisymmetric Tumor Laser irradiation model, 767
Domain Plot Parameters edit window,
  2D AC Generator model, transient, 528
Domain plus PMLs, 2D concave mirror model, with PMLs, 714
Dual-carrier systems, 170
Dual-pane windows
  comparison of single- and triple-pane windows with, 35
  modeling, 16–17
Dust precipitators, 3D electrostatic potential models and, 612, 622, 633
Eddy currents
discovery of, 392
inductive heating model and, 322
Edison, Thomas Alva, 494
Electric (AC/DC) Materials Properties Library, 513
Electrical impedance theory, 461–464
Electrical impedance tomography, 460
Electrical resistance divider, touch screen and, 574
Electrical resistance theory, 573–575
Electrical resistance tomography, defined, 460
Electrical resistivity tomography, 460
Electric currents and solids, history behind our understanding of, 324–325, 391–393
Electric field, \( z \)-component
2D Concave Mirror model, without PMLs, 737
2D Concave Mirror model, with PMLs, 723
2D Dielectric Lens model, without PMLs, 703
Electric field plot, \( z \)-component, 0.5 m
2D Concave Mirror model, without PMLs, 740
2D Dielectric Lens model, without PMLs, 704, 705
Electric field plot, \( z \)-component, 1.0 m
2D Concave Mirror model, without PMLs, 741, 742
2D Dielectric Lens model, without PMLs, 705, 706
Electric field plot, \( z \)-component, 1.5 m
2D Concave Mirror model, without PMLs, 743, 744
2D Dielectric Lens model, without PMLs, 706, 707
Electric field plot, \( z \)-component, 2D Concave Mirror model, without PMLs, 739
Electricity, history behind science of, 115
Electric potential plot cross-section
3D thin layer resistance model: thin layer approximation, 593, 610
3D thin layer resistance model: thin layer subdomain, 611
Electrochemical polishing (electropolishing) technique, 115, 116, 117, 154
Electromagnetic induction, 493
Electromagnetic wave equation calculations, fundamental difficulties related to, 671
Electromotive force, transformed AC power and, 497
Electronic device structures, fabricating, 203–204
Electronic lock pads, 573
Electrons
n-type, in semiconductors, 203
in solids, 168
Electrostatic field mapping, 572
Electrostatic generator, invention of, 611
Electrostatic modeling basics, 611–612
Electrostatic scalar potential \( V \), relationship to electric field vector \( \mathbf{E} \), 611–612
Electrostats (es) physics boundary settings
3D electrostatic potential between five cylinders model, 627
3D electrostatic potential between two cylinders model, 616
physics subdomain settings
3D electrostatic potential between five cylinders model, 627
3D electrostatic potential between two cylinders model, 616
Electrostatics problems, complexity and difficulty of, 618
Electro-Thermal Application Mode. See COMSOL Multiphysics Electro-Thermal Application Mode
Electro-thermal coupling, 455
Ellipse, points added to in 2D Electric Impedance Sensor model: advanced, 482, 483
Ellipse edit window
2D axisymmetric Thermos_Container_1 model, 268r
2D Concave Mirror model, without PMLs, 726
2D Concave Mirror model, with PMLs, 711
2D Electric Impedance Sensor model: advanced, 480
Ellipsoid edit window, 3D magnetic field of a Helmholtz coil with a magnetic test object model, 656
EMB1 and BLK1 selected
  3D thin layer resistance model: thin layer approximation, 584
  3D thin layer resistance model: thin layer subdomain, 601
Embed edit window
  3D thin layer resistance model: thin layer approximation, 582
  3D thin layer resistance model: thin layer subdomain, 599
EMB1 on top of block BLK2, 3D thin layer resistance model: thin layer approximation, 583
EMB1 on top of block BLK3, 3D thin layer resistance model: thin layer subdomain, 600
EMF. See Electromotive force
Equation of continuity, 634
Errors, common sources of, 37–38
Expression radio button, 590, 607
Exterior temperature
  1D dual-pane analysis, 26, 27
  1D single-pane analysis, 13, 15
  1D triple-pane window analysis, 34
Extrinsic conduction mode, 204
F
Faraday, Michael, 115, 493
Faraday’s law of induction, 530
FDTD electromagnetic modeling calculations, 671
FEM. See Finite Element Method
Finite-difference time-domain electromagnetic modeling calculations. See FDTD electromagnetic modeling calculations
Finite Element Method, COMSOL Multiphysics software based on, 8
First approximation result models, 323
First-cut solution, 6
First estimate review of conditions of use, 572
First principles analysis, applying to model definition, 35–37
Fixed-volume impedance difference, in basic 2D Electric Impedance Sensor model, 492
Floating contacts, 171, 196, 208, 211, 221
Fluctuating difference volume, in advanced 2D Electric Impedance Sensor model, 492
Fluctuating parameters, validity of model and, 635
Foucault, Leon, 391, 392
Foucault currents, 392
Fourier, Jean Baptiste Joseph, 229, 326
Fourier’s analysis, 462
Fourier’s law, 229, 326
Four-wire touch screen technology, 574
Free Mesh Parameters
  Boundary page, 2D AC Generator Sector model, static, 552
  Global tab, 2D axisymmetric Microwave Cancer Therapy model, 787
  subdomain, 2D Dielectric Lens model, with PMLs, 687
  subdomain 3, 2D axisymmetric Microwave Cancer Therapy model, 788
  2D axisymmetric Tumor Laser Irradiation model, 762
  2D Concave Mirror model, without PMLs, 733
  2D Concave Mirror model, with PMLs, 719
  2D Dielectric Lens model, without PMLs, 699
  Free mesh parameters, 165, 317, 388
Free Mesh Parameters edit window
  General tab
    3D magnetic field of a Helmholtz coil model, 643
    3D magnetic field of a Helmholtz coil with a magnetic test object model, 660
    Subdomain (2, 3) tab, 3D magnetic field of a Helmholtz coil with a magnetic test object model, 661
    Subdomain (4) tab
      3D magnetic field of a Helmholtz coil with a magnetic test object model, 661
      Subdomain tab, 3D magnetic field of a Helmholtz coil model, 644
      3D electrostatic potential between five cylinders model, 629
      3D electrostatic potential between two cylinders model, 618
Free Mesh Parameters edit window (continued)
- 3D thin layer resistance model: thin layer subdomain, 604
- 2D AC Generator model, static, 519
- 2D AC Generator Sector model, static, 552
- 2D axisymmetric Thermos_Container_1 model, 280
- 2D axisymmetric Thermos_Container_2 model, 296
- 2D axisymmetric Thermos_Container_3 model, 312
- 2D Electric Impedance Sensor model: advanced, 488
- 2D Electric Impedance Sensor model: basic, 473
Free Mesh Parameters window, 80
- 2D electrochemical polishing model, 142
- KdV equation model, 72
  - second variation on, 86
- 2D Resistive_Heating_3 model, 382
Free mesh (quad), 2D Electrochemical Polishing model, 143
  - second variation on, 162

Geometry components
- 3D electrostatic potential between five cylinders model, 623
- 3D electrostatic potential between two cylinders model, 613
- 3D magnetic field of a Helmholtz coil model, 638
- 3D magnetic field of a Helmholtz coil with a magnetic test object model, 654
- 3D thin layer resistance model: thin layer approximation, 578
- 3D thin layer resistance model: thin layer subdomain, 594
- 2D axisymmetric Microwave Cancer Therapy model, 774, 776, 778
- 2D axisymmetric Tumor Laser Irradiation model, 752
- 2D Concave Mirror model, with PMLs, 708
- 2D Dielectric Lens model, with PMLs, 677

Geometry edges check box, 662

Geometry modeling
- 3D electrostatic potential between five cylinders model, 623
- 3D electrostatic potential between two cylinders model, 613, 615
- 3D magnetic field of a Helmholtz coil model, 638–639
- 3D magnetic field of a Helmholtz coil with a magnetic test object model, 653–655
- 3D thin layer resistance model: thin layer approximation, 578
- 3D thin layer resistance model: thin layer subdomain, 593, 595–596, 598–600
- 2D axisymmetric Microwave Cancer Therapy model, 772, 774, 776, 778, 779
- 2D axisymmetric Tumor Laser Irradiation model, 750, 753–755
- 2D Concave Mirror model, without PMLs, 725, 727
- 2D Concave Mirror model, with PMLs, 707, 710, 712
- 2D Dielectric lens model, without PMLs, 693–694
- 2D Dielectric Lens model, with PMLs, 677–678, 681
Geometry Rectangles Creation, 2D AC
   Generator model, static, 502t
Geom2 work-plane
   3D thin layer resistance model: thin layer
      approximation, 580
   3D thin layer resistance model: thin layer
      subdomain, 597
Geophysics, electrical resistance tomography
   and, 460
Germanium, semiconductor carrier types and, 203
Gilbert, William, 115
Global Equations, physics settings, 2D AC
   Generator Sector model, static, 551
Global Equations edit window, 2D AC
   Generator Sector model, static, 551, 551t
Global Expressions, 2D AC Generator Sector
   model, static, 538
Global Expressions edit window, 2D AC
   Generator Sector model, static, 538, 538t, 539
Global variables plot, 2D AC Generator Sector
   model, transient, 566
Global Variables Plot edit window, 2D AC
   Generator Sector model, transient, 565
GMRES (iterative solver), 618, 619, 630
Good first approximation, 323, 388, 454, 455, 748
Graphical user interface, 2
Grid edit window, 2D Axisymmetric
   Inductive_Heating_1 model, 395t, 396
Group index designation, floating contact
   couples and, 176
GUI. See Graphical user interface

H
Hall, Edwin, 169
Hall coefficient ($R_H$), 170
Hall effect, 115
discovery of, 169
Hall effect model. See also 2D Hall effect model
   implicit assumptions in, 170
Hall effect sensor geometry, electron flow, 170
Hall effect sensors
   applications of, 171
   magnetostatic modeling applied to, 649
Hall effect voltage, 181, 200
Hall voltage ($V_H$), 169, 170
Hard nonlinear magnetic materials, 529, 568
Hardware, selecting, for successful modeling, 1–2
Heat capacity, heat conduction calculation
   and, 234
Heat conduction theory, 228–229, 316, 325–326
Heater bar assembly
   2D Resistive_Heating_2 model, 351
   2D Resistive_Heating_3 model, 372
Heat flow indicator, 1D triple-pane window
   with, 36
Heat flux
demonstrating, 2D Resistive_Heating_1
   model, 341
   2D Resistive_Heating_3 model, 388
Heat transfer, 434. See also Bioheat models
general, physics boundary settings
   2D axisymmetric Cylinder Conduction
      model, first variation on, 245
   2D axisymmetric Cylinder Conduction
      model, second variation on, including
      vacuum cavity, 259
   2D Axisymmetric Inductive_Heating_2
      model, 427
   2D axisymmetric Thermos_Container_1
      model, 277, 279
   2D axisymmetric Thermos_Container_2
      model, 293–294, 296
   2D Resistive_Heating_3 model, 375
general, physics subdomain settings
   2D axisymmetric Cylinder Conduction
      model, first variation on, 245
   2D axisymmetric Cylinder Conduction
      model, second variation on, including a
      vacuum cavity, 256
   2D axisymmetric Cylinder_Conduction_1
      model, 233–234
   2D Axisymmetric Inductive_Heating_2
      model, 426
   2D axisymmetric Thermos_Container_1
      model, 274
   2D axisymmetric Thermos_Container_2
      model, 289–290, 305–306
   2D Inductive_Heating_3 model, 446
   2D Resistive_Heating_3 model, 371–372
Heat transfer (continued)
history behind, 228
as important design consideration, 227
modeling, 229
Heat transfer by conduction
physics boundary settings
  2D Resistive_Heating_1 model, 334
  2D Resistive_Heating_2 model, 353–354
physics subdomain settings
  2D Resistive_Heating_1 model, 332
  2D Resistive_Heating_2 model, 352–353
Heat Transfer by Conduction Application Mode, 326, 371
Heat transfer coefficients, 317
Heat transfer coefficient window,
  1D single-pane heat flow model, 11
Heat Transfer Module, 228, 316
  bioheat equation and, 747
  2D axisymmetric Cylinder Conduction model, first variation on, 240
Heat Transfer Module Model Library, 229, 265
Heaviside, Oliver, 90, 462
Helmholtz coil, 635, 666
  3D magnetic field of a Helmholtz coil model and creation of, 638
Helmholtz coil model, 572
Helmholtz coil pair
  3D magnetic field of a Helmholtz coil model, 640
  3D magnetic field of a Helmholtz coil model and uniformity of, 649
  3D magnetic field of a Helmholtz coil with a magnetic test object model, 656
Helmholtz coil pair, sphere, and magnetic ellipsoid, 3D magnetic field of a Helmholtz coil with a magnetic test object model, 657
Helmholtz coil pair and sphere, 3D magnetic field of a Helmholtz coil model, 641
High-frequency currents, 2D electric impedance sensor models and, 460, 492
Hole, block with, 2D Resistive_Heating_1 model, 331
Holes
  p-type, in semiconductors, 203
  in solids, 168
Hyperthermic oncology, 769
I
Identity Boundary Pairs window, 2D AC Generator Sector model, static, 538
Identity pair, 3D thin layer resistance model: thin layer approximation, 585
Identity-pair-contact resistance approximation, in 3D thin layer resistance model: thin layer approximation, 586–587
Imbalance-offset geometry, 221
Impedance
  resistance mapped into, 462
  single frequency analysis of, 462
Import button, 534
Import CAD Data From File select window, 2D AC Generator Sector model, static, 533
Induced Voltage vs. Time view, 2D AC Generator model, transient, 527, 529
Induction heating equations, 392–394
Inductive heating model, 322
Industrial process imaging, electrical resistance tomography and, 460
Information transmission, measurement of a difference and, 77
Init button, in 1D single-pane heat flow model, 9
Initial Conditions window
  KdV equation model, 71t
    first variation on, 79t
    second variation on, 85
  1D telegraph equation model, 94t
    first variation on, 101t
    second variation on, 107t
Initialized mesh
  1D dual-pane window with air gaps, 23
  1D triple-pane window with air gaps, 32
Initialize Mesh button, 125, 235, 338, 360, 450
In-Plane Electric Currents (emqvw)
physics boundary settings
2D Electric Impedance Sensor model:
advanced, 484
2D Electric Impedance Sensor model:
basic, 470, 472
physics subdomain settings
2D Electric Impedance Sensor model:
advanced, 484
2D Electric Impedance Sensor model:
basic, 470

In-Plane TE waves (rfweh)
physics application mode properties
2D Concave Mirror model,
without PMLs, 727
2D Concave Mirror model,
with PMLs, 714
2D Dielectric Lens model,
without PMLs, 697
2D Dielectric Lens model, with PMLs, 682
physics application scalar variables
2D Concave Mirror model,
without PMLs, 730
2D Concave Mirror model, with PMLs, 714
2D Dielectric Lens model,
without PMLs, 697
2D Dielectric Lens model, with PMLs, 683
physics boundary settings
2D Concave Mirror model,
without PMLs, 732
2D Concave Mirror model, with PMLs, 718
2D Dielectric Lens model,
without PMLs, 698
2D Dielectric Lens model, with PMLs, 686
physics subdomain settings
2D Concave Mirror model,
without PMLs, 730
2D Concave Mirror model, with PMLs, 714
2D Dielectric Lens model,
without PMLs, 697
2D Dielectric Lens model, with PMLs, 683–685
Interchange source and destination button,
538, 538

Interior temperature
1D dual-pane analysis and, 26, 27
1D single-pane analysis and, 13, 15
1D triple-pane analysis and, 34
Intersection command, 2D AC Generator model, static, 502, 509
Intrinsic conduction mode, 203
Inverted mesh element warning, 144, 163
Ions, in solids, 168

J
Joule, James Prescott, 228, 324, 391
Joule heating, 322, 388, 434, 454
device design considerations and, 324, 391
modern, importance of, 326, 346, 367, 394, 411, 434
Joule Heating in Conductive Media DC Application Mode, 326, 371
Joule’s law, 391, 392, 455, 494, 495, 770

K
KdV equation, 64–65
in standard notation and formula in COMSOL documentation, 65
KdV equation model
boundary conditions settings, 70–71
defining fundamental physics conditions, 67–69
first variation on, 77–83
changing subdomain settings, 77–79
Free Mesh Parameters window, 80
Initial Conditions window, 79
mesh generation, 79
model solution, 82
model solution, Animate page, 83
Open Model window, 78
postprocessing animation, 82–83
Remeshed model, 80
scalar expressions, 77
Scalar Expressions window, 78
Solve Parameters window, 81
Solver Parameters window, Time Stepping page, 81
solving, 79–82
Subdomain Settings window,
PDE coefficients, 79t
KdV equation model (continued)
Free Mesh Parameters window, 72
initial condition for, 65
Initial Conditions window, 71t
KdV model solution, Animate page, 76
KdV model solution Plot Parameters
Window, Line page, 76
Meshed model, 72
mesh generation, 72
1D Axis/Grid Settings window (x), 66, 88
1D geometry for, 66, 66–67
periodic boundary condition settings, 67
Periodic Boundary Conditions window, 67
Destination page, 69
Destination page, boundary 2, 68
Destination Vertices page, vertex 2, 69
Source page, 67
Source page, boundary 1, variable u2, 69
Source Vertices page, 70
Source Vertices page, vertex 1, 68
postprocessing, 75
second variation on, 83–90
Animate page, 89
changing subdomain settings, 85–86
Free Mesh Parameters window, 86
Initial Conditions window, 85t
mesh generation, 86
model solution, 89
Open Model window, 84
postprocessing animation, 88
remeshed model, 87
scalar expressions, 84
Scalar Expressions window, 85
Solver Parameters window, 87
Solver Parameters window, Time Stepping
page, 88
solving, 86, 88
Subdomain Settings window, PDE
coefficients, 85t
Solver Parameters window, 73
Solver Parameters window, Time Stepping
page, 74
solving, 72, 75
negated KdV model solution, 74
start building, 65–70
subdomain settings, 71
Subdomain Settings window,
PDE coefficients, 71t
summary and conclusions about, 90
viewing solution to, as an animation, 75, 76
Keep interior boundaries check box, 754,
774, 776
2D AC Generator model, 502, 503
static, 509, 510
Kennelley, Arthur E., 462
Kittel, Charles., 168
Korteweg, Diederik, 65

L
Lagrange-quartic choice, verifying, 772
Laplace, Pierre-Simon de, 612
Laplacian operator, uses for, 612
Large dimensional fields, 572
Laser beam energy, bioheat equation and, 749
Length semiaxes edit windows, 655
Line, closed polyline (solid) edit window, 535
Line Color Expression window, 13, 15
Line Data edit window, 2D Hall effect model, 185t
Line edit window, 2D axisymmetric Microwave
Cancer Therapy model, 778
Line/Extrusion plot radio button, 590, 607,
649, 665
Line specification window, 1D dual pane, for
left pane, 17
Line window, 1D dual-pane window, 25
linspace command, 2D Electric Impedance
Sensor model: advanced and solver, 489
Load button, 717, 731
Subdomain Settings page, COMSOL Material
Library, 40
Lorentz force, 169, 170
Low dimensionality geometric choices, making, 5
Lung function, 2D electric impedance
tomography research on, 460, 493

M
Magnetic ellipsoid, sphere, and Helmholtz
coil pair, 3D magnetic field of a
Helmholtz coil with a magnetic test
object model, 657
Magnetic field, obtaining graphical plot of, in 3D magnetic field of a Helmholtz coil model, 648–649

Magnetic flux density and magnetic potential, 2D AC Generator model, transient, 528

Magnetic flux density and magnetic potential, z component, 2D AC Generator Sector model, transient, 565

Magnetic vector potential (A) with z component, in static and transient sector-based models, 530

Magnetism, 115
Magnetometers, magnetostatic modeling applied to, 649

Magnetostatic field mapping, 572
Magnetostatic models applications for, 649, 666 basics, 634–635 relationships between potentials and fields, 635

Magnetostatics (emqa)
physics boundary settings 3D magnetic field of a Helmholtz coil model, 642 3D magnetic field of a Helmholtz coil with a magnetic test object model, 659

physics subdomain settings 3D magnetic field of a Helmholtz coil model, 641 3D magnetic field of a Helmholtz coil with a magnetic test object model, 658

Mass action law, electron and hole carrier densities and, 204

Materials and databases, 39–61
COMSOL Material Library module: searchable materials library, 40–43 guidelines and considerations, 39–40 MatWeb: searchable materials properties website, 43–48

PKS-MPD: searchable materials properties database, 48–61

Materials/Coefficients Library copper 2D Concave Mirror model, without PMLs, 731 2D Concave Mirror model, with PMLs, 717

edit page, PKS-MPD, 58, 59
load window 2D AC Generator model, static, 515 2D AC Generator Sector model, static, 544
UNS C10100 defined properties, first half, 44
UNS C10100 defined properties, second half, 44

Materials/Coefficients Library window, 2D AC Generator model, static, 514
Materials selected page, PKS-MPD, 60
Materials selected Properties page, PKS-MPD, 61

Materials selection and definition, importance of, 39
Matrix Elements edit window, 175t
2D Hall effect model, first variation on, 192t 2D Hall effect model, second variation on, 210t

MatWeb: searchable materials properties website, 43–48
access classes, 43, 45, 45

MatWeb membership level features comparison page, 45
MatWeb metal alloy UNS C10100 selection, 46
MatWeb Metal Alloy UNS Number search selection page, 46
MatWeb properties of UNS C10100, oxygen-free electronic-grade copper, 48
MatWeb search results for UNS C10100, oxygen-free electronic-grade copper, 47
MatWeb selection of UNS C10100, oxygen-free electronic-grade copper, 47
MatWeb selection search types, login home page, 45

Maximum element size, 165, 317, 388
Maximum Element Size edit window, 603, 660, 661, 732, 761, 784
Maxwell, James Clerk, 228, 634
Maxwell’s equations, 634 fundamental difficulties related to, 671
Mechanical polishing technique, 116 surface normal vector n and current vector J, 116, 117

Medical imaging, electrical resistance tomography and, 460
Medical studies, magnetostatic modeling applied to, 649
MEMS Module, Hall effect models and, 171
Mesh
3D electrostatic potential between five cylinders model, 630
3D electrostatic potential between two cylinders model, 619
3D magnetic field of a Helmholtz coil model, 644
3D magnetic field of a Helmholtz coil with a magnetic test object model, 662
3D thin layer resistance model: thin layer approximation, 589
3D thin layer resistance model: thin layer subdomain, 605
2D AC Generator model, static, 518
2D axisymmetric Microwave Cancer Therapy model, 789
2D axisymmetric Tumor Laser Irradiation model, 763
2D Concave Mirror model, without PMLs, 733
2D Concave Mirror model, with PMLs, 720
2D Dielectric Lens model, without PMLs, 700
2D Dielectric Lens model, with PMLs, 687
2D Electric Impedance Sensor model: advanced, 489
2D Electric Sensor model: basic, 473
Mesh Application Mode (ALE), rotation modeling and, in static and transient sector-based models, 531
Meshed boundaries, copied, 2D AC Generator Sector model, static, 553
Meshed model, KdV equation model, 72
Mesh generation
KdV equation model, 72
first variation on, 79
second variation on, 86
1D telegraph equation model, 94
first variation on, 101
second variation on, 108
3D electrostatic potential between five cylinders model, 628
3D electrostatic potential between two cylinders model, 617
3D magnetic field of a Helmholtz coil model, 643
3D magnetic field of a Helmholtz coil with a magnetic test object model, 660
3D thin layer resistance model: thin layer approximation, 588
3D thin layer resistance model: thin layer subdomain, 603–604
2D AC Generator model, static, 518
2D AC Generator Sector model, static, 552–554
2D axisymmetric Cylinder Conduction model, first variation on, 246
2D axisymmetric Cylinder Conduction model, second variation on, including vacuum cavity, 261
2D axisymmetric heat conduction model, 235
2D Axisymmetric Inductive_Heating_1 model, 406
2D Axisymmetric Inductive_Heating_2 model, 430
2D axisymmetric Microwave Cancer Therapy model, 784
2D axisymmetric Thermos_Container_1 model, 279
2D axisymmetric Thermos_Container_2 model, 296
2D axisymmetric Tumor Laser Irradiation model, 761, 763
2D Concave Mirror model, without PMLs, 732
2D Concave Mirror model, with PMLs, 718
2D Dielectric Lens model, without PMLs, 698
2D Dielectric Lens model, with PMLs, 686
2D Electric Impedance Sensor model: advanced, 488
2D Electric Impedance Sensor model: basic, 472
2D Electrochemical Polishing model, 125
first variation on, 140
second variation on, 159
2D Hall effect model, 180
first variation on, 198, 198
second variation on, 214
2D Inductive_Heating_3 model, 450
2D Resistive_Heating_1 model, 338
2D Resistive_Heating_2 model, 360
2D Resistive_Heating_3 model, 380
Mesh generator, thin layer approximation and, 577, 592–593
Mesh mapping, 568
Mesh model, 2D Resistive_Heating_3 model, 382
Mesh refinement
1D dual-pane heat flow model, 22
1D dual-pane window with air gap, 23
1D single-pane heat flow model, 11, 13
1D triple-pane heat flow model, 32
1D triple-pane window with air gaps, 33
Mesh Remaining (Free) button, on Mesh toolbar, 554
Mesh Selected button, 553, 603, 604, 718, 732, 763
Mesh window
2D axisymmetric Cylinder Conduction model, first variation on, 248
2D axisymmetric Cylinder_Conduction_1 model, 237
2D axisymmetric Inductive_Heating_1 model, 407
2D axisymmetric Inductive_Heating_2 model, 431
2D Inductive_Heating_3 model, 451
2D Resistive_Heating_1 model, 339
2D Resistive_Heating_2 model, 361
Microwave AC, joule heating and, 324
Microwave antenna
cross-section, 770
plus tissue, 771
Microwave cancer therapy, 769–770
Mixed boundary conditions, 71
Mixed-materials modeling, 388, 453
Mixed-mode modeling, 321–323, 388, 454. See also 2D complex mixed-mode modeling
Model building preparation, materials selection, definition and, 39
Model definition, first principles analysis applied to, 35–37
Modeling errors, common sources of, 37–38
Model mesh
2D axisymmetric Thermos_CONTAINER_1 model, 281
2D axisymmetric Thermos_CONTAINER_2 model, 297
2D axisymmetric Thermos_CONTAINER_3 model, 313
Model Navigator
Heat Transfer Module, 2D axisymmetric Microwave Cancer Therapy model, 771
initial solution, 2D AC Generator Sector model, transient, 558
initial solution selection, 2D AC Generator Sector model, transient, 558
1D telegraph equation model, 92
RF Module, 2D axisymmetric Microwave Cancer therapy model, 772
Model Navigator command sequence, 677, 707
Model Navigator initial solution, 2D AC Generator model, transient, 523
Model Navigator setup
3D electrostatic potential between five cylinders model, 623
3D magnetic field of a Helmholtz coil model, 636
3D thin layer resistance model: thin layer approximation, 577
3D thin layer resistance model: thin layer subdomain, 594
2D AC Generator model, static, 499
2D AC Generator Sector model, static, 532
2D axisymmetric Cylinder Conduction model first variation on, 242
second variation on, including a vacuum cavity, 252
2D axisymmetric Cylinder_Conduction_1 model, 230
2D axisymmetric Inductive_Heating_1 model, 394
2D axisymmetric Inductive_Heating_2 model, 412
2D axisymmetric Inductive_Heating_3 model, 437
2D axisymmetric Thermos_CONTAINER_1 model, 266
Model Navigator setup (continued)

- 2D axisymmetric Thermos_Container_2 model, 287, 303
- 2D axisymmetric Tumor Laser Irradiation model, 751
- 2D Concave Mirror model, without PMLs, 725
- 2D Concave Mirror model, with PMLs, 708
- 2D Dielectric Lens model, without PMLs, 692
- 2D Dielectric Lens model, with PMLs, 676
- 2D Electric Impedance Sensor model: advanced, 478
- 2D Electric Impedance Sensor model: basic, 465
- 2D Resistive_Heating_1 model, 327
- 2D Resistive_Heating_2 model, 348

Morse code, 77

Move edit window

- 3D thin layer resistance model: thin layer approximation, 583
- 3D thin layer resistance model: thin layer subdomain, 600

.mov extension, for saved animation in Power Mac, 75

Moving mesh (ALE), 529, 568

Moving Mesh Application Mode, 2D Electrochemical Polishing model and, 117–118

Multi-coil heating models, 454

Multiphysics General Industrial Applications demonstration model, 464

Multiphysics Model Library, 326, 393

Multiphysics Model Navigator window, 171, 188

- 2D Hall effect model, second variation on, 205

Niobium

- in 2D axisymmetric Cylinder Conduction model, 229
- in 2D axisymmetric Cylinder Conduction model, first variation on, 240
- in 2D axisymmetric Cylinder Conduction model, second variation on, including a vacuum cavity, 250

Nitrogen, crucible surrounded by, in 2D axisymmetric Inductive_Heating_2 model, 434

Nonlinear partial differential equations, role of, 64

O

ODE. See Ordinary differential equation

Ohm, Georg, 115, 167, 324, 391, 461, 493, 573

Ohm’s law, 167, 168, 322, 324–325, 388, 391, 392, 454, 455, 461, 493, 494

microwave cancer therapy theory and, 770
touch screen principle and, 573–575

1D axes/grid settings window, 66

1D Axisymmetric advanced-level modeling, 63

1D beginning-level-moderate-level modeling, 63

1D coordinate system, 5

1D dual-pane heat flow model, 16–27

- Boundary Settings window, 21
- Constants specification window, 17
dual-pane analysis and conclusions, 26–27

filled-in 1D dual-pane Boundary Settings window for boundary 1, 21

filled in-1D dual-pane Boundary Settings window for boundary 4, 22

Line specification window for air gap, 18
Line specification window for left pane, 17

1D dual-pane window general Plot Parameters window, 24

1D dual-pane window Line window, 25

1D dual pane window solution plotted using default values, 24

1D dual-pane window solution plotted using °F and Color Bar, 27

1D dual-pane window solution set to use color expression, 26

1D dual-pane window solution set to use °F, 25
1D dual-pane window with air gap with initialized mesh, 23
1D dual-pane window with air gap with refined mesh, 23
1D dual-pane workspace after clicking Zoom Extents icon, 19
1D dual-pane workspace showing both panes and air gap, 18
opening workspace, 16
subdomain settings, initial conditions, 20
Subdomain Settings Physics window settings
air gap, 20
left pane, 19
right pane, 20
1D KdV equation, solitons, optical fibers and, 65
1D modeling considerations, 63–64
1D modes, with COMSOL Multiphysics software, 63
1D single-pane heat flow model, 6–16
analysis and conclusions, 13, 15
boundary settings entered, 10–11
Boundary Settings window, 10
Filled-in Boundary Settings window for boundary 1, 11
Filled-in Boundary Settings window for boundary 2, 12
1D Constants specification window, 7
1D line specification window, 7
1D single-pane window General Plot Parameters window, 12, 14
1D single-pane window line Plot Parameters window, 12, 15
1D single-pane window solution plotted using default values, 11, 14
1D single-pane window solution plotted using °F and color bar, 13, 16
1D single-pane window with initialized mesh, 13
1D single-pane window with refined mesh, 13
1D Subdomain Settings Physics window settings, 9
1D Subdomain Settings window, 8
opening workspace, 6–7
physics of heat flow through single-pane window, 13, 15
plot presentation changes, 12–13
Subdomain Settings Init window settings, 10
0.005 m line shown in workspace, 8
1D telegraph equation model, 90–111
boundary conditions, 93
Boundary Settings window, 93
Constants window, 93
first variation on, 98–105
boundary conditions, 99
Boundary Settings window, 99, 100
Constants window, 99, 99t, 105t
Initial Conditions window, 101
mesh, 102
mesh generation, 101
model reset, 100
PDE, Coefficient window, Init page, 102
PDE, Subdomain Settings window,
PDE coefficients, 101
Plot Parameters window, Animate page, 104
postprocessing, 103
postprocessing animation, 103
pulse amplitude plot, low-loss line, 104
Solver Parameters window, Time Stepping page, 103
solving, 101
subdomain settings, 99–100
Subdomain Settings window, PDE, 100
Initial Conditions window, 94
mesh generation, 94
Model Navigator, 92
1D geometry, 92
PDE, Coefficient window, 94
PDE, Coefficient window, Init window, 95
PDE, telegraph equation model mesh, 95
postprocessing, 96
postprocessing animation, 96, 98
pulse amplitude plot, 97
second variation on, 105–111
boundary conditions, 106
Boundary Settings window, 106, 106t
Constants window, 105
Initial Conditions window, 107
mesh generation, 107
model mesh, 108
1D telegraph equation model (continued)
model reset, 108
PDE, Coefficient window, Init page, 108
Plot Parameters window, Animate page, 111
postprocessing, 109–110
postprocessing animation, 110
pulse amplitude plot, high-loss line, 111
second variation on, 107
solving, 109
subdomain settings, 106
Subdomain Settings window, PDE coefficients, 107
solution to, 97
Solver Parameters window, Time Stepping page, 96
solving, 94, 96
subdomain settings, 93
Subdomain Settings window, PDE coefficients, 93
summary and conclusions about, 110
telegraph equation geometry window, 92
Telegraph Equation Plot Parameters window, Animate page, 98
1D triple-pane heat flow model, 27–35
blank 1D triple-pane Boundary Settings window, 31
boundary settings, 32
Constants specification window, 28
filled-in 1D triple-pane Boundary Settings window for boundary 1, 31
1D triple-pane window Solution plotted using default values, 33
1D triple-pane window solution plotted using °F and Color Bar, 34
1D triple-pane window with air gaps with initialized mesh, 32
1D triple-pane window with air gaps with refined mesh, 33
opening workspace, 28
postprocessing parameters, 34
subdomain settings, initial conditions, 30
Subdomain Settings window, Init settings, 30
Subdomain Settings window, Physics setting, 29
triple-pane analysis and conclusions, 34–35
triple-pane window subdomain settings, 30
triple-pane window workspace lines, 28
workspace after clicking Zoom Extents icon, 29
1D triple-pane window, with heat flow indicator, 36
1D window panes heat flow models, 6–35
1D dual-pane heat flow model, 16–27
1D single-pane heat flow model, 6–16
1D triple-pane heat flow model, 27–35
Opaque thermally conductive materials, 306, 316
Open Model window, 78, 84
Optical coefficient of absorption for laser photons of tumors, 749
Options menu, COMSOL Material Library, 40
Ordinary differential equation, 460, 568

P
Paint sprayers, 3D electrostatic potential models and, 612, 622, 633
Paired stator (CO1) and rotor (CO2), 2D AC Generator Sector model, static, 537
Parametric Solver (UMFPACK)
solving 2D axisymmetric Cylinder Conduction model, first variation on, 246, 249
2D axisymmetric Cylinder Conduction model, second variation on, including vacuum cavity and, 262
2D axisymmetric Cylinder_Conduction_1 model and, 236, 238
2D axisymmetric Cylinder_Conduction_1p model and, 239
2D axisymmetric Thermos_Container_1 model and, 282
2D axisymmetric Thermos_Container_2 model and, 298
2D axisymmetric Thermos_Container_3 model and, 314
2D Hall effect model and, 180
first variation on, 198
second variation on, 216
Particle accelerators, 3D electrostatic potential models and, 612, 622, 633
PDAs. See Personal digital assistants
PDE

Coefficient window, Init page, second variation on COMSOL 1D telegraph equation model, 108

Subdomain Settings window, PDE coefficients, second variation on COMSOL 1D telegraph equation model, 107

Pennes, Harry H., 747

Penne's equation, 747

Perfectly matched layer models, 671–744

function of methodology, 672

theory behind, 671

3D Cartesian domain with, 672, 673

3D cylindrical domain with, 672, 674

3D spherical domain with, 672, 673

2D Cartesian domain with, 672, 672

2D Concave Mirror model with, 707–724

2D Concave Mirror model without, 724–744

2D Dielectric Lens model with, 676–691

2D Dielectric Lens model without, 691–707

Perfusion rate, defined, 748

Periodic boundary condition settings, for KdV equation model, 67

Periodic Boundary Conditions window

Destination page, 69

Destination page, boundary 2, 68

Destination Vertices page, vertex 2, 69

KdV equation model, 67

Source page, boundary 1, variable u2, 69

Source page, KdV equation model and, 67

Source Vertices page, 70

Source Vertices page, vertex 1, 68

Periodic Point Conditions

Destination page, 2D AC Generator Sector model, static, 550

Destination Vertices page, 2D AC Generator Sector model, static, 551

Source page, 2D AC Generator Sector model, static, 549

Source Vertices page, 2D AC Generator Sector model, static, 550

Permeability for free space in SI units, numerical value of, 636, 641, 658

Permittivity, AC realm modeling, skin depth and, 463

Permittivity for free space in SI units, numerical value of, 616, 627

Perpendicular Induction Currents, Vector Potential, physics subdomain settings, 2D AC Generator model, static, 513–515

Personal digital assistants, 573

Physical properties, typical coupling of, in developed model, 37

Physics boundary settings

Azimuthal Induction Currents, Vector Potential (emqa), 2D axisymmetric Inductive_Heating_1 model, 401–402

Conductive Media DC (dc)

2D Electrochemical Polishing model, 123

2D Electrochemical Polishing model, first variation on, 137

2D Electrochemical Polishing model, second variation on, 156

2D Resistive_Heating_2 model, 358, 360

2D Resistive_Heating_3 model, 379

2D AC Generator model, static, 516

general heat transfer

2D axisymmetric Inductive_Heating_1 model, 404

2D axisymmetric Thermos_CONTAINER_1 model, 277

Moving Mesh (ALE)

2D Electrochemical Polishing model, 125

2D Electrochemical Polishing model, first variation on, 138, 140

Perpendicular Induction Currents, Vector Potential (emqa), 2D AC Generator Sector model, static, 547

Physics settings

Periodic Point Conditions, 2D AC Generator Sector model, static, 549–551

2D axisymmetric Inductive_Heating_1 model, 398

2D axisymmetric Inductive_Heating_2 model, 419

2D axisymmetric Inductive_Heating_3 model, 440
Physics subdomain settings
Azimuthal Induction Currents, Vector Potential (emqa), 2D Axisymmetric Inductive Heating_1 model, 400
Conductive Media DC
2D Electrochemical Polishing model, 123
2D Electrochemical Polishing model, first variation on, 137
2D Electrochemical Polishing model, second variation on, 156
2D Resistive Heating_2 model, 354, 356
2D Resistive Heating_3 model, 377
general heat transfer, 2D axisymmetric Inductive Heating_1 model, 403–404
Moving Mesh (ALE) (ale)
2D AC Generator model, static, 515
2D AC Generator Sector model, static, 542
Perpendicular Induction Currents, Vector Potential (emqa), 2D AC Generator Sector model, static, 542–544
PKS-MPD, 48–61
Composition materials selection page for copper, 52
Composition percentage selection added page for copper, 51
Composition percentage selection page for copper, 50
Composition selection added page for copper, 50
Composition selection page for copper, 49
Copper file selected as library to be added, 59
defined properties in, 48
exporting file as text file, 57
main selection page in, 48, 49
Materials/Coefficients Library edit page, 58, 59
Materials selected page, 60
Materials selected Properties page, 61
Materials selected verification page for copper, 56
Materials selection Print Preview page 1 for copper, 54
Materials selection Print Preview page 2 for copper, 55
Materials selection Properties display page for copper, 53, 55, 56
Materials selection properties for copper (UNS C10100) exported, 58
Materials selection Tensile Strength display page for copper, 57
Print Materials selection page for copper, 52
Selection Criteria window in, 48
Planck, Max, 228
Plot Cross-Section Parameters
General page, 2D Hall Effect_2 model, 201
Line/Extrusion page, 2D Hall Effect_2 model, 202
Line/Extrusion page, 2D Hall Effect_3 model, 220
Plot Parameters
Animate tab
2D AC Generator Sector model, transient, 567
2D AC Generator model, transient, 530
2D axisymmetric Tumor Laser Irradiation model, 768
2D Concave Mirror model, without PMLs, 738
2D Concave Mirror model, with PMLs, 724
2D Dielectric Lens model, without PMLs, 704
2D Dielectric Lens model, with PMLs, 692
animation, final frame, 2D axisymmetric Tumor Laser Irradiation model, 769
Arrow edit window, 2D Resistive Heating_1 model, 342
Contour Data page
2D Hall Effect_3 model, 218
2D Hall effect model, first variation on, 200
Contour tab
2D AC Generator model, transient, 527
2D AC Generator Sector model, transient, 564
General tab, 2D AC Generator model, transient, 525
postprocessing, Surface tab (°C)
2D axisymmetric Microwave Cancer Therapy model, 791
2D axisymmetric Tumor Laser Irradiation model, 765
Surface tab
- postprocessing, 2D Dielectric Lens model, without PMLs, 702
- 2D AC Generator model, transient, 526
- 2D AC Generator Sector model, transient, 563
- 2D Concave Mirror model, with PMLs, 722
- 2D Dielectric Lens model, with PMLs, 690
- 2D axisymmetric Inductive Heating model, first variation on, 436

Plot Parameters edit window

Boundary tab
- 3D thin layer resistance model: thin layer approximation, 590
- 3D thin layer resistance model: thin layer subdomain, 607

General tab, 3D thin layer resistance model: thin layer subdomain, 606
- 3D magnetic field of a Helmholtz coil model, 650
- 2D axisymmetric Inductive_Heating_2 model, 434
- 2D Electric Impedance Sensor model: advanced, 491
- 2D Electric Sensor model: basic and selection of, 476
- 2D Inductive_Heating_1 model, 409, 410
- 2D Resistive_Heating_1 model, 341
- 2D Resistive_Heating_2 model, 363
- 2D Resistive_Heating_3 model, 385

Plot Parameters selection window

Arrow tab, 3D magnetic field of a Helmholtz coil with a magnetic test object model, 667

Boundary tab
- 3D magnetic field of a Helmholtz coil model, 648
- 3D magnetic field of a Helmholtz coil with a magnetic test object model, 666

General tab
- 3D magnetic field of a Helmholtz coil model, 646
- 3D magnetic field of a Helmholtz coil with a magnetic test object model, 664

Slice tab
- 3D magnetic field of a Helmholtz coil model, 647
- 3D magnetic field of a Helmholtz coil with a magnetic test object model, 665
- 3D electrostatic potential between five cylinders model, 632
- 3D electrostatic potential between two cylinders model, 621

Plot Parameters window

Animate page
- KdV equation model, first variation on, 83
- KdV equation model, second variation on, 89
- KdV model solution, 76
- 1D telegraph equation model, 98
- 1D telegraph equation model, first variation on, 104
- 1D telegraph equation model, second variation on, 111

Contour Data page, 2D Hall_Effect_1 model, 183
general, 1D dual-pane window, 24

Line page, KdV model solution, 76
- 1D single-pane heat flow model, 12, 15
- 2D axisymmetric Cylinder Conduction model, second variation on, including vacuum cavity and, 263
- 2D axisymmetric Cylinder_Conduction_1p model, 240
- 2D axisymmetric Inductive_Heating_3 model, 456
- 2D axisymmetric Thermos_Container_1 model, 283, 285
- 2D axisymmetric Thermos_Container_2 model, 299, 301
- 2D axisymmetric Thermos_Container_3 model, 314
- 2D Electric Impedance Sensor model: advanced, 493
- 2D Electrochemical Polishing model, 144
- 2D Electrochemical Polishing model, second variation on, 14
- 2D Resistive_Heating_1 model, 346
- 2D Resistive_Heating_2 model, 366
- 2D Resistive_Heating_3 model, 389
INDEX

PML domain, wave equation solution example inside, 675
PML rectangles
  2D Concave Mirror model, with PMLs, 710
  2D Dielectric lens model, with PMLs, 679
Point constraints, 171
Point edit window
  2D Hall effect model, 175
  2D axisymmetric Cylinder Conduction model, 232, 233
    first variation on, 244, 244
    second variation on, including a vacuum cavity, 255
  2D Electric Impedance Sensor model:
    advanced, 482
    basic, 468
Points, adding to boundary of rectangle, 2D Hall effect model, 173
Polishing, reduction of asperities and, 116
Polyline, closed, 2D generator geometry and, 535
Postprocessing
  KdV equation model, 75
  1D telegraph equation model, 96
    first variation on, 103
    second variation on, 109–110
Postprocessing animation
  KdV equation model
    first variation on, 82
    second variation on, 88
  1D telegraph equation model, 96, 98
    first variation on, 103, 105
    second variation on, 110
Postprocessing parameters
  1D dual-pane heat flow model, 23
  1D single-pane heat flow model, 12
  1D triple-pane heat flow model, 34
Postprocessing Plot Parameters, Surface tab,
  2D Concave Mirror model, without PMLs, 736
Postprocessing presentation(s), 1D single-pane heat flow model, 12
Preconditioner pull-down list, 619
Predefined quantities pull-down list, 664
Premium Member access, MatWeb, 43, 45, 45, 46

Priestley, Joseph, 115
Primary input power, 495
Proportionality constant, for 2D electropolishing technique, 117
Pryor Knowledge Systems-Materials Properties Database. See PKS-MPD
Pulse amplitude plot
  1D telegraph equation model, 97
  1D telegraph equation model, high-loss line, second variation on, 111
  1D telegraph equation model, low-loss line, first variation on, 104

Q
Quadrilateral mesh (quad), 165–166, 317, 388
Quasi-static methodology, 6, 571, 572
Quasi-static models, transient models vs., 321
QuickTime player, free, animations viewed with, 75

R
Radial position in space, 227
Radius edit window, 639, 655
Rectangle
  circle and, 2D Resistive_Heating_1 model, 330
  created, 2D Resistive_Heating_3 model, 370
  points and
    physics settings, 2D Electric Impedance Sensor model:
      basic, 468
  2D axisymmetric Cylinder Conduction model, first variation on, 244
  rotor created, 2D AC Generator model, static, 509
  2D axisymmetric Microwave Cancer Therapy model, 775
  2D Electric Impedance Sensor model:
    advanced, 480
    basic, 467
  2D Resistive_Heating_1 model, 329
Rectangle edit window
  2D axisymmetric Cylinder Conduction model, 232
    first variation on, 243
    second variation on, including a vacuum cavity, 253
2D axisymmetric Inductive_Heating_1 model, 398
2D axisymmetric Microwave Cancer Therapy model, 774, 777, 778
2D axisymmetric Thermos_Container_1 model, 268t, 269t
2D axisymmetric Thermos_Container_2 model, 289t, 305t
2D axisymmetric Tumor Laser Irradiation model, 750, 752, 753, 755
2D Concave Mirror model, without PMLs, 727
2D Concave Mirror model, with PMLs, 708, 709, 712
2D Dielectric Lens model, without PMLs, 694
2D Dielectric Lens model, with PMLs, 677, 677, 678, 680
2D Electric Impedance Sensor model: advanced, 481
2D Electric Impedance Sensor model: basic, 467
2D Hall_Effect_2 model, 190, 191t
2D Hall_Effect_3 model, 207
2D Resistive_Heating_1 model, 329
2D Resistive_Heating_2 model, 349t
2D Resistive_Heating_3 model, 370t
Rectangle geometry
2D Hall_Effect_2 model, 190
2D Hall_Effect_3 model, 207
Rectangles (R1, R2), 2D axisymmetric Tumor Laser Irradiation model, 753
Refine Mesh button, 125, 214, 235, 238, 338, 360
Registered Member access, MatWeb, 43, 45
Relative Permittivity edit window, 616
Relativistic effects, 6
Remesh button, 141, 160, 261, 472, 518, 644, 661
Remeshed model
KdV equation model, first variation on, 80
KdV equation model, second variation on, 87
Reset Model command, 79, 86
Resistance, 168
of homogeneous, isotropic solid material, 168
mapping of, into impedance, 462
Resistance changes, temperature changes and, 391
Resistive heating model, 322
first variation on, 325
second variation on, 325
solving, 325
Resistivity, of homogeneous, isotropic solid material, 169
Revolve edit window
3D magnetic field of a Helmholtz coil model, 639
3D magnetic field of a Helmholtz coil with a magnetic test object model, 655
RF Module, PML technique explicitly available in, 671, 672
Rotary motion, 2D generator model and, 460
Rotor assembly, 2D AC Generator Sector model, static, 536, 538
Rotor created circles, 2D AC Generator model, static, 508
Rotor created rectangles, 2D AC Generator model, static, 509
Rotor Geometry Circles Creation, 2D AC Generator model, static, 508
Rotor Geometry Rectangles Creation, 2D AC Generator model, static, 509
“Run out of memory” problem, 577, 593
Russell, John Scott, 65
S
Samarium cobalt (radial, inward), addition of, to 2D AC Generator model, static, 515
Samarium cobalt (radial, outward), addition of, to 2D AC Generator model, static, 515
Save As edit window
3D electrostatic potential between five cylinders model, 626
3D electrostatic potential between two cylinders model, 615
3D magnetic field of a Helmholtz coil model, 637
3D magnetic field of a Helmholtz coil with a magnetic test object model, 653
3D thin layer resistance model: thin layer subdomain, 596
2D AC Generator model, Stator Geometry Circles Creation, 501
Save As edit window (continued)
2D AC Generator Sector model, static, 556
2D axisymmetric Tumor Laser Irradiation model, 754
2D Concave Mirror model, without PMLs, 726
2D Concave Mirror model, with PMLs, 711
2D Dielectric Lens model, without PMLs, 693
2D Dielectric Lens model, with PMLs, 679
2D Electric Impedance Sensor model:
advanced, 479
2D Electric Impedance Sensor model:
basic, 466
Save As window, 2D axisymmetric Microwave Cancer Therapy model, 773
Saving, model building and, 15
Scalar expressions
KdV equation model, first variation on, 77
KdV equation model, second variation on, 84
physics settings
2D axisymmetric Tumor Laser Irradiation model, 755
2D Electric Impedance Sensor model:
advanced, 483
2D Electric Impedance Sensor model:
basic, 466
Scalar Expressions edit window, 399t, 400
2D axisymmetric Inductive_Heating_2
model, 421, 421t
2D axisymmetric Inductive_Heating_3
model, 441, 441t
2D axisymmetric Tumor Laser Irradiation
model, 756, 757
2D Electric Impedance Sensor model:
advanced, 483t, 484
2D Electric Impedance Sensor model:
basic, 469
Scalar Expressions file, 231, 253
Scalar Expressions window, 78, 85
Scalar variables, physics settings
2D Electric Impedance Sensor model:
advanced, 484
2D Electric Impedance Sensor model:
basic, 468
2 TM waves (rffh), 2D axisymmetric
Microwave Cancer Therapy model, 782
Scale button, 136, 155
Scale edit window, 2D electropolishing_3
model, 155
Scale factor Auto check box, 647, 664
Scattered electric field, z-component (V/m), 735
solution
2D dielectric lens model, with PMLs, 689
2D dielectric lens model, without PMLs, 701
Scattered electric field, z component (V/m), 2D
Concave Mirror model, with PMLs, 721
Scattering boundary condition
from Boundary condition pull-down list, 686
outer PML boundary and, 674
Secondary output power, 495
Select by Group check box, 686, 718
Selection Criteria window, PKS-MPD, 41
Select Remaining button, 604, 718, 732
Semiconductors, carrier types in, 168, 203–204
Semiconductor sensors, 170
Set formula edit window, 615
sigma_Bi_T, scalar expression for, 441
sigma_Cu_T, scalar expression for, 441
Signal amplitude, adequate, receiving correct
message and, 83
Signal-to-noise ratio, minimum detectable
signal and, 77
Silica glass, thermal conductivity of, 17
Silicon, semiconductor carrier types and, 203
Silicon sample, 2D Hall effect model, first
variation on, anisotropic coupling of
magnetic field and current flowing in, 192
Silicon wafer, 2D Hall effect model, first
variation on, closer approach to
construction of specimen as
constructed from, 186
Single-coil heating models, 454
Single-pane windows, dual- and triple-pane
windows compared with, 35t
60 Hz wavelength calculation, 635
Skin, tissue, and tumor (CO1), 2D axisymmetric
Tumor Laser Irradiation model, 756
Skin depth, 493
AC realm modeling and, 463
parameters in 2D Electric Impedance Sensor
model: basic, 464
Slice check box, 606
Slice plot, default
  3D thin layer resistance model: thin layer approximation, 589
  3D thin layer resistance model: thin layer subdomain, 605
Smooth check box, 588
Soft iron (without losses), addition of, to 2D AC Generator model, static, 515
Soft nonlinear magnetic materials, 529, 568
Solid materials, three potential mobile carriers of charge in, 168
Soliton propagation problems, 65
Soliton pulses, splitting of, reduction of argument for initial conditions in KdV model solution and, 82–83
Soliton wave propagation, in diverse media, KdV equations and, 90
Solver and Solver Parameters
  1D dual-pane heat flow model, 22
  1D single-pane heat flow model, 11
  1D triple-pane window, using default values, 33, 33
Solver Manager, Solve For page, 2D AC Generator Sector model, transient, 560
Solver Parameters
  Advanced edit window
    2D axisymmetric Inductive_Heating_1 model, 408
    2D axisymmetric Inductive_Heating_3 model, 452
    2D axisymmetric Microwave Cancer Therapy model, 789
    2D axisymmetric Tumor Laser Irradiation model, 764
    2D Concave Mirror model, without PMLs, 734
    2D Concave Mirror model, with PMLs, 720
    2D Dielectric Lens model, without PMLs, 700
    2D Dielectric Lens model, with PMLs, 688
Solver Parameters edit window
  Advanced edit window, 2D Axisymmetric Inductive_Heating_2 model, 432
  3D electrostatic potential between two cylinders model, 631
  3D electrostatic potential between two cylinders model, 620
  2D AC Generator model
    static, 520
    transient, 524
  2D AC Generator Sector model
    static, 555
    transient, 559
  2D axisymmetric Cylinder Conduction model, first variation on, 248
  2D axisymmetric Cylinder Conduction model, second variation on, including vacuum cavity, 262
  2D axisymmetric Cylinder_Conduction_1p model and, 239
  2D axisymmetric Inductive_Heating_1 model, 407
  2D axisymmetric Inductive_Heating_2 model, 432
  2D axisymmetric Thermos_Container_1 model, 281
  2D axisymmetric Thermos_Container_2 model, 297
  2D axisymmetric Thermos_Container_3 model, 313
  2D Electric Impedance Sensor model: advanced, 490
  2D Electric Sensor model: basic, 474
  2D Inductive_Heating_3 model, 451
  2D Resistive_Heating_1 model, 340
  2D Resistive_Heating_2 model, 362
  2D Resistive_Heating_3 model, 383
Solver Parameters window
  KdV equation model, 73
    first variation on, 81
    second variation on, 87
  Time Stepping page, 74
    KdV equation model, first variation on, 81
    KdV equation model, second variation on, 88
    1D telegraph equation model, first variation on, 103
    1D telegraph equation model, second variation on, 109
    2D Electrochemical Polishing model, 143
    second variation on, 162
Solver Parameters window (continued)

2D Hall_Effect_1 model, 182
  2D Hall_Effect_2 model, 199
  2D Hall_Effect_3 model, 216
SOR gauge, 636
Space coordinates
  in 1D model, 64
  in 3D transient solution model, 573
  in transient solution model, 461
  in 2D model, 114, 115
Space dimensions, 6
Specify Object commands, 396
Sphere, Helmholtz coil pair, and magnetic ellipsoid, 3D magnetic field of a Helmholtz coil with a magnetic test object model, 657
Sphere and Helmholtz coil pair, 3D magnetic field of a Helmholtz coil model, 641
Sphere edit window
  3D electrostatic potential between five cylinders model, 623, 624
  3D electrostatic potential between two cylinders model, 613, 614
  3D magnetic field of a Helmholtz coil model, 640
  3D magnetic field of a Helmholtz coil with a magnetic test object model, 657
Spherical coordinate systems, 5
Spherical coordinate transform angle rotational sense for phi and, 4
  rotational sense for theta and, 5
sqrt argument, 3
Square edit window
  3D magnetic field of a Helmholtz coil model, 638, 638, 639
  3D magnetic field of a Helmholtz coil with a magnetic test object model, 654, 655
  3D thin layer resistance model: thin layer approximation, 581
  3D thin layer resistance model: thin layer subdomain, 598
  2D Concave Mirror model, without PMLs, 728
  2D Concave Mirror model, with PMLs, 713
  2D Dielectric Lens model, without PMLs, 695
Static electricity, study of, 611
Static methods, 572
Stationary Solver
  2D axisymmetric Cylinder-Conduction_1 model and, 236
  2D Electric Impedance Sensor model: advanced and, 488
  2D Electric Impedance Sensor model: basic and, 463
  2D Electric Sensor model: basic and, 474
Stator and rotor
  composite objects, 2D AC Generator model, static, 511
  paired, 2D AC Generator model, static, 512
Stator and rotor Create Pairs edit window, 2D AC Generator model, static, 512
Stator assembly, 2D AC Generator Sector model, static, 536, 538
Steady-state model, 6
Steady-state solution
  to 3D model, parameters and, 572
  to 2D axisymmetric models, 324
  to 2D coordinate system model, 461
  to 2D model, 323
Steady-state value, 2D Resistive_Heating_3 model and, 384
Streamline check box, 619
Subdomain edit window
  3D thin layer resistance model: thin layer approximation, 585t
  3D thin layer resistance model: thin layer subdomain, 601t
  2D AC Generator model, static, 516t
  2D AC Generator Sector model, static, 544t, 545, 546, 547
  2D axisymmetric Cylinder Conduction model, first variation on, 245t
  2D axisymmetric Cylinder Conduction model, second variation on, including a vacuum cavity, 258t
  2D axisymmetric Cylinder_Conduction_1 model, 234t
  2D axisymmetric Inductive_Heating_1 model, 401t, 403t, 403t, 404
  2D axisymmetric Inductive_Heating_2 model, 423t, 426t
2D axisymmetric Thermos_Container_1 model, 274t
2D axisymmetric Thermos_Container_2 model, 290t, 291t, 305t, 306t, 308, 308t
2D Electric Impedance Sensor model: advanced, 485t
2D Electric Impedance Sensor model: basic, 470t
2D Inductive_Heating_3 model, 442t, 446t, 447, 448
2D Resistive_Heating_1 model, 332t
Subdomain Expressions
physics settings, 2D axisymmetric Tumor Laser Irradiation model, 755, 757
2D AC Generator Sector model, static, 539
Subdomain Expressions edit window
2D AC Generator Sector model, static, 539t, 540, 540t, 541
2D axisymmetric Tumor Laser Irradiation model, 757
Subdomain Integration Variables
physics settings, 2D AC Generator model, static, 513
2D AC Generator Sector model, static, 539
Subdomain Integration Variables edit window
2D AC Generator model, static, 513t, 513t
2D AC Generator Sector model, static, 540t, 541, 542
Subdomain mesh, 165, 317, 388
Subdomain settings changing
KdV equation model, first variation on, 77
KdV equation model, second variation on, 85
Electric Parameters edit window
2D axisymmetric Inductive_Heating_2 model, 423, 424
2D axisymmetric Inductive_Heating_3 model, 442, 443, 444, 445
Initial value edit window, 2D axisymmetric Tumor Laser Irradiation model, 760
Init window, 2D Resistive_Heating_1 model, 336
KdV equation model, 71
1D telegraph equation model, 93–94 first variation on, 99–100
second variation on, 106
physics settings: 2 TM waves (rfwh),
2D axisymmetric Microwave Cancer Therapy model, 782
Physics tab
subdomain, 2D Concave Mirror model, without PMLs, 730
subdomain 2, 2D Concave Mirror model, without PMLs, 731
subdomain 5, 2D Concave Mirror model, with PMLs, 717
subdomain 5, 2D Dielectric Lens model, with PMLs, 685
subdomain 7, 2D Concave Mirror model, with PMLs, 718
subdomain 7, 2D Dielectric Lens model, with PMLs, 685
subdomain 1, 2D Dielectric Lens model, without PMLs, 697
subdomain 2, 2D Dielectric Lens model, without PMLs, 698
3D magnetic field of a Helmholtz coil model, 641t
3D magnetic field of a Helmholtz coil with a magnetic test object model, 658t
triple-pane window, 30t
triple-pane window, initial conditions, 30t
2D axisymmetric Microwave Cancer Therapy model, 780t, 781, 782t
2D axisymmetric Tumor Laser Irradiation model, 758, 758t, 759
2D Hall effect model, 173, 175 first variation on, 191
second variation on, 208, 210
x absorption, 2D Concave Mirror model, with PMLs, 716
x absorption, 2D Dielectric Lens model, with PMLs, 684
y absorption, 2D Concave Mirror model, with PMLs, 716
y absorption, 2D Dielectric Lens model, with PMLs, 684
Subdomain settings, Conductive Media DC edit window, 355
  2D Resistive_Heating_2 model, 356, 357, 358
  2D Resistive_Heating_3 model, 377, 377t, 378
Init edit window
  2D Resistive_Heating_2 model, 358
  2D Resistive_Heating_3 model, 379
  2D Electrochemical Polishing model, 123
Subdomain settings, Init edit window
  2D axisymmetric Inductive_Heating_2 model, 429
  2D axisymmetric Inductive_Heating_3 model, 449
  2D Resistive_Heating_1 model, 333
  2D Resistive_Heating_2 model, 354
  2D Resistive_Heating_3 model, 375
Subdomain Settings, Moving Mesh edit window
  2D AC Generator model, static, 516
  2D AC Generator Sector model, static, 543
Subdomain settings, PML type selection
  2D Concave Mirror model, with PMLs, 715
  2D Dielectric Lens model, with PMLs, 683
Subdomain settings (2), Electric Parameters edit window, 2D axisymmetric Inductive_Heating_1 model, 400
Subdomain Settings edit window
  3D electrostatic potential between five cylinders model, 627
  3D electrostatic potential between two cylinders model, 616
  3D magnetic field of a Helmholtz coil model, 642
  3D magnetic field of a Helmholtz coil with a magnetic test object model, 658, 659
  3D thin layer resistance model: thin layer approximation, 585
  3D thin layer resistance model: thin layer subdomain, 602, 603, 604
  2D AC Generator model, static, 516, 517, 518
  2D axisymmetric Cylinder Conduction model, 234
  2D axisymmetric Cylinder Conduction model, first variation on, 245

2D axisymmetric Inductive_Heating_2 model, 428
2D Electric Impedance Sensor model: advanced, 485
2D Electric Impedance Sensor model: basic, 470
2D Resistive_Heating_1 model, 333, 336
2D Resistive_Heating_2 model, 352, 353
2D Resistive_Heating_3 model, 373, 374
Subdomain Settings Physics window settings
  1D dual-pane, air gap, 20
  1D dual-pane, left pane, 19
  1D dual-pane, right pane, 20
Subdomain Settings window
  Init settings, 1D triple-pane, 30
PDE coefficients
  KdV equation model, 71t
  KdV equation model, first variation on, 79t
  KdV equation model, second variation on, 85
  1D telegraph equation model, 93
  1D telegraph equation model, first variation on, 100t, 101
  1D telegraph equation model, second variation on, 107t
Physics settings, 1D triple-pane, 29
2D Electrochemical Polishing model, 124
2D Electrochemical Polishing model, first variation on, 137
Suppress Boundaries selection window
  3D electrostatic potential between five cylinders model, 633
  3D electrostatic potential between two cylinders model, 621
  3D magnetic field of a Helmholtz coil model, 645
  3D magnetic field of a Helmholtz coil with a magnetic test object model, 663
Suppress Subdomains
  2D Concave Mirror model, with PMLs, 722
  2D Dielectric Lens model, with PMLs, 689
Surface check box, 561
Surface temperature (°C), 2D axisymmetric Microwave Cancer Therapy model, 792
Surface voltage distribution plot
  default, 2D Hall_Effect_1 model, 182
  default, 2D Hall_Effect_2 model, 199
  default, 2D Hall_Effect_3 model, 217
Symmetry, 2D generator sector model and use of, 460
Sze, S. M., 168

T
Tank Export Geometry Objects, Save As window, 2D axisymmetric
  Thermos_CONTAINER_1 model, 273
Tank profile, outer, 2D axisymmetric
  Thermos_CONTAINER_1 model, 270
Tank(s)
  components, 2D axisymmetric
    Thermos_CONTAINER_1 model, 271
  components with lid line, 2D axisymmetric
    Thermos_CONTAINER_1 model, 272
  2D axisymmetric Thermos_CONTAINER_1 model, 273
Tank structure creation, 2D axisymmetric
  Thermos_CONTAINER_1 model, 270
Telegraph equation, development of, 90
Telegraph equation electrical component model, 90
Temperature calculations
  1D dual-pane analysis and, 26–27
  1D single-pane analysis and, 13, 15
  1D triple-pane analysis and, 34–35
elevations in
  hyperthermic oncology and, 769
tumor cell death and, 765, 769, 770, 788, 794
  as function of applied power versus radius,
    2D axisymmetric microwave cancer therapy model, 793
Temperature and heat flux, 2D
  Resistive_HEATING_1 model, 343
Temperature changes, resistance changes and, 391
Temperature uniformity, 2D axisymmetric
  Thermos_CONTAINER_1 model, 277
Temperature vs. time plot
  2D Resistive_HEATING_1 model, 344, 345
  2D Resistive_HEATING_2 model, 365
  2D Resistive_HEATING_3 model, 387
Tesla, Nikola, 494
Thales of Miletus, 611
Thermal conductivity
  loading, 1D single-pane heat flow model, 9
  loading, 1D dual-pane heat flow model, 18
Thermal insulation boundary condition, 782
Thermal losses, DC power and, 496
Thermodynamics, heat transfer and science of, 228
Thermos, origin of term, 265
Thermos laminar flow model, 265
Thermos laminar hcoefficient model, 265
Thick layers, 572
Thin layer approximation, applications for, 592–593
Thin layer approximation model applications for, 577
  in solution of direct current conduction model, 575–576
Thin layer orthogonal voltage dividers, in touch screen technology, 574
Thin layer resistance modeling basics, 575–577
Thin layers, 572
Thin layer technology, touch screen and, 573
Thomson, William (Lord Kelvin), 228
3D Cartesian domain, with PMLs, 672, 673
3D coordinate system, 5
  plus time, 573
  in steady-state solution to 3D model, 572–573
  in transient solution model, 573
3D cylindrical domain, with PMLs, 672, 674
3D electrostatic potential between cylinders models, 572
3D electrostatic potential between five cylinders model, 622–633
Boundary Settings, 627
Boundary Settings (1–4, 23, 24, 28, 29) edit window, 628
Boundary Settings (5–14, 19–22, 25, 26, 31–38) edit window, 628
Boundary Settings (15–18, 27, 30) edit window, 629
3D electrostatic potential between five cylinders model (continued)
Create Composite Object edit window, 626
Cylinder CYL1 edit window, 624
Cylinder CYL2 edit window, 624
Cylinder CYL3 edit window, 625
Cylinder CYL4 edit window, 625
Cylinder CYL5 edit window, 625
default solution plot, 631
Free Mesh Parameters edit window, 629
Geometry Components, 623
geometry modeling, 623, 626
mesh, 630
mesh generation, 628
Model Navigator setup, 623
physics boundary settings:
  electrostatics (es), 627
physics subdomain settings: electrostatics (es), 627
Plot Parameters selection window, 632
postprocessing and visualization, 630, 632
Solver Parameters edit window, 631
solving, 630
Sphere edit window, 614
start building, 613
streamline plot with suppressed boundaries, 622
Subdomain Settings edit window, 616
summary and conclusions about, 622
Suppress Boundaries selection window, 621
3D magnetic field of a Helmholtz coil model, 636–652
Boundary Settings (1–4, 21, 22, 31, 32) edit window, 643
Boundary Settings (2, 3) edit window, 642
constants, 637
Cross-Section Plot Parameters edit window, 650
derivation of, 636
Free Mesh Parameters edit window
  General tab, 643
  Subdomain tab, 644
Geometry Components, 638
generality modeling, 638
Helmholtz coil pair, 640
mesh, 644
mesh generation, 643–644
Model Navigator setup, 636
physics boundary settings: Magnetostatics (emqa), 642
physics subdomain settings: Magnetostatics (emqa), 641
Plot Parameters selection window
Index
3D thin layer resistance models (continued)

- Cross-Section Line Data Parameters, 592
- Cross-Section Plot Parameters edit window, 592
- default slice plot, 589
- derivation of, 577
- EMB1 and BLK1 selected, 584
- Embed edit window, 582
- EMB1 on top of block BLK2, 583
- Geometry Components, 578
- geometry modeling, 578–583
- Geom2 work-plane, 580
- identity-pair-contact resistance approximation used in, 586–587
- mesh, 589
- mesh generation, 588
- model identity pair, 585
- Model Navigator setup, 577
- Move edit window, 583
- physics boundary settings: Conductive Media DC (dc), 586
- physics subdomain settings: Conductive Media (DC) (dc), 583–584
- Plot Parameters edit window, Boundary tab, 590
- postprocessing and visualization, 588
- solving, 588
- Square edit window, 581
- start building, 577
- Subdomain edit window, 585
- Subdomain Settings window, 585
- summary and conclusions about, 591–593
- TLR voltage measured across the layer, 590–591
- Work-Plane Settings edit window, 580
- Work-Plane settings in, 580
- X-Axis Data edit window, 591
- thin layer subdomain, 593–611
- BLK1 edit window, 594
- BLK2 edit window, 595
- BLK3 edit window, 595
- Boundary Settings (1, 2, 4, 5, 7, 8, 10, 12–17) edit window, 603
- Boundary Settings—Conductive Media DC (dc) edit window, 601

Boundary Settings (3) edit window, 603
Boundary Settings (11) edit window, 604
Circle edit window, 598
CO1 (intersection of circle and plane), 599
Create Composite Object window, 598
cross-section electric potential plot, 610
cross-section electric potential plot, thin layer approximation, 610
cross-section electric potential plot, thin layer subdomain, 611
Cross-Section Line Data Parameters, 609
Cross-Section Plot Parameters edit window, 609
default slice plot, 605
Embed edit window, 599
EMB1 on top of block BLK3, 600
Free Mesh Parameters edit window, 604
Geometry Components, 594
geometry modeling, 593, 595–596, 598–600
Geom2 work-plane, 597
mesh, 605
mesh generation, 603–604
Model Navigator setup, 594
model view, 596
Move edit window, 600
physics boundary settings: Conductive Media DC (dc), 601
physics subdomain settings: Conductive Media DC (dc), 600
Plot Parameters edit window, Boundary tab, 607
Plot Parameters edit window,
General tab, 606
postprocessing and visualization, 606–607
Save As edit window, 596
solution, boundary plot, 608
solving, 604
Square edit window, 598
start building, 593
Subdomain Settings (1, 3) edit window, 602
Subdomain Settings (2) edit window, 602
summary and conclusions about, 608–609
TLR voltage measured across the layer, 607–608
Work-Plane Settings edit window, 597
Work-Plane Settings in, 595
X-Axis Data edit window, 608
3D touch screen divider circuit, 574
3D touch screen geometry, 574
Time coordinates
  in 1D models, 64
  in 3D transient solution model, 573
  in transient solution model, 461
  in 2D models, 114, 115
Time-dependent models. See Transient (or time-dependent) models
Time dependent solver, solving Kdv equation model and, 73
Time-dependent solving
  2D Axisymmetric Inductive_Heating_1 model, 408
  2D Axisymmetric Inductive_Heating_2 model, 431
  2D Axisymmetric Inductive_Heating_3 model, 452
  2D Resistive_Heating_1 model, 339
  2D Resistive_Heating_2 model, 361
  2D Resistive_Heating_3 model, 383
Times edit window
  2D AC Generator model: transient, 523
  2D AC Generator Sector model: transient, 559
Time Stepping page
  Solver Parameters window
    COMSOL 1D telegraph equation model, 96
    first variation on KdV equation model, 81
    first variation on telegraph equation model, 103
    KdV equation model, 74
    second variation on KdV equation model, 88
    second variation on telegraph equation model, 109
Time to temperature, 2D axisymmetric tumor laser irradiation model, 767
Tissue (human)
  transparency of, in certain infrared wavelengths, 750
  2D axisymmetric microwave cancer therapy model and conductivity of, 770
  TLR voltage measured across the layer

3D thin layer resistance model: thin layer approximation, 590–591
3D thin layer resistance modeling: thin layer subdomain, 607–608
T-max, comparison of, for Cylinder Conduction models 1p and 2, 249t
“To the first order,” meaning of, 495
Touch screen, 573
  3D divider circuit, 574
  3D geometry, 574
Transformed AC power, 497
  for power line transmission, 498
Transient analysis
  2D Axisymmetric Cylinder Conduction model, 234
  2D electrochemical polishing models, 165
  2D electro-thermal interaction modeling of Joule heating, 325
  2D resistive heating models, 388, 454, 455
Transient calculations, physical property values and conduction calculation in, 332
Transient (or time-dependent) models
  dependent variables in, 390, 460
  physics of, difficulty level, 459–460
  quasi-static models vs., 321
Transient solution models
  parameter variance in, 323, 389–390
  3D models and, 573
  2D axisymmetric coordinate system and, 227
  2D axisymmetric models and, 324
  2D coordinate system models and, 461
Transparent thermally conductive materials, 306, 316
Transverse electromagnetic wave propagated in z direction, voltage relationship for, 463
Triangular mesh, 165, 317, 388, 454
  default, in COMSOL Multiphysics software, 140
Triple-pane windows
  dual- and single-pane windows compared with, 35t
  modeling, 28
  workspace lines, 28t
Tumor cell death, temperature elevations and, 765, 769, 770, 788, 794
Tumor laser irradiation theory, 749
2D AC Generator models
static, 498–521

Application Mode Properties dialog box, 514
assembling Generator Geometry
(stator and rotor), 512
circles and rectangles created, 502
circles creation, 501
composite objects, 511
constants, 499–500
Constants edit window, 500, 500
Create Composite Object edit window,
503, 504, 510
derivation of, 498–499
Free Mesh Parameters edit window, 519
generator geometry, 500, 502–503,
505–506, 508–510
Geometry Circles: Copy, Rotate,
and Paste, 506
Geometry Circles Creation, 505
Geometry Rectangles creation, 502
initial solution, 521
Materials/Coefficients Library load
window, 515
Materials/Coefficients Library window, 514
mesh, 519
mesh generation, 518
model CO1, 503
model CO2, 504
Model Navigator setup, 499
paired stator and rotor, 512, 513
Paste C1 and C2, 506
physics boundary settings, 516
physics settings: Subdomain Integration
Variables, 513
physics subdomain settings: Moving Mesh
(ALE) (ale), 515
physics subdomain settings: Perpendicular
Induction Currents, Vector Potential
(emqa), 513–515
role of, 520
rotated, pasted circles, 507
rotated paste C3 and C4, 506
rotating portion (rotor) created, 506
rotor created circles, 508
rotor created rectangles, 509
Rotor Geometry Circles Creation, 508
Rotor Geometry Rectangles Creation, 509
Save As edit window, 501
solving, 520, 521
start building, 499
stationary portion of generator created, 506
stator and rotor composite objects, 511
stator and rotor Create Pairs edit window, 512
Stator and Rotor names assigned to
composite objects in, 510
Stator Geometry Circles Creation, 500
Subdomain edit window, 516
Subdomain Integration Variables edit
window, 513, 513
Subdomain Settings (1, 3-19)
edit window, 516
Subdomain Settings (2, 28)
edit window, 517
Subdomain Settings (20, 23, 24, 27)
edit window, 517
Subdomain Settings (21, 22, 25, 26)
edit window, 518
Subdomain Settings—Moving Mesh
edit window, 516
Subdomain Settings—Moving Mesh
(19-28) edit window, 518
summary and conclusions about, 529
two new created circles, 505
union, intersection, and difference
commands, 502, 509
union of all objects, CO1, 507
transient, 498, 522–529
animation, final frame, 531
derivation of, 522
Domain Plot Parameters edit window, 528
Induced voltage vs. Time, 529
magnetic flux density and magnetic
potential in, 528
Model Navigator initial solution, 523
Plot Parameters, Animate tab, 530
Plot Parameters, Contour tab, 527
Plot Parameters, General tab, 525
Plot Parameters, Surface tab, 526
postprocessing and visualization, 525–527
postprocessing animation, 529
Solver Parameters edit window, 524
Solver Parameters entered exactly as specified in, 523
solving, 522–523, 524
start building, 522
summary and conclusions about, 529

2D AC Generator Sector models
static, 530, 531–557
 Application Mode Properties:
   Perpendicular Induction Currents, Vector Potential (emqa), 542, 543
assemble the geometry (stator and rotor), 536, 538
Boundary Settings, Conditions page
   (1–4, 7, 8, 15, 16, 19, 20), 548
Boundary Settings, Pairs page (1), 549
Boundary Settings, Weak Constr. page
   (1–4, 7, 8, 15, 16, 19–21, 23), 548
constants, 532
Constants edit window, 533, 533t
copied meshed boundaries, 553
copying mesh from one edge to the other edge, 553
coupling variables note, 542
Create Composite Object, intersection
   (CO1, CO3), 536
Create Composite Object, intersection
   (CO2, CO1), 536
created one-eighth generator sector
   (CO3, CO4), 537
dependent variables case changes in, 532
derivation of, 531
Free Mesh Parameters, Boundary page, 552
Free Mesh Parameters edit window, 552
generator geometry and closed polyline
   (solid), 535
Generator Sector Geometry, 532, 534–536
Global Equations edit window, 551, 551t
Global Expressions edit window, 538r, 539
Identity Pairs window, 538
Import CAD Data From File select window, 533
imported CAD file, 534
initial solution, 557

Interchange source and destination button, 538
Line, closed polyline (solid) edit window, 535
Materials/Coefficients Library load window, 544
meshed view, 554
mesh generation, 552–554
Mesh Remaining (Free) button, 554
Model Navigator setup, 532
names in Application Mode Name edit window, 532
with omega unselected, 556
Options: Global Expressions, 538
Options: Subdomain Expressions, 539
Options: Subdomain Integration Variables, 539
paired stator (CO1) and rotor (CO2), 537
pairing of stator and rotor in, 538
Periodic Point Conditions, Destination page (1), 550
Periodic Point Conditions, Destination Vertices page (11), 551
Periodic Point Conditions,
   Source page (4), 549
Periodic Point Conditions, Source Vertices page (4), 550
Physics Boundary Settings: Perpendicular Induction Currents, Vector Potential (emqa), 547–549
Physics Settings: Global Equations, 551
Physics Settings: Periodic Point Conditions, 549–551
Physics Subdomain Settings: Moving Mesh (ALE) (ale), 542
Physics Subdomain Settings: Perpendicular Induction Currents, Vector Potential (emqa), 542–544, 546
Save As edit window, 556
Solver Parameters edit window, 555
solving, 554–555
start building, 531
Subdomain edit windows, 544t
Subdomain Expressions (2, 4) edit window, 541
2D AC Generator Sector models (continued)
Subdomain Expressions edit window, 539t, 540t
Subdomain Expressions (1) edit window, 541
Subdomain Expressions (1–4) edit window, 540
Subdomain Expressions (5–8) edit window, 540
Subdomain Integration Variables (1, 2, 4) edit window, 541
Subdomain Integration Variables (7, 8) edit window, 542
Subdomain Settings, Forces (1, 2, 4) edit window, 547
Subdomain Settings (1, 6) edit window, 545
Subdomain Settings (3, 5, 7, 8) edit window, 546
Subdomain Settings (7, 8) edit window, 547
Subdomain Settings—Moving Mesh (ALE) edit window (1–4), 543
summary and conclusions about, 555, 557

transient, 530, 557–568
animation, final frame, 568
derivation of, 557
global variables plot, 566
Global Variables Plot edit window, 565
magnetic flux density and magnetic potential, z component, 565
Model Navigator, initial solution, 558
Model Navigator, initial solution selection, 558
Parameters, general tab, 562
Plot Parameters, Animate tab, 567
Plot Parameters, Contour tab, 564
Plot Parameters, Surface tab, 563
postprocessing and visualization, 561–562, 564
postprocessing animation, 566
solution default plot, final frame, 561
Solver Manager, Solve For page, 560
Solver Parameters edit window, 559
solving, 559–560
start building, 557
summary and conclusions about, 568
2D axisymmetric advanced-level
2D modeling, 226
2D axisymmetric coordinate system, 389–393
basics of, 389
discussion about, 324
plus time, 322, 324, 390
2D Axisymmetric Cylinder Conduction models, 229–240, 230
Boundary Settings: general heat transfer, 235
Boundary Settings (2, 5, 6) edit window, 236
Boundary Settings (3) edit window, 237
Boundary Settings—General Heat Transfer edit window, 235t
consolidating calculational parameters, 231
constants, 231
Constants edit window, 231t, 231t
cylinder rectangle, 232
default solver used with, 238
first variation on, 240–250
Boundary Settings: General Heat Transfer edit window, 246t
Boundary Settings (2, 5, 6) edit window, 247
Boundary Settings (3) edit window, 247
Constants edit window, 242, 242t
cylinder rectangle, 243
derivation of, 240
final frame, 251, 252
mesh generation, 246
model animation, final frame, 241
model mesh window, 237, 248
Model Navigator setup, 230, 242
models 1p and 2, comparison of T-max for, 249, 249t
Parametric (UMFPACK) used with, 246, 249
physics boundary settings: general heat transfer, 245
physics subdomain settings: general heat transfer, 245
Plot Parameters window, 240, 250
Point edit window, 244, 244t
points added in, 243
Rectangle edit window, 243
rectangle with points, 244
Solver Parameters edit window, 248
solving, 246–247
start building, 241
Subdomain edit window, 245
Subdomain Settings edit window, 245
mesh generation, 235
niobium in, 229
Parametric Solver (UMFPACK), 239
parametric solving of, 236, 238
physics boundary settings: general heat transfer, 235
physics subdomain settings: general heat transfer, 233–234
Point edit window, 232, 233
postprocessing animation, 238, 240
Rectangle edit window, 232
rectangle with points, 233
results summary, 264
second variation on, including a vacuum cavity animation, final frame, 251, 264
Boundary Settings (1, 4) edit window, 259
Boundary Settings (2, 5, 10)
edit window, 260
Boundary Settings (3) edit window, 260
Boundary Settings—General Heat Transfer edit window, 259
composite object, 257
consolidating calculational parameters, 253
constants, 253
Constants edit window, 253, 253t
Create Composite Object edit window, 256
cylinder rectangles (1 and 2), 255
derivation of, 250
mesh, 261
mesh generation, 261
Model Navigator setup, 252
Parametric Solver use, 262
physics boundary settings: general heat transfer, 259
physics subdomain settings: general heat transfer, 256, 258
Plot Parameters window, 263
Point Edit window, 255t
points added to, 254
postprocessing animation, 261, 263
Rectangle edit window, 253t
Rectangle edit window (1), 254
Rectangle edit window (2), 254
rectangles with points, 256
second variation on, 250–263
setting pressure for vacuum cavity, 258
Solver Parameters edit window, 262
solving, 261
start building, 250
static and quasi-static calculations in, 259
Subdomain Edit window, 258t
Subdomain Settings (1) edit window, 257
Subdomain Settings (2) edit window, 258
Solver Parameters edit window, 239
solving, 236
start building, 230
static and quasi-static calculations with, 234
Subdomain edit window, 234
Subdomain Settings edit windows, 234
summary and conclusions about, 263–264
2D axisymmetric heat conduction modeling, 229
2D axisymmetric Inductive Heating models, 393–411, 399, 422
animation, final frame, 411
Application Scalar Variables edit window, 399
Axis edit window, 395, 395t
Boundary Settings (1, 3, 5) edit window, 401, 405
Boundary Settings (2, 7, 9) edit window, 402, 406
Boundary Settings edit window, 401t, 402t, 404r
Boundary Settings (10–13) edit window, 402
Circle edit window, 397
consolidating calculational parameters, 396
constants, 396, 398
Constants edit window, 397, 397t
coupling of Joule heating and heat transfer in, 393
degrees Centigrade in, 410
derivation of, 393
first variation on, 411–433
animation, final frame, 436
Application Scalar Variables edit window, 420
2D axisymmetric Inductive Heating models (continued)

Boundary Settings (1, 2, 4) edit window, 425
Boundary Settings (1, 3, 4), edit window, 429
Boundary Settings (2, 5, 9) edit window, 425
Boundary Settings (2, 10, 14) edit window, 430
Boundary Settings edit window, 423t, 426t, 427t
Boundary Settings (12–203) edit window, 426
Circle edit window, 419t
CO1, CO3, 417
CO2, 416
coil, 427
constants, 413–416, 418–419
Constants edit window, 413t, 414
Create Composite Object edit window, 416, 417, 418, 421
Create Composite Object edit windows, 415
crucible, building, 418
crucible and coil, 420
derivation of, 411
inductively heated crucible built in, 411
mesh generation, 430
mesh window, 431
Model Navigator setup, 412
options and settings, 413
physics boundary settings: Azimuthal Induction Currents, Vector Potential (emqa), 423
physics boundary settings: general heat transfer (htgh), 427
physics settings, 419, 421
physics subdomain settings: Azimuthal Induction Currents, Vector Potential (emqa), 422
physics subdomain settings: general heat transfer (htgh), 426–427
Plot Parameters edit window, 434
Plot Parameters window, 436
postprocessing and visualization, 431, 433
Scalar Expressions edit window, 421, 421t
Solver Parameters, Advanced edit window, 432
Solver Parameters edit window, 432
solving, 430–431, 433
start building, 412
Subdomain edit window, 423t, 426t
Subdomain Settings (1, 3) edit window, 428
Subdomain Settings (1), Electric Parameters edit window, 423
Subdomain Settings (1–50), Init edit window, 429
Subdomain Settings (2), Electric Parameters edit window, 424
Subdomain Settings (3–50), Electric Parameters edit window, 424
Subdomain Settings (2–50) edit window, 428
temperature distribution shown in degrees Centigrade, 431, 435
3D rendition of, 412
time-dependent solving of, 431
Grid edit windows, 395t, 396
mesh generation, 406
mesh window, 407
Model Navigator setup, 394
options and settings, 395
physics boundary settings: general heat transfer (htgh), 404
physics settings, 398
physics subdomain settings: Azimuthal Induction Currents, Vector Potential (emqa), 400
physics subdomain settings: general heat transfer (htgh), 403–404
Plot Parameters edit window, 409, 410
postprocessing and visualization, 408
postprocessing animation, 408
Rectangle edit windows, 398
Scalar Expressions edit window, 399t, 400
second variation on, 433–456
animation, final frame, 456
Application Scalar Variables edit window, 441
bismuth and building filled inductively heated crucible in, 434
bismuth subdomain 3, 440
Boundary Settings (1, 3–7) edit window, 444, 449
Boundary Settings (2, 9, 14) edit window, 445, 450
Boundary Settings edit window, 444t, 448t
Boundary Settings (17–208) edit window, 445
coil, 446
constants, 437, 439–440
Constants Edit window, 438, 438t
coupling of Joule heating and heat transfer in, 433–434
in degrees Centigrade, 435, 455
derivation of, 433
imported crucible and coil with rectangle, 439
mesh generation, 450
mesh window, 451
Model Navigator setup, 437
mode names in Application mode window in, 435
physics boundary settings: Azimuthal Induction Currents, Vector Potential (emqa), 442, 445
physics boundary settings: general heat transfer (htgh), 448
physics settings, 440
physics subdomain settings: Azimuthal Induction Currents, Vector Potential (emqa), 441–442
physics subdomain settings: general heat transfer (htgh), 446, 448
Plot Parameters edit window, 434, 454
Plot Parameters window, 456
postprocessing and visualization, 452
postprocessing animation, 453
Scalar Expressions edit window, 441, 441t
Solver Parameters, Advanced edit window, 452
Solver Parameters edit window, 451
solving, 450, 452, 453
start building, 435
Subdomain edit window, 442t, 446t
Subdomain Settings (1), Electric Parameters edit window, 442
Subdomain Settings (1–51), Init edit window, 449
Subdomain Settings (2, 4–51) edit window, 447
Subdomain Settings (2), Electric Parameters edit window, 443
Subdomain Settings (3), Electric Parameters edit window, 443
Subdomain Settings (4–51), Electric Parameters edit window, 444
Subdomain Settings (1) edit window, 447
Subdomain Settings (3) edit window, 448
3D rendition of, 437
time-dependent solving of, 452
Solver Parameters, Advanced edit window, 408
Solver Parameters edit window, 407
solving, 406, 409
start building, 394
Subdomain edit window, 401t, 403t
Subdomain Settings (1–3), Init edit window, 405
Subdomain Settings (2, 3) edit window, 404
Subdomain Settings (2), Electric Parameters edit window, 400
Subdomain Settings (1) edit window, 403
summary and conclusions about, 453–455
3D rendition of, 394
time-dependent solving of, 408
2D axisymmetric insulated container design, 265
2D axisymmetric microwave cancer therapy model, 770–794
antenna and model domain, 799
antenna plus tissue, 771
Application Scalar Variables, 782t
Boundary Settings, 781, 783t
Boundary Settings, (8), Port tab, 787
Boundary Settings (1, 3), 785
Boundary Settings (2, 14, 18, 20, 21), 785
Boundary Settings (5–7, 9, 11–13, 17), 786
Boundary Settings (8), 786
composite object (CO1), 776
constants, 772
Constants edit window, 773, 773t
Create Composite Object edit window, 775, 777
Constants edit window, 287, 288t
edit window, 291
Free Mesh Parameters edit window, 296
import, 288
import and rectangle R1, 289
importing 2D axisymmetric thermos container, 288
mesh, 297
mesh generation, 296
Model Navigator setup, 287
Parametric Solver use, 298
physics boundary settings: general heat transfer, 293–294, 296
physics subdomain settings: general heat transfer, 289–290, 293
Plot Parameters window, 299, 301
postprocessing, 298, 301
Rectangle edit window, 289t
Solver Parameters edit window, 297
solving, 296, 298
start building, 286
Subdomain edit window, 290t, 292
Subdomain edit window (2, 7), 291t
Subdomain edit window (4), 291t
Subdomain edit window (5, 9), 291t
Subdomain Settings (1, 3, 6, 8) edit window, 290
Subdomain Settings (4) edit window, 292
surface temperature (ºC), 299
temperature uniformity in, 293
user interface display window, 300
vacuum cavity display window, 300
Free Mesh Parameters edit window, 280
half-ellipse creation, 269
Line edit window, 271
mesh, 281
mesh generation, 279
Model Navigator setup, 266
names for modeler-defined parameters, 266
outer tank profile, 270
outer tank profile creation, 269
Parametric Solver use, 282
physics boundary settings: general heat transfer, 277, 279
physics subdomain settings: general heat transfer, 274
Plot Parameters window, 283, 285
postprocessing, 282
Rectangle Edit window, 268t, 269t
rectangles R1 and R2, 268
second variation on, 301–318
animation, final frame, 318
Boundary Integration edit window, 315
Boundary Settings (8, 14, 21) edit window, 310
Boundary Settings (2) edit window, 309
Boundary Settings (28) edit window, 311
Boundary Settings (34) edit window, 311
boundary settings—General Heat Transfer edit window, 309t, 310
choosing name for, 304
constants, 302
Constants edit window, 303, 303t
creating domain for boundary information to be applied, 304
energy lost in this model vs. with urethane foam insulation in 2D axisymmetric Thermos_Container_1 model, 316
Free Mesh Parameters edit window, 312
glass material and vacuum cavity in, 301
import, 304, 304
mesh, 313
mesh generation, 312
Model Navigator setup, 303
Parametric Solver use, 314
physics boundary settings: general heat transfer, 309–310
physics subdomain settings: general heat transfer, 305–306
Plot Parameters window, 314, 317
postprocessing, 312, 315–316
postprocessing animation, 316
Rectangle edit window, 305t
Solver Parameters edit window, 313
solving, 312
start building, 312
Subdomain edit windows, 305t, 306t, 308t
2D axisymmetric Thermos_Container models
(continued)
Subdomain Settings (1, 3, 6, 8)
edit window, 306
Subdomain settings (2, 7) edit window, 307
Subdomain Settings (5, 9) edit window, 307
Subdomain Settings (4) edit window, 308, 308
surface temperature (ºC), 315
user interface display window, 316
Solver Parameters edit window, 281
solving, 279, 282
start building, 265
subdomain edit window (1, 3, 6, 8), 274
subdomain edit window (2, 7), 274
subdomain edit window (4), 274
subdomain edit window (5, 9), 274
Subdomain Settings (1, 3, 6, 8)
edit window, 275
Subdomain Settings (2, 7) edit window, 275
Subdomain Settings (5, 9) edit window, 276
Subdomain Settings (4) edit window, 276
summary and conclusions about, 316–317
surface temperature (ºC), 283
tank, 273
tank components, 271
tank components with lid line, 272
tank Export Geometry Objects, Save As window, 273
tank structure creation steps, 270
temperature uniformity in, 277
thermos container modeling results
summary, 317
user interface display window, 284
2D axisymmetric Tumor Laser Irradiation model, 749–769
Boundary Settings, 760
Boundary Settings (1, 3–5), 761
Boundary Settings (2, 8, 9), 761
Boundary Settings (7), 762
Circle edit window, 754
constants, 750
Constants edit window, 751, 752
Create Composite Object edit window, 755
derivation of, 749
Domain Plot Parameters, Point tab, 767
Free Mesh Parameters, subdomain 2, 762
Geometry Components, 752
graph, 763
mesh generation, 761
modeling domain overview, 750
Model Navigator setup, 751
physics boundary settings: Bioheat Equation (htbh), 760
physics settings: Scalar Expressions, 755
physics settings: Subdomain Expressions, 755, 757
physics subdomain settings: Bioheat Equation (htbh), 758
Plot Parameters, Animate tab, 768
Plot Parameters, animation, final frame, 769
postprocessing and visualization, 763, 765
postprocessing Plot Parameters, Surface tab (ºC), 765
Rectangle edit window (R1), 752
Rectangle edit window (R2), 753
Rectangle edit window (R3), 755
rectangles (R1, R2), 753
Save As edit window, 754
Scalar Expressions edit window, 756
skin, tissue, and tumor (CO1), 756
solution, temperature (K), 764
Solver Parameters, 764
solving, 763
start building, 750
Subdomain Expressions (1) edit window, 757
Subdomain Expressions (2) edit window, 757
Subdomain Expressions (3) edit window, 757
Subdomain Settings, 758
Subdomain Settings (1), 758
Subdomain Settings (2), 759
Subdomain Settings (3), 759
Subdomain Settings, Initial value edit window, 760
summary and conclusions about, 768–769
surface temperature (ºC), 766
time to temperature, 767
2D beginning-level to advanced-level
2D modeling, 113, 226
2D_Bio_MCT_1 model. See 2D axisymmetric microwave cancer therapy model
2D Cartesian domain, with PMLs, 672, 672
2D complex mixed-mode modeling
   considerations relative to, 459–460
   implicit assumptions in, 460
2D concave mirror model, without PMLs, 724–744
   Application Mode Properties edit window, 729
   Application Scalar Variables edit window
      (lambda1_rfweh), 730
   Boundary Settings, 732
   concave mirror (CO1), 728
   Create Composite Object edit window, 727
   derivation of, 724
   electric field, z-component, 737
   electric field plot, z-component, 0.5 m, 739, 740
   electric field plot, z-component, 1.0 m, 741, 742
   electric field plot, z-component, 1.5 m, 743
   Ellipse edit window (E1), 726
   Ellipse edit window (E2), 726
   geometry modeling, 725, 727
   Materials-Coefficients Library, copper, 731
   mesh generation, 732
   model domain, 729
   model mesh, 733
   Model Navigator setup, 725
   physics application mode properties: In-Plane
      TE waves (rfweh), 727
   physics application scalar variables: In-Plane
      TE waves (rfweh), 730
   physics boundary settings: In-Plane TE waves (rfweh), 732
   physics subdomain settings: In-Plane TE waves (rfweh), 730
   Plot Parameters, Animate tab, 738
   postprocessing and visualization, 734–735
   postprocessing Plot Parameters,
      Surface tab, 736
   Rectangle edit window (R1), 727
   Save As edit window, 726
   scattered electric field, z-component (V/m), 735
   Solver Parameters, 734
   solving, 732
   Square edit window (SQ1), 728
   start building, 724
   subdomain Free Mesh Parameters, 733
   Subdomain Settings, Physics tab, subdomain 1, 730
   Subdomain Settings, Physics tab, subdomain 2, 731
   summary and conclusions about, 736–737
2D concave mirror model, with PMLs, 707–724
   Application Mode Properties edit window, 715
   Application Scalar Variables edit window
      (lambda0_rfweh), 715
   Boundary Settings, 719
   concave mirror (CO1), 713
   Create Composite Object edit window, 712
   derivation of, 707
   domain plus PMLs, 714
   electric field, z-component, 723
   Ellipse edit window (E1), 711
   Ellipse edit window (E2), 711
   Free Mesh Parameters, subdomain, 719
   Geometry Components, 708t
   geometry modeling, 707, 710, 712
   Materials-Coefficients Library, copper, 717
   mesh, 720
   mesh generation, 718
   Model Navigator setup, 708
   physics application mode properties: In-Plane
      TE waves (rfweh), 714
   physics application scalar variables: In-Plane
      TE waves (rfweh), 714
   physics boundary settings: In-Plane TE waves (rfweh), 718
   physics subdomain settings: In-Plane TE waves (rfweh), 714
   Plot Parameters, Animate tab, 724
   Plot Parameters, Surface tab, 722
   PML rectangles, 710
   postprocessing and visualization, 721, 723
   Rectangle edit window (R1), 708
   Rectangle edit window (R2), 709
   Rectangle edit window (R3), 709
   Rectangle edit window (R4), 709
2D concave mirror model, with PMLs
(continued)
Rectangle edit window (R5), 712
Save As edit window, 711
scattered electric field, z-component (V/m), 721
Solver Parameters, 720
solving, 718
Square edit window, 713
start building, 707
Subdomain Settings, Physics tab, subdomain 5, 717
Subdomain Settings, Physics tab, subdomain 7, 718
Subdomain Settings, PML type selection, 715
Subdomain Settings, x absorption, 716
Subdomain Settings, y absorption, 716
summary and conclusions about, 723
Suppress Subdomains, 722
2D coordinate system, 5
discussion about, 322–323
plus time, 322, 323, 461
2D dielectric lens model, without PMLs, 691–707
Application Mode Properties edit window, 696
Application Scalar Variables edit window (lambda0_rfweh), 697
Boundary Settings, 699
Circle edit window (C1), 693
Create Composite Object edit window, 694
derivation of, 691
dielectric lens (CO1), 695
domain, 696
electric field, z-component, 703
electric field, z-component, 0.5 m, 704
Free Mesh Parameters, subdomain, 699
geometry modeling, 693–694
mesh, 700
mesh generation, 698
Model Navigator setup, 692
model plot electric field, z-component, 0.5 m, 705
model plot electric field, z-component, 1.0 m, 705, 706
model plot electric field, z-component, 1.5 m, 706, 707
physics application mode properties: In-Plane TE waves (rfweh), 696
physics application scalar variables: In-Plane TE waves (rfweh), 697
physics boundary settings: In-Plane TE waves (rfweh), 698
physics subdomain settings: In-Plane TE waves (rfweh), 697–698
Plot Parameters, Animate tab, 704
postprocessing and visualization, 701–702
postprocessing Plot Parameters, Surface tab, 702
Rectangle edit window (R1), 694
Save As edit window, 693
scattered electric field, z-component (V/m), 701
Solver Parameters, 700
solving, 698, 701
Square edit window (SQ1), 695
start building, 691
Subdomain Settings, subdomain 1, 697
Subdomain Settings, subdomain 2, 698
summary and conclusions about, 702–703
2D dielectric lens model, with PMLs, 676–691
Application Mode Properties edit window, 682
Application Scalar Variables edit window (lambda0_rfweh), 683
Boundary Settings, 686
Circle edit window, 680
Create Composite edit window, 680
derivation of, 676
dielectric lens (CO1), 681
domain plus PMLs, 682
domain (SQ1), 681
electric field, z-component, 691
Free Mesh Parameters, 687
Geometry Components, 677
geometry modeling, 677–678, 681
mesh, 687
mesh generation, 686
Model Navigator setup, 676
physics application mode properties: In-Plane TE waves (rfweh), 682
physics application scalar variables: In-Plane TE waves (rfweh), 683
Index

physic boundary settings: In-Plane TE waves (rfweh), 686
physic subdomain settings: In-Plane TE waves (rfweh), 683–685
Plot Parameters, Animate tab, 692
Plot Parameters, Surface tab, 690
PML rectangles, 679
postprocessing and visualization, 688, 690
Rectangle edit window (R1), 677
Rectangle edit window (R2), 677
Rectangle edit window (R3), 678
Rectangle edit window (R4), 678
Rectangle edit window (R5), 680
Save As edit window, 679
scattered electric field, z-component (V/m), 689
Solver Parameters, 688
solving, 686
start building, 676
Subdomain Settings, Physics tab, subdomain 5, 685
Subdomain Settings, Physics tab, subdomain 7, 685
Subdomain Settings, PML type selection, 683
Subdomain Settings, x absorption, 684
Subdomain Settings, y absorption, 684
summary and conclusions about, 690–691
Suppress Subdomains, 689
2D electric impedance sensor models
advanced, 477–493
animation, final frame, 494
Application Scalar Variables edit window, 484
Boundary Settings (1, 4, 5, 8) edit window, 486
Boundary Settings (6, 7) edit window, 487
Boundary Settings (2, 3) edit window, 486
Boundary Settings—In-Plane Electric Currents (emqvw) edit window, 485t
Boundary Settings (port) edit window, 487
Color Range edit window, 491
constants, 477, 479, 481–482
Constants edit window, 478t, 479
Create Composite Object edit window, 481
Create Composite Object result, 482
ellipse and points, 483
Ellipse edit window, 480
Free Mesh Parameters edit window, 488
high-frequency currents used in, 460
linspace function changes in, 489
mesh, 489
mesh generation, 488
Model Navigator setup, 478
physic boundary settings: In-Plane Electric Currents (emqvw), 484
physic settings: Scalar Expressions, 483
physic settings: Scalar Variables, 484
physic subdomain settings: In-Plane Electric Currents (emqvw), 484
Plot Parameters edit window, 491
Plot Parameters window, 493
Point edit window, 482t
postprocessing and visualization, 489
postprocessing animation, 492
rectangle, 480
rectangle added to ellipse in, 481
Rectangle edit window, 481
Save As edit window, 479
Scalar Expressions edit window, 483t, 484
solution with detected areas, 492
Solver Parameters edit window, 490
solving, 488–489, 490
start building, 477
Subdomain edit window, 485t
Subdomain edit window, 485t
Subdomain Settings edit window, 485
basic, 464–477
Application Scalar Variables edit window, 469
Boundary Settings (1, 2, 6) edit window, 471
Boundary Settings (3, 5) edit window, 471
Boundary Settings (4) edit window, 472
Boundary Settings—In-Plane Electric Currents edit window, 471t
Boundary Settings (port) edit window, 472
Color Range edit window, 476
consolidating calculational parameters, 464
constants, 464–466
Constants edit window, 465t, 466
derivation of, 464
Free Mesh Parameters edit window, 473
high-frequency currents used in, 460
2D electric impedance sensor models (continued)
importing/exporting expressions
edit windows as text files, 465
mesh, 473
mesh generation, 472
Model Navigator setup, 465
physics boundary settings: in-plane electric
currents (emqvw), 470, 472
physics settings: scalar expressions, 468
physics settings: scalar variables, 468
physics subdomain settings: in-plane
electric currents (emqvw), 470
Plot Parameters edit window, 476
postprocessing and visualization, 474
rectangle, 467
rectangle and points, 468
Rectangle edit window, 467
Save As edit window, 466
Scalar Expressions edit window, 469, 469t
skin depth parameters for, 464
solution with detected areas, 477
Solver Parameters edit window, 474
solving, 474, 475
start building, 464
Subdomain edit windows, 470, 470t
summary and conclusions about, 475
high-frequency currents employed in, 460
summary and conclusions about, 492–493
2D electrochemical polishing (electropolishing)
theory, 115–166
as inverse of electroplating, 117
Moving Mesh Application Mode, 117–118
numerical solution model and, 115–116
surface normal vector $\mathbf{n}$ and current
vector $\mathbf{J}$, 117
2D asperity (bump) on electrode, 116
2D electrochemical polishing models
boundary settings, Moving Mesh (ALE)
window, 125t
building started for, 118–119, 122
Circle edit window, 120
Constants Edit window, 118t
Constants edit window, 119
electrode with asperity, 122
electrolyte rectangle, 120
electropolishing_1 model Boundary
Settings, Conductive Media DC:
boundaries set, 124
electropolishing_1 model Boundary
Settings, Moving Mesh (ALE):
boundaries 3, 4, 6, 7 window, 125
first variation on, 130–147
animation Plot Parameters window, 131
boundary settings, Conductive Media
DC window, 137t
boundary settings, Moving Mesh (ALE):
boundaries organized by color, 142
boundary settings, Moving Mesh (ALE)
window, 140
boundary settings (1, 5), Conductive Media
DC: boundaries set, 138
boundary settings (1, 5), Moving Mesh
(ALE): Boundaries window, 140
boundary settings (1, 5 = blue; 3, 4, 7 5
green; 2 = red) Conductive Media DC:
boundaries set, 139
boundary settings (2), Conductive Media
DC: boundaries set, 139
boundary settings (2), Moving Mesh
(ALE): Boundaries window, 141
boundary settings (3, 4, 6, 7), Conductive
Media DC: boundaries set, 138
boundary settings (3, 4, 6, 7), Moving
Mesh (ALE): Boundaries window, 141
Circle edit window, 134
Constants Edit window, 131t
Constants edit window, 132
electrode with asperity, 135
electrolyte rectangle, 133
Free Mesh Parameters window, 142
free mesh (quad), 143
mesh generation, 140
Model Navigator setup, 132
physics boundary settings: Conductive
Media DC, 137
physics boundary settings: Moving Mesh
(ALE), 138, 140
physics subdomain settings: Conductive
Media DC, 137
Plot Parameters window, 144
Index

boundary settings (1, 7), Conductive Media DC: boundaries set, 157
boundary settings (1, 7), Moving Mesh (ALE): Boundaries window, 159
boundary settings (1, 7 = blue; 3–6, 8–13 = green; 2 = red), Conductive Media AC, boundaries set, 158
boundary settings (2), Conductive Media DC: boundaries set, 158
boundary settings (2), Moving Mesh (ALE): Boundaries window, 160
boundary settings (3–6, 8–13), Conductive Media DC: boundaries set, 157
boundary settings (3–6, 8–13), Moving Mesh (ALE): Boundaries window, 160
Circle edit window, 151
Constants edit window, 148t, 149
Create Composite Object edit window, 154
electrode with asperities, 154
electrolyte rectangle, 150
Ellipse edit window, 152
Free Mesh Parameters window, 161
free mesh (quad), 162
mesh generation, 159–160
Model Navigator setup, 149
Paste edit window, 153
physics boundary settings: Conductive Media DC, 156
physics subdomain settings: Conductive Media DC, 156
postprocessing, 144–145
postprocessing animation, 146
rectangle and circle, 134
Rectangle edit window, 133
scaled electrolyte/electrode geometry, 136
Scale edit window, 136
selected rectangle and circle, 135
Solver Parameters window, 143
solving, 141, 144
starting building for, 130–132, 134, 136
Subdomain Settings window, 137
surface Plot Parameters window: Moving Mesh (ALE), y direction, 146
surface plot window: Moving Mesh (ALE), y direction, 147
surface plot window, total normal current density, 145
mesh, 126
mesh generation, 125
modeling results summary, 166t
physics boundary settings: Conductive Media DC, 123
physics boundary settings: Moving Mesh (ALE), 125
physics subdomain settings: Conductive Media DC, 123
Plot Parameters window, 127
Plot Parameters window: Moving Mesh (ALE), y direction, 129
postprocessing, 127–128
postprocessing animation, 129–130
power of, with diverse projects, 166
rectangle and circle, 121
Rectangle edit window, 119
scaled electrolyte/electrode geometry, 123
Scale edit window, 122
second variation on, 147–165
animation Plot Parameters window, 148, 167
boundary settings, Conductive Media DC window, 156t
boundary settings: Moving Mesh (ALE), 159
boundary settings, Moving Mesh (ALE): boundaries organized by color, 161
boundary settings, Moving Mesh (ALE) window, 159t
boundary settings (1, 7), Conductive Media DC: boundaries set, 157
boundary settings (1, 7), Moving Mesh (ALE): Boundaries window, 159
boundary settings (1, 7 = blue; 3–6, 8–13 = green; 2 = red), Conductive Media AC, boundaries set, 158
boundary settings (2), Conductive Media DC: boundaries set, 158
boundary settings (2), Moving Mesh (ALE): Boundaries window, 160
boundary settings (3–6, 8–13), Conductive Media DC: boundaries set, 157
boundary settings (3–6, 8–13), Moving Mesh (ALE): Boundaries window, 160
Circle edit window, 151
Constants edit window, 148t, 149
Create Composite Object edit window, 154
electrode with asperities, 154
electrolyte rectangle, 150
Ellipse edit window, 152
Free Mesh Parameters window, 161
free mesh (quad), 162
mesh generation, 159–160
Model Navigator setup, 149
Paste edit window, 153
physics boundary settings: Conductive Media DC, 156
physics subdomain settings: Conductive Media DC, 156
postprocessing, 162–164
postprocessing animation, 164–165
R1-C1-E1-E2 information, keying in, 153
rectangle and circle, 151
Rectangle edit window, 150
scaled electrolyte/electrode geometry, 155
Scale edit window, 155
Solver Parameters window, 162
solving, 160, 163
starting building for, 147, 149, 151–155
Subdomain Settings window, 156
surface Plot Parameter window: Moving Mesh (ALE), y direction, 165
surface Plot Parameter window, total normal current density, 163
2D electrochemical polishing models (continued)

Surface Plot window, total normal current density, 164

2D electropolishing_3 model
(C1, E1, E2, R1), 153

2D electropolishing_3 model
(C1, E1, R1), 152

selected rectangle and circle, 121

Solver Parameters window, 126
solving, 125, 127

subdomain settings, Conductive Media DC window, 123t

Subdomain Settings window, 124
summary and conclusions about, 165–166

surface plot window, 128

surface plot window: Moving Mesh (ALE), y direction, 130

2D guidelines, for new COMSOL multiphysics modelers, 113–115
coordinate system, 114–115

2D modeling considerations, 113–114

2D Hall effect models, 171–222

Application Mode Properties window, 172
boundary settings, 176, 176t, 180

Boundary Settings (1), 177

Boundary Settings (4), 178

Boundary Settings (5), 178

Boundary Settings (8), 179

Boundary Settings, Weak Constr. button, 179

Boundary Settings (2, 3, 5–7, 10, 13–16, 19), 195

conductivity matrix elements, 194

constants, 189

Constants edit window, 189, 189t

Create Composite Object window, 191

Cross-section Line Data edit window, 202t
default surface voltage distribution plot, 199
grid, Subdomain Settings (1, 3, 4, 5), 193
grid, Subdomain Settings (2), 193

grid with added rectangles, 192

Matrix elements edit window, 194

mesh, 198

mesh generation, 198

model plot $V_H$, 203

Multiphysics Model Navigator window, 188

Plot Cross-Section Parameters, General page, 201

Plot Cross-Section Parameters, Line/Extrusion page, 202

Plot Parameters, Contour Data page, 200

postprocessing, 198, 200, 202

postprocessing animation, 202–203

Rectangle edit window, 190, 191t
rectangle geometry, 190
solving, 198

start building, 186

subdomain settings, 191–192

surface voltage distribution plot, with contour lines, 201

geometry, 172–173

Matrix elements edit window, 175t

mesh, 181

first variation on, 186–203

animation Plot Parameters window, 187, 204

Application Mode Properties window, 188

boundary settings, 194–197, 194t

Boundary Settings (1), 194

Boundary Settings (8), 195

Boundary Settings (12), 196

Boundary Settings (20), 196

Boundary Settings, final configuration, 197

Boundary Settings, Weak Constr. page, 197

Boundary Settings (2, 3, 5–7, 10, 13–16, 19), 195
mesh generation, 180
model plot $V_H$, 186
Multiphysics Model Navigator window, 171
Plot Parameters window, Contour
  Data page, 183
Points edit window, 175t
postprocessing, 181
postprocessing animation, 185–186
Rectangle edit window, 173
rectangle geometry, 174
rectangle geometry with points, 174
results summary, 222t
second variation on, 203–221
  Animation Plot Parameters window, 204, 221
  Application Mode Properties window, 205
Boundary Settings, 211–214
Boundary Settings (1), 211
Boundary Settings (8), 212
Boundary Settings (14), 213
Boundary Settings (18), 213
Boundary Settings (25), 214
Boundary Settings, final configuration, 215
Boundary Settings, Weak Constr. page, 214
Boundary Settings (2, 3, 5–7, 10–12, 15–17, 20, 21, 23, 24), 212
conductivity matrix elements, 210
constants, 206
Constants edit window, 206, 206t
Create Composite Object window, 208
Cross-Section Line Data edit window, 217t
default surface voltage distribution plot, 217
geometry, 206–207
geometry with added rectangles, 209
Matrix Elements edit window, 210t
mesh, 215
mesh generation, 214
model plot $V_H$, 220
Multiphysics Model Navigator window, 205
Plot Cross-Section Parameters, General
  page, 219
Plot Cross-Section Parameters,
  Line/Extrusion page, 220
Plot Parameters, Contour Data page, 218
postprocessing, 216–218
postprocessing animation, 218, 221
purpose of, 203
Rectangle edit window, 207, 208t
rectangle geometry, 207
Solver Parameters window, 216
solving, 216
start building, 205
subdomain settings, 208–210
Subdomain settings (1, 3, 4, 5, 6), 209
Subdomain Settings (2), 210
surface voltage distribution plot, with
  contour lines, 219
Solver Parameters window, 182
solving, 180
Subdomain Settings, 173, 175, 176
summary and conclusions about,
  221–222
  surface voltage distribution (2T), with
    contour lines, 184
2D inductive heating considerations,
  2D axisymmetric coordinate system, 389–393
2D mixed-mode modeling
  considerations with, 321–322
  implicit assumptions relative to, 322
  2D coordinate systems, 322–323
2D modeling
  challenges with, 113
  implicit assumptions with, 114
2D modeling modes, in COMSOL Multiphysics
  software, 113–114
2D Resistive Heating models, 327–345
  with all boundary settings, 338
animation, final frame, 347
block with hole, 331
boundary conditions overview, 332
Boundary Settings (1, 4–8)
  edit window, 334
Boundary Settings (2, 3, 5–8)
  edit window, 337
Boundary Settings (2, 3) edit window, 335
Boundary Settings—Conductive Media DC (dc) Edit window, 337t
Boundary Settings (1) edit window, 337
Boundary Settings (4) edit window, 338
2D Resistive Heating models (continued)

Boundary Settings—Heat Transfer by Conduction (ht) edit window, 334
Circle edit window, 330
consolidating calculational parameters, 328
constants, 328
Constants edit window, 328, 328t
coupling of Joule Heating in Conductive Media AC and Heat Transfer by Conduction Application Mode, 331
coupling of two modes within, 326, 331
Create Composite Object edit window, 331
Cross-Section Plot Parameters, General edit window, 343
Cross-Section Plot Parameters, Point edit window, 344
degrees Centigrade, 342
first variation on, 345–366
with all boundary settings, 360
animation, final frame, 367
Boundary Settings (1, 40) edit window, 355
Boundary Settings (2, 3, 5–8) edit window, 359
Boundary Settings (2, 3) edit window, 355
Boundary Settings—Conductive Media DC (dc) edit window, 359
Boundary Settings (1) edit window, 359
Boundary Settings (4) edit window, 360
Boundary Settings—Heat Transfer by Conduction (ht) edit window, 354t
Combined Heat Transfer by Conduction (ht) boundary settings, 356
consolidation of calculational parameters in, 349
constants, 347
Constants edit window, 348t, 349
coupling of Joule Heating in Conductive Media DC Application and Heat Transfer by Conduction Application Mode, 351
Create Composite Object edit window, 350
Cross-Section Plot Parameters, General edit window, 364
Cross-Section Plot Parameters, Point edit window, 365
degrees Centigrade in, 361, 364
heater bar assembly, 351
materials demonstrated in, 345
mesh generation, 360
Model Navigator setup, 348
physical property values for Nichrome and copper required for conduction calculation in, 353
physics boundary settings: Conductive Media DC (dc), 358, 360
physics boundary settings: heat transfer by conduction (ht), 353–354
physics subdomain settings: Conductive Media DC (dc), 354, 356
physics subdomain settings: heat transfer by conduction (ht), 352
Plot Parameters edit window, 363
Plot Parameters window, 346, 366
postprocessing and visualization, 361, 363
Rectangle edit window, 349t
rectangles created, 350
Solver Parameters edit window, 362
solving, 361, 362
start building, 346–347
Subdomain Settings, Init edit window, 354
Subdomain Settings (1, 8) edit window, 352
Subdomain Settings—Conductive Media DC (dc), Init edit window, 358
Subdomain Settings—Conductive Media DC (dc) edit window, 356t, 357, 358t
Subdomain Settings—Conductive Media DC (dc) edit window (1, 8), 357
Subdomain Settings edit window, 352t, 353t
Subdomain Settings (2–7) edit window, 353
temperature versus time at x = 0,
y = 0.1, 365
3D rendition of, 347
time-dependent solving of, 361
mesh generation, 338
mesh window, 339
Model Navigator setup, 327
model rectangle, 329
physics boundary settings: Conductive Media DC (dc), 335, 338
physics boundary settings: heat transfer by conduction (ht), 334
physics subdomain settings: Conductive Media DC (dc), 334–335
physics subdomain settings: heat transfer by conduction (ht), 332
Plot Parameters, Arrow edit window, 342
Plot Parameters edit window, 341
Plot Parameters window, 346
postprocessing and visualization, 339, 341, 344
postprocessing animation, 344–345
rectangle and circle, 330
Rectangle edit window, 329
second variation on, 366–388
   with all boundary settings, 381
Alumina, boundary conditions overview, 372
Alumina introduced in, 366
animation, final frame, 390
applications for materials and configuration in, 367
boundary conditions overview, 372
Boundary Settings (1, 40) edit window, 376
Boundary Settings (2, 3, 5, 26, 28, 39) edit window, 380
Boundary Settings (2, 3, 5, 28, 39) edit window, 376
Boundary Settings (2, 3, 5, 28, 39) edit window, 376
Boundary Settings—Conductive Media DC (emdc) edit window, 379
Boundary Settings (1) edit window, 380
Boundary Settings—Conductive Media DC (emdc) edit window (2, 4, 8, 10, 12), 378
Boundary Settings (3, 5, 7, 9, 11) edit window, 373
Boundary Settings—Conductive Media DC (emdc), Init edit window, 379
Boundary Settings—Conductive Media DC (emdc) edit window (1, 13), 377
Subdomain Settings, Conductive Media DC (emdc) edit window (2, 4, 8, 10, 12), 378
Subdomain Settings (3, 5, 7, 9, 11) edit window, 373
Subdomain Settings—Conductive Media DC (emdc), Init edit window, 379
Subdomain Settings—Conductive Media DC (emdc) edit window, 378
Subdomain Settings—Conductive Media DC (emdc) edit window (1, 13), 377
Subdomain Settings edit windows, 373t, 374t, 375t
temperature versus time at \( x = 0, \ y = 0.1 \), 387
3D rendition of, 368
time-dependent of, 368
Solver Parameters edit window, 340
solving, 339, 340
derivation of, 366
Free Mesh Parameters window, 382
heater bar assembly, 372
heat flux (proportional arrows), 388
import paths for, 369
mesh generation, 380
model mesh, 382
Navigator setup, 368
physical property values for copper, Nichrome, and Alumina required for conduction calculation in, 375
physics boundary settings: Conductive Media DC (emdc), 379
physics boundary settings: general heat transfer (htgh), 375
physics boundary settings: general heat transfer (htgh), 371–372
physics domain settings: general heat transfer (htgh), 371–372
physics subdomain settings: Conductive Media DC (emdc), 377–378
Plot Parameters edit window, 385
Plot Parameters window, 389
postprocessing and visualization, 383–385
postprocessing animation, 385, 388
Rectangle edit window, 370
rectangles created, 370
solving, 382, 383, 384
start building, 367
Subdomain Settings, Conductive Media DC (emdc) edit window (2, 4, 8, 10, 12), 378
Subdomain Settings (3, 5, 7, 9, 11) edit window, 373
Subdomain Settings—Conductive Media DC (emdc), Init edit window, 379
Subdomain Settings—Conductive Media DC (emdc) edit window, 378
Subdomain Settings—Conductive Media DC (emdc) edit window (1, 13), 377
Subdomain Settings edit windows, 373t, 374t, 375t
temperature versus time at \( x = 0, \ y = 0.1 \), 387
3D rendition of, 368
time-dependent of, 368
Solver Parameters edit window, 340
solving, 339, 340
derivation of, 366
Free Mesh Parameters window, 382
heater bar assembly, 372
heat flux (proportional arrows), 388
import paths for, 369
mesh generation, 380
model mesh, 382
Navigator setup, 368
physical property values for copper, Nichrome, and Alumina required for conduction calculation in, 375
physics boundary settings: Conductive Media DC (emdc), 379
physics boundary settings: general heat transfer (htgh), 375
physics boundary settings: general heat transfer (htgh), 371–372
physics domain settings: general heat transfer (htgh), 371–372
physics subdomain settings: Conductive Media DC (emdc), 377–378
Plot Parameters edit window, 385
Plot Parameters window, 389
postprocessing and visualization, 383–385
postprocessing animation, 385, 388
Rectangle edit window, 370
rectangles created, 370
solving, 382, 383, 384
start building, 367
Subdomain Settings, Conductive Media DC (emdc) edit window (2, 4, 8, 10, 12), 378
Subdomain Settings (3, 5, 7, 9, 11) edit window, 373
Subdomain Settings—Conductive Media DC (emdc), Init edit window, 379
Subdomain Settings—Conductive Media DC (emdc) edit window, 378
Subdomain Settings—Conductive Media DC (emdc) edit window (1, 13), 377
Subdomain Settings edit windows, 373t, 374t, 375t
temperature versus time at \( x = 0, \ y = 0.1 \), 387
3D rendition of, 368
time-dependent of, 368
Solver Parameters edit window, 340
solving, 339, 340
2D Resistive Heating models (continued)
  start building, 327
  Subdomain edit window, 332
  Subdomain Settings: Conductive Media DC
     (dc) Edit window, 335
  Subdomain Settings, Init edit window, 333, 336
  Subdomain Settings edit window, 333, 336
  summary and conclusions about, 388
  temperature and heat flux, 343
  temperature versus time at \( x = 0, y = 0.4 \), 345
  3D rendition of, 327
  time-dependent solving of, 339

U
UMFPACK. See Parametric solver
     (UMFPACK)
Uniform Color radio button, 181, 526, 562, 647
Union button, 506
Union command, 2D AC Generator model,
     static, 502, 509
Unregistered class of access, MatWeb, 43, 45
UNS C10100 properties, Materials/Coefficient
     Library, 43
Untransformed AC power, 497
Use selected points as destination check box, 550
Use weak constraints check box, 176, 548

V
Vacuum, 317
Vacuum flask, invention of, 265
Vacuum flask containers, 265
Vector dot product current \((K*nJ_{dc})\), 165
Voltage difference methods, determining
     between upper/lower surfaces, 181
Voltage divider, 574
von Guericke, Otto, 611

W
“War of Currents,” 494–498
Wave equation PDE, achieving desired behavior
     for and transformation of, 672, 674
Wave equation problems, PML methodology
     applied to, 671
Wave equation solution examples
     inside modeling domain, 675
     inside PML domain, 675
Weak Constr. tab, 176
Weak constraints, 176, 221
Weak constraints pull-down list, 172
Westinghouse, George, 494
Work-Plane settings
  3D thin layer resistance model: thin layer
     approximation and use of, 580
  3D thin layer resistance modeling, thin layer
     subdomain, 595
Work-Plane Settings edit window
  3D magnetic field of a Helmholtz coil
     model, 638
  3D magnetic field of a Helmholtz coil with
     a magnetic test object model, 654
  3D thin layer resistance model: thin layer
     approximation, 580
  3D thin layer resistance model: thin layer
     subdomain, 597

X
X-Axis Data edit window
  3D thin layer resistance model: thin layer
     approximation, 591
  3D thin layer resistance model: thin layer
     subdomain, 608
X-ray tubes, 3D electrostatic potential models
     and, 612, 622, 633
x-y-z coordinate orientation, for COMSOL
     modeling calculations, 2, 3
x-y-z to spherical coordinate conversion,
     equations for, 2–3

Z
Zoom Extents button, 136, 155, 172, 189, 191,
     207, 231, 243, 254, 268, 329, 350, 370,
     398, 466, 479, 505, 536, 579, 580, 595,
     596, 615, 626, 639, 655, 677, 694, 710,
     727, 753, 774
COMSOL Multiphysics workspace
     window, 92
Zoom Extents icon, 28
  1D dual-pane workspace after
     clicking, 19
  1D triple-pane workspace after
     clicking, 29